Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

25.05.2006, 19:00

Was soll man besser benutzen OSS oder doch ALSA?!?

Hallo!!!

Bei meinem Gentoo auf dem Dell I6000 benutze ich OSS, doch ich habe auch schon mehrmals gelesen, dass man dafür auch ALSA verwenden könnte. Was sind eigentlich die Vorteile ALSA gegenüber OSS?

Mfg Djon
Fachgymnasium "Technik" TFG99 in Wernigerode
3./Nachschubbataillon 411 in Burg ( bei Magdeburg)
Hochschule "Harz" in Wernigerode
Fachbereich AI - "Kommunikationsinformatik"

2

25.05.2006, 19:44

"Erst nachdem wir alles verloren haben, haben wir die Freiheit, alles zu tun."
"It's only after we've lost everything, that we're free to do anything!"

Jabber: Die ID kann via PN erfragt werden.

3

25.05.2006, 20:11

Hallo!!!

Vielen Dank für den Hinweis. Ich werde wahrscheinlich doch lieber auf ALSA setzen. Mal schauen ob der Umstieg problemlos klappt.


Mfg Djon
Fachgymnasium "Technik" TFG99 in Wernigerode
3./Nachschubbataillon 411 in Burg ( bei Magdeburg)
Hochschule "Harz" in Wernigerode
Fachbereich AI - "Kommunikationsinformatik"

4

25.05.2006, 20:26

Deine Frage damit geklärt und das Tehma somit "gelöst"?

Zitat

... oder doch ALSA?!?

Zitat

Hallo!!!

Das mit den Interpunktionsregeln sollte man vielleicht auch wiederholen. 8) ;)

Also eigentlich sollte der Umstieg keine größeren Probleme machen.
Alsa installieren und dann solltest du natürlich noch deine USE-Flags anpassen (alsa -oss). Zuletzt dann noch ein "emerge -vaDNu world".
Gibt hier ja auch ein alsa howto,
"Erst nachdem wir alles verloren haben, haben wir die Freiheit, alles zu tun."
"It's only after we've lost everything, that we're free to do anything!"

Jabber: Die ID kann via PN erfragt werden.

5

25.05.2006, 21:49

Also wie ich schon befürchtet haben, kam es bei dem Umstieg zu Problemen. Hier ist Ausschnitt aus dem dmesg

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
Intel 810 + AC97 Audio, version 1.01, 21:33:30 May 22 2006
ACPI: PCI Interrupt 0000:00:1e.2[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
PCI: Setting latency timer of device 0000:00:1e.2 to 64
i810: Intel ICH4 found at IO 0xec40 and 0xed00, MEM 0xdffffe00 and 0xdffffd00, IRQ 11
i810: Intel ICH4 mmio at 0xe0812e00 and 0xe0814d00
i810_audio: Primary codec has ID 0
i810_audio: Audio Controller supports 6 channels.
i810_audio: Defaulting to base 2 channel mode.
i810_audio: Resetting connection 0
i810_audio: Connection 0 with codec id 0
ac97_codec: AC97 Audio codec, id: 0x8384:0x7652 (SigmaTel STAC9752/53)
i810_audio: AC'97 codec 0 supports AMAP, total channels = 2
oprofile: using timer interrupt.
NET: Registered protocol family 2
IP route cache hash table entries: 8192 (order: 3, 32768 bytes)
TCP established hash table entries: 32768 (order: 5, 131072 bytes)
TCP bind hash table entries: 32768 (order: 5, 131072 bytes)
TCP: Hash tables configured (established 32768 bind 32768)
TCP reno registered
IPv4 over IPv4 tunneling driver
ip_conntrack version 2.4 (4094 buckets, 32752 max) - 172 bytes per conntrack
TCP bic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
Using IPI Shortcut mode
ACPI wakeup devices: 
 LID PBTN PCI0 USB0 USB1 USB2 USB4 USB3 MODM PCIE 
ACPI: (supports S0 S3 S4 S5)
ReiserFS: sda6: found reiserfs format "3.6" with standard journal
ReiserFS: sda6: using ordered data mode
ReiserFS: sda6: journal params: device sda6, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: sda6: checking transaction log (sda6)
ReiserFS: sda6: Using r5 hash to sort names
VFS: Mounted root (reiserfs filesystem) readonly.
Freeing unused kernel memory: 124k freed
ACPI: PCI Interrupt 0000:03:01.0[A] -> Link [LNKD] -> GSI 7 (level, low) -> IRQ 7
Yenta: CardBus bridge found at 0000:03:01.0 [1028:0188]
snd_timer: Unknown symbol snd_oss_info_register
snd_timer: Unknown symbol snd_oss_info_register
Yenta: ISA IRQ mask 0x0418, PCI irq 7
Socket status: 30000006
pcmcia: parent PCI bridge I/O window: 0x2000 - 0x2fff
pcmcia: parent PCI bridge Memory window: 0xdfc00000 - 0xdfcfffff
pcmcia: parent PCI bridge Memory window: 0x30000000 - 0x31ffffff
snd_pcm: Unknown symbol snd_timer_notify
snd_pcm: Unknown symbol snd_timer_interrupt
snd_pcm: Unknown symbol snd_timer_new
snd_pcm: Unknown symbol snd_timer_notify
snd_pcm: Unknown symbol snd_timer_interrupt
snd_pcm: Unknown symbol snd_timer_new
snd_ac97_codec: Unknown symbol snd_interval_refine
snd_ac97_codec: Unknown symbol snd_pcm_hw_rule_add
snd_ac97_codec: Unknown symbol snd_interval_refine
snd_ac97_codec: Unknown symbol snd_pcm_hw_rule_add
snd_intel8x0m: Unknown symbol snd_ac97_resume
snd_intel8x0m: Unknown symbol snd_pcm_new
snd_intel8x0m: Unknown symbol snd_pcm_lib_preallocate_pages_for_all
snd_intel8x0m: Unknown symbol snd_ac97_mixer
snd_intel8x0m: Unknown symbol snd_ac97_bus
snd_intel8x0m: Unknown symbol snd_ac97_suspend
snd_intel8x0m: Unknown symbol snd_pcm_lib_malloc_pages
snd_intel8x0m: Unknown symbol snd_pcm_lib_ioctl
snd_intel8x0m: Unknown symbol snd_pcm_lib_free_pages
snd_intel8x0m: Unknown symbol snd_pcm_set_ops
snd_intel8x0m: Unknown symbol snd_pcm_hw_constraint_list
snd_intel8x0m: Unknown symbol snd_pcm_suspend_all
snd_intel8x0m: Unknown symbol snd_pcm_period_elapsed
snd_intel8x0m: Unknown symbol snd_ac97_write
snd_intel8x0: Unknown symbol snd_ac97_pcm_close
snd_intel8x0: Unknown symbol snd_ac97_resume
snd_intel8x0: Unknown symbol snd_pcm_new
snd_intel8x0: Unknown symbol snd_pcm_limit_hw_rates
snd_intel8x0: Unknown symbol snd_pcm_lib_preallocate_pages_for_all
snd_intel8x0: Unknown symbol snd_ac97_pcm_open
snd_intel8x0: Unknown symbol snd_ac97_set_rate
snd_intel8x0: Unknown symbol snd_ac97_update_bits
snd_intel8x0: Unknown symbol snd_ac97_mixer
snd_intel8x0: Unknown symbol snd_ac97_bus
snd_intel8x0: Unknown symbol snd_ac97_pcm_double_rate_rules
snd_intel8x0: Unknown symbol snd_ac97_suspend
snd_intel8x0: Unknown symbol snd_pcm_lib_malloc_pages
snd_intel8x0: Unknown symbol snd_pcm_lib_ioctl
snd_intel8x0: Unknown symbol snd_pcm_lib_free_pages
snd_intel8x0: Unknown symbol snd_pcm_set_ops
snd_intel8x0: Unknown symbol snd_pcm_hw_constraint_list
snd_intel8x0: Unknown symbol snd_ac97_get_short_name
snd_intel8x0: Unknown symbol snd_pcm_suspend_all
snd_intel8x0: Unknown symbol snd_ac97_pcm_assign
snd_intel8x0: Unknown symbol snd_pcm_hw_constraint_integer
snd_intel8x0: Unknown symbol snd_pcm_hw_constraint_msbits
snd_intel8x0: Unknown symbol snd_pcm_period_elapsed
snd_intel8x0: Unknown symbol snd_ac97_tune_hardware
b44.c:v0.97 (Nov 30, 2005)
ACPI: PCI Interrupt 0000:03:00.0[A] -> Link [LNKC] -> GSI 9 (level, low) -> IRQ 9
eth0: Broadcom 4400 10/100BaseT Ethernet 00:12:3f:e9:82:8d
snd_timer: Unknown symbol snd_oss_info_register
snd_pcm: Unknown symbol snd_timer_notify
snd_pcm: Unknown symbol snd_timer_interrupt
snd_pcm: Unknown symbol snd_timer_new
snd_ac97_codec: Unknown symbol snd_interval_refine
snd_ac97_codec: Unknown symbol snd_pcm_hw_rule_add
snd_intel8x0: Unknown symbol snd_ac97_pcm_close
snd_intel8x0: Unknown symbol snd_ac97_resume
snd_intel8x0: Unknown symbol snd_pcm_new
snd_intel8x0: Unknown symbol snd_pcm_limit_hw_rates
snd_intel8x0: Unknown symbol snd_pcm_lib_preallocate_pages_for_all
snd_intel8x0: Unknown symbol snd_ac97_pcm_open
snd_intel8x0: Unknown symbol snd_ac97_set_rate
snd_intel8x0: Unknown symbol snd_ac97_update_bits
snd_intel8x0: Unknown symbol snd_ac97_mixer
snd_intel8x0: Unknown symbol snd_ac97_bus
snd_intel8x0: Unknown symbol snd_ac97_pcm_double_rate_rules
snd_intel8x0: Unknown symbol snd_ac97_suspend
snd_intel8x0: Unknown symbol snd_pcm_lib_malloc_pages
snd_intel8x0: Unknown symbol snd_pcm_lib_ioctl
snd_intel8x0: Unknown symbol snd_pcm_lib_free_pages
snd_intel8x0: Unknown symbol snd_pcm_set_ops
snd_intel8x0: Unknown symbol snd_pcm_hw_constraint_list
snd_intel8x0: Unknown symbol snd_ac97_get_short_name
snd_intel8x0: Unknown symbol snd_pcm_suspend_all
snd_intel8x0: Unknown symbol snd_ac97_pcm_assign
snd_intel8x0: Unknown symbol snd_pcm_hw_constraint_integer
snd_intel8x0: Unknown symbol snd_pcm_hw_constraint_msbits
snd_intel8x0: Unknown symbol snd_pcm_period_elapsed
snd_intel8x0: Unknown symbol snd_ac97_tune_hardware
snd_timer: Unknown symbol snd_oss_info_register
snd_pcm: Unknown symbol snd_timer_notify
snd_pcm: Unknown symbol snd_timer_interrupt


Ich habe die Anleitung befolgt, doch es hat nicht gebracht.
Woran könnte das liegen?


Mfg Djon
Fachgymnasium "Technik" TFG99 in Wernigerode
3./Nachschubbataillon 411 in Burg ( bei Magdeburg)
Hochschule "Harz" in Wernigerode
Fachbereich AI - "Kommunikationsinformatik"

6

26.05.2006, 01:00

mein tipp:

1. kernelquellen installieren, kernel bauen, passende module installieren
2. mit dem neuen kernel booten, /usr/src/linux soll auf *diese* kernelquellen zeigen
3. dann emerge alsa-headers, alsa-libs neu.

irgendwie scheinen deine module nicht ins kernel zu wollen. das hab ich immer mit neu-bauen gelöst.
:):):)

7

26.05.2006, 04:02

ok, probiere ich gleich mal aus.


Mfg Djon
Fachgymnasium "Technik" TFG99 in Wernigerode
3./Nachschubbataillon 411 in Burg ( bei Magdeburg)
Hochschule "Harz" in Wernigerode
Fachbereich AI - "Kommunikationsinformatik"

8

26.05.2006, 11:58

ALSA Guide

schau dir lieber diese anleitung an!
MfG MyD

9

26.05.2006, 19:01

Unser Öber Süperpröfi macht wohl gerne Werbung für sein HowTo... :D

{Musste sein, denn bei jeder ALSA/OSS-Frage kommst du, sagst "ALSA-HowTo" und im Thread ist Ruhe. :D [Sollte jetzt ein Lob sein (Applaus!)]}

10

26.05.2006, 20:00

hmm eigentlich steht da ja alles drinne auch zu:
Unknown symbol etc.

ist das howto jetzt gut oder net?
habe deine sätze irgendwie nciht ganz verstanden.
MfG MyD

11

26.05.2006, 21:45

Hallo!!!

So, habe jetzt die Guide befolgt, hat soweit alles geklappt. Meine Soundkarte wurde erfolgreich erkannt, doch ich habe immernoch kein Sound. Hier ist der Auszug aus dmesg:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
intel8x0_measure_ac97_clock: measured 55469 usecs
intel8x0: clocking to 48000
ACPI: PCI Interrupt 0000:00:1e.3[B] -> Link [LNKB] -> GSI 5 (level, low) -> IRQ 5
PCI: Setting latency timer of device 0000:00:1e.3 to 64
ALSA /var/tmp/portage/alsa-driver-1.0.11/work/alsa-driver-1.0.11/pci/ac97/ac97_codec.c:2009: MC'97 1 converters and GPIO not ready (0xff00)
b44.c:v0.97 (Nov 30, 2005)
ACPI: PCI Interrupt 0000:03:00.0[A] -> Link [LNKC] -> GSI 9 (level, low) -> IRQ 9
eth0: Broadcom 4400 10/100BaseT Ethernet 00:12:3f:e9:82:8d
Adding 1004020k swap on /dev/sda5.  Priority:-1 extents:1 across:1004020k
ReiserFS: sda7: found reiserfs format "3.6" with standard journal
ReiserFS: sda7: using ordered data mode
ReiserFS: sda7: journal params: device sda7, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
ReiserFS: sda7: checking transaction log (sda7)
ReiserFS: sda7: Using r5 hash to sort names
snd_seq_oss: Unknown symbol snd_unregister_oss_device
snd_seq_oss: Unknown symbol snd_register_oss_device
snd_seq_oss: Unknown symbol snd_oss_info_register
snd_mixer_oss: Unknown symbol snd_unregister_oss_device
snd_mixer_oss: Unknown symbol snd_register_oss_device
snd_mixer_oss: Unknown symbol snd_mixer_oss_notify_callback
snd_mixer_oss: Unknown symbol snd_oss_info_register
snd_mixer_oss: Unknown symbol snd_lookup_oss_minor_data
snd_pcm_oss: Unknown symbol snd_unregister_oss_device
snd_pcm_oss: Unknown symbol snd_register_oss_device
snd_pcm_oss: Unknown symbol snd_mixer_oss_ioctl_card
snd_pcm_oss: Unknown symbol snd_oss_info_register
snd_pcm_oss: Unknown symbol snd_lookup_oss_minor_data
snd_mixer_oss: Unknown symbol snd_unregister_oss_device
snd_mixer_oss: Unknown symbol snd_register_oss_device
snd_mixer_oss: Unknown symbol snd_mixer_oss_notify_callback
snd_mixer_oss: Unknown symbol snd_oss_info_register
snd_mixer_oss: Unknown symbol snd_lookup_oss_minor_data


Was habe ich da falsch gemacht?

Mfg Djon
Fachgymnasium "Technik" TFG99 in Wernigerode
3./Nachschubbataillon 411 in Burg ( bei Magdeburg)
Hochschule "Harz" in Wernigerode
Fachbereich AI - "Kommunikationsinformatik"

12

27.05.2006, 12:22

was sagt ein

Quellcode

1
# cat /proc/asound/cards

und hast du mittels alsamixer die kanäle unmuted ?(
sind die module sauber geladen (lsmod) ?(
hattest du vorher im kernel alsa ausgewählt und danach dann die alsa-driver eingespielt ?(
MfG MyD

13

27.05.2006, 17:16

Hallo!!!

Also hier ist die Ausgabe:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
cat /proc/asound/cards
0 [ICH6           ]: ICH4 - Intel ICH6
                      Intel ICH6 with STAC9752,53 at 0xdffffe00, irq 11
 1 [Modem          ]: ICH-MODEM - Intel ICH6 Modem
                      Intel ICH6 Modem at 0xee00, irq 5


lsmod
Module                  Size  Used by
acx                   123592  0 
snd_seq_midi_event      5440  0 
snd_seq                40720  1 snd_seq_midi_event
snd_seq_device          5964  1 snd_seq
snd_intel8x0m          12492  1 
snd_intel8x0           25628  1 
snd_ac97_codec         78880  2 snd_intel8x0m,snd_intel8x0
b44                    19212  0 
snd_ac97_bus            1728  1 snd_ac97_codec
yenta_socket           20172  3 
snd_pcm                63304  3 snd_intel8x0m,snd_intel8x0,snd_ac97_codec
rsrc_nonstatic          8256  1 yenta_socket
snd_timer              16452  2 snd_seq,snd_pcm
snd                    35192  11 snd_seq,snd_seq_device,snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
snd_page_alloc          6856  3 snd_intel8x0m,snd_intel8x0,snd_pcm


Ich habe es genauso wie es in der Anleitung stand erst alles aus dem Kernel (OSS und ALSA) entfernt und erst dann alsa-driver emerged. Kanäle sind im alsamixer unmuted.

Edit: Zusätzlich kommt noch nach dem Login eine Fehlermeldung von arts:

Quellcode

1
2
Error while initializing the sound driver:
device /dev/dsp can't be opened (No such file or directory)....


Mfg Djon
Fachgymnasium "Technik" TFG99 in Wernigerode
3./Nachschubbataillon 411 in Burg ( bei Magdeburg)
Hochschule "Harz" in Wernigerode
Fachbereich AI - "Kommunikationsinformatik"

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Djon« (28.05.2006, 09:05)


14

30.05.2006, 20:12

Kann mir denn keiner helfen???
Fachgymnasium "Technik" TFG99 in Wernigerode
3./Nachschubbataillon 411 in Burg ( bei Magdeburg)
Hochschule "Harz" in Wernigerode
Fachbereich AI - "Kommunikationsinformatik"

15

30.05.2006, 20:17

Nun, das aRts den Pfad /dev/dsp nicht findet, liegt daran, dass bei ALSA die OSS-Emulation deaktiviert ist, denn das ist nämlich der klassische OSS-Gerätepfad. Du solltest aRts auf ALSA umstellen.

P.S.: Du musst sicherstellen, dass der Kanals PCM lautgestellt ist.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Carminox« (30.05.2006, 20:18)


16

30.05.2006, 20:23

Wie stelle ich Arts auf Alsa um?
Fachgymnasium "Technik" TFG99 in Wernigerode
3./Nachschubbataillon 411 in Burg ( bei Magdeburg)
Hochschule "Harz" in Wernigerode
Fachbereich AI - "Kommunikationsinformatik"

17

30.05.2006, 20:28

Ich benutze zwar kein KDE (ich nutzte es 'mal), aber es müsste im Kontrollcenter unter Sound sein.

18

30.05.2006, 20:42

Schau mal unter http://www.gentooforum.de/thread.php?threadid=10309

Ich bin auch gerade an dem Problem. Vielleicht finden wir ja alle gemeinsam eine Lösung
Man kann nicht alles wissen, aber alles lernen!

19

30.05.2006, 20:59

Ich glaube bei mir liegt das Problem bisschen woanders. Bei mir kommt es beim Reinladen folgender Module zu einer Fehlermeldung:

Quellcode

1
2
3
snd-seq-oss
snd-pcm-oss
snd-mixer-oss


Ich habe keine Ahnung warum die Module nicht da sind. Habe schon verschiedene Anleitungen ausprobiert, doch alles erfolglos :-(

Edit: Habe jetzt versucht Alsa in den Kernel aufzunehme (davor habe ich alsa-driver unmerged), doch es kam zu noch mehr Fehlern :-(

Mfg Djon
Fachgymnasium "Technik" TFG99 in Wernigerode
3./Nachschubbataillon 411 in Burg ( bei Magdeburg)
Hochschule "Harz" in Wernigerode
Fachbereich AI - "Kommunikationsinformatik"

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Djon« (30.05.2006, 21:26)


20

30.05.2006, 22:45

So, ich bin jetzt etwas weiter gekommen. Ich habe alsa-driver unmerged, den überflüssigen Ordner per Hand gelöscht und alsa im Kernel aufgenommen. Jetzt werden alle Module ohne Probleme geladen. Unter Kontrollzentrum habe ich das Soundsystem auf alsa umgestellt. Ich habe im alsamixer alle Kanäle aufgedreht, doch zu meinem grossen erstaunen habe ich immernoch keinen Sound. Doch woran könnte es noch liegen????


Mfg Djon
Fachgymnasium "Technik" TFG99 in Wernigerode
3./Nachschubbataillon 411 in Burg ( bei Magdeburg)
Hochschule "Harz" in Wernigerode
Fachbereich AI - "Kommunikationsinformatik"