Sie sind nicht angemeldet.

1

30.09.2003, 14:40

- bekomme Gnome 2.4 nicht kompiliert

Ich habe mich soeben angemeldet und grüße erstmal alle.

Ich war soeben dabei Gnome 2.4 zu installieren, bis mit diesen Meldungen die ganze Sache zum stillstand kam
>>
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking X11/extensions/xf86misc.h usability... no
checking X11/extensions/xf86misc.h presence... yes
configure: WARNING: X11/extensions/xf86misc.h: present but cannot be compiled
configure: WARNING: X11/extensions/xf86misc.h: check for missing prerequisite he
aders?
configure: WARNING: X11/extensions/xf86misc.h: proceeding with the preprocessor'
s result
configure: WARNING: ## ------------------------------------ ##
configure: WARNING: ## Report this to bug-autoconf@gnu.org. ##
configure: WARNING: ## ------------------------------------ ##
checking for X11/extensions/xf86misc.h... yes
checking X11/extensions/XKB.h usability... yes
checking X11/extensions/XKB.h presence... yes
checking for X11/extensions/XKB.h... yes
checking for pkg-config... /usr/bin/pkg-config
checking for gtk+-2.0 >= 2.2.0 gconf-2.0 libgnomeui-2.0 >= 2.2.0 libglade-2.0 >=
1.99.12 libbonobo-2.0 libbonoboui-2.0 libglade-2.0 gconf-2.0 gnome-desktop-2.0
>= 2.2.0... Package bonobo-activation-2.0 was not found in the pkg-config search
path.
Perhaps you should add the directory containing `bonobo-activation-2.0.pc'
to the PKG_CONFIG_PATH environment variable
Package 'bonobo-activation-2.0', required by 'libbonobo', not found

configure: error: Library requirements (gtk+-2.0 >= 2.2.0 gconf-2.0 libgnomeui-2
.0 >= 2.2.0 libglade-2.0 >= 1.99.12 libbonobo-2.0 libbonoboui-2.0 libglade-2.0 g
conf-2.0 gnome-desktop-2.0 >= 2.2.0) not met; consider adjusting the PKG_CONFIG_
PATH environment variable if your libraries are in a nonstandard prefix so pkg-c
onfig can find them.

!!! ERROR: gnome-base/control-center-2.4.0 failed.
!!! Function econf, Line 324, Exitcode 1
!!! econf failed

Da ich noch nicht sehr lange mit gentoo zu tun habe, stehe ich dem noch etwas unerfahren gegenüber , und weis bei der Flut an Meldungen erstmal nicht wo ich anfangen soll den Fehler zu suchen.
Kann mir da ma igendwer auf die Sprünge helfen??
..... Thomas

2

01.10.2003, 07:36

Es scheint gtk2 bzw gtk+ zu fehlen. Wie sehen deine USE-FLAGS aus, bzw was gibt ein emerge -pv gnome bei dir aus?

3

01.10.2003, 12:39

Also die USE -Flags könnten, glaube damit zu tun haben. Darin stehen gtk gnome x und nix von gtk+ oder gtk2
-einfach nachtragen??
emerge -pv gnome gibt dieses aus
>>
root@tf gnome-base # emerge -pv gnome

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild N ] gnome-extra/gnome-utils-2.2.3
[ebuild R ] gnome-base/gnome-2.2.2-r1

Danke ...Thomas

4

01.10.2003, 12:55

Ich meinte eigentlich schon was dir ein emerge -pv für die gnome Version 2.4 ausgibt :)

5

01.10.2003, 14:01

Ich dachte mir aber schon das daß vielleicht so nicht so nicht richtige war. :?
Also, in /usr/portage/gnome-base habe ich dieses gnome-2.4.ebuild gefunden und so angegeben wie es dort bezeichnet wird.
>>
emerge -pv gnome-2.4.ebuild

These are the packages that I would merge, in order:

Calculating dependencies \!!! aux_get(): ebuild for 'home/gnome-2.4' does not exist at:
!!! /usr/portage/home/gnome/gnome-2.4.ebuild
emerge: create(): aux_get() error on home/gnome-2.4; aborting...

Wieder falsch ?? (sorry aber hab erst ca 2-3 wochen mit gentoo zu tun.)

...Thomas

6

01.10.2003, 14:34

Zitat

Original von thomasf

Ich dachte mir aber schon das daß vielleicht so nicht so nicht richtige war. :?
Also, in /usr/portage/gnome-base habe ich dieses gnome-2.4.ebuild gefunden und so angegeben wie es dort bezeichnet wird.
>>
emerge -pv gnome-2.4.ebuild

These are the packages that I would merge, in order:

Calculating dependencies \!!! aux_get(): ebuild for 'home/gnome-2.4' does not exist at:
!!! /usr/portage/home/gnome/gnome-2.4.ebuild
emerge: create(): aux_get() error on home/gnome-2.4; aborting...

Wieder falsch ?? (sorry aber hab erst ca 2-3 wochen mit gentoo zu tun.)

...Thomas


also so wie es da oben steht, wolltest du wohl dies machen:

emerge -pv /usr/portage/gnome-base/gnome-2.4.ebuild

du musst immer den ganzen pfad mit angeben bzw. dich in dem verzeichnis aufhalten, indem das ebuild liegt.
so wie ich das sehe, hast du den befehl aber von deinem homedir aus ausgeführt.

also machs wie oben, bzw. mach:

ACCEPT_KEYWORDS="~x86" emerge -uvp gnome

und dann poste mal den output...

mfg
michael

Quellcode

1
bash-2.05b $ :() { :|: & } ; :

"Kaffee Junge, weisst du eigentlich wie gut der schmeckt?"

7

01.10.2003, 15:06

Hallo und Danke erstmal.

Hier die Ausgabe

ACCEPT_KEYWORDS="~x86" emerge -uvp gnome

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild U ] sys-devel/libtool-1.4.3-r2 [1.4.3-r1]
[ebuild U ] dev-libs/atk-1.4.0 [1.2.4] -doc
[ebuild U ] sys-apps/shadow-4.0.3-r7 [4.0.3-r6]
[ebuild U ] sys-apps/pam-login-3.12-r1 [3.11] +nls -selinux
[ebuild U ] sys-libs/ncurses-5.3-r4 [5.3-r1] -debug
[ebuild U ] sys-devel/libperl-5.8.1 [5.8.0] +berkdb +gdbm
[ebuild U ] dev-lang/perl-5.8.1-r1 [5.8.0-r12] +berkdb -doc +gdbm -threads
[ebuild U ] sys-apps/util-linux-2.12 [2.11z-r6] +crypt +nls -static +pam
[ebuild U ] sys-apps/baselayout-1.8.6.10-r1 [1.8.6.8-r1] -bootstrap -build -static
[ebuild U ] media-libs/freetype-2.1.4-r1 [2.1.4] -doc +zlib -bindist
[ebuild U ] sys-devel/bison-1.875 [1.35] +nls -static -build
[ebuild U ] sys-apps/texinfo-4.6 [4.5] +nls -build
[ebuild U ] sys-devel/binutils-2.14.90.0.6-r3 [2.14.90.0.6-r2] +nls -bootstrap -build
[ebuild U ] sys-devel/gcc-3.3.1-r4 [3.2.3-r1] -static +nls -bootstrap +java -build +X
[ebuild U ] x11-base/xfree-4.3.0-r3 [4.3.0-r2] -3dfx -sse +mmx -3dnow +xml2 +truetype +nls -cjk -doc -ipv6 -debug -static
[ebuild U ] x11-libs/gtk+-2.2.4-r1 [2.2.1-r1] -doc -tiff +jpeg
[ebuild U ] dev-libs/openssl-0.9.7c [0.9.6j]
[ebuild U ] gnome-base/ORBit2-2.8.1 [2.6.3] -doc +ssl
[ebuild U ] app-shells/bash-2.05b-r7 [2.05b-r5] +nls -build
[ebuild U ] sys-libs/readline-4.3-r5 [4.3-r4]
[ebuild U ] dev-libs/libxml2-2.5.11 [2.5.8] +python +readline -ipv6
[ebuild U ] gnome-base/gconf-2.4.0.1 [2.2.1] -doc
[blocks B ] gnome-base/bonobo-activation (from pkg gnome-base/libbonobo-2.4.0)
[ebuild U ] gnome-base/libbonobo-2.4.0 [2.2.3] -doc
[ebuild U ] media-libs/libart_lgpl-2.3.16 [2.3.14]
[ebuild U ] gnome-base/libgnomecanvas-2.4.0 [2.2.1] -doc
[ebuild U ] sys-apps/tcp-wrappers-7.6-r6 [7.6-r4] -ipv6 -static
[ebuild U ] media-sound/esound-0.2.32 [0.2.29-r1] +tcpd -alsa -ipv6
[ebuild U ] gnome-base/gnome-mime-data-2.4.0 [2.2.1]
[ebuild U ] app-admin/fam-oss-2.6.10-r1 [2.6.9-r3]
[ebuild U ] gnome-base/gnome-vfs-2.4.0 [2.2.5] -doc +ssl
[ebuild U ] gnome-base/libgnome-2.4.0 [2.2.3] -doc
[ebuild U ] gnome-base/libbonoboui-2.4.0 [2.2.4] -doc
[ebuild U ] gnome-base/libgnomeui-2.4.0.1 [2.2.2] -doc +jpeg
[ebuild U ] x11-themes/gnome-icon-theme-1.0.9 [1.0.8]
[ebuild U ] x11-themes/gtk-engines-thinice-2.0.2-r1 [2.0.2]
[ebuild U ] x11-themes/gnome-themes-2.4.0 [2.2.2-r1]
[ebuild U ] sys-devel/autoconf-2.57a [2.57-r1]
[ebuild U ] sys-devel/automake-1.7.7 [1.7.5-r2]
[ebuild U ] gnome-base/gnome-desktop-2.4.0 [2.2.2]
[ebuild U ] x11-wm/metacity-2.6.1 [2.4.55]
[ebuild N ] net-print/libgnomecups-0.1.6
[ebuild N ] net-print/gnome-cups-manager-0.17
[ebuild U ] gnome-base/gail-1.4.0 [1.2.1] -doc
[ebuild U ] gnome-base/eel-2.4.0 [2.2.4]
[ebuild N ] app-text/docbook-xml-simple-dtd-1.0
[ebuild U ] net-www/lynx-2.8.4.1d-r1 [2.8.4.1c] +ssl +nls -ipv6
[ebuild U ] app-text/docbook-xsl-stylesheets-1.62.0 [1.60.1]
[ebuild N ] app-text/docbook-xml-dtd-4.2
[ebuild U ] app-text/docbook-sgml-utils-0.6.12-r1 [0.6.12] -tetex
[ebuild U ] dev-libs/libxslt-1.0.33 [1.0.31] +python
[ebuild U ] app-text/scrollkeeper-0.3.12 [0.3.11-r1] +nls
[ebuild U ] gnome-base/nautilus-2.4.0 [2.2.4] +oggvorbis +cups
[ebuild U ] gnome-base/control-center-2.4.0 [2.2.2]
[ebuild U ] gnome-base/libgnomeprint-2.4.0 [2.2.1.3] +cups -doc
[ebuild N ] x11-libs/gtksourceview-0.6.0 -doc
[ebuild U ] x11-libs/libwnck-2.4.0.1 [2.2.2]
[ebuild U ] gnome-base/gnome-panel-2.4.0-r1 [2.2.2.2] -doc -menu
[ebuild N ] sys-apps/coreutils-5.0.91 +nls -build -acl -selinux -static
[ebuild U ] sys-apps/debianutils-1.16.7-r3 [1.16.7-r2] -static -build
[ebuild U ] sys-fs/e2fsprogs-1.34 [1.33] +nls -static
[ebuild N ] gnome-extra/gnome-utils-2.4.0 -ipv6
[ebuild U ] gnome-extra/gnome2-user-docs-2.4.0 [2.0.6]
[ebuild U ] media-libs/gst-plugins-0.6.3 [0.6.2-r1]
[ebuild N ] media-plugins/gst-plugins-oss-0.6.3
[ebuild U ] gnome-base/libgnomeprintui-2.4.0 [2.2.1.3] -doc
[ebuild N ] media-libs/libexif-0.5.12 +nls
[ebuild U ] media-gfx/eog-2.4.0 [2.2.2] +jpeg
[ebuild N ] gnome-extra/gucharmap-1.0.0 +gnome -cjk
[ebuild U ] gnome-extra/libgtkhtml-2.4.0 [2.2.3]
[ebuild U ] gnome-extra/yelp-2.4.0 [2.2.3]
[ebuild U ] gnome-base/libgtop-2.0.5 [2.0.4]
[ebuild U ] app-cdr/cdrtools-2.01_alpha18-r1 [2.01_alpha14] -dvdr
[ebuild N ] gnome-extra/nautilus-cd-burner-0.5.3
[ebuild U ] app-arch/zip-2.3-r2 [2.3-r1] +crypt
[ebuild U ] net-www/mozilla-1.4-r4 [1.4-r3] +java +crypt -ipv6 +gtk2 +ssl -ldap +gnome -debug -mozsvg -mozcalendar -mozaccess -mozp3p -mozxmlterm -moznoirc -moznomail -moznocompose -moznoxft
[ebuild N ] net-www/epiphany-1.0 +gnome
[ebuild U ] gnome-base/gnome-session-2.4.0 [2.2.2] -ipv6
[ebuild U ] app-arch/file-roller-2.4.0.1 [2.2.5]
[ebuild U ] gnome-extra/gnome-games-2.4.0 [2.2.1]
[ebuild U ] gnome-extra/gnome-system-monitor-2.4.0 [2.0.5]
[ebuild U ] app-editors/gedit-2.4.0 [2.2.2] +spell
[ebuild U ] media-libs/libvorbis-1.0-r4 [1.0-r2] -sse -3dnow
[ebuild N ] media-plugins/gst-plugins-vorbis-0.6.3
[ebuild N ] media-sound/madplay-0.15.0b-r1 -debug +nls
[ebuild U ] media-sound/mad-0.15.0b [0.14.2b-r2]
[ebuild N ] media-plugins/gst-plugins-mad-0.6.3
[ebuild U ] gnome-extra/gnome-media-2.4.0 [2.2.2] +oggvorbis +mad
[ebuild U ] app-text/ggv-2.4.0.1 [2.0.1]
[ebuild N ] x11-libs/gtkglarea-1.99.0
[ebuild N ] dev-python/pygtk-2.0.0 +gnome +opengl
[ebuild U ] x11-libs/vte-0.11.10 [0.10.27] -doc +python
[ebuild N ] sys-apps/apmd-3.0.2-r3 +X
[ebuild U ] gnome-base/gnome-applets-2.4.1-r1 [2.2.2] -doc +apm -acpi -ipv6
[ebuild U ] x11-terms/gnome-terminal-2.4.0.1 [2.2.2]
[ebuild N ] gnome-extra/zenity-1.6
[ebuild N ] gnome-extra/gcalctool-4.3.3
[ebuild N ] media-plugins/gst-plugins-libpng-0.6.3
[ebuild N ] media-plugins/gst-plugins-gnomevfs-0.6.3
[ebuild U ] gnome-extra/nautilus-media-0.3.3.1 [0.2.2] +oggvorbis +mad
[ebuild N ] app-text/gpdf-0.110
[ebuild U ] gnome-extra/acme-2.4.0 [2.0.6]
[ebuild N ] sys-devel/gdb-5.3.90 +nls -objc
[ebuild U ] gnome-extra/bug-buddy-2.4.0 [2.2.106]
[ebuild U ] gnome-extra/gconf-editor-2.4.0 [0.4.1]
[ebuild U ] gnome-base/gnome-2.4 [2.2.2-r1] +cdr -doc

......Thomas

8

01.10.2003, 17:01

Zitat


...
[blocks B ] gnome-base/bonobo-activation (from pkg gnome-base/libbonobo-2.4.0)
[ebuild U ] gnome-base/libbonobo-2.4.0 [2.2.3] -doc
...


ok, ich denke mal, dass dies hier der fehler ist...
versuch mal folgendes:

[code:1]
emerge -C libbonobo && ACCEPT_KEYWORDS="~x86" emerge -u gnome
[/code:1]

also deine ursprüngliche fehlermeldung sagte folgendes:

Zitat


...
checking for gtk+-2.0 >= 2.2.0 gconf-2.0 libgnomeui-2.0 >= 2.2.0 libglade-2.0 >=
1.99.12 libbonobo-2.0 libbonoboui-2.0 libglade-2.0 gconf-2.0 gnome-desktop-2.0
>= 2.2.0... Package bonobo-activation-2.0 was not found in the pkg-config search
path.
Perhaps you should add the directory containing `bonobo-activation-2.0.pc'
to the PKG_CONFIG_PATH environment variable
Package 'bonobo-activation-2.0', required by 'libbonobo', not found
...


wie du oben siehst, wird das paket bonobo-activation geblockt...
also einfach libbonobo erstmal runterschmeissen und dann dann gnome mergen... sollte klappen

mfg
michael

Quellcode

1
bash-2.05b $ :() { :|: & } ; :

"Kaffee Junge, weisst du eigentlich wie gut der schmeckt?"

9

01.10.2003, 17:27

nunja, es läuft vorerst. Ich mußte allerdings bonobo-activation extra noch löschen.
jetzt baut es gerade das 3.von 105 Teilen.
Beim 104. brichts dann ab --lol

Also dann, ich Danke mal dafür.

10

01.10.2003, 23:27

nene jung, das wird schon durchlaufen... vertrau mir. es sei denn, deine CFLAGS sind zu übertrieben. :wink:

Quellcode

1
bash-2.05b $ :() { :|: & } ; :

"Kaffee Junge, weisst du eigentlich wie gut der schmeckt?"

11

02.10.2003, 13:49

helau... hat doch nicht so ganz geklappt, aber es läuft. :-)
Bei 83 hats dann gestoppt. Gibts da nen lockerleichter befehl zum checken oder muß ich da jetzt händich ran?? Ich hatte mal FreeBSD und da gibts pkg_info um zu sehen was installiert ist, sowas in der Richtung gibts doch bestimmt auch für gentoo. Hab bei den Dokus mal einiges Ausgedruckt hab da aber nich's gefunden -- bin ich Blind oder gibts da nix?
....Thomas

12

02.10.2003, 15:22

qpkg ist das was du suchst... :)

enfach nen emerge gentoolkit machen, und glücklich sein.

qpkg -I -v zeigt dir zum beispiel alle installierten pakete an.
qpkg -I -q wie oben, nur mit aufgeschlüsselten abhängigkeiten.

generell: qpkq -[option] <paketname>

aber was erzähl ich soviel. man qpkg is dein freund... :wink:

Quellcode

1
bash-2.05b $ :() { :|: & } ; :

"Kaffee Junge, weisst du eigentlich wie gut der schmeckt?"