Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

04.08.2006, 15:34

[gelöst] emerge von cdk schlägt fehl.

Beim emergen von cdk bricht es mit folgender Meldung ab:

name -Wl,libcdk.so.1 -o .libs/libcdk.so.1.0.0
i686-pc-linux-gnu-g++: /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/../../../crti.o: No such file or directory
i686-pc-linux-gnu-g++: /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/crtbeginS.o: No such file or directory
i686-pc-linux-gnu-g++: /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/crtendS.o: No such file or directory
i686-pc-linux-gnu-g++: /usr/lib/gcc/i686-pc-linux-gnu/3.4.4/../../../crtn.o: No such file or directory
make: *** [libcdk.la] Fehler 1

!!! ERROR: dev-libs/cdk-4.9.11.20031210-r2 failed.
Call stack:
ebuild.sh, line 1539: Called dyn_compile
ebuild.sh, line 939: Called src_compile
cdk-4.9.11.20031210-r2.ebuild, line 30: Called die

!!! make failed!
!!! If you need support, post the topmost build error, and the call stack if relevant.

Was kann ich tun?
Ullrich Andreas
Meine Konfiguration:
x86_64/Gentoo-10.1/gcc Version 4.5.3/KDE-Version 4.9.3/Kernel version 2.6.34-gentoo-r6
Graphic: 2x Nvidia 9600-GT OC SLI,Drucker: Samsung CLP-315W

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »andreasullrich« (23.08.2006, 21:59)


2

04.08.2006, 16:07

lass mich raten
du hast nicht gcc 3.4.4 ?

les dir mal
http://www.gentoo.org/doc/en/gcc-upgrading.xml
durch

wieviele millionen thread werden davon noch kommen? :/

3

04.08.2006, 16:17

ich habe gcc 3.4.6
Ullrich Andreas
Meine Konfiguration:
x86_64/Gentoo-10.1/gcc Version 4.5.3/KDE-Version 4.9.3/Kernel version 2.6.34-gentoo-r6
Graphic: 2x Nvidia 9600-GT OC SLI,Drucker: Samsung CLP-315W

4

04.08.2006, 17:50

Mal das ganze System auf die neuen USE-Flags anpassen.
emerge --update --newuse world emerge -p --depclean (Achtung bei dem Befehl,überlegen was gelöscht wird) revdeb-rebuild (vorher das "gentoolkit" Packet Installieren )

5

23.08.2006, 18:32

RE: emerge von cdk schlägt fehl.

Hallo,

ich weiss nicht ob du das Problem schon geloest hast. Wenn nicht dann setzte mal ein Link von gcc 3.4.6 nach gcc 3.4.4. Ich weiss nicht ob das so richtig ist aber bei mir hat es geklappt.

mfg
Joerg

6

23.08.2006, 21:59

Super, ich habe den link von 3.4.4 auf 3.4.6 gesetzt.
Jetzt gehts!

Das prob ist gelöst!
Ullrich Andreas
Meine Konfiguration:
x86_64/Gentoo-10.1/gcc Version 4.5.3/KDE-Version 4.9.3/Kernel version 2.6.34-gentoo-r6
Graphic: 2x Nvidia 9600-GT OC SLI,Drucker: Samsung CLP-315W