Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

22.09.2006, 19:06

[gelöst] mplayer im Vollbild abspielen

Also vor meiner Neuinstallation von Gentoo konnte ich meine Filme die ich mit meiner TV-Karte aufgenommen habe noch in Vollbild sehen, nachdem ich aber jetzt gentoo frisch installiert habe eigentlich mit dem selben Konfigurations dateien funktioniert es nicht mehr.

kde 3.5.2
Bildschirmauflösung 1280x1024
Filmauflösung 756x576

Also wenn ich auf F drücke springt der Mplayer schon in den Vollbild modus aber der film bleibt weiterhin so klein wie er ist sprich 756x576.


Weiß jemand wie man den Fehler korrigieren kann?
Phenom X4 9550
Gigabyte GA-MA770-UD3
Gentoo 64 Bit Stable
8 GB Ram
Audigy 2 Zs
Geforce 9800 GTX
VDR
Hauppauge Nexus-S Rev 2.2 + 2.1

Lenovo G550 T4300
Gentoo 64 Bit Stable
4 GB Ram

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »cyrix20« (22.09.2006, 21:20)


2

22.09.2006, 19:27

weiß es nich direkt, aber ich glaube, du hast da dass use flag falsch gesetzt, hatte ich auch mal, und dann habe ich mit neuen use flags gemerged, und dann gings wieder, gibt bestimmtn how to, wofür man die meiseten use flags braucht, oder bsit du dir sicher, dass es nich daran liegen kann?

3

22.09.2006, 21:19

Hab jetzt nach langem Suchen in einem anderen Forum die Lösung gefunden!!


Im Mplayer auf einstellungen -> Video -> statt X11 gl2 anwählen

Schon läufts!!!
Phenom X4 9550
Gigabyte GA-MA770-UD3
Gentoo 64 Bit Stable
8 GB Ram
Audigy 2 Zs
Geforce 9800 GTX
VDR
Hauppauge Nexus-S Rev 2.2 + 2.1

Lenovo G550 T4300
Gentoo 64 Bit Stable
4 GB Ram

4

25.10.2006, 00:49

Bei mir kommt dann ein Fehler:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
$ mplayer -vo gl2 film.avi
...
....
....
VO: [gl2] 512x384 => 512x384 BGR 24-bit  
Xlib:  extension "GLX" missing on display ":0.0". 
Xlib:  extension "GLX" missing on display ":0.0". 
[gl2] no GLX support present FATAL: 
Kann Videoausgabetreiber nicht initialisieren! VDec: VO wird versucht,
auf 512 x 384 (Bevorzugter Farbraum: Planar YV12) zu setzen.
VDec: using Planar YV12 as output csp (no 0) Film-Aspekt ist 1.33:1 -
Vorskalierung zur Korrektur der Seitenverhältnisse.
No accelerated colorspace conversion found VO:
[gl2] 512x384 => 512x384 BGR 24-bit  
Xlib:  extension "GLX" missing on display ":0.0". 
Xlib:  extension "GLX" missing on display ":0.0". 
[gl2] no GLX support present 
FATAL: Kann Videoausgabetreiber nicht initialisieren!  
FATAL: Konnte Videofilter (-vf) oder -ausgabetreiber (-vo) nicht initialisieren. 


Auch "gl" und "xorgx" scheitern :-(
Im Übrigen bin ich der Meinung, daß Karthago zerstört werden muß.

[SIZE=5]AMD Athlon-XP 3000+, ATI Radeon 9200SE, 120 GB HD, 518 DDR-RAM
Gentoo seit 2004.3, KDE, Qt, -Gnome
[/SIZE]

5

25.10.2006, 07:19

/etc/mplayer.conf bearbeiten und die Option "zoom=yes" setzen.
"Erst nachdem wir alles verloren haben, haben wir die Freiheit, alles zu tun."
"It's only after we've lost everything, that we're free to do anything!"

Jabber: Die ID kann via PN erfragt werden.

6

25.10.2006, 15:58

Hm, danke, die Idee war nicht schlecht. Es funktioniert auch, aber
es ruckelt verdammt arg:

Quellcode

1
2
3
 ***************************************************
 **** Dein System ist zu LANGSAM zum Abspielen! ****
 ***************************************************


Ich hab auch noch die mplayer.conf vom alten System gecheckt,
da hatte ich nichts verändert...

Ich bin mir sicher, daß es mit gl2 gehen würde, weiß aber nicht,
welches Paket ich dafür brauche. openGL hab ich in der make.conf
drin ?(
Im Übrigen bin ich der Meinung, daß Karthago zerstört werden muß.

[SIZE=5]AMD Athlon-XP 3000+, ATI Radeon 9200SE, 120 GB HD, 518 DDR-RAM
Gentoo seit 2004.3, KDE, Qt, -Gnome
[/SIZE]

7

25.10.2006, 16:10

Alternativ kannst mal xv probieren (USE-Flag setzen nicht vergessen).
"Erst nachdem wir alles verloren haben, haben wir die Freiheit, alles zu tun."
"It's only after we've lost everything, that we're free to do anything!"

Jabber: Die ID kann via PN erfragt werden.

8

25.10.2006, 19:45

[gelöst][gelöst] mplayer im Vollbild abspielen
;)
Danke





.
Im Übrigen bin ich der Meinung, daß Karthago zerstört werden muß.

[SIZE=5]AMD Athlon-XP 3000+, ATI Radeon 9200SE, 120 GB HD, 518 DDR-RAM
Gentoo seit 2004.3, KDE, Qt, -Gnome
[/SIZE]