Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

19.12.2006, 16:08

T43 libata und Kernel 2.6.19

Hi,

schon längere Zeit verwende ich auf meinem Thinkpad T43 Gentoo Linux. Bisher habe ich es nie hinbekommen mein DVD Laufwerk mit den SATA Treibern zu verwenden.

siehe: Problemen mit SATA unter LINUX (englisch)

Da der neue 2.6.19er Kernel eine Verbesserung dieses Problems versprach dachte ich, dies wäre mal wieder einen Versuch wert, da ich bisher keine DVD's ansehen konnte (Laufwerk zu langsam).

Nach einem make oldconfig und einigen Anpassungen..

Quellcode

1
2
3
4
5
6
7
8
9
10
Device Drivers  --->  ATA/ATAPI/MFM/RLL support   komplett deaktiviert
Device Drivers  --->  Serial ATA (prod) and Parallel ATA (experimental) drivers  --->
   <*> ATA device support
   <*>   AHCI SATA support
   < >   ServerWorks Frodo / Apple K2 SATA support
   <*>   Intel PIIX/ICH SATA support
   ...
   <*>   Intel PATA MPIIX support
   <*>   Intel PATA old PIIX support (Experimental)
   ...

Erkennt das System auch meine Festplatten nicht.

Hat irgendjemand das selbe Problem, oder hat es irgendjemand gelöst?

Gruß

Christian

EDIT:
Aus irgend einem Grund laufen die Festplatten nach einem erneuten Kernel Compilieren wieder. Doch mein DVD-Laufwerk ist noch immer nicht zu finden.

Boot Parameter sind unter anderem. libata.atapi=enabled hdc=noprobe
Wobei hdc=noprobe wohl überflüssig ist, wenn ich keine IDE Treiber mehr habe...

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Junior« (19.12.2006, 16:20)