Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

14.02.2008, 18:28

Probleme beim emergen - segmentation fault, glibc error, ...

Hi,
ich hab auf einem Rechner ein 32bit Gentoo installiert. Leider erhalte ich beim emergen von Programmen immer wieder Fehler.

Quellcode

1
2
3
4
5
 pcre_exec.c:4938: internal compiler error: Segmentation fault 
Please submit a full bug report, with preprocessed source if appropriate. 
See  for instructions.  

The bug is not reproducible, so it is likely a hardware or OS problem. 


oder

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
*** glibc detected *** /bin/bash: double free or corruption (out): 0x08111cd0 **
*
======= Backtrace: =========
/lib/libc.so.6[0xb7e3ba00]
/lib/libc.so.6(cfree+0x89)[0xb7e3d6f9]
/bin/bash(dispose_word+0x18)[0x8069f68]
/bin/bash(dispose_words+0x57)[0x806a077]
/bin/bash(dispose_command+0x1bb)[0x806a2ab]
/bin/bash(dispose_command+0x83)[0x806a173]
/bin/bash(dispose_command+0x78)[0x806a168]
/bin/bash(dispose_command+0x78)[0x806a168]
/bin/bash(dispose_command+0x78)[0x806a168]
/bin/bash(dispose_command+0x78)[0x806a168]
/bin/bash(dispose_command+0x78)[0x806a168]
/bin/bash(dispose_command+0x9b)[0x806a18b]
/bin/bash[0x808a897]
/bin/bash[0x808a5d0]
/bin/bash[0x806dccc]
/bin/bash[0x806ebee]
/bin/bash(execute_command_internal+0x5b3)[0x806ce23]
/bin/bash(execute_command+0x60)[0x806b4f0]
/bin/bash[0x806c38e]
/bin/bash(execute_command_internal+0xa23)[0x806d293]
/bin/bash(execute_command+0x60)[0x806b4f0]
/bin/bash(reader_loop+0x70)[0x805e880]
/bin/bash(main+0x122c)[0x805e39c]
/lib/libc.so.6(__libc_start_main+0xdc)[0xb7debfdc]
/bin/bash[0x805c0b1]
======= Memory map: ========
08048000-080e3000 r-xp 00000000 08:03 1427840	/bin/bash
080e3000-080e8000 rw-p 0009a000 08:03 1427840	/bin/bash
080e8000-08150000 rw-p 080e8000 00:00 0      	[heap]
b7b00000-b7b21000 rw-p b7b00000 00:00 0
b7b21000-b7c00000 ---p b7b21000 00:00 0
b7c99000-b7ca3000 r-xp 00000000 08:03 1480894	/usr/lib/gcc/i686-pc-linux-gnu/
4.1.2/libgcc_s.so.1
b7ca3000-b7ca4000 r--p 00009000 08:03 1480894	/usr/lib/gcc/i686-pc-linux-gnu/
4.1.2/libgcc_s.so.1
b7ca4000-b7ca5000 rw-p 0000a000 08:03 1480894	/usr/lib/gcc/i686-pc-linux-gnu/
4.1.2/libgcc_s.so.1
b7cae000-b7ced000 r--p 00000000 08:03 606239 	/usr/lib/locale/de_DE.utf8/LC_C
TYPE
b7ced000-b7cee000 r--p 00000000 08:03 606240 	/usr/lib/locale/de_DE.utf8/LC_N
UMERIC
b7cee000-b7cef000 r--p 00000000 08:03 606241 	/usr/lib/locale/de_DE.utf8/LC_T
IME
b7cef000-b7dcf000 r--p 00000000 08:03 606242 	/usr/lib/locale/de_DE.utf8/LC_C
OLLATE
b7dcf000-b7dd0000 r--p 00000000 08:03 606243 	/usr/lib/locale/de_DE.utf8/LC_M
ONETARY
b7dd0000-b7dd1000 r--p 00000000 08:03 606245 	/usr/lib/locale/de_DE.utf8/LC_M
ESSAGES/SYS_LC_MESSAGES
b7dd1000-b7dd2000 r--p 00000000 08:03 606246 	/usr/lib/locale/de_DE.utf8/LC_P
APER
b7dd2000-b7dd3000 r--p 00000000 08:03 606247 	/usr/lib/locale/de_DE.utf8/LC_N
AME
b7dd3000-b7dd4000 r--p 00000000 08:03 606248 	/usr/lib/locale/de_DE.utf8/LC_A
DDRESS
b7dd4000-b7dd5000 r--p 00000000 08:03 606249 	/usr/lib/locale/de_DE.utf8/LC_T
ELEPHONE
b7dd5000-b7dd6000 rw-p b7dd5000 00:00 0
b7dd6000-b7f00000 r-xp 00000000 08:03 1511858	/lib/libc-2.6.1.so
b7f00000-b7f02000 r--p 0012a000 08:03 1511858	/lib/libc-2.6.1.so
b7f02000-b7f03000 rw-p 0012c000 08:03 1511858	/lib/libc-2.6.1.so
b7f03000-b7f06000 rw-p b7f03000 00:00 0
b7f06000-b7f08000 r-xp 00000000 08:03 1511874	/lib/libdl-2.6.1.so
b7f08000-b7f09000 r--p 00001000 08:03 1511874	/lib/libdl-2.6.1.so
b7f09000-b7f0a000 rw-p 00002000 08:03 1511874	/lib/libdl-2.6.1.so
b7f0a000-b7f43000 r-xp 00000000 08:03 1556482	/lib/libncurses.so.5.6
b7f43000-b7f4b000 rw-p 00039000 08:03 1556482	/lib/libncurses.so.5.6
b7f4b000-b7f4d000 rw-p b7f4b000 00:00 0
b7f4d000-b7f4e000 r--p 00000000 08:03 606250 	/usr/lib/locale/de_DE.utf8/LC_M                                	EASUREMENT
b7f4e000-b7f55000 r--s 00000000 08:03 1721127	/usr/lib/gconv/gconv-modules.ca                                	che
b7f55000-b7f56000 r--p 00000000 08:03 606251 	/usr/lib/locale/de_DE.utf8/LC_I                                	DENTIFICATION
b7f56000-b7f70000 r-xp 00000000 08:03 1511856	/lib/ld-2.6.1.so
b7f70000-b7f71000 r--p 00019000 08:03 1511856	/lib/ld-2.6.1.so
b7f71000-b7f72000 rw-p 0001a000 08:03 1511856	/lib/ld-2.6.1.so
bf9b1000-bf9c7000 rw-p bffea000 00:00 0      	[stack]
ffffe000-fffff000 r-xp 00000000 00:00 0      	[vdso]
 


gcc und glibc hab ihc schon reemergt. Den Arbeitsspeicher hab ich auch schon mit memtest86+ überprüft.

An was können die Fehler noch liegen?

Hier noch ein paar Deatils zur Hardware:

Quellcode

1
2
3
4
5
6
7
8
9
CPU: Intel D Processor 805, 2x2666MHz
RAM: 2x 2GB von GeIL
Mainboard: Asus P5GC-VM
GraKa: Asus EN6200LE TC256/TD 
Soundkarte: Terratec Aureon 5.1   
TV-Karte 1: Pinnacle PCTV Sat   
TV-Karte 2: Pinnacle PCTV Sat XE   
Festplatte: Samsung HD250HJ   
DVD-Brenner: Samsung SH-S203D


Danke für eure Hilfe.

dsiggi

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »dsiggi« (19.03.2008, 17:23)


2

14.02.2008, 18:55

Hallo,

wie oft hast du den Memtest denn durchlaufen lassen?
Beim Emergen kann da schon der RAM mehr gefordert werden. Bau doch mal zum Test einen Riegel abwechselnd heraus und teste, ob es dann funktioniert.
Tritt der Error bei jedem Emerge oder nur sporadisch auf?
...so long, Sven

Wiki Blog

3

14.02.2008, 18:59

Hi,
ich hab Memtest über Nacht (ca. 9 Stunden) laufen lassen. Ohne Fehler.

Das mit dem Ausbauen werd ich mal testen.

Die Fehler tretten nur sporadisch auf.

Grad eben wollt ich mein System updaten. Andauernt bricht emerge ab. Nach einem Neustart läuft es aber.

4

14.02.2008, 19:43

Klingt für mich nach nem Problem mit den RAM´s. Wenn ich raten müsste ^^, würd ich vll. auch noch die Festplatten und/oder ein thermisches Problem in Betracht ziehen.
...so long, Sven

Wiki Blog

5

14.02.2008, 20:55

Hi,
also Übertemperatur schließ ich aus. Das Gehäuse ist offen, und die CPU hat maximal 46°C.

Wegen Festplatte: Gibt es hierfür auch ein Tool wie memtest, um diese zu testen?

dsiggi

mollilinux

unregistriert

6

14.02.2008, 20:59

hast du Änderungen an deiner Hardware vorgenommen, wie z.B eine stärkere Grafikkarte oder mehr RAM?

Könnte sein dass dein Netzteil zu schwach ist.

Wieviel Watt hat dein Netzteil?

7

14.02.2008, 21:43

Nabend dsiggi

Hast du eventuell Übertaktet (Overclocking) ?
FSB korrekt eingestellt?
Zu scharfe Latenzen im Ram eingestellt?

Oder wie mollilinux schon anmerkte, eventuell ein zu schwaches Netzteil?

MfG
josef.95

8

15.02.2008, 07:55

Hallo,

Du kannst das ganze System ja mal mit toolstar testen lassen. Ansonsten würde ich auch noch im Bios versuchen alles auf Safe zu stellen (also schön slow :D :D ).

Viele Grüße

Andreas
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

9

15.02.2008, 13:14

Hi,
bin grad dabei GCC mit verschiedenen Ram Konfigirationen zu bauen. Bin mla gepannt obs am RAm liegt.

Die Hardware ist komplett (außer die TV-Karten) neu.

Das Netzteil hat 300W.

Am FSB und sonstigem kann cih gar nix ändern. Das ist im Bios nicht möglich.

Einstellungen laut Bios für CPU:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
Frequency: 2.666Hz
FSB Speed: 533MHz
Cache L1: 32kB
Cache L2: 2048kB
Radio Actual Value: 20
CPUID: F47

Hardware Prefetcher: Enabled
Adjacent Cache Line Prefetch: Enabled
Max CPUID Value Limit: Disabled
CPU TM function: Enabled
Execute Disable Bit: Enabled
Single Logical Processor Mode: Disabled


Einstellunge laut Bios für RAM:

Quellcode

1
2
3
4
DRAM Frequenzy: Auto
Configure DRAM Timing by SPD: Enabled
Hyper Path 3: Auto
DRAM Throttling Threshold: Auto


Von toolstar hab ich mir mal die Demo-Version geladen, werd ich dann mal drüber laufen lassen.

dsiggi

10

15.02.2008, 13:47

Was hast Du alles für Hardware im System verbaut?
Meine Rechtschreibfehler sind gewollt und unterliegen dem Copyright des Verfassers, es sei denn, sie sind explizit unter die GPL gestellt .....

Außerdem sind sie ein Ausdruck der Persönlichkeit des Schreibers!

11

15.02.2008, 14:30

CPU: Intel D Processor 805, 2x2666MHz
RAM: 2x 2GB von GeIL
Mainboard: Asus P5GC-VM
GraKa: Asus EN6200LE TC256/TD
Soundkarte: Terratec Aureon 5.1
TV-Karte 1: Pinnacle PCTV Sat
TV-Karte 2: Pinnacle PCTV Sat XE
Festplatte: Samsung HD250HJ
DVD-Brenner: Samsung SH-S203D

12

15.02.2008, 15:02

2 TV Karten + Grafikbeschleuniger ... kommt man da mit einem 300W Netzteil aus?
+ 2 Cpu + 2 Speicher .....

Hast Du mal eine Verbrauchsberechnung durchgeführt?

P.S: was für ein Netzteil (Hersteller, Typ, Wirkungsgrad) ist es denn??
Meine Rechtschreibfehler sind gewollt und unterliegen dem Copyright des Verfassers, es sei denn, sie sind explizit unter die GPL gestellt .....

Außerdem sind sie ein Ausdruck der Persönlichkeit des Schreibers!

13

15.02.2008, 15:57

Hi,
so eine Verbrauchsrechung hab ich nicht gemacht. Das ist halt das Standart Netzteil von dem Gehäuse.

Quellcode

1
2
3
4
5
6
Hersteller: Asus
Bezeichnung: TS-300P
Gesamt 250 Watt
Combined Power 3,3V/5V 135 Watt
Eingangsspannung 230V, 50Hz                                                                                                                                                                                                                                    
Hauptanschluss


Vom Wirkungsgrad steht nix drauf.

dsiggi

14

15.02.2008, 16:27

2 TV Karten + Grafikbeschleuniger ... kommt man da mit einem 300W Netzteil aus?
+ 2 Cpu + 2 Speicher .....

Zitat

Combined Power 3,3V/5V 135 Watt


Ich denke auch, das könnte knapp werden, die CPU schluckt ja schon ca.110 Watt (unter voll last und das ist beim Compilieren ja meist der Fall)

Du könntest ja mal zum Testen die beiden TV Karten heraus nehmen.

MfG
josef.95

15

15.02.2008, 16:42

Okay,
werd ich machen. Lass grad die Demo-Version von toll*star drüber laufen.
CPU, RAM, Graka, PCI-Karten sind okay. Grad testet er die Festplatte.

dsiggi

16

16.02.2008, 14:33

Hab grad gcc 2 mal emergen lassen, keine Probleme.
Dann hab ich mythtv gestartet und TV mit PiP geschaut. Also beide TV-Karten + Graka waren in Benutzung.

Dann hab ich noch mla gcc emergen lassen, dort kam nun folgender Fehler

Quellcode

1
2
3
4
5
6
7
8
/var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/gcc/dojump.c:161: interner Compiler-Fehler: in stmt_ann, bei tree-flow-inline.h:148
Bitte senden Sie einen vollständigen Fehlerbericht auf Englisch ein;
bearbeiten Sie die Quellen zunächst mit einem Präprozessor, wenn es
dienlich ist.
Fehler in der deutschen Übersetzung sind an translation-team-de@lists.sourceforge.net zu melden.

Gehen Sie gemäß den Hinweisen in <URL:http://bugs.gentoo.org/> vor.
The bug is not reproducible, so it is likely a hardware or OS problem.


Ist wahrscheinlich wirklich das Netzteil.

ddsiggi

17

16.02.2008, 18:28

Ist wahrscheinlich wirklich das Netzteil.


Das würde ich auch so sehen!
Eine solide Stromversorgung ist das a und o eines jeden PC,s
Ich würde empfehlen dir ein gutes Marken Netzteil mit ca. 450 - 500 Watt zu holen.

MfG
josef.95

18

18.02.2008, 16:37

Also bei der Belastung würde ich auch sagen, das die Stromversorgung Heftig" Unterdimensioniert ist:
"Gesamt 250 Watt"

Habe zwar bei meinem Server es auch (300 Watt und dann 6 Platten), dort ist aber die CPU etwas seeehr viel kleiner ... ;o)
Meine Rechtschreibfehler sind gewollt und unterliegen dem Copyright des Verfassers, es sei denn, sie sind explizit unter die GPL gestellt .....

Außerdem sind sie ein Ausdruck der Persönlichkeit des Schreibers!

19

18.02.2008, 19:51

Das würde ich auch so sehen!
Eine solide Stromversorgung ist das a und o eines jeden PC,s
Ich würde empfehlen dir ein gutes Marken Netzteil mit ca. 450 - 500 Watt zu holen.


Ich würde vor allem auf den Wirkungsgrad achten. Das Netzteil sollte auf jeden Fall min 80 % Wirkungsgrad haben, ansonsten verpufft alles in Hitze und Wärme und das Ist gut für EON aber schlecht für Deinen Geldbeutel.

Lieber nen Paar Euro mehr ausgeben.


Viele Grüße
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

20

20.02.2008, 15:46

Hi,
etz hab ich ein Problem
Es handelt sich ja um ein µATX-Netzteil. Ich hab hab maximal eins mit 380Watt gefunden.
Reicht das?

dsiggi