Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

19.04.2008, 21:43

probleme nach RAM upgrade auf 4GiB

Hallo!

Ich habe für mein HP 530 Notebook 2x2GiB DDR2 RAM gekauft und gleich eingebaut. Jetzt hab ich ein paar kleine Probleme :D.
Im BIOS wird 4GiB angezeigt und dmidecode -t memory sagts auch:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
# dmidecode 2.9
SMBIOS 2.4 present.

Handle 0x000A, DMI type 16, 15 bytes
Physical Memory Array
	Location: System Board Or Motherboard
	Use: System Memory
	Error Correction Type: None
	Maximum Capacity: 4 GB
	Error Information Handle: No Error
	Number Of Devices: 2

Handle 0x000B, DMI type 17, 27 bytes
Memory Device
	Array Handle: 0x000A
	Error Information Handle: No Error
	Total Width: 64 bits
	Data Width: 64 bits
	Size: 2048 MB
	Form Factor: SODIMM
	Set: None
	Locator: DIMM #1
	Bank Locator: Not Specified
	Type: DDR2
	Type Detail: Synchronous
	Speed: 667 MHz (1.5 ns)
	Manufacturer: 7F98000000000000
	Serial Number: 8D354F62
	Asset Tag: Not Specified
	Part Number: 9905295-055.A00LF 

Handle 0x000C, DMI type 17, 27 bytes
Memory Device
	Array Handle: 0x000A
	Error Information Handle: No Error
	Total Width: 64 bits
	Data Width: 64 bits
	Size: 2048 MB
	Form Factor: SODIMM
	Set: None
	Locator: DIMM #2
	Bank Locator: Not Specified
	Type: DDR2
	Type Detail: Synchronous
	Speed: 667 MHz (1.5 ns)
	Manufacturer: 7F98000000000000
	Serial Number: 83354762
	Asset Tag: Not Specified
	Part Number: 9905295-055.A00LF





Problem 1 - Sound:

Die Audio Ausgabe via ALSA funktioniert nicht mehr richtig. Wenn ich mplayer mit dem Parameter -ao alsa starte, bekomme ich folgende Fehlermeldung:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
....
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
[AO_ALSA] alsa-lib: pcm_mmap.c:369:(snd_pcm_mmap) mmap failed: Invalid argument
[AO_ALSA] alsa-lib: pcm_direct.c:975:(snd1_pcm_direct_initialize_slave) unable to install hw params
[AO_ALSA] alsa-lib: pcm_dmix.c:1008:(snd_pcm_dmix_open) unable to initialize slave
[AO_ALSA] Playback open error: Invalid argument
Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video

Exiting... (End of file)

... mit -ao alsa:device=hw=0,0,0 funktionierts. Natürlich hackt es hier bei allen Programen die auf die ALSA Schnitstelle zugreifen.

Problem 2 -DRI:
DRI Funktioniert nicht mehr.
Die xorg.conf und die Xorg.0.log habe ich angehängt (sonts wirds ein bisschen zu lang :D )
Ausgabe von glxinfo mit gesetzter LIBGL_DEBUG Variable:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
name of display: :0.0
libGL error: XF86DRIQueryDirectRenderingCapable returned false
display: :0  screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating, 
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method, 
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe, 
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context, 
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory, 
GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control, 
GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control, 
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync, 
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer, 
GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context, 
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer, 
GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGIS_multisample, 
GLX_SGIX_fbconfig, GLX_EXT_texture_from_pixmap
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)
OpenGL extensions:
GL_ARB_depth_texture, GL_ARB_draw_buffers, GL_ARB_fragment_program, 
GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture, 
GL_ARB_occlusion_query, GL_ARB_point_parameters, GL_ARB_point_sprite, 
GL_ARB_shadow, GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp, 
GL_ARB_texture_compression, GL_ARB_texture_cube_map, 
GL_ARB_texture_env_add, GL_ARB_texture_env_combine, 
GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3, 
GL_ARB_texture_mirrored_repeat, GL_ARB_texture_non_power_of_two, 
GL_ARB_texture_rectangle, GL_ARB_transpose_matrix, GL_ARB_vertex_program, 
GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, 
GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate, 
GL_EXT_blend_logic_op, GL_EXT_blend_minmax, GL_EXT_blend_subtract, 
GL_EXT_clip_volume_hint, GL_EXT_copy_texture, GL_EXT_draw_range_elements, 
GL_EXT_fog_coord, GL_EXT_framebuffer_object, GL_EXT_multi_draw_arrays, 
GL_EXT_packed_pixels, GL_EXT_paletted_texture, GL_EXT_point_parameters, 
GL_EXT_polygon_offset, GL_EXT_rescale_normal, GL_EXT_secondary_color, 
GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, 
GL_EXT_shared_texture_palette, GL_EXT_stencil_wrap, GL_EXT_subtexture, 
GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp, 
GL_EXT_texture_env_add, GL_EXT_texture_env_combine, 
GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias, 
GL_EXT_texture_mirror_clamp, GL_EXT_texture_object, 
GL_EXT_texture_rectangle, GL_EXT_vertex_array, GL_APPLE_packed_pixels, 
GL_ATI_draw_buffers, GL_ATI_texture_env_combine3, 
GL_ATI_texture_mirror_once, GL_ATIX_texture_env_combine3, 
GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate, 
GL_MESA_pack_invert, GL_MESA_ycbcr_texture, GL_NV_blend_square, 
GL_NV_fragment_program, GL_NV_light_max_exponent, GL_NV_point_sprite, 
GL_NV_texgen_reflection, GL_NV_texture_rectangle, GL_NV_vertex_program, 
GL_NV_vertex_program1_1, GL_SGI_color_matrix, GL_SGI_color_table, 
GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp, 
GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SGIX_depth_texture, 
GL_SGIX_shadow, GL_SGIX_shadow_ambient, GL_SUN_multi_draw_arrays

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
0x24 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x27 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
0x28 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
0x29 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x2a 24 dc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x5c 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon

Ich bin für jeden Tipp dankbar.

Schönen Abend noch
Klemens
»klemens« hat folgende Dateien angehängt:
  • Xorg.0.log.txt (42,36 kB - 1 mal heruntergeladen - zuletzt: 20.04.2008, 00:49)
  • xorg.conf.txt (3,12 kB - 1 mal heruntergeladen - zuletzt: 20.04.2008, 00:51)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »klemens« (24.04.2008, 11:19)


2

20.04.2008, 00:25

Hallo Klemens

Bist du dir sicher das die genanten Probleme mit der Ram Aufrüstung zusammenhängen?
Was für ein System verwendest du? (Architektur, 32 oder 64Bit)

Wie hat dein System den neuen Ram aufgenommen, was sagt ein:

Quellcode

1
2
3
grep MemTotal /proc/meminfo
und
dmesg | grep mem
?
Bedenke das du bei einem 32Bit System mit 4Gig Ram im Kernel CONFIG_HIGHMEM64G setzen solltest.

MfG
josef.95

3

20.04.2008, 15:35

Hallo Josef,

danke für deine rasche Antwort!

Ich habe ein 32Bit System, Prozessor ist ein Intel T2050 (1,6GHz)

Ausgabe von lspci

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 01)
02:06.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
02:08.0 Ethernet controller: Intel Corporation 82562ET/EZ/GT/GZ - PRO/100 VE (LOM) Ethernet Controller Mobile (rev 01)
10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
 

Ausgabe von grep MemTotal /proc/meminfo

Quellcode

1
MemTotal:  3494080 kB



Ausgabe von dmesg | grep mem

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
  DMA zone: 32 pages used for memmap
  Normal zone: 1760 pages used for memmap
  HighMem zone: 5103 pages used for memmap
  Movable zone: 0 pages used for memmap
swsusp: Registered nosave memory region: 000000000009f000 - 00000000000a0000
swsusp: Registered nosave memory region: 00000000000a0000 - 00000000000e0000
swsusp: Registered nosave memory region: 00000000000e0000 - 0000000000100000
Memory: 3491216k/3530560k available (4484k kernel code, 38116k reserved, 1964k data, 292k init, 2613056k highmem)
virtual kernel memory layout:
lowmem  : 0xc0000000 - 0xf8000000   ( 896 MB)
system 00:00: iomem range 0x0-0x9ffff could not be reserved
system 00:00: iomem range 0xe0000-0xfffff could not be reserved
system 00:00: iomem range 0x100000-0xd77fffff could not be reserved
system 00:09: iomem range 0xffb00000-0xffbfffff could not be reserved
system 00:09: iomem range 0xfff00000-0xffffffff could not be reserved
system 00:0a: iomem range 0xf8000000-0xfbffffff has been reserved
system 00:0a: iomem range 0xfec00000-0xfec000ff could not be reserved
system 00:0a: iomem range 0xfed20000-0xfed3ffff could not be reserved
system 00:0a: iomem range 0xfed45000-0xfed8ffff could not be reserved
system 00:0a: iomem range 0xfed90000-0xfed9afff could not be reserved
system 00:0b: iomem range 0xfeda0000-0xfedbffff could not be reserved
system 00:0b: iomem range 0xfee00000-0xfee00fff could not be reserved
Freeing initrd memory: 1728k freed
highmem bounce pool size: 64 pages
Total HugeTLB memory allocated, 0
agpgart: Detected 7932K stolen memory.
ehci_hcd 0000:00:1d.7: irq 19, io mem 0xf0584000
Freeing unused kernel memory: 292k freed


Im Kernel ist alles richtig eingestellt:

zcat /proc/config.gz | grep HIGHMEM

Quellcode

1
2
3
4
5
# CONFIG_NOHIGHMEM is not set
# CONFIG_HIGHMEM4G is not set
CONFIG_HIGHMEM64G=y
CONFIG_HIGHMEM=y
# CONFIG_DEBUG_HIGHMEM is not set

Schönen Tag noch
Klemens

4

21.04.2008, 10:20

Moin Klemens

Die Ausgaben bezüglich des Ram schauen doch soweit ich es beurteilen kann ganz OK aus.

Zur Grafik:

Quellcode

1
2
3
4
5
6
7
8
Section "Monitor"
	#DisplaySize	  330   210	# mm
	Identifier   "Monitor0"
	VendorName   "LPL"
	ModelName    "db00"
        HorizSync    ?? - ??
        VertRefresh  ?? - ??
EndSection
Hier würde ich eventuell noch die Frequenzen mit angeben die dein Display schafft.

In der Section "Screen" würde ich noch:
DefaultDepth 24
hinzufügen,
und in der SubSection noch etwa

SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection

Die Modes solltest du noch deinem Display Format anpassen.
Zum ermitteln der Monitor Daten eignet sich zb das Tool
sys-apps/ddcxinfo-knoppix
recht gut.

MfG
josef.95

5

22.04.2008, 17:48

Les dir doch mal von der c't Ausgabe 8 (31.03.2008) die ganzen Artikel über 64 Bit (geht viel über 4 GB RAM) durch.
"Erst nachdem wir alles verloren haben, haben wir die Freiheit, alles zu tun."
"It's only after we've lost everything, that we're free to do anything!"

Jabber: Die ID kann via PN erfragt werden.

6

24.04.2008, 10:16

Hallo, danke für die Antworten.

Ich habe mir den Artikel in der C't durchgelesen und da stand, dass man bei einem 32Bit System PAE aktivieren muss.

Ist bei mir aber schon aktiviert: CONFIG_X86_PAE=y

Noch eine Frage, wenn ich auf z.B. Youtube geh und mir einen Film anschauen möchte, bekomm ich auf der Konsole folgende meldungen:

Quellcode

1
2
3
4
5
6
7
8
9
10
$ firefox 
ALSA lib pcm_mmap.c:369:(snd_pcm_mmap) mmap failed: Invalid argument
ALSA lib pcm_direct.c:975:(snd1_pcm_direct_initialize_slave) unable to install hw params
ALSA lib pcm_dsnoop.c:585:(snd_pcm_dsnoop_open) unable to initialize slave
ALSA lib pcm_mmap.c:369:(snd_pcm_mmap) mmap failed: Invalid argument
ALSA lib pcm_direct.c:975:(snd1_pcm_direct_initialize_slave) unable to install hw params
ALSA lib pcm_dsnoop.c:585:(snd_pcm_dsnoop_open) unable to initialize slave

(firefox-bin:6416): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
 


Weiss jemand wie man das beheben kann?

[EDIT]


Juhu.... Es geht.. :D Ich habe jetzt die Kernel Module unter /lib/modules gelöscht und den Kernel noch einmal vollständig neu übersetzt.Jetzt funktioniert DRI und ALSA wieder ohne Probleme...

Nochmals Danke für eure Hilfe!

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »klemens« (24.04.2008, 11:19)