Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

06.05.2008, 13:31

Raid 0; DmRaid -> Findet Root-Device nicht

Hallo.
Ich hatte Gentoo installiert und beim Booten kam folgende Meldung:

Quellcode

1
2
3
4
5
6
>> Activating mdev...
>> Activating Device-Mapper raid(s)...
>> Determining root device...
>> The root block device is unspecified or not detected
Please specify a device to boot, or "shell" for a shell...
boot() ::


Nach suche im Netz bin ich auf folgende Anleitung gestoßen -> http://de.gentoo-wiki.com/Installieren_v…d_Konfiguration

So wie ich das verstehe muß ich dort die aufwendigere Methode benutzen, da ich den Kernel 2.6.24 nutze.

Leider hagt es dort schon beim ersten Schritt. Entweder stimmt der Link nicht oder die Adresse gibts nicht mehr.

Nun meine Frage:

1. Gibts das auch irgendwo anders? Ich habe nichts gefunden.
2. Könnte ich das anders lösen?

Die leichtere Lösung hat auch nicht funktionert, da diese Genkernel-Version wohl nicht mehr im Portage-Tree ist.

P.s: Ich habe was gefunden -> http://gentoo-wiki.com/HOWTO_Install_Gen…id/dmraidinitrd
Das ist wohl das Skript. Kann ich das einfach so abtippen?

MfG eddi

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »eddi1983« (14.05.2008, 18:50)


2

06.05.2008, 14:07

Ich denke nicht Das Du die Aufwendige Lösung verwenden musst.

Die Lösung ist ja nun schon von 2006 oder noch älter

Zitat

Update: 26.09.2006: Habe auf dmraid-1.0.0.rc11 geupdated.


Was hast Du für Festplatten verbaut ?? STATA oder IDE ???

Wenn Du Sata hast und mit genkernel Deinen Kernel gebaut hast verwende bitte --manuconfig.

Quellcode

1
genkernel --menuconfig all


Dort dann bitte die Module für SATA eintragen!!

Ansonsten kannst Du mal bitte nach dem Fehler, so wie es dort steht "shell" eingeben.

Danach folgendes:

Quellcode

1
more /proc/partitions


und schauen ob Deine Platten angezeigt werden.

Viele Grüße
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

3

06.05.2008, 14:11

Hallo eddi, Willkommen im Forum ;)

Wie bist du nun vorgegangen beim bau der initrd?
wie hast du sie erstellt?

Prinzipiell funktioniert das script von Gerte Hoogewerf immer noch wunderbar, es müssen nur die URL's angepasst werden.

Die einfachere Methode wie in der Anleitung http://de.gentoo-wiki.com/Installieren_v…d_Konfiguration
beschrieben funktioniert wieder mit den Aktuellen genkernel scripts
Du solltest dir also mit den Aktuellen genkernel scripts eine lauffähige initrd bauen können.
Ich baue mir meinen kernel manuell, und lasse mir dann mit:

Quellcode

1
genkernel --dmraid initrd
die initrd bauen.

Wenn es mit einer neuen initrd immer noch nicht klappt, dann poste doch bitte auch mal dein grub.conf Eintrag

Stelle auch sicher das die Dateisystem Treiber die du verwendest (ext3 reiserfs) und die SATA Controller Treiber fest im kernel gesetzt sind.

EDIT:
Beachte auch: wenn du deinen kernel manuell baust das:

Quellcode

1
2
3
4
Device Drivers  --->
*] Multiple devices driver support (RAID and LVM)  --->
CONFIG_MD_RAID0=y
<*>   Device mapper support
gesetzt ist! (CONFIG_MD_RAID0 oder,und 1 eventuell anpassen)

MfG
josef.95

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »josef.95« (06.05.2008, 14:41)


4

06.05.2008, 15:05

So fuktioniert jetzt fast. Im Kernel waren die Sata-Treiber nicht mit drin. Initrd habe ich auch neu erstellt. ich weiß jetzt also nicht, was genau geholfen hat.

Jetzt habe ich nur noch Probleme mit Grub. Nur die Grub-Bash erscheint. Mit der Super-Grub-Disk kann ich Gentoo aber booten.

Mein Kernel und Grub befinden sich auf einer seperaten Partiion (hd0,0).
Root ist auf /dev/mapper/isw_hchhidchg_raid6

Hier die Grub.conf. Nur das Wichtigste

Quellcode

1
2
kernel (hd0,0)/boot/kernel-genkernel-x86_64-2.6.24-gentoo-r7 root=/dev/ram0 real_root=/dev/mapper/isw_hchhidchg_raid6 init=/linuxrc ramdisk=8192 dodmraid udev
initrd (hd0,0)/boot/initramfs-genkernel-x86_64-2.6.24-gentoo-r7


Die Boot-Partition ist primär.
Der Rest ist auf logischen Partitionen.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »eddi1983« (06.05.2008, 15:12)


5

06.05.2008, 15:32

So fuktioniert jetzt fast. Im Kernel waren die Sata-Treiber nicht mit drin. Initrd habe ich auch neu erstellt. ich weiß jetzt also nicht, was genau geholfen hat.
Es werden wahrscheinlich die fehlenden SATA Treiber gewesen sein.

Zu grub
Installiere grub doch einfach noch mal neu in den mbr
Hast du im BIOS eingestellt, das von der HDD gebotet wird auf der die grub Partition liegt? Die HDD von der gebootet wird ist in der Regel dann (hd0)

6

06.05.2008, 15:56

Hmm. Das klappt net.

Habe den Grub in folgenden Schritten installiert,

Quellcode

1
2
3
4
5
#grub --device-map=/dev/null
grub> device (hd0,0) /dev/mapper/nvidia_abiccada1
grub> device (hd0) /dev/mapper/nvidia_abiccada
grub> root (hd0,0)
grub> setup (hd0)


Es kam auch keine Fehlermedlung. Grub müßte also richtig installiert sein. Oder sollte man den vorher deinstallieren? Geht das überhaupt?

Mit der Super-Grub-Disk kann ich es ja starten. Deise liest ja die menu.lst aus die auf der Platte ist. Und von dort kann ich dann ja Gentoo und Vista auswählen.

Weiß nicht was ich noch machen kann. Den Grub normal zu installieren geht bei Raid ja nicht.

7

06.05.2008, 16:04

Wo liegt deine /boot Partition genau?
Hast du sie mit auf dem raid , oder auf einer anderen HDD?

EDIT:
Wenn du /boot mit auf dem raid hast, dann beachte bitte grub nicht aus einer chroot Umgebung heraus auszuführen!!
Ansonsten sollte es wie in:
http://de.gentoo-wiki.com/Installieren_v…d_Konfiguration
klappen.

PS: Bin etwa gegen 20 Uhr wieder hier,
viel erfolg ;)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »josef.95« (06.05.2008, 16:25)


8

06.05.2008, 16:34


Habe den Grub in folgenden Schritten installiert,

Quellcode
#grub --device-map=/dev/null
grub> device (hd0,0) /dev/mapper/nvidia_abiccada1
grub> device (hd0) /dev/mapper/nvidia_abiccada
grub> root (hd0,0)
grub> setup (hd0)

Es kam auch keine Fehlermedlung. Grub müßte also richtig installiert sein.


Zitat

device (hd0,0) /dev/mapper/nvidia_abiccada1
Du musst natürlich den Namen des Raid's anpassen!
Also ähnlich wie

Quellcode

1
grub> device (hd0,0) /dev/mapper/isw_hchhidchg_raid???

9

06.05.2008, 18:46

Ja. Natürlich. Es lief auch vorgestern schonmal. Mußte aber wegen einem Fehler Gentoo neu installieren.

Meine Boot-Partition ist: dev/mapper/isw_hchhidchg_raid1.
Meine Root-Partition ist: dev/mapper/isw_hchhidchg_raid6.

Meine grub.conf:

Quellcode

1
2
kernel (hd0,0)/boot/kernel-genkernel-x86_64-2.6.24-gentoo-r7 root=/dev/ram0 real_root=/dev/mapper/isw_hchhidchg_raid6 init=/linuxrc ramdisk=8192 dodmraid udev
initrd (hd0,0)/boot/initramfs-genkernel-x86_64-2.6.24-gentoo-r7


Oder muß ich dort wo jetzt raid6 steht raid1 eintragen. Also /boot oder /root.

Zu allem überfluß kann ich keine Kernel mehr kompilieren. Der Vorgang bricht mit

Quellcode

1
genkernel failed to compile modules

ab.

10

06.05.2008, 20:26

Hallo eddi, sorry für meine knappe Antwort vorhin, ich wahr etwas im Stress.

Der Eintrag in der grub.conf sollte eigentlich korrekt sein.
Wie ist den jetzt der Aktuelle stand, kannst du das Gentoo auf dem Raid mit der "Super-Grub-Disk" korrekt booten,und läuft es dann korrekt?

11

06.05.2008, 22:05

Ja.
Mit der Super-Grub-Disk kann ich Gentoo wie Vista einwandfrei booten. Die Disk holt sich ja die Menu.lst von der Partition. Nur greift wohl Grub da nicht drauf zu oder es findet sie nicht.

12

06.05.2008, 22:22

Hm.. , bist du dir sicher das von der richtigen HDD (Raid Verbund) gebootet wird, sprich BIOS Einstellung?

13

06.05.2008, 22:27

Dort kann man nur Harddisk auswählen. Keine unterschiedlichen Platten. Grub hat sich auch zerschossen. Ich installier Gentoo wohl nochmal neu.

14

06.05.2008, 22:46

Dort kann man nur Harddisk auswählen. Keine unterschiedlichen Platten.
Hm.. das kann ich so kaum glauben, du mußt im BIOS doch Auswählen können von welcher HDD gebootet wird, wenn mehrere HDD's vorhanden sind?

Zitat

Grub hat sich auch zerschossen. Ich installier Gentoo wohl nochmal neu.
grub sollte sich neu Installieren lassen, der mbr sollte sich auch neu schreiben lassen.
Was ist passiert mit deinem gentoo?, kann man es nicht mehr retten?
Du kannst sonst auch mit einer 64BitLiveCD per chroot ins gentoo wechseln und versuchen es wieder in Ordnung zu bringen.

15

06.05.2008, 22:47

Neu installieren, nur weil der Bootloader nicht geht? Selbst bei Windows gibt es schon Möglichkeiten den Bootloader ohne eine Neu-Installation zu schreiben. Bei der Neu-Installation wirst Du wahrscheinlich an der selben Stelle hängen bleiben.
Solange Du auf das System noch per Live-CD oder Super-Grub-Disk zugreifen kannst, ist nichts verloren.
Poste mal folgendes durch:

Quellcode

1
2
3
4
5
ls -l /boot
ls -l /dev/mapper/
cat /boot/grub/menu.lst
mount
fdisk -l
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

16

06.05.2008, 23:06

fdisk -l


bei einem dmraid muss es

Quellcode

1
fdisk -l dev/mapper/isw_hchhidchg_raid
lauten.

17

07.05.2008, 11:40

EDIT:
Wenn du /boot mit auf dem raid hast, dann beachte bitte grub nicht aus einer chroot Umgebung heraus auszuführen!!
Was meinst du damit? Bei der Installation ist man ja in einer Chroot-Umgebung.


Dort kann man nur Harddisk auswählen. Keine unterschiedlichen Platten.
Hm.. das kann ich so kaum glauben, du mußt im BIOS doch Auswählen können von welcher HDD gebootet wird, wenn mehrere HDD's vorhanden sind?

Ich habe da was gefunden. Man kann dort aber nur SCSI-0: Intel Raid und austauschbaren Datenträger wählen. Steht auf SCSI-0: Intel Raid.

Das folgende ist aus der Chroot-Umgebung. Muß mit der Live-CD booten. Hatte nochmal Genkernel ausgeführt. Jetzt hängt es dort beim booten. Wollte wieder den alten machen, hängt sich aber immer auf mit:

Quellcode

1
genkernel failed to compile modules


1. ls -l /boot

Quellcode

1
2
3
4
5
6
-rw-r--r--	1	root root	1276869	May	7	05:01	System.map-genkernel-x86_64-2.6.24-gentoo-r7
lrwxrwxrwx 1	root root            			  1	May    7   02:05	boot ->
drwxer-xr-x 2    root root      	1024    May        7  02:23	grub
-rw-r--r--      1    root root	2252937   May        7  02:32	initramfs-genkernel-x86_64-2.6.24-gentoo.r7
-rw-r--r-- 	 1   root root     2191928   May        7    05:01     kernel-genkernel-x86_64-2.6.24-gentoo-r7
 


2. ls -l /dev/mapper

Quellcode

1
2
3
4
5
6
7
8
9
10
11
crw-rw---- bla bla control
brw-------- bla bla isw_hchhidchg_raid1 -> Dort ist Boot (Primär)
siehe oben _raid2 -> Win (Primär)
s.o. _raid3 -> Win (Primär)
s.o. _raid5 -> Swap (logisch)
s.o. _raid6 -> Root (logisch)
s.o. _raid7 -> usr (log)
s.o. _raid8 -> usr/portage (log)
s.o. _raid9 -> home (log)
s.o. _raid10 -> fat32 (log)
s.o. _raid11 -> Win (log)


3. cat /boot/grub/menu.lst

Quellcode

1
No such file or directory

Hä? Woher holt sich dann die Super-Grub-Disk die Menu.lst

4. mount

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
rootfs on / type rootfs (rw)
tmpfs on /type tmpfs (rw)
/dev/sr0 on /mnt/cdrom type iso9660 (ro)
/dev/loop0 on /mnt/livecd type squashfs (ro)
proc on /proc type proc (rw,nosuid,nodev,noexec)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec)
udev on /dev type tmpfs (rw,nosuid)
devpts on /dev/pts type devpts (rw,nosuid,noexec)
tmpfs on /mnt/livecd/lib64/firmware type tmpfs (rw)
tmpfs on /mnt/livecd/usr/portage type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw,nosuid,noexec)
/dev/mapper/isw_hchhidchg_raid6 on / type ext3 (rw,data=ordered)
/dev/mapper/isw_hchhidchg_raid1 on /boot ext2 (rw)
/dev/mapper/isw_hchhidchg_raid7 on /usr type ext3 (rw)
/dev/mapper/isw_hchhidchg_raid8 on /usr/portage type reiserfs (rw)
/dev/mapper/isw_hchhidchg_raid9 on /home typ ext3 (rw,data=ordered)
none on /proc type proc (rw)
udev on /dev type tmpfs(rw,nosuid) 


5. fdsik -l /dev/mapper/isw_hchhidchg_raid

Quellcode

1
2
3
4
5
6
7
8
9
10
11
/dev/mapper/isw_hchhidchg_raid1 boot 83 Linux
_raid2 boot 7 NTFS
_raid3 7 NTFS 
_raid4 5 Extended
_raid5 82 Swap
_raid6 83 Linux
_raid7 83 Linux
_raid8 83 Linux
_raid9 83 Linux
_raid10 b Fat32
_raid11 7 NTFS


Ich hoffe das hilft euch weiter. Ich habe das alles tippen müssen. Ich befürchte aber, daß das nicht aussagekräftig ist, weil es von der Live-CD ist. Hoffentlich irre ich mich da.

18

07.05.2008, 12:04

(3) /boot/grub/menu.lst ist ein Link auf grub.conf. Existiert bei dir /boot/grub/grub.conf? Wenn ja, setze mal einen Symlink.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

19

07.05.2008, 12:36

Grub.conf existiert.
Wie würde der Symlink sein?

ln -sf /boot/grub/grub.conf /boot/grub/menu.lst

Ist das so richtig?

20

07.05.2008, 12:39

Zitat von »josef.95«
EDIT:
Wenn du /boot mit auf dem raid hast, dann beachte bitte grub nicht aus einer chroot Umgebung heraus auszuführen!!

Was meinst du damit? Bei der Installation ist man ja in einer Chroot-Umgebung.
Dies ist ein häufig begangener fehler, ist mir auch schon passiert ;)
Wenn du dies nicht beachtet hast wird es mit Sicherheit dein jetziges Problem hervorrufen.

Zitat aus dem Howto

Zitat

Starten Sie nicht grub-install! Es wird nicht richtig laufen und wahrscheinlich sda1 usw. anstelle Ihres RAID erkennen. Stellen Sie ebenfalls sicher grub nicht aus einer chroot Umgebung heraus auszuführen in welcher Sie sich wahrscheinlich befinden wenn Sie von der Gentoo LiveCD aus Installieren und den Anweisungen von Gentoo.org bzw. Gentoo.de folgen. Es kennt /dev/mapper nicht und würde zu Fehlern mit grub führen. Springen Sie in diesem Fall zu einer anderen Konsole indem Sie ALT+2 drücken. Starten Sie grub stellen Sie sicher dass es auf /dev/null als Gerät verweist.

Um den MBR neu zu schreiben gehe wie folgt vor:
Starte eine LiveCD
Mounte deine root und /boot Partition
Mache KEIN chroot in dein Installiertes gentoo!!
gehe auf einer konsole und gehe etwa so vor: (gebe nicht die Kommentare mit ein)

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
grub --device-map=/dev/null
grub> device (hd0,0) /dev/mapper/isw_hchhidchg_raid1
grub> device (hd0) /dev/mapper/isw_hchhidchg_raid
grub> root (hd0,0)
Filesystem is ext2fs, partition type 0x83
grub> setup (hd0)
Checking if "/boot/grub/stage1" exists... yes
Checking if "/boot/grub/stage2" exists... yes
Checking if "/boot/grub/e2fs_stage1_5" exists... yes
Running "embed /boot/grub/e2fs_stage1_5 (hd0)"... 16 sectors are embedded.
succeeded
Running "install /boot/grub/stage1 (hd0) (hd0)1+16 p (hd0,0)/boot/grub/stage2 /boot/grub/menu.lst"...succeeded
Done.
grub> quit
So sollte es funktionieren.

Zitat


Zitat von »josef.95«

Zitat von »eddi1983«
Dort kann man nur Harddisk auswählen. Keine unterschiedlichen Platten.

Hm.. das kann ich so kaum glauben, du mußt im BIOS doch Auswählen können von welcher HDD gebootet wird, wenn mehrere HDD's vorhanden sind?

Ich habe da was gefunden. Man kann dort aber nur SCSI-0: Intel Raid und austauschbaren Datenträger wählen. Steht auf SCSI-0: Intel Raid.
Hier muss ich mich korrigieren, du hast warscheinlich nur zwei SATA Platten im Rechner, diese hast du zu einem Raid Verbunden, wird also wie eine HDD behandelt.
Sollte so also in Ordnung sein, entschuldige für dies Missverständnis meinerseits :whistling: