Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

05.10.2008, 01:01

mergen von ebulid schlägt immer fehl ! probleme mit portage!!!

Hallo
Ich habe noch immer das problem das ich nix von der portage installieren kann !!!

weder rar von einer beschreibung noch andere sachen...

BEISPIEL RAR

Zitat

# emerge rar
--- Invalid atom in /etc/portage/package.keywords: app-arch/rar-3.7.1
--- Invalid atom in /etc/portage/package.keywords: sys-libs/glibc-2.6
--- Invalid atom in /etc/portage/package.keywords: sys-libs/glibc-2.4
Calculating dependencies -
!!! All ebuilds that could satisfy ">=sys-libs/glibc-2.4" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-libs/glibc-2.5-r4 (masked by: package.mask)
- sys-libs/glibc-2.4-r4 (masked by: package.mask)
- sys-libs/glibc-2.6 (masked by: package.mask, ~amd64 keyword)
- sys-libs/glibc-2.6.1 (masked by: package.mask)
- sys-libs/glibc-2.7-r2 (masked by: package.mask, ~amd64 keyword)
- sys-libs/glibc-2.8_p20080602 (masked by: package.mask, ~amd64 keyword)
- sys-libs/glibc-2.5.1 (masked by: package.mask, missing keyword)
- sys-libs/glibc-2.5-r2 (masked by: package.mask)
- sys-libs/glibc-2.5-r3 (masked by: package.mask)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
!!! (dependency required by "app-arch/rar-3.7.1" [ebuild])

schon alles probiert auch mit den keys leider ohne erfolg

oder Streamripper

Zitat

~ # emerge streamripper
Calculating dependencies ...done!
>>> emerge (1 of 5) media-libs/libogg-1.1.3 to /
!!! No package digest file found: /usr/portage/media-libs/libogg/files/digest-libogg-1.1.3
!!! Type "ebuild foo.ebuild digest" to generate it.
ns26462 ~ #

irgendwie stimmt am system was nicht bitte mal echt um hilfe weiss nicht mehr weiter...

Danke im vorraus

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Zaba« (07.10.2008, 21:08)


2

05.10.2008, 01:30

Hallo Zaba,

geht es immer noch um deinen Root-Server?

Das Problem bei dir ist ja, dass der Server schon länger nicht mehr aktualisiert wurde und die installierte Portage-Version nicht mehr zu dem aktuellen Portage-Tree passt.

Willst Du jetzt waagen dein Gentoo wieder auf den aktuellsten Stand zu bringen?
Bist Du auch für den Fall bereit, dass was schief laufen kann?
Ich kann dir gern helfen, aber die Verantwortung trägst Du :!:

Falls ja:
Zuerst nimm bitte die 3 Einträge aus /etc/portage/package.keywords raus. Diese sind nicht notwendig und syntaktisch falsch.

Als ersten Schritt solltest Du sys-apps/portage auf den neuesten Stand bringen:

Quellcode

1
2
ebuild /usr/portage/sys-apps/portage/portage-2.1.4.4.ebuild digest
emerge -1 =portage-2.1.4.4


Dies wird wahrscheinlich auf einen Fehler laufen. Bitte poste die gesamte Ausgabe. Dann können wir weiter machen.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

3

05.10.2008, 01:42

Danke bell

also es kommt nun das

Zitat

# emerge -1 =portage-2.1.4.4
Calculating dependencies ...done!

!!! Error: the <sys-apps/portage-2.1.4_rc1 package conflicts with another package.
!!! both can't be installed on the same system together.
!!! Please use 'emerge --pretend' to determine blockers.

Zitat


ns26462 sys-apps # cd /usr/portage/sys-apps/portage
ns26462 portage # dir
ChangeLog portage-2.0.51.22-r3.ebuild portage-2.2_rc11.ebuild
files portage-2.1.1-r2.ebuild portage-2.2_rc8.ebuild
Manifest portage-2.1.4.4.ebuild portage-2.2_rc9.ebuild
metadata.xml portage-2.1.5.6.ebuild
ns26462 portage #

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »Zaba« (05.10.2008, 01:54)


4

05.10.2008, 01:54

Schicke mir bitte PM die SSH-Zugangsdaten, dann werde ich versuchen es zu reparieren. Über das Forum würde es zu lange dauern. Es ist schon einiges zu tun.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

5

07.10.2008, 19:05

Alles wunderbar geklappt

Großen dank nochmal an bell

Thema kann nun geschlossen werden!