Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

13.11.2008, 23:43

acpi auf dem eeepc

Hi, ich bekomme acpi auf dem eeepc nicht zum laufen.
Das Paket acpi4asus funktioniert mit dem 2.6.25 kernel nicht.

Quellcode

1
error: 'struct led_classdev' has no member named 'class_dev'

Auf der alten gentoo wiki stand, dass man sich das Paket daher selber kompilieren solle, indem man es sich aus dem cvs zieht.

Quellcode

1
2
cvs -d:pserver:anonymous@acpi4asus.cvs.sourceforge.net:/cvsroot/acpi4asus login 
cvs -z3 -d:pserver:anonymous@acpi4asus.cvs.sourceforge.net:/cvsroot/acpi4asus co -P .

Damit bekomme ich aber genau die gleiche Version, nämlich 0.41. Dementsprechend gibt es da genau den gleichen Fehler.
Wie machen das die anderen Distributionen? Gibt es noch andere Versionen als die 0.41? Die SFSeite macht nicht den Eindruck, da dort nichts höheres gelistet ist.
Was ist das für eine Fehlermeldung und wie lässt sich vielleicht die Ursache beheben?

2

14.11.2008, 06:58

So wie ich das sehe sollte das in den Linux Kernel eingeflossen sein. Der letzte update (0.41) auf der Seite war ja schon im Februar und somit ziemlich lange her.

Wenn du im Kernel ASUS_LAPTOP setzt, sollte es das sein.

Mal einen 2.6.27 probiert?
http://www.dyle.org
IM-Account (Jabber!) sind auf meiner HP ...
There is no place like /home

http://www.gentooforum.de
http://www.gentoofreunde.org

<div>how to annoy a web developer?</span>

3

14.11.2008, 16:25

Geht leider trotzdem nicht. Ich hatte es erst als Modul drin, jetzt fest. Es gibt zwar /proc/acpi aber darin kein asus/ für wi-fi usw.
/proc/acpi gabs vorher auch schon.
2.6.27 könnte ich auch mal testen