Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

14.01.2009, 13:28

libopensync + synce + Evolution + WM6 = nur Probleme :-(

Tach zusammen,

ich wollte mal mit libopensync und synce meine WM6-Smartphone (Samsung SGH-i780) per Kabel mit Evolution synchronisieren. Dazu habe ich folgedne Komponeneten installiert:

synce 0.12
synce-librapi2 0.12-r1
synce-librra 0.12
synce-librtfcomp 0.12
synce-libsynce 0.12
synce-odccm 0.12
synce-serial 0.12
synce-sync-engine 0.12
synce-trayicon 0.12

Statt hal wird odccm genutzt.

Desweiteren sind folgende libopensync-Komponenten installiert:
libopensync 0.22
libopensync-plugin-synce 0.22
libopensync-plugin-evolution2 0.22
msynctool 0.22

und dann noch
multisync-gui 0.91

Folgende Schritte führe ich aus, um die Synchronisierung zu starten:

1) sudo odccm -f
2) sync-engine
3) create_partnership.py "Linux desktop" "Contacts,Calendar"
4) Smartphone über USB mit Laptop verbinden
5) multisync-gui starten
6) Synchronisierung konfigurieren
a) add group
b) Kontakte und Termine auswählen
c) add member evo2-sync
d) add member synce-plugin
7) synchronierung starten

Leider habeich damit keinen Erfolg (es sei denn, man kann es als Erfolg werten, dass alle meine Kontakte und Kalender-Einträge futsch sind)

Hier die Ausgabe von odccm nach Schritt 4:

Quellcode

1
2
3
4
5
6
** (odccm:19935): DEBUG: PDA network interface discovered! udi='/org/freedesktop/Hal/devices/net_80_00_60_0f_e8_00'
** (odccm:19935): DEBUG: device_info_received
** (odccm:19935): DEBUG: 2c 1f ed c3 5a 63 54 09 16 0c d1 10 ac 8c 29 f3 05 00 00 00 02 00 00 00 07 00 00 00 74 00 77 00 2d 00 69 00 70 00 61 00 71 00 00 00 05 02 98 07 11 0a 00 00 05 00 00 00 22 35 df 0d 00 00 00 00 0f 00 00 00 50 6f 63 6b 65 74 50 43 00 53 53 44 4b 00 00 08 00 00 00 53 47 48 2d 69 37 38 30 00 02 00 00 00 05 00 00 00 02 00 00 00 05 00 00 00 02 00 00 00 00 00 00 00 10 00 00 00 0c 00 00 00 5d 00 00 00 01 00 00 00
** (odccm:19935): DEBUG: extradata:
** (odccm:19935): DEBUG: 10 00 00 00 0c 00 00 00 5d 00 00 00 01 00 00 00
** Message: device_info_received: registering object path '/org/synce/odccm/Device/_C3ED1F2C_635A_0954_160C_D110AC8C29F3_'


Hier die Ausgabe von sync-engine nach Schritt 4:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
SynCE sync-engine starting up
2009-01-14 13:04:36,662 DEBUG syncengine : running main loop
2009-01-14 13:04:36,663 DEBUG syncengine : creating SyncEngine object
2009-01-14 13:04:36,689 DEBUG syncengine : installing signal handlers
2009-01-14 13:25:16,173 INFO engine.syncengine.kernel : _CBDeviceConnected: device connected at path /org/synce/odccm/Device/_C3ED1F2C_635A_0954_160C_D110AC8C29F3_
2009-01-14 13:25:16,174 INFO engine.config.Config : UpdateConfig - unable to open system config file - using defaults
2009-01-14 13:25:16,174 INFO engine.config.Config : UpdateConfig - unable to open system config file - using defaults
2009-01-14 13:25:16,180 INFO engine.syncengine.kernel :  device tw-ipaq connected
2009-01-14 13:25:16,181 INFO engine.syncengine.kernel : ProcessAuth : processing authorization for device 'tw-ipaq'
2009-01-14 13:25:16,186 INFO engine.syncengine.kernel : ProcessAuth: authorization not required for device 'tw-ipaq'
2009-01-14 13:25:16,187 DEBUG engine.syncengine.kernel : OnConnect: setting up RAPI session
2009-01-14 13:25:16,985 DEBUG engine.syncengine.kernel : OnConnect: Attempting to bind partnerships
2009-01-14 13:25:16,985 INFO engine.partnerships.Partnerships : AttemptToBind: Reading partnerships and looking for host binding
2009-01-14 13:25:16,986 INFO engine.partnerships.Partnerships : ClearDevicePartnerships: clearing all device partnership info
2009-01-14 13:25:16,987 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: reading partnerships from device registry
2009-01-14 13:25:17,172 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: read partnership ID = 232731938, Hostname = twarth
2009-01-14 13:25:17,172 DEBUG engine.partnerships.Partnerships : _read_device: Adding entry
2009-01-14 13:25:17,288 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: read partnership ID = 0, Hostname = 
2009-01-14 13:25:17,405 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: querying synchronization source information from device
2009-01-14 13:25:17,406 DEBUG engine.xmlutil : _config_query: CeProcessConfig request is 
<wap-provisioningdoc>
  <characteristic type="Sync">
	<characteristic-query recursive="false" type="Sources"/>
  </characteristic>
</wap-provisioningdoc>
2009-01-14 13:25:18,138 DEBUG engine.xmlutil : _config_query: CeProcessConfig response is 
<?xml version="1.0" encoding="utf-8"?>
<wap-provisioningdoc>
  <characteristic type="Sync">
	<characteristic recursive="false" type="Sources">
  	<characteristic type="{64CAACCA-3E86-E9A9-728D-C945973D61C1}"/>
	</characteristic>
  </characteristic>
</wap-provisioningdoc>

2009-01-14 13:25:18,140 DEBUG engine.xmlutil : _config_query: CeProcessConfig request is 
<wap-provisioningdoc>
  <characteristic type="Sync">
	<characteristic type="Sources">
  	<characteristic-query type="{64CAACCA-3E86-E9A9-728D-C945973D61C1}"/>
	</characteristic>
  </characteristic>
</wap-provisioningdoc>
2009-01-14 13:25:18,789 DEBUG engine.xmlutil : _config_query: CeProcessConfig response is 
<?xml version="1.0" encoding="utf-8"?>
<wap-provisioningdoc>
  <characteristic type="Sync">
	<characteristic type="Sources">
  	<characteristic type="{64CAACCA-3E86-E9A9-728D-C945973D61C1}">
    	<characteristic type="Engines">
      	<characteristic type="{176F4FFD-F20C-4BD4-BDD7-01D0726C567B}">
        	<characteristic type="CarrierConnectorList"/>
        	<characteristic type="Providers">
          	<characteristic type="{7E29B5F7-C686-4B0C-9892-FD8BAD8E0D08}">
            	<parm name="Enabled" value="0"/>
            	<parm name="Name" value="Favorites"/>
            	<parm name="ReadOnly" value="1"/>
          	</characteristic>
          	<characteristic type="{0DD8685C-E272-4FCB-9ECF-2EAD7EA2497B}">
            	<parm name="Enabled" value="1"/>
            	<parm name="Name" value="Contacts"/>
            	<parm name="ReadOnly" value="0"/>
          	</characteristic>
          	<characteristic type="{89768ABD-D173-18E3-16EC-98034F67B775}">
            	<parm name="Enabled" value="0"/>
            	<parm name="Name" value="WorldMate"/>
            	<parm name="ReadOnly" value="0"/>
          	</characteristic>
          	<characteristic type="{C6D47067-6E92-480E-B0FC-4BA82182FAC7}">
            	<parm name="Enabled" value="0"/>
            	<parm name="Name" value="E-mail"/>
            	<parm name="ReadOnly" value="0"/>
          	</characteristic>
          	<characteristic type="{8E98CB51-85A4-4777-8DEB-A0298DF8899F}">
            	<parm name="Enabled" value="0"/>
            	<parm name="Name" value="Notes"/>
            	<parm name="ReadOnly" value="1"/>
          	</characteristic>
          	<characteristic type="{BEA275EB-E3B7-641F-3D77-752349BAAA63}">
            	<parm name="Enabled" value="0"/>
            	<parm name="Name" value="AvantGo"/>
            	<parm name="ReadOnly" value="1"/>
          	</characteristic>
          	<characteristic type="{783AE4F6-4C12-4423-8270-66361260D4F1}">
            	<parm name="Enabled" value="0"/>
            	<parm name="Name" value="Tasks"/>
            	<parm name="ReadOnly" value="0"/>
          	</characteristic>
          	<characteristic type="{A38DEEBF-C535-D8E2-AE24-8AE61845CF82}">
            	<parm name="Enabled" value="0"/>
            	<parm name="Name" value="Media"/>
            	<parm name="ReadOnly" value="1"/>
          	</characteristic>
          	<characteristic type="{4A5D9FE0-F139-4A63-A5A4-4F31CEEA02AD}">
            	<parm name="Enabled" value="1"/>
            	<parm name="Name" value="Calendar"/>
            	<parm name="ReadOnly" value="0"/>
          	</characteristic>
          	<characteristic type="{B7B6ACB2-AF1D-43F5-BF9A-586111B263EF}">
            	<parm name="Enabled" value="0"/>
            	<parm name="Name" value="Files"/>
            	<parm name="ReadOnly" value="0"/>
          	</characteristic>
        	</characteristic>
        	<characteristic type="Settings">
          	<parm name="CarrierConnector" value=""/>
          	<parm name="ClientNegotiated" value="1"/>
          	<parm name="ClientProtocolVersion" value="2.5"/>
          	<parm name="ConflictResolution" value="1"/>
          	<parm name="DeviceAddressingMethod" value="0"/>
          	<parm name="DevicePhoneNumber" value=""/>
          	<parm name="DeviceSMSAddress" value=""/>
          	<parm name="Domain" value="DEFAULT"/>
          	<parm name="EmailAddress" value=""/>
          	<parm name="Logging" value="0"/>
          	<parm name="NotificationsSupported" value="0"/>
          	<parm name="RefreshCertAuthXml" value="0"/>
          	<parm name="SavePassword" value="1"/>
          	<parm name="ServerAutdSupport" value="0"/>
          	<parm name="ServerCertAuthRequired" value="0"/>
          	<parm name="ServerHTMLMailSupport" value="0"/>
          	<parm name="URI" value="Microsoft-Server-ActiveSync"/>
          	<parm name="UseSSL" value="0"/>
          	<parm name="User" value="DEFAULT"/>
        	</characteristic>
      	</characteristic>
    	</characteristic>
    	<parm name="Name" value="Linux desktop"/>
    	<parm name="Server" value="twarth"/>
    	<parm name="StoreType" value="2"/>
  	</characteristic>
	</characteristic>
  </characteristic>
</wap-provisioningdoc>

2009-01-14 13:25:18,917 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: read source GUID = {64CAACCA-3E86-E9A9-728D-C945973D61C1}, Hostname = twarth, Description = Linux desktop
2009-01-14 13:25:18,917 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: source matches partnerhip from registry.  Initializing partnership
2009-01-14 13:25:18,920 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: querying partnerhip synchronization items (providers)
2009-01-14 13:25:18,921 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: found provider Files
2009-01-14 13:25:18,921 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: found provider Calendar
2009-01-14 13:25:18,922 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: provider is enabled
2009-01-14 13:25:18,922 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: provider ID is 0
2009-01-14 13:25:18,922 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: found provider Media
2009-01-14 13:25:18,923 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: found provider Tasks
2009-01-14 13:25:18,923 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: found provider AvantGo
2009-01-14 13:25:18,923 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: found provider Notes
2009-01-14 13:25:18,924 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: found provider E-mail
2009-01-14 13:25:18,924 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: found provider WorldMate
2009-01-14 13:25:18,924 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: found provider Contacts
2009-01-14 13:25:18,925 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: provider is enabled
2009-01-14 13:25:18,925 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: provider ID is 1
2009-01-14 13:25:18,925 DEBUG engine.partnerships.Partnerships : ReadDevicePartnerships: found provider Favorites
2009-01-14 13:25:18,935 INFO engine.partnerships.Partnership : AttemptToBind : bound partnership P1: id=0xddf3522, guid="{64CAACCA-3E86-E9A9-728D-C945973D61C1}", hostname="twarth", name="Linux desktop", sync_items=[ Calendar, Contacts ] - running config
2009-01-14 13:25:18,935 INFO engine.partnerships.Partnership : synchronization of time to host is disabled
2009-01-14 13:25:18,936 INFO engine.partnerships.Partnership : DTPT multihoming is disabled
2009-01-14 13:25:18,937 DEBUG engine.xmlutil : _config_query: CeProcessConfig request is 
<wap-provisioningdoc>
  <characteristic type="Sync">
	<characteristic type="Settings">
  	<parm name="AllowDTPTMultihoming" value="0"/>
	</characteristic>
  </characteristic>
</wap-provisioningdoc>
2009-01-14 13:25:19,438 DEBUG engine.xmlutil : _config_query: CeProcessConfig response is 
<?xml version="1.0" encoding="utf-8"?>
<wap-provisioningdoc>
  <characteristic type="Sync">
	<characteristic type="Settings">
  	<parm name="AllowDTPTMultihoming" value="0"/>
	</characteristic>
  </characteristic>
</wap-provisioningdoc>

2009-01-14 13:25:19,439 DEBUG engine.partnerships.Partnerships : AttemptToBind: Valid host binding found for partnership in slot 1
2009-01-14 13:25:19,730 DEBUG engine.syncengine.kernel : StartSessions: starting AirSync handler
2009-01-14 13:25:19,733 DEBUG engine.airsync.AirsyncThread : run: listening for Airsync requests
2009-01-14 13:25:19,733 DEBUG engine.syncengine.kernel : StartSessions: calling RAPI start_replication
2009-01-14 13:25:19,778 DEBUG engine.syncengine.kernel : StartSessions: calling RAPI sync_resume
2009-01-14 13:25:19,944 DEBUG engine.syncengine.kernel : StartSessions: starting RRA session
2009-01-14 13:25:19,945 INFO RRAThread : new RRA handler thread created
2009-01-14 13:25:19,946 INFO RRASyncManager : connecting to RRA
2009-01-14 13:25:21,539 INFO RRASyncManager : connected
2009-01-14 13:25:21,540 DEBUG RRAThread : have 5 object types
2009-01-14 13:25:21,541 DEBUG RRASyncManager : No RRA type subscriptions - ignoring RRA sync items
2009-01-14 13:25:21,542 DEBUG RRAThread : run: starting RRA event loop
[rra_syncmgr_start_events:655] No valid subscriptions



Und hier die Meldung von multisync-gui nach Schritt 7

Quellcode

1
2
3
4
5
6
Member 2 of type evo2-sync just connected
[synce_socket_listen:214] bind failed, error: 98 "Address already in use"
Member 1 of type synce-plugin had an error while connecting: can't connect
Member 2 of type evo2-sync just disconnected
All clients have disconnected
The sync failed: Unable to connect one of the members



Leider habe ich keinen Hinweis im Internet gefunden, woran es liegen kann, dass ich die Meldung erhalte "Address already in use".

Kennt jemand von euch diesen Fehler?

Danke und Gruß
tobiwwwan

2

15.01.2009, 09:46

"Address already in use" bedeutet, das ein Prozess einen Port aufmachen will, der vom Betriebssystem bereits vergeben ist.

Bsp.: ein Webserver schnappt sich i.d.R. Port 80 (== HTTP). Wenn du nun einen 2. Webserver startest und dieser sich auch den Port 80 schnappen will, dann klopft das Betriebssystem letzteren mit eben dieser Meldung auf die Finger: geht nicht!

Wer welchen Port gerade hat, erfährst du mit netstat. Bsp.

Quellcode

1
# netstat -nelpt
listet dir auf, welcher Pozess auf deiner Maschine gerade auf welchen Portnummern auf Kontakt von aussen wartet.

Da ich deine Appikation aber nicht kenne erschöpft sich hiermit mein Senf zu diesem Thema. Ich habe leider keine Wissen, auf welchen Port sich deine App binden will und wer dort bereits schon sitzt ...

Gibt es nicht mehr Debug-Output?
http://www.dyle.org
IM-Account (Jabber!) sind auf meiner HP ...
There is no place like /home

http://www.gentooforum.de
http://www.gentoofreunde.org

<div>how to annoy a web developer?</span>

3

16.01.2009, 02:00

Was die Fehlermeldung bedeutet, weiß ich... ich weiß nur nicht, wo sie herkommt, bzw. warum sie kommt. Ich geh da wirklich nach Anleitung (z.B: http://www.synce.org) vor :-(

Trotzdem Danke ;-)