Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

01.03.2009, 13:53

Clocksource tsc unstable

Gude, :)

seit einigen Wochen tritt (dmesg) folgender Fehler mind. ein Mal täglich auf:

Zitat

/dev/vmmon[0]: HostIF_ReadUptime: detected settimeofday: fixed uptimeBase old 18445508165510580946 new 18445508165507336963 attempts 1
und das System wird dann derart langsam, dass neu gebootet werden muss. Am Kernel-Modul vmmon liegt es nicht, denn auch ohne vmmon geladen zu haben, tritt der Fehler wie folgt auf:

Zitat

Clocksource tsc unstable (delta = 1310039829 ns)
Woran könnte das liegen?

By the way:

Quellcode

1
2
$ uname -a
Linux cerberus 2.6.26-gentoo-r3 #23 SMP Sun Mar 1 00:16:46 CET 2009 i686 Genuine Intel(R) CPU T2130 @ 1.86GHz GenuineIntel GNU/Linux


Greetz
Dannyboy

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »dannyboy« (15.03.2009, 14:38)


2

01.03.2009, 16:03

Hm.. hier auf meinem Desktop Rechner habe ich im "dmesg" auch folgendes

Quellcode

1
2
3
4
 # dmesg | grep -i tsc
Fast TSC calibration using PIT
Marking TSC unstable due to cpufreq changes
Clocksource tsc unstable (delta = -291678239 ns)
Dies hängt mit dem ACPI CPU-Frequenz Treiber zusammen.
Ohne CPU Frequenz runtertaktung gibt es nur noch

Quellcode

1
2
# dmesg | grep -i tsc
Fast TSC calibration using PIT

Habe dies bisher nicht als Fehler oder Warnung wahrgenommen sondern als Info..., den Probleme gab es bisher keine.

Schalte doch mal den CPU Frequenz Kram bei dir ab (wenn aktiviert), und schaue ob die Meldungen in "dmesg" noch auftauchen, und es mit deinem langsam werdenden System zusammenhängt.

Edit: Siehe zb auch http://www.linuxquestions.org/questions/…nstable-568932/

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »josef.95« (01.03.2009, 16:19)


3

02.03.2009, 01:37

Hi josef.95,
mhm, ich habe den CPU-Takt nicht geändert, ACPI-Einstellungen finde ich im BIOS keine und ACPI als solches wird auch nicht verwendet (Grub: acpi=off).
Nach dem Systemstart:

Quellcode

1
2
3
4
5
6
7
8
9
dmesg | egrep -i "acpi|tsc"
BIOS-e820: 0000000077fa8000 - 0000000077fb0000 (ACPI NVS)
BIOS-e820: 0000000077fb0000 - 0000000077fbe000 (ACPI data)
BIOS-e820: 0000000077fbe000 - 0000000077ff0000 (ACPI NVS)
Kernel command line: root=/dev/sda2 acpi=off quiet nodhcp nopcmcia clocksource=tsc
checking TSC synchronization [CPU#0 -> CPU#1]: passed.
ACPI: Interpreter disabled.
pnp: PnP ACPI: disabled
[fglrx] ACPI is disabled on this system

... und nach ein oder zwei Stunden tritt dann der im initialen Posting beschriebene Fehler auf, was einen Reboot erfordert. Hängt es evtl. mit den ACPI-Einstellungen des Kernels zusammen? --> index.php?page=Attachment&attachmentID=2181

Greetz
Dannyboy

4

06.03.2009, 18:16

Jetzt musst du erst mal sagen, welche Lektüre du schon abgehandelt hast, weil Suchmaschinen spucken da ja auch einiges aus und wir wollen das ja nicht alles wiederholen (notsc, hpet, ...).
"Erst nachdem wir alles verloren haben, haben wir die Freiheit, alles zu tun."
"It's only after we've lost everything, that we're free to do anything!"

Jabber: Die ID kann via PN erfragt werden.

6

15.03.2009, 14:32

Hi @all,
ich verwende nun alternativ jiffies als Clocksource seit einer Woche, doch komischerweise tritt der tsc-Fehler immer noch auf. :wacko:

Greetz
dannyboy

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »dannyboy« (15.03.2009, 14:39)


7

31.03.2009, 09:13

@dannyboy

Wenn du in deinem Bios "HPET - High Precision Event Timer" hast und aktiviert, dann benutze lieber clocksource=hpet statt jiffies

@all

Ich habe dieses "tsc unstable" - Problem auch. Konnte es bis jetzt auch nicht lösen. Ich gebe dem Kernel den Parameter clocksource=hpet mit, ABER NICHT "notsc" - daraus folgt:

Die Fehlermeldung

Quellcode

1
Clocksource tsc unstable (delta = -291678239 ns)


tritt immer noch auf.

ABER:

Wenn ich dann auch noch den Parameter "notsc" mitgebe, läuft mein System nicht mit voller Leistung! So als wenn nur ein Kern aktiv ist / phpsysinfo meldet beispielsweise nur die Hälfte an System-Bogomips. Das gleiche tritt auf, wenn ich den Clocksource-Parameter nicht mitgebe und nur "notsc"...

:!: Also seit vorsichtig mit dem Parameter

Quellcode

1
notsc


und Mehrkern bzw. 64bit-Systemen :!: