Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

16.03.2009, 19:14

ccache will nicht

Hallo liebes Forum!
Sobald ich ccache anmache emerged der Pc einige Pakete nicht mehr!
Zum Beispiel wenn ich pidgin emergen will. Und auch bei anderen Paketen!
Ich poste mal die log!
Und die Ausgabe von emerge --info!
Kann da jemand vllt weiterhelfen?
Lg Ferhan


Ps: Ich hatte "das gleiche" Problem bei diesem thread!
»Deustferhan« hat folgende Dateien angehängt:
  • emergeinfo.txt (4,11 kB - 4 mal heruntergeladen - zuletzt: 16.03.2009, 23:01)
  • log.txt (36,01 kB - 4 mal heruntergeladen - zuletzt: 16.03.2009, 23:05)
2.6.28-gentoo-r5
i686 AMD Athlon(tm) XP 3200+ AuthenticAMD GNU/Linux
GeForce 7600Gs
gcc4.1
glibc2.6

2

16.03.2009, 23:17

Um ein Bug oder ein grundsätzliches Problem mit ccache auszuschließen habe ich noch mal mein gutes "altes" immer noch heißgeliebtes gentoo mit kde:3.5 gestartet und habe dein ursprüngliches Problem Paket kde-base/kcontrol-3.5.10 mit ccache merged, es lief einwandfrei durch.

Ich habe grad gesehen das du da recht Abenteuerliche CFLAGS nutzt

Quellcode

1
CFLAGS="-O2 -march=athlon-xp -m32 -pipe -fomit-frame-pointer -msse -mmmx -m3dnow"
Nimm doch bitte mal das "m32" raus und probiere es dann noch mal.

MfG

3

16.03.2009, 23:42

So habs rausgenommen und versucht, aber es nichts gebracht es kommt immer noch dieselbe Fehlereldung!?
Lg Ferhan
2.6.28-gentoo-r5
i686 AMD Athlon(tm) XP 3200+ AuthenticAMD GNU/Linux
GeForce 7600Gs
gcc4.1
glibc2.6

4

16.03.2009, 23:58

Hm.. schalte doch auch bitte für ein test mal "distcc" und "prelink" ab.

Quellcode

1
# FEATURES="-distcc -prelink" emerge -1 =kde-base/kcontrol-3.5.10

5

18.03.2009, 13:48

das es so lange gedauert hat bis ich antworte...
Hatte viel um die Ohren die letzten Tage!
Habs gemacht also prelink und distcc ausgemacht und trotzdem kommt die gleiche Fehlermeldung!
Gibts da eine andere Lösung?
Lg Ferhan
2.6.28-gentoo-r5
i686 AMD Athlon(tm) XP 3200+ AuthenticAMD GNU/Linux
GeForce 7600Gs
gcc4.1
glibc2.6

6

21.03.2009, 13:32

Keiner eine Idee?
2.6.28-gentoo-r5
i686 AMD Athlon(tm) XP 3200+ AuthenticAMD GNU/Linux
GeForce 7600Gs
gcc4.1
glibc2.6

7

22.03.2009, 23:26

Keiner eine Idee?
Ich zZt aus der Ferne nicht wirklich...

Prüfe doch noch einmal deine Ccache Konfiguration durch, siehe hierzu zb http://en.gentoo-wiki.com/wiki/Ccache

Für alle anderen, dies ist die Fortsetzung aus dem Thread [gelöst] Kcontrol lässt sich nicht emergen

viel Erfolg