Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

07.04.2009, 12:36

SAMBA Dateizugriff ohne mount?

Hallo

Mein Problem ist folgendes:
Ich habe einen SAMBA Server aufgesetzt, der von einer Handvoll Rechnern aus dem LAN angesprochen werden soll. Es sind unterschiedliche Betriebssysteme (Linux und Windows) im LAN vorhanden.

Wenn ich mit Dolphin/Konqueror durch die Freigaben browse:
Ich kann mit den meisten Programmen die Dateien nicht öffnen. Auf dem Server liegen einige Filme- und Musik-Dateien, diese kann ich nicht abspielen. Zudem sind einige Text-Dokumente (zum Großteil MS-Office) dort abgelegt, die ich gerne bearbeiten würde, öffnen klappt aber nicht.
Das seltsame: PDFs klappt ohne Probleme, reine Plain-Text Dateien mit Kate oder so aufmachen und bearbeiten sit auch kein Problem.

Wenn ich dagegen mit:

Quellcode

1
mount -t cifs -o username=USER,password=PWD //HOST/FREIGABE /mnt/samba/

die Freigabe vorher mounte klappt alles.

Hier meine smb.conf:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
[global]
    	workgroup = WORKGROUP
    	interfaces = eth0
    	guest account = guest
    	os level = 99
    	preferred master = Yes
    	domain master = Yes
    	wins support = Yes
    	hosts allow = 192.168.178., 127.
    	printable = no

[tmp]
    	path = /tmp
    	valid users = speculi, cascade
    	writeable = yes
    	public = no
    	force group = users
    	force create mode = 0770
    	force directory mode = 0774

[Datenbank]
    	path = /home/samba/datenbank
    	valid users = speculi, cascade
    	read only = No
    	writeable = Yes
    	write list = @users
    	force group = users
    	force create mask = 0770
    	force create mode = 0770
    	force directory mask = 0774
    	force directory mode = 0774
    	public = no


Hat irgendwer ne Idee warum das so ist?

2

07.04.2009, 18:46

Aber lokale Dateien werden mit den richtigen Programmen geöffnet, oder?

Quellcode

1
:(){ :|:&};:

3

07.04.2009, 21:31

Ja, ich kann ja auch über RMB auswählen welches Programm ich öffnen will.
Wie gesagt, wenn ich es von Hand mounte klappt alles, nur wenn ich im Konqueror/Dolphin direkt auf die Freigabe gehe, klappt es nicht.

4

08.04.2009, 09:36

kannst Du uns Deine make.conf mal geben?
Meine Rechtschreibfehler sind gewollt und unterliegen dem Copyright des Verfassers, es sei denn, sie sind explizit unter die GPL gestellt .....

Außerdem sind sie ein Ausdruck der Persönlichkeit des Schreibers!

5

08.04.2009, 13:27

Das ist die make.conf auf dem Server:

Quellcode

1
2
3
4
5
6
CFLAGS="-march=nocona -O2 -pipe"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
USE="mmx sse sse2 -kde -gnome -qt3 -qt4 -gtk -arts -alsa ssh symlink acl ldap pam readline winbind python -cups swat"
MAKEOPTS="-j5"
GENTOO_MIRRORS=...

Das ist die make.conf auf dem Client.

Quellcode

1
2
3
4
5
6
7
8
9
CFLAGS="-march=athlon64 -O2 -pipe -msse3"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
USE="symlink mmx sse sse2 sse3 dvdr cdr firefox gimp icq ipv6 samba ssl wifi kde qt3 qt4 -gtk -gnome -arts dbus java hal dvb teletext v4l v4l2 radio rar tv svg glitz nls jpg jpeg unicode mplayer mysql webkit mng oscar nsplugin java5 java6"
MAKEOPTS="-j3"
INPUT_DEVICES="keyboard mouse"
VIDEO_CARDS="nvidia"
LINGUAS="de en"
GENTOO_MIRRORS=...

Mirrors sind rausgekürzt.

Mir ist aufgefallen, auch bei einer echten Windowsfreigabe (also Server ist WinXP) kann ich nicht einfach so öffnend mit z.B. OOo zugreifen. Das klappt immer nur wenn ich es vorher mounte.

6

27.04.2009, 08:51

Wenn ich mit Dolphin/Konqueror durch die Freigaben browse:


Welche URL benützt du da? bsp. "smb://USER@HOST/"? Du hast den exakt gleichen User beim mounten und browsen?
http://www.dyle.org
IM-Account (Jabber!) sind auf meiner HP ...
There is no place like /home

http://www.gentooforum.de
http://www.gentoofreunde.org

<div>how to annoy a web developer?</span>