Sie sind nicht angemeldet.

1

27.05.2009, 22:22

Important mit news und eselect news probleme

So mein letztes Problem hoffe ich mit meinem Notbook.
hab ein
#emerge --sync gemacht
und danach
# emerge --update --newuse world

nun hab ich das Problem mit

Important : 1 news items need reading for repository 'gentoo'
Use eselect news to read nes items


so hab nun
eselect news geschrieben und es ist nur so eine art help info gekommen mit
eselect news list kam dann

unread news items

2009-04-18-java-config-wrapper-0.16
generation 1 java setup deprecated

jo und nun was muss ich nun machen ??

hab das tool mal deinsterliert was auch nix brachte

das problem ist ich kann nun nichts installieren weil es sich hier immer aufhängt ... komisch

zb. kann ich jetzt nicht Firefox installieren der hat als abhängigkeit bei mir xulrunner und der macht mir jetzt diese fehlermeldung

/usr/portage/eclass/java-utils-2.eclass: line 2097: java-config: command not found
*
* Can't run java-config --help
* Have you upgraded python recently but haven't
* run python-updater yet?
*
* ERROR: net-libs/xulrunner-1.9.0.10 failed.
* Call stack:
* ebuild.sh, line 48: Called pkg_setup
* xulrunner-1.9.0.10.ebuild, line 45: Called java-pkg-opt-2_pkg_setup
* java-pkg-opt-2.eclass, line 45: Called java-pkg_init
* java-utils-2.eclass, line 2102: Called die
* The specific snippet of code:
* die "Can't run java-config --help"
* The die message:
* Can't run java-config --help
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/net-libs/xulrunner-1.9.0.10/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/net-libs/xulrunner-1.9.0.10/temp/die.env'.
*
!!! When you file a bug report, please include the following information:
GENTOO_VM= CLASSPATH="" JAVA_HOME=""
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info

so nun steht ich mal wieder an der wand und weis nicht weiter .. hoffe es kann mir wer helfen

mfg
schatti
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Schattenschlag« (01.06.2009, 20:34)


2

27.05.2009, 22:59

Ein jdk (java) hast du schon installiert, zb "sun-jdk" ?

3

27.05.2009, 23:24

Zitat

unread news items

2009-04-18-java-config-wrapper-0.16
generation 1 java setup deprecated

jo und nun was muss ich nun machen ??


Wie der Name schon sagt, gibt es dort Neuigkeiten zu irgendwelchen Paketen.

Mit

Quellcode

1
eselect news list

werden die vorhanden Neuigkeiten aufgelistet.

Quellcode

1
eselect news read  2009-04-18-java-config-wrapper-0.16

gibt dir Informationen zu diesem Paket.

4

28.05.2009, 14:22

Sorry hatte ich vergessen zu schreiben noch den befehl hab ich auch schon versucht das einzige was da raus kommt ist

Title Generation 1 Java Setup Deprecated
Author Petteri RÀty <betelgeuse@gentoo.org>
Posted 2009-04-18
Revision 2

jo und was soll mir das jetzt sagen ? muss ich den autor was schicken ??
jo und jetzt sehe ich das meine umlaute auch nicht gehne ups..

aber danke mal für den tipp ..
mit dem java-sdk muss ich gucken heute abend gucken ... meld mich dann nochmal

mfg
schatti
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

5

28.05.2009, 18:09

Also bei mir steht das:

eselect news read 2009-04-18-java-config-wrapper-0.16

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
2009-04-18-java-config-wrapper-0.16
  Title                      Generation 1 Java Setup Deprecated
  Author                     Petteri Räty <betelgeuse@gentoo.org>
  Posted                     2009-04-18
  Revision                   2

For a long time the Java team required a 1.4 JDK to be
installed in order for old java ebuilds to work. All these
ebuilds are now gone from the main tree so the requirement
to have a 1.4 JDK installed has been lifted.

In order to remove things left over by the generation 1
setup please run java-check-environment and follow the
instructions.

If you want to remove 1.4 JDKs, you should use emerge --depclean.
Depending on what you have installed you might not need a
1.4 JDK any more. To see if you still need a 1.4 JDK use:

emerge -av --depclean virtual/jdk:1.4

If you don't need virtual/jdk:1.4 any more then you can remove the
individual JDKs. First get the list of installed JDKs with
eselect and then remove those that are not needed any longer with
depclean, for example:

eselect java-vm list
emerge -av --depclean sun-jdk:1.4

6

01.06.2009, 20:32

hab jetzt das gemacht was bei dir gekommen ist ... naja meldung ist jetzt weg

wie gesagt ich hatte diese meldung leider nicht sorry

danke für die hilfe

mfg
schatti
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''