Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

01.06.2009, 16:20

emerge --sync funktioniert nicht mehr

Ich hab zwar kein KDE4 sondern nur 3.5.9 aber irgendwie funktioniert mein "emerge --sync" nicht mehr.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
emerge --sync


Performing Global Updates: /usr/portage/profiles/updates/2Q-2009
(Could take a couple of minutes if you have a lot of binary packages.)
  .='update pass'  *='binary update'  #='/var/db update'  @='/var/db move'
  s='/var/db SLOT move'  %='binary move'  S='binary SLOT move'
  p='update /etc/portage/package.*'
.........................
ERROR: Malformed update entry 'move >=kde-base/konq-plugins-4 kde-misc/konq-plugins'
Traceback (most recent call last):
  File "/usr/bin/emerge", line 40, in <module>
    retval = _emerge.emerge_main()
  File "/usr/lib64/portage/pym/_emerge/__init__.py", line 14830, in emerge_main
    if portage._global_updates(trees, mtimedb["updates"]):
  File "/usr/lib64/portage/pym/portage/__init__.py", line 7914, in _global_updates
    moves = vardb.move_ent(update_cmd)
  File "/usr/lib64/portage/pym/portage/dbapi/vartree.py", line 165, in move_ent
    raise InvalidPackageName(cp)
InvalidPackageName: >=kde-base/konq-plugins-4


Weiß jemand wie ich den Fehler beheben kann?
Phenom X4 9550
Gigabyte GA-MA770-UD3
Gentoo 64 Bit Stable
8 GB Ram
Audigy 2 Zs
Geforce 9800 GTX
VDR
Hauppauge Nexus-S Rev 2.2 + 2.1

Lenovo G550 T4300
Gentoo 64 Bit Stable
4 GB Ram

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »cyrix1983« (01.06.2009, 16:42)


2

01.06.2009, 16:30

Nutze doch vorm posten auch die Suchfunktion...
zb ein Thread unter deinem.., vermutlich gleiches Prob.
nach sync: portage.exception.InvalidPackageName

MfG

3

01.06.2009, 16:42

So mein emerge --sync läuft wieder, hab portage auf einem Funktionierenden rechner gepackt und auf dem nicht funktionierenden entpackt. Jetzt läufts wieder.
Danke für den Link! Hätte vielleicht besser die unteren Threads durchsehen sollen.
Phenom X4 9550
Gigabyte GA-MA770-UD3
Gentoo 64 Bit Stable
8 GB Ram
Audigy 2 Zs
Geforce 9800 GTX
VDR
Hauppauge Nexus-S Rev 2.2 + 2.1

Lenovo G550 T4300
Gentoo 64 Bit Stable
4 GB Ram