Sie sind nicht angemeldet.

[gelöst] Hibernate als User

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

20.08.2009, 21:14

Hibernate als User

Hallo,

bei mir geht das Hibernate nicht als User. Kann mir jemand einen Tip geben woran das liegen könnte? Habe in den Gentoo Hotows nichts gefunden.

Als Root geht es ohne Probleme.
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

2

20.08.2009, 21:19

Hi
Meinst du von einer Konsole, oder aus einem WM Menu heraus?

3

21.08.2009, 08:35

WM Menü (Gnome)
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

4

23.08.2009, 02:15

AFAIK nutzen die neueren Desktops nun alle "pm-utils"
dies erhältst du zb mit als Depend wenn "hal" mit USE="laptop" gebaut wird.

5

26.08.2009, 13:16

Ok Danke, geht jetzt soweit. Nur beim schreiben ins RAM wacht das Notebook nicht mehr auf. Nur noch ein buntes Bild.

Das ist aber ein anderes Problem.

Gruß
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

6

01.09.2009, 13:56

Das ist aber ein anderes Problem.
Du möchtest es dennoch in diesem Thread behandeln?

Suspend-To-Disk funktioniert aber korrekt?
was für ein Grafik Treiber und Framebuffer wird denn verwendet?

MfG

7

03.09.2009, 17:35

Suspend-To-Disk funktioniert aber korrekt?
was für ein Grafik Treiber und Framebuffer wird denn verwendet?


Ja,Suspend-To-Disk geht ohne Probleme und funktioniert sehr gut.

Bei Suspemd-To-RAM sehe ich beim starten vom Rechner nicht mal mehr das Bios. Ich verwende uvesafb. Ich denke mal das der Speicher beim Suspemd-To-RAM so beschrieben wird das er beim aufwachen Fehler bringt. Grafik Karte ist eine Nvidia.

Das ganze läuft auf einem acer aspire 8930g.

Viele Grüße
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

8

04.09.2009, 02:28

Bei Suspemd-To-RAM sehe ich beim starten vom Rechner nicht mal mehr das Bios.
Hehe, das ist ja das schöne, es geht bei Suspemd-to-RAM
wirklich sehr flott. (wenn es den korrekt funktioniert)

Schau doch auch noch mal im BIOS, evtl. muss es dort noch aktiviert bzw konfiguriert werden, es sollte dort unter
"S3" = Suspend to RAM
bzw
"S4" = Suspend to Disk
zu finden sein.
Ansonsten schau auch mal nach "ACPI" , (im BIOS sowie im Kernel) das sollte korrekt laufen!

Viel Erfolg!

9

05.09.2009, 08:15

Schau doch auch noch mal im BIOS, evtl. muss es dort noch aktiviert bzw konfiguriert werden, es sollte dort unter
"S3" = Suspend to RAM
bzw
"S4" = Suspend to Disk
zu finden sein.
Ansonsten schau auch mal nach "ACPI" , (im BIOS sowie im Kernel) das sollte korrekt laufen!


Gibt es nicht im Bios. Es ist ja ein Notbook und da sind die Möglichkeiten im Bios immer sehr beschränkt.

Gruß Andreas
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

10

11.09.2009, 21:03

Ansonsten hab ich im Kernel noch

Quellcode

1
2
3
4
$ zgrep SUSPEND /proc/config.gz
CONFIG_ARCH_SUSPEND_POSSIBLE=y
CONFIG_SUSPEND=y
CONFIG_SUSPEND_FREEZER=y
gesetzt.

11

11.09.2009, 21:54

Hallo,

das habe ich bei mir auch alles aktiviert.

Zitat

zgrep SUSPEND /proc/config.gz
CONFIG_ARCH_SUSPEND_POSSIBLE=y
CONFIG_SUSPEND=y
CONFIG_SUSPEND_FREEZER=y
# CONFIG_USB_SUSPEND is not set



Ich verwende die gentoo-sources mit dem tuxonice patch. Aktuell 2.6.39-r4. Der 2.6.31er ist noch nicht im Funtoo Tree, das dauert noch 1 oder 2 Tage.

Ich werde aber auch nochmal eine Ubuntu Live CD versuchen um zu schauen ob es da geht.

Gruß Andreas
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

12

12.09.2009, 00:09

Hier auf meinem Notebook läuft es mit den normalen gentoo-sources , auch mit dem 29er Kernel.

Nur beim schreiben ins RAM wacht das Notebook nicht mehr auf. Nur noch ein buntes Bild.
Um die Sache mal ein wenig einzugrenzen, würde es ohne gestartetes X funktionieren, also aus einer normalen Konsole heraus mal ein

Quellcode

1
# pm-suspend
probieren.
Ist da ansonsten nichts genaueres an Info zu finden, zb im "dmesg", syslog oder /var/log/pm-suspend.log ?

/edit
Was für ein Grafik Treiber verwendest du da?
auch: verwendest du ein framebuffer , wenn ja was für einen?

MfG

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »josef.95« (12.09.2009, 00:16)


13

16.09.2009, 07:09

Hallo,

pm-suspend aus der Console funktioniert auch nicht. Als framebuffer verwende ich uvesa-tng. Habe ich auch schon weiter oben geschrieben.

In der log ist auch nichs zu finden.

Zitat

scsi_mod 55564 7 sbp2,usb_storage,scsi_transport_fc,sr_mod,sg,sd_mod,libata
total used free shared buffers cached
Mem: 3114628 148320 2966308 0 31876 49476
-/+ buffers/cache: 66968 3047660
Swap: 41977804 0 41977804
success.
/usr/lib/pm-utils/sleep.d/00powersave suspend suspend: success.
/usr/lib/pm-utils/sleep.d/01grub suspend suspend: disabled.
/usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/55NetworkManager suspend suspend: disabled.
/usr/lib/pm-utils/sleep.d/75modules suspend suspend: success.
/usr/lib/pm-utils/sleep.d/90clock suspend suspend: disabled.
/usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend: success.
/usr/lib/pm-utils/sleep.d/95led suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/98smart-kernel-video suspend suspend: success.
/etc/pm/sleep.d/99laptop-mode suspend suspend: success.
/usr/lib/pm-utils/sleep.d/99video suspend suspend: kernel.acpi_video_flags = 0
success.


Wobei wenn ich sage es funktioniert nicht, muss ich sagen das Ausschalten geht schon und die Powerled blinkt dann auch orange und signalisiert mir das er ein Suspend gemacht hat.

Nur aufwachen geht dann nicht mehr.

Gruß Andreas
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

14

22.09.2009, 00:44

Hallo,

seit dem BIOS Update funktioniert pm-suspend. Nur die Tastatur geht nicht nach dem aufwachen unter X. Werde jetzt noch ein paar Tests machen


Danke
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay