Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

41

15.09.2009, 09:51

Es ist eine IDE Platte - deswegen einfach bitte mal folgendes Testen dauert ja nicht land und schließt einige Fehler aus


/boot/grub/grub.conf

Quellcode

1
2
3
4
5
6
7
default 0
timeout 3
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Gentoo Linux 2.6.30-r6
root (hd0,0)
kernel /boot/kernel-2.6.30-gentoo-r6 root=/dev/hda3


/etc/fstab

Quellcode

1
2
3
4
5
6
7
8
9
/dev/hda1           	/boot       	ext3        	noauto,noatime  0 2
/dev/hda3           	/           	ext3        	noatime     	0 1
/dev/hda2           	none        	swap        	sw          	0 0
/dev/hda5           	/home       	ext3        	noatime     	0 2
/dev/cdrom          	/mnt/cdrom  	auto        	noauto,ro   	0 0
#/dev/fd0           	/mnt/floppy 	auto        	noauto      	0 0


proc                	/proc       	proc        	defaults    	0 0
Phenom X4 9550
Gigabyte GA-MA770-UD3
Gentoo 64 Bit Stable
8 GB Ram
Audigy 2 Zs
Geforce 9800 GTX
VDR
Hauppauge Nexus-S Rev 2.2 + 2.1

Lenovo G550 T4300
Gentoo 64 Bit Stable
4 GB Ram

42

15.09.2009, 10:32


Fehler beim Hochfahren:

Quellcode

1
2
3
4
5
6
7
8
9
10
VFS: Canot open root device "sda3" or unknow-block(0,0)
Please append a correct "root=" boot option; here are the vailable partions:

1640 80043264 hdd driver: ide-gd
  1641	56196		hdd1
  1642	2939895		hdd2
  1643	73248367	hdd3
  1644	1		hdd4
  1645	705028		hdd5
0300	705028		hda drive: ide-cdrom


Wenn ich das lese, denke ich, du solltest mal root=/dev/hdd3 versuchen...

43

15.09.2009, 10:39

@Jeff richtig wollte es auch so editieren hab mich nur verhippelt

grub hdd = (3,0)

Quellcode

1
2
3
4
5
6
7
default 0
timeout 3
splashimage=(hd3,0)/boot/grub/splash.xpm.gz

title Gentoo Linux 2.6.30-r6
root (hd3,0)
kernel /boot/kernel-2.6.30-gentoo-r6 root=/dev/hdd3

fstab

Quellcode

1
2
3
4
5
6
7
8
/dev/hdd1           	/boot       	ext3        	noauto,noatime  0 2
/dev/hdd3           	/           	ext3        	noatime     	0 1
/dev/hdd2           	none        	swap        	sw          	0 0
/dev/hdd5           	/home       	ext3        	noatime     	0 2
/dev/cdrom          	/mnt/cdrom  	auto        	noauto,ro   	0 0
#/dev/fd0           	/mnt/floppy 	auto        	noauto      	0 0

proc                	/proc       	proc        	defaults    	0 0


So müsste es dann stimmern. Sorry wegen dem 1. Beitrag da hab ich mich selbst verhippelt
Phenom X4 9550
Gigabyte GA-MA770-UD3
Gentoo 64 Bit Stable
8 GB Ram
Audigy 2 Zs
Geforce 9800 GTX
VDR
Hauppauge Nexus-S Rev 2.2 + 2.1

Lenovo G550 T4300
Gentoo 64 Bit Stable
4 GB Ram

44

15.09.2009, 10:42

Ich habe mit hd0 versucht, geht absolute nicht.

Mit hd3:

/etc/fstab:

Quellcode

1
2
3
4
5
6
7
8
9
/dev/hdd1           	/boot       	ext3        	noauto,noatime  0 2
/dev/hdd3           	/           	ext3        	noatime     	0 1
/dev/hdd2           	none        	swap        	sw          	0 0
/dev/hdd5           	/home       	ext3        	noatime     	0 2
/dev/cdrom          	/mnt/cdrom  	auto        	noauto,ro   	0 0

proc                	/proc       	proc        	defaults    	0 0

shm                 	/dev/shm    	tmpfs       	nodev,nosuid,noexec 	0 0


/boot/grub/grub.conf:

Quellcode

1
2
3
4
5
6
7
default 0
timeout 3
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title Gentoo Linux 2.6.30-r6
root (hd0,0)
kernel /boot/kernel-2.6.30-gentoo-r6 root=/dev/hdd3


Fehler beim Hochfahren:

Quellcode

1
2
3
4
5
6
7
8
9
10
* Chicking root filesystem
fsck ext3: No such file or directory while trying to open /dev/hdd3
/dev/hdd3:
The supperblock could not be read or does not describe a correct ext2 filesystem. 
If the device is valid and it really contains an ext2 filesystem 
(and you might) try running e2fsck with an alternate supperbloc: 
e2fsck -b 8193 <device>

* Filesystem could not be fixid : (Give root password for maintenance 
(or type Contrl-D to continue)):

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »terr« (15.09.2009, 10:53)


45

15.09.2009, 10:57

root (hd0,0) ?

root (hd3,0)
Phenom X4 9550
Gigabyte GA-MA770-UD3
Gentoo 64 Bit Stable
8 GB Ram
Audigy 2 Zs
Geforce 9800 GTX
VDR
Hauppauge Nexus-S Rev 2.2 + 2.1

Lenovo G550 T4300
Gentoo 64 Bit Stable
4 GB Ram

46

15.09.2009, 11:13

Ok, der root-Eintrag im grub scheint zu stimmen. Und die richtige Partition findet er wohl auch. Hast du denn auch ext3-Unterstützung fest in den Kernel eingebaut?
Irgendwas will da mim Filesystem nicht so ganz...

47

15.09.2009, 11:35

root (hd0,0) ?

root (hd3,0)
mit root (hd3,0) geht's gar nichts, root (hd0,0) soll richtig sein.
Hast du denn auch ext3-Unterstützung fest in den Kernel eingebaut?
Irgendwas will da mim Filesystem nicht so ganz...
ich habe nur folgendes Befehler ausgeführt:

Quellcode

1
2
# mke2fs /dev/sda1
# mke2fs -j /dev/sda3


Wie kann ich ext3-Unterstüzung in den Kernel einbauen?

48

15.09.2009, 14:29

Du hast ihn doch sicher mit make menuconfig gebaut? Fann musst du bei file-Systems schauen, ob ext3 fest (mit Sternchen) im Kernel eingebaut ist, nicht als Modul (m)...

49

15.09.2009, 17:00

es geht einfach nicht. Ich gebe auf. Ich werde mal die Festplatte umstecken.

Vielen vielen Dank für eure Hilfe. :thumbsup:

Grüße
terr