Sie sind nicht angemeldet.

1

24.01.2010, 19:31

VDR findet keine DVBkarte

Hallo Leute

Hab mir VDR installiert leider läßt es sich nicht starten. VDR findet keine dVBkarte :( auch mit kaffeine wird keine brauchbare Hardware gefunden. Folgendes habe ich gemacht. Kernel für DVB kompiliert. Treiber im Kernel einkompiliert. VDR ganz normal mit emerge installiert.

Quellcode

1
2
3
dmesg | grep dvb
[1.513294] saa7146: register extension 'budget dvb'.
[1.513906] saa7146: register extension 'budget_ci dvb'.


und wie man sieht auch geladen. Dann auch noch die richtige Firmware installiert.

Quellcode

1
-rw-r--r-- 1 root root 242696 Jan 23 12:08 /lib/firmware/dvb-ttpci-01.fw


Wie http://www.vdr-wiki.de/wiki/index.php/Gentoo_DVB_Treiber beschrieben, kann ich auch nicht herausfinden was ich für Module brauche. Da

Quellcode

1
modprobe evdev 


auch nicht funktioniert, obwohl installiert... kopfkratz. In meiner make.conf steht

Quellcode

1
DVB_CARDS="ttpci"


Leute bitte helft mir ich weis nicht mehr weiter. Ich vermute ja das mir im Kernel noch was fehlt, nur leider finde ich es nicht.

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »boospy« (06.02.2010, 16:23)


2

24.01.2010, 21:18

so Allrounder wie vlc kommt damit auch nicht klar?
ich hatte immer eine Box, daher mußte ich sowas nie über den Rechner frickeln ..
System:
i7 P2600 @ 3,4GHz
jabber: poedel@jabber.ccc.de

3

24.01.2010, 21:46

Hi,

ne leider nicht :( .
VDR ist eigentlich eh das einfachste... irgendwo liegt halt der Hund begraben....

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

4

24.01.2010, 23:42

aber FTA Sender kannste schaun, geht nur die Verschlüsselung nicht?
System:
i7 P2600 @ 3,4GHz
jabber: poedel@jabber.ccc.de

5

25.01.2010, 00:19

Um was für eine Karte, bzw Chipsatz geht es denn?
Hilfreich wäre zb die "lspci" Ausgabe.

6

25.01.2010, 00:35

Full Feature Hauppage Nexus-S

Quellcode

1
06:02.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)


VDR und auch andere Programme tun so als wäre die Karte nicht da. Module geladen, Firmware am richtigen Platz. Hab zur Sicherheit mal schnell ne VDR in nem Ubuntu Live installiert. Die Hardware ist ok.

lg
Boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

7

25.01.2010, 14:15

Hi

ich vermute das dir da noch Grundlegende Treiber fehlen, im Kernel findet sich zb

Quellcode

1
2
3
4
5
6
7
    │ Symbol: VIDEO_SAA7146 [=n]                                                                                                          │
  │   Selected by: VIDEO_SAA7146_VV [=n] && MEDIA_SUPPORT [=m] && VIDEO_V4L2 [=m] || DVB_BUDGET_CORE [=n] && MEDIA_SUPPORT [=m] && DVB_ │
  │                                                                                                                                     │
  │                                                                                                                                     │
  │ Symbol: VIDEO_SAA7146_VV [=n]                                                                                                       │
  │   Selects: VIDEOBUF_DMA_SG [=n] && VIDEO_SAA7146 [=n]                                                                               │
  │   Selected by: VIDEO_MXB [=n] && MEDIA_SUPPORT [=m] && VIDEO_CAPTURE_DRIVERS [=y] && VIDEO_V4L2 [=m] && PCI [=y] && VIDEO_V4L1 [=m]

Ansonsten gibt es aber auch sehr viel Info zu diesem Chipsatz zu finden..
siehe zb auch http://www.vdrportal.de/board/thread.php…d0aba3aeaa53b99
Ich persönlich würde vermutlich die Kernelinternen Treiber Module bevorzugen.

Viel Erfolg

8

26.01.2010, 23:02

Ok Leute, meine VDR geht. Um das zu bewerkstelligen, hab ich aber sämtliche Treiber und Dinge die mit DVB und v4l im Kernel aktiviert. Das gefällt mir natürlich nicht. Wie kann ich jetzt herausfinden, was die Karte braucht?

Wie ist denn das mit den Sourcequellen? Man kann VDR ganz normal aus Gentoo heraus installieren oder auch mit Layman eine andere Quelle (war wohl bei VDR immer so) hinzufügen und von dort die Pakete holen. Was ist den gescheiter? Bei Ubuntu waren die externen VDRpakte meistens net so supa.

Vielen dank und

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »boospy« (26.01.2010, 23:15)


9

26.01.2010, 23:08

Ist es evtl. ein Berechtigungsproblem? Wie sehen die Berechtigungen des Devices aus?

Quellcode

1
find /dev/dvb* -exec ls -l {} \;

Bist Du in der Gruppe drin?
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

10

26.01.2010, 23:20

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
crw-rw---- 1 root video 212, 3 Jan 26  2010 audio0
crw-rw---- 1 root video 212, 4 Jan 26  2010 ca0
crw-rw---- 1 root video 212, 0 Jan 26  2010 demux0
crw-rw---- 1 root video 212, 1 Jan 26  2010 dvr0
crw-rw---- 1 root video 212, 7 Jan 26  2010 frontend0
crw-rw---- 1 root video 212, 6 Jan 26  2010 net0
crw-rw---- 1 root video 212, 5 Jan 26  2010 osd0
crw-rw---- 1 root video 212, 2 Jan 26  2010 video0
crw-rw---- 1 root video 212, 4 Jan 26  2010 /dev/dvb/adapter0/ca0
crw-rw---- 1 root video 212, 6 Jan 26  2010 /dev/dvb/adapter0/net0
crw-rw---- 1 root video 212, 7 Jan 26  2010 /dev/dvb/adapter0/frontend0
crw-rw---- 1 root video 212, 5 Jan 26  2010 /dev/dvb/adapter0/osd0
crw-rw---- 1 root video 212, 2 Jan 26  2010 /dev/dvb/adapter0/video0
crw-rw---- 1 root video 212, 3 Jan 26  2010 /dev/dvb/adapter0/audio0
crw-rw---- 1 root video 212, 1 Jan 26  2010 /dev/dvb/adapter0/dvr0
crw-rw---- 1 root video 212, 0 Jan 26  2010 /dev/dvb/adapter0/demux0


In der Gruppen Video bin ich drinnen. Boote ich aber meinen schlanken Kernel ohne den vielen Treibern und Optionen, geht da nix.

Achja, ich hab 3 Devices "Video0 1 und 2" Ich hab aber nur 2 Geräte. Einmal die Satkarte und einmal die Webkam, wobei die Webkam noch immer keinen Mux macht. Hmm...

Zitat

vivi /dev/video0
uvc kamera /dev/video1
dvb /dev/video2
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

11

27.01.2010, 00:00

lspci und lsusb zeigen unter den Geräteinfos noch den akut verwendeten Treiber bzw. das Modul an. Daran müßte man erkennen können, welche Module welche Hardware konkret benötigt ..
System:
i7 P2600 @ 3,4GHz
jabber: poedel@jabber.ccc.de

12

28.01.2010, 17:06

Oder du probierst es einfach aus.
Einen nach dem anderen Treiber aus dem Kernel nehmen, immer wieder neu kompilieren, rebooten, testen, neue config schreiben...
Viel Vergnügen ;-)
Ich verspreche dir, du wirst mit der Zeit richtig schnell werden. ccache und distcc einrichten, und du kannst deinen Kernel bis zu 30mal die Stunde neu bauen.

PS: Nein, ich meine es nicht ernst.

13

28.01.2010, 17:36

OK, Leute

Dann geh ichs an ;)

lg
Boospy
____________________________
Nachtrag:

Äusserst seltsam ist, das die VDR jetzt auch mit meinem Erstkompilieten Kernel läuft. Ich hab in der Zwischenzeit einige Dinge nachinstalliert. Hm, weis aber nicht genau, was dann das ausschlaggebende war. Naja, egal. Jedenfalls funzt es.

lg
Boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »boospy« (01.02.2010, 00:17)