Sie sind nicht angemeldet.

1

17.04.2010, 18:24

Emerge Problem auf 1&1 VServer

Hallo zusammen,

ich versuche gerade gentoo auf einem VServer von 1&1 zu installieren. Ich gehe dabei nach folgender Anleitung vor: http://log.onthebrink.de/2008/04/gentoo-on-1-vserver.html.

Ich habe allerdings die aktuelle portage version zur Installation genommen (10.0).

Leider bekomme ich jetzt bei der Installation von jedem Paket gemeldet, dass folgendes packages leider maskiert ist (masked by: missing keyword)

Beispiel:

Quellcode

1
2
3
4
5
6
7
8
9
10
 emerge eselect
Calculating dependencies   
!!! All ebuilds that could satisfy "eselect" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-admin/eselect-1.2.8 (masked by: missing keyword)
- app-admin/eselect-1.2.9 (masked by: missing keyword)
- app-admin/eselect-1.2.10 (masked by: missing keyword)

For more information, see MASKED PACKAGES section in the emerge man page or 
refer to the Gentoo Handbook.


meine make.conf sieht so aus:

Quellcode

1
2
3
4
5
6
7
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
ACCEPT_KEYWORDS="~x86"
ARCH="x86"


der symlink auf die make.profile ist auch richtig gesetzt:

Quellcode

1
lrwxrwxrwx  1 root root 44 Apr 17 18:00 /etc/make.profile -> /usr/portage/profiles/default/linux/x86/10.0


Ich habe den Verdacht, dass ich eine inkompatible stage zu portage hab:


Laut Anleirung habe ich folgende versionen genommen

Quellcode

1
2
3
wget ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/experimental/x86/vserver/stage3-i686-20060317.tar.bz2

wget ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/snapshots/portage-latest.tar.bz2


Ich bin eigentlich ziemlich fit, was gentoo installationen und linux im allgemeinen angeht und habe auch soweit nix im inet gefunden.

weiss jmd weiter?

2

17.04.2010, 18:50

Dein Stage ist ja von 2006! Das kannst Du vergessen.

Nimm eins von hier: http://bb.xnull.de/projects/gentoo/
Diese sind bereits mit Openrc vorkonfiguriert.
Leider funktionieren sie nur mit den aktuelleren VServer Versionen, die bei Gentoo noch testing sind.

Nimm als Anleitung das offizielle Howto: http://www.gentoo.org/proj/en/vps/vserver-howto.xml
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

3

17.04.2010, 18:57

Ich habe den Verdacht, dass ich eine inkompatible stage zu portage hab:
stage3-i686-20060317.tar.bz2
Das könnte schon gut sein, sie ist ja auch sehr sehr alt...
Ich würde da eher versuchen eine aktuellere Stage zu nehmen, siehe zb http://www.gentoo.org/proj/en/vps/vserver-howto.xml

Zitat

In the meantime please download a stage3/4 or gentoo-vserver stage from here

/edit: da war bell ein wenig schneller

Viel Erfolg