Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

28.04.2010, 15:44

Umstellung von manuell auf Genkernel, wie gehe ich am besten vor

Hallo Leute

Nachdem ich doch einige Probleme habe, wurde mir empfohlen auf Genkernel umzustellen, da das Hardwareproblem (also die Erkennung der Hardware) dann wohl zur Verkangenheit angehörten wird. Vertehe ich das richtig das bei Genkernel einfach alles als Modul kompiliert wird, sodas ich mir über die Hardware keine Gedanken machen muss? Also keinen DVB-S, kein Wlan usw. manuell einstellen... Wenn ja, wäre das natürlich supa. Ich habe den Link hier gefunden.
http://www.gentoo.org/doc/de/genkernel.xml Kann ich nachdem vorgehen?

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »boospy« (11.08.2011, 00:45)


2

28.04.2010, 16:19

Jain...

1. Durch die mittels Genkernel erstellte initramfs wird eine Hardware-Erkennung durchgeführt
2. Ist etwas im Kernel nicht aktiviert (auch nicht als Modul) nützt dir diese Erkennung ebenfalls nichts. Genkernel baut aber von Haus aus ziemlich viele Module ein.

Mittels

Quellcode

1
genkernel --menuconfig all


lässt sich die Konfiguration aufrufen und, wie du es bestimmt bereits kennst, auch verändern.


MfG, Andre

//edit: Natürlich kannst du nach dem Link vorgehen ;)
Sys:
AMD FX (tm)-6300 Six-Core Processor
GeForce GTX 650 1024MB
16384 MB DDR3 1600Mhz
ASUS M5A97 R2.0
Samsung SSD 830 (sys)

OS: Gentoo ~amd64
WM: i3
Kernel: vanilla-sources
VGA: nouveau
INIT: OpenRC :)

██ ██ █ ████ everything ███ █████ is █████ ████ ████ fine ████ ███ █ ██████ trust █████ ██████ ███ your █████ ████ government. Parts of this comment have been found in violation of H.R. 3261, S.O.P.A and Senate Bill 968, P.I.P.A. and have been censored for your benefit.

3

28.04.2010, 16:24

Hallo,

also beim genkernel wird sehr viel als Modul gebaut. Es kann aber durchaus noch möglich sein das einige Sachen Fehlen. Ich glaube UVESA-TNG ist noch nicht aktiviert als Standard. Es kann auch durchaus möglich sein das beim WLAN was nicht aktiviert ist.

Ich würde Dir auf jeden Fall empfehlen die Config durchzugehen. Du kannst ja mit folgendem Befehl auch die Kernel einstellungen beim genkernel ändern.

Zitat

genkernel --menuconfig all


Ich würde z.b. auch die CPU richtig einstellen.

Mit lspci kannst Du schauen welche Hardware bei Dir verbaut ist.

Viele Grüße
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

4

28.04.2010, 16:58

Ok, Leute vielen Dank. Ich mach das mal. Und melde mich dann wieder.

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

5

28.04.2010, 17:15

Genkernel bringt eigene Standard Kernel-Konfigurationen. Diese liegen unter

Quellcode

1
2
/usr/share/genkernel/arch/$(uname -m)/kernel-config
/usr/share/genkernel/defaults/kernel-config

Diese sind entwas veraltet: sys-kernel/genkernel-3.4.10.906

Quellcode

1
2
3
4
5
6
$ head /usr/share/genkernel/arch/x86_64/kernel-config
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.24-gentoo-r7
# Fri May  9 01:16:07 2008
#
Diese alte Config wird dann irgendwie für den aktuellen Kernel aktualisiert. Das geht auch ab und zu schief.

Versuche lieber dir Deine Konfig mit

Quellcode

1
make allmodconfig
zu generieren
(Vorher die ".config" wegsichern und entfernen)
Diese Konfig kannst Du dann nach Deinen Bedürfnissen anpassen.

PS: Ich nutze Genkernel wegen der initramfs. Jedoch nutze ich die mitgelieferte Configs nicht, sondern lasse mit dem Parameter "--oldconfig" immer meine vorhandene und selbst gewartete ".config" benutzen.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

6

28.04.2010, 18:39

So, hab die alte Config wegesichert, hab sie aber nicht gelöscht (vergessen). Nachdem ich die Config durchgesehen habe ist mir aufgefallen das ziehmlich alles als Modul kompiliert wird. Dann hab mich noch die DVB-S Dinge und ein paar andere Sachen hinzugefügt und kompiliert. Der Kernel und initramfs wurde nach /boot geschrieben. In der menu.list hab ich noch folgenden eintrag hinzufügt:

Quellcode

1
2
3
4
5
6
7
8
9
title Gentoo Linux 2.6.31-r6
root (hd0,0)
kernel /boot/kernel-genkernel-x86_64-2.6.31-gentoo-r10 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_$
initrd /boot/initramfs-genkernel-x86_64-2.6.31-gentoo-r10

#-maneller Kernel
title Gentoo Linux 2.6.31-r10-2
root (hd0,0)
kernel /boot/gentoo-manuell-kernel root=/dev/sda2 real_root=/dev/sda2

Braucht ich den die Option ramdisk?. Ich trau mich ehrlichgesagt nicht rebooten. Möchte nicht schon wieder mit ner Livedisk hochfahren und Dinge dort einstellen.

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

7

28.04.2010, 18:53

Das sieht doch soweit sehr gut aus.

Das mit der Live CD wirst Du wohl nicht brauchen. Du hast doch noch Deinen manuellen Kernel in der menu.lst stehen.

Bootet Dein neuer nicht, kannst Du einfach den alten wieder starten.

Gruß
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

8

28.04.2010, 19:57

So, nach dem reboot sahs zuerst gar nicht schlecht aus. Alles wurde geladen keine Fehlermeldung, bis auf die DVBkarte. Aber das ist egal, da ich nur was vergessen anzuhaken. Leider hatte ich auch

- kein X
- keine Tastatur
- Maus konnte ich ja nicht testen.

Hab mich per SSH eingeloggt und hab wieder auf manuellen Kernel zurückgestellt (Module musste ich natürlich rekompilieren). Kein X war mir ja klar da ich ja auch den nvidiatreiber neu kompilieren musste. Aber keine Tastatur? Woran könnte das liegen? Ich hatte noch nie das eine Tastatur nicht funktionierte. Sie hängt per USB drann. Ich hab dann noch folgendes probiert:

Quellcode

1
2
emerge -q xorg-server media-libs/mesa x11-drivers/nvidia-drivers x11-drivers/xf86-input-evdev
 x11-drivers/xf86-input-joystick x11-drivers/xf86-input-virtualbox x11-drivers/xf86-video-v4l

Hatte leider keine Auswirkung.

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

9

28.04.2010, 20:19

Quellcode

1
emerge module-rebuild


und dann

Quellcode

1
module-rebuild rebuild


Wenn es dann immer noch nicht geht, hast Du was im Kerrnel vergessen zu aktivieren.

USB z.b.

Gruß
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

10

29.04.2010, 01:04

Ich habe alles nochmal rekompiliert. USB für Tastatur war nicht enthalten. Wenn ich jetzt X starte, geht der Prozess X auf 100% und es werden keine Tastatureingaben mehr angenommen, der Bildschirm schaltet sich aus. Ich habe eine Nvidiagrafikkarte. Sie ist mit eselect ausgewählt,und das Modul ist geladen. Muss man denn sonst noch was bei der Kernelumstellung oder in der Kernelconfig beachten?

lg boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

11

29.04.2010, 08:54

Wenn du auf diese Maschine mit SSH dann raufgehst, was siehst du denn in der /var/log/Xorg.0.log und dmesg?

... und verwendest du jetzt den alten oder neuen Kernel. Das ist mir nach deiner vorletzten post nicht klar ... :huh:

.. auch: kannst du Probleme mit der Graka ausschliessen, wenn du vlt. mal VESA ladest? Benutzt du eine Xorg.conf oder keine mehr? Hast du "hal" im USE und "evdev" als INPUT?
http://www.dyle.org
IM-Account (Jabber!) sind auf meiner HP ...
There is no place like /home

http://www.gentooforum.de
http://www.gentoofreunde.org

<div>how to annoy a web developer?</span>

12

29.04.2010, 11:03

Hallo

Entschuldige bitte meine etwas verwirrenden Angaben. Ich fahre mit dem genkernel hoch. Fehler der Grafikkarte kann ich auschließen, da sie mit dem manuellen Kernel funzt. Ich habe hal als und evdev als input. In der xorg.log steht ein error:

Quellcode

1
2
3
4
5
6
7
8
9
10
(II) Apr 29 00:41:56 NVIDIA(0): Validated modes:
(II) Apr 29 00:41:56 NVIDIA(0):     "nvidia-auto-select"
(II) Apr 29 00:41:56 NVIDIA(0): Virtual screen size determined to be 1920 x 1200
(--) Apr 29 00:41:56 NVIDIA(0): DPI set to (93, 95); computed from "UseEdidDpi" X config
(--) Apr 29 00:41:56 NVIDIA(0):     option
(==) Apr 29 00:41:56 NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) Apr 29 00:41:56 NVIDIA(0): Initialized GPU GART.
(II) Apr 29 00:41:59 NVIDIA(0): Setting mode "nvidia-auto-select"
(EE) Apr 29 00:42:27 NVIDIA(0): WAIT: (E, 0, 0x827d, 0)

In der dmesg steht unter nvidia folgendes:

Quellcode

1
2
3
nvidia: module license 'NVIDIA' taints kernel.
nvidia 0000:05:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
nvidia 0000:05:00.0: setting latency timer to 64

Dann gibt es da noch lsmod:

Quellcode

1
2
nvidia               8743320  0 
i2c_core               12240  7 lnbp21,stv0299,dvb_ttpci,nvidia,videodev,i2c_i801,ttpci_eeprom


Die xorg.conf nutze ich nur noch für die Übergabe des Grafiktreibers:

Quellcode

1
2
3
4
5
6
7
Section "Device"
    Identifier  "Card0"
    Driver      "nvidia"
    VendorName  "nVidia Corporation"
    BoardName   "G92 [GeForce 8800 GT]"
    BusID       "PCI:5:0:0"
EndSection


Sonst fällt mir im Momemt jetzt auch nicht ein.

lg boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

13

29.04.2010, 13:41

=)

Also irgendwie mag dein nvidia-treiber den neuen Kernel ja gar nicht ... kannst du mal probeweise auf andere Treiber-Versionen ausweichen? Das ist sehr seltsam, obwohl ... wie sieht denn jetzt deine .config aus?
http://www.dyle.org
IM-Account (Jabber!) sind auf meiner HP ...
There is no place like /home

http://www.gentooforum.de
http://www.gentoofreunde.org

<div>how to annoy a web developer?</span>

14

29.04.2010, 14:17

Ich vermute, der nvidia beißt sich mit dem framebuffer-Treiber (welcher ist jetzt aktiv?). Gehe nochmal die uvesafb Anleitung durch oder deaktiviere den Framebuffer.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

15

29.04.2010, 14:41

Falls du nicht weiter kommst poste bitte auch mal die Ausgabe von

Quellcode

1
# dmesg | grep vesa

wenn da nichts kommt, dann poste bitte auch noch mal deine komplette Kernelzeile aus der grub.conf.

16

29.04.2010, 16:58

Framebuffer deaktiviert
bei Vesa kommt nichts, hier die Kernelzeile:

Quellcode

1
kernel /boot/kernel-genkernel-x86_64-2.6.31-gentoo-r10 root=/dev/ram0 init=/linuxrc real_root=/dev/sda2

Ein älterer Nvidiatreiber reagiert gleich.

Ich hab mir doch gleich gedacht das das mit dem Genkernel eine Blöde Idee war. Hab mal zum Test mit der manuellen Methode den aktuell Stable Kernel 2.6.32-gentoo-r7 gebaut. Läuft. Ich weis nicht ob sich das bringt hier noch weiter so forschen wo der Wurm liegt. Ich werde mich wohl dem Problemen die ich noch habe, ihr kennt sie ja alle (CD-brenner usw.) direkt witmen.
Genkernel sollte ja eigentlich ein Hilfsmittel sein. Naja...

Was mir auch noch aufgefallen ist: Bei Genkernel dreht der Prozessorlüfter auch beim Kompilieren nicht wirklich viel schneller. Die Steigerung ist minimal. Bei meinem manuell kompilierten, gibt er ganz schön gas. Ich werd wohl mal die Configs vergleich müssen.

Kann man denn den Genkernel ein anderes Modulverzeichnis übergeben, damit ich nicht immer bei Nichtfunktion den manuellen Kernel rekompilieren muß? Dann kann ich mich mit diesem Problem ohne Zeitdruck befassen.

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »boospy« (29.04.2010, 17:05)


17

29.04.2010, 17:35

Zitat

Kann man denn den Genkernel ein anderes Modulverzeichnis übergeben, damit ich nicht immer bei Nichtfunktion den manuellen Kernel rekompilieren muß? Dann kann ich mich mit diesem Problem ohne Zeitdruck befassen.


Du kannst im genkernel --menuconfig folgenden Parameter mitgeben:

Quellcode

1
2
3
4
5
  │ Symbol: LOCALVERSION [=]                                                │  
│ Prompt: Local version - append to kernel release                        │  
│   Defined at init/Kconfig:79                                            │  
│   Location:                                                             │  
│     -> General setup                                                    │  

zB. "-gk". Dann hast Du das Module-Verzeichnis "/lib/modules/2.6.32-gentoo-r7-gk" für die Genkernel-Module. Entsprechend heißen auch die Dateien unter /boot
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

18

29.04.2010, 22:56

Danke Bell, so werd ich es machen. Dann kann ich mit Ruhe probieren.

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

19

11.08.2011, 00:44

So, damit das der Richtigkeit halber auch auf gelöst gesetzt wird. Nutze Genkernel schon auf allen Servern, da ist man dann mit den Updaten schneller. Der Grund warum es bei meinem Beispiel hier nicht funktioniert war sehr einfach, obwohl die alte Konfig in das Kernelverzeichnis kopiert wurde, wurde dies ignoriert. Funktioniert natürlich nur so:

Quellcode

1
genkernel --bootloader=grub --oldconfig --makeopts=-j9 all

Wobei man diese Optionen auch alle schon in der /etc/genkernel.conf festlegen kann. Dann würde ein

Quellcode

1
genkernel all

genügen.

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at