Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

21.06.2010, 07:55

Mail Versand über ssmtp klappt nicht immer: dead.letter

Hallo,

ich habe vor kurzem die System-Aktualisierung meines Home-Servers per Cron-Job gelöst. Die Ausgabe des Jobs ist so weit wie möglich "quiet", so dass die versendete Mail noch überflogen werden kann. Das Problem ist, öfter kommt die e-Mail nicht, mit der Ausgabe der Aktualisierung.

Der Mail-Versand läuft über mail-mta/ssmtp -> Mailserver
Der Mailserver ist eine vserver Instanz auf der selben Hardware und über ein Dummy-Netzwerk (dummy0). mit dem Host und anderen VMs verbunden.
Auf dem Mailserver läuft mail-mta/postfix

Wenn das Problem passiert, habe ich eine leere Datei /root/dead.letter auf dem Host (Absende-System).
und eine Fehlermeldung "sSMTP[4787]: Connection lost in middle of processing" in der /var/log/messages ebenfalls auf dem Host.

Auf dem Mailserver selbst sehe ich nichts, also weder Fehler noch dass überhaupt versucht wurde eine Mail zu empfangen.

Hat jemand eine Idee was ich machen kann?
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »bell« (14.07.2010, 10:39) aus folgendem Grund: Tags angepasst


2

22.06.2010, 14:27

Bin wohl nicht allein mit dem Problem: http://forums.gentoo.org/viewtopic-t-302341.html, hab jedoch noch keine Lösung.
Das Problem scheint wohl zu sein, dass ssmtp beim Start des Cron-Jobs bereits die Verbindung zum Mail-Server aufbaut. Wegen der längeren Laufzeit gibt es einen Timeout.

Kann mir jemand einen anderen "leichten" mta empfehlen? Er braucht nur die Mails weiterleiten, wie der ssmtp.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

3

23.06.2010, 07:33

Letzter Beitrag zu meinem Selbstgespräch...
Hab gestern auf dem System von ssmtp auf mail-mta/nullmailer umgestellt. Heute nacht ist das System-Update ohne Probleme gelaufen, obwohl Python dabei gewesen ist. Ich denke, mit dem nullmailer ist das Problem gelöst. Falls nicht, melde ich mich nochmal.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

Verwendete Tags

dead.letter, mail, smtp, ssmtp