Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

25.06.2010, 09:54

Problem mit Skystar HD2 (DVB-S/S2)

Hallo,

ich habe seit einigen Tagen die Skystar HD2 von TechniSat, unter Windows 7 hat so weit alles funktioniert. :P
Was genau das Problem unter Gentoo ist, weiß ich nicht, aber Kaffeine kann z.B. keinen Sendersuchlauf machen.

Die Ausgabe von "lspci" ergibt, dass die Karte erkannt wird:

Quellcode

1
05:01.0 Multimedia controller: Twinhan Technology Co. Ltd Mantis DTV PCI Bridge Controller [Ver 1.0] (rev 01)


"mantis_core" und "mantis" sind als Modul erstellt, allerdings sagt mir die rc.log

Quellcode

1
2
3
4
* Loading module mantis ...
/etc/init.d/modules: Zeile 59:  2647 Getötet            	modprobe -q mantis
 * Failed to load mantis [ !! ]
 * Loading module mantis_core ... [ ok ]


VDR kann nicht gestartet werden, da kein DVB-Gerät gefunden werden kann.

Kernel ist "linux-2.6.34-gentoo-r1"

Wenn weitere Infos nötig sind, einfach sagen. :)

Mfg

2

30.06.2010, 21:02

Ist das nicht die gleiche Karte wie in http://www.gentooforum.de/artikel/18957/…arte-nicht.html

Hast du selbst den mantis treiber in die module-liste eingefügt? Wenn ja, dann nimm ihn mal raus.

Mach jedenfalls mal ein

Quellcode

1
# dmesg
und dann ein

Quellcode

1
# modprobe -v mantis
Guck dann anschließend was sich bei einem erneuten

Quellcode

1
# demsg
geändert hat. Dort sollte jetzt was drinn steht, woran es hackt ...
http://www.dyle.org
IM-Account (Jabber!) sind auf meiner HP ...
There is no place like /home

http://www.gentooforum.de
http://www.gentoofreunde.org

<div>how to annoy a web developer?</span>

3

25.07.2010, 16:52

Das sind verschiedene Karten.

Im Anhang mal der Output vom zweiten dmesg, kann damit leider nicht viel anfangen.

Quellcode

1
/etc/init.d/vdr start

ergibt

Quellcode

1
2
3
4
* Preparing start of vdr:
 *   Waiting for DVB devices ...
 * 	No DVB device found.                                                                                                                                                         	[ !! ]
 * 	If you do not use DVB hardware, then disable DVB_DEVICE_WAIT in /etc/conf.d/vdr
»^S7evinK« hat folgende Datei angehängt:
  • dmesgout2.txt (71,64 kB - 1 mal heruntergeladen - zuletzt: 28.07.2010, 08:50)

4

28.07.2010, 08:44

Hallo,

hast Du v4l-dvb-hg installiert?? Man kann auch in die make.conf mehrere repositories angeben.

Vielleicht kannst Du mal das versuchen.

Viele Grüße
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

5

28.07.2010, 09:17

unter Windows 7 hat so weit alles funktioniert. :P
Mit so einem Spruch reißt du hier keine Fliege mehr vom Hocker...
Wenn ich das richtig sehe lief dieser Chipsatz unter Linux schon als es Windows 7 noch gar nicht gab ;)

Was für ein Kernel wird denn verwendet?
Was sagt ein

Quellcode

1
# modprobe -v ModulName
?
Wurde die passende Firmware bereitgestellt?

6

28.07.2010, 09:31

Kernel ist "linux-2.6.34-gentoo-r1"




josef.95 steht doch da was für ein Kernel er verwendet.

Soweit ich weiß, braucht man für die Skystar HD2 keine Firmware laden.

Wichtig ist das die liplianin Treiber verwendet werden.

Gruß
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Planeshift« (28.07.2010, 09:37)


7

28.07.2010, 11:04


Mit so einem Spruch reißt du hier keine Fliege mehr vom Hocker...
Wenn ich das richtig sehe lief dieser Chipsatz unter Linux schon als es Windows 7 noch gar nicht gab ;)
Damit wollte ich Aussagen, dass kein Hardwaredefekt vorliegt. :P
Kernel ist "linux-2.6.34-gentoo-r1"
Wichtig ist das die liplianin Treiber verwendet werden.

Mittlerweile r2.

Werd nochmal versuchen die liplianin Treiber zu installieren. :)


//
So, bei "make" scheitert das leider schon.

Quellcode

1
2
3
4
5
6
7
8
9
10
/home/s7evink/Desktop/dvb/s2-liplianin-0af9e0ff39af/v4l/ak881x.c: In function 'ak881x_probe':
/home/s7evink/Desktop/dvb/s2-liplianin-0af9e0ff39af/v4l/ak881x.c:265: error: implicit declaration of function 'kzalloc'
/home/s7evink/Desktop/dvb/s2-liplianin-0af9e0ff39af/v4l/ak881x.c:265: warning: assignment makes pointer from integer without a cast
/home/s7evink/Desktop/dvb/s2-liplianin-0af9e0ff39af/v4l/ak881x.c:283: error: implicit declaration of function 'kfree'
make[3]: *** [/home/s7evink/Desktop/dvb/s2-liplianin-0af9e0ff39af/v4l/ak881x.o] Fehler 1
make[2]: *** [_module_/home/s7evink/Desktop/dvb/s2-liplianin-0af9e0ff39af/v4l] Error 2
make[2]: Leaving directory `/usr/src/linux-2.6.34-gentoo-r2'
make[1]: *** [default] Fehler 2
make[1]: Leaving directory `/home/s7evink/Desktop/dvb/s2-liplianin-0af9e0ff39af/v4l'
make: *** [all] Fehler 2


laut http://www.finnchristiansen.de/?tag=s2-liplianin soll man in der "Firedtv/Floppydtv" deaktivieren, nur finde ich diesen Eintrag in der menuconfig nirgends, zumal der Fehler bei mir anscheinend nichts mit diesem Firedtv zu tun hat.


//
Anleitung für Mantis Treiber von LinuxTV.org
auch nach dem Reboot funktioniert modprobe nicht. Sagt mir immer "Invalid argument". :/

Quellcode

1
2
3
4
5
6
gentoo_ dvb # modprobe -v mantis
insmod /lib/modules/2.6.34-gentoo-r2/kernel/drivers/media/IR/ir-core.ko 
WARNING: Error inserting ir_core (/lib/modules/2.6.34-gentoo-r2/kernel/drivers/media/IR/ir-core.ko): Invalid argument
WARNING: Error inserting ir_common (/lib/modules/2.6.34-gentoo-r2/kernel/drivers/media/IR/ir-common.ko): Invalid argument
WARNING: Error inserting mantis_core (/lib/modules/2.6.34-gentoo-r2/kernel/drivers/media/dvb/mantis/mantis_core.ko): Invalid argument
FATAL: Error inserting mantis (/lib/modules/2.6.34-gentoo-r2/kernel/drivers/media/dvb/mantis/mantis.ko): Invalid argument

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »^S7evinK« (28.07.2010, 13:24)