Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

10.12.2010, 12:44

Networkmanager verhindert Internet

Hallo Forum!

Dank Eurer Hilfe habe ich seit dieser Woche ein gentoo mit gnome und es läuft! Fast! ;-)
Meine Internet Verbindung lief out-of-the-box seit der Installation. Jetzt wollte ich unter gnome den networkmanager installieren um bequemer meine Internetverbindungen (eth0, wlan, mobiles breitband) verwalten zu können. Doch ich bekomme den nm nicht zum Laufen und/oder er blockiert mein Internet komplett.


alex-laptop alex # ifconfig
eth0 Protokoll:Ethernet Hardware Adresse 00:19:b9:85:67:52
inet Adresse:192.168.2.2 Bcast:192.168.2.255 Maske:255.255.255.0
inet6 Adresse: fe80::219:b9ff:fe85:6752/64 Gültigkeitsbereich:Verbindung
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:12085 errors:0 dropped:0 overruns:0 frame:0
TX packets:8371 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:1000
RX bytes:12715786 (12.1 MiB) TX bytes:1324693 (1.2 MiB)
Interrupt:17


lo Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:23 errors:0 dropped:0 overruns:0 frame:0
TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:414 (414.0 B) TX bytes:414 (414.0 B)

dell inspiron 1520
gentoo-sources-2.6.35-r12

dhcp-3.1.2_p1

networkmanager-0.7.2-r1


ich hab den networkmanager aus dem rc default rausgenommen, jetzt geht mein internet wieder. dafür geht im gnome die System/Einstellungen/Netzwerkverbindungen nicht mehr und kein nm-applet

Wo liegt der Fehler bzw. wie finde ich den heraus?

2

10.12.2010, 13:06

Hast Du Deinem USER das Recht für den Networkmanager gegeben?

Quellcode

1
polkit-auth --grant org.freedesktop.network-manager-settings.system.modify --user "DeinBenutzerName"


Außerdem sollte ansonsten alle anderen netzwerkstart Scripte aus dem Runlevel.

Also kein Eth0 und wlan0 starten lassen beim booten, sonnst geht der Networmanager nicht.

Gruß
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

3

10.12.2010, 13:12

Hier habe ich mal noch nen Link zum Englischen Wiki, damit sollte es dann auch klappen.

http://en.gentoo-wiki.com/wiki/NetworkManager

Gruß
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

4

11.12.2010, 19:01

Als ich den Networkmanager ausprobierte, hatte ich lauter Probleme. Ich empfehle dir, wicd anzuschauen.


5

11.12.2010, 19:36

Ich empfehle dir, wicd anzuschauen.
Soweit mir bekannt unterstützt wicd aber nicht die vom Threadersteller geforderten Modem-Einwahlverbindung.

6

11.12.2010, 19:42

Hier noch mal nen deutscher Link, der auf dem englischen Wiki Eintrag beruht und noch ein paar extra Erklärungen mit drin hat
http://www.gentoofreunde.org/node/533

7

13.12.2010, 10:05

Kann es sein, das es Abhängigkeitsprobleme sind?
nm-applet hat Version 0.8 und verlangt networkmanager 0.8 aber der networkmanager ist für x86 0.7.2-r1 als stable markiert.
Ich bin noch nicht so lange bei gentoo und weiß nicht, wie ich das Problem am besten löse.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »alex1974« (13.12.2010, 10:23)


8

13.12.2010, 11:51

Kann es sein, das es Abhängigkeitsprobleme sind?
nm-applet hat Version 0.8 und verlangt networkmanager 0.8 aber der networkmanager ist für x86 0.7.2-r1 als stable markiert.

Hmm.., ja aber networkmanager-0.7.2-r1 gibt es doch schon gar nicht mehr im portage Tree...
Kann es sein das du schon länger kein "emerge --sync" mehr gemacht hast?
Die aktuell stable Versionen sind unter x86 networkmanager-0.8-r1 und nm-applet-0.8
siehe zb auch: http://packages.gentoo.org/package/net-m…anager?full_cat

Wenn das nach einem --sync immer noch nicht klappt dann poste doch bitte mal die Ausgabe von

Quellcode

1
emerge -pvuDNt nm-applet

9

13.12.2010, 14:05

Kann es sein, das es Abhängigkeitsprobleme sind?
nm-applet hat Version 0.8 und verlangt networkmanager 0.8 aber der networkmanager ist für x86 0.7.2-r1 als stable markiert.
Ich bin noch nicht so lange bei gentoo und weiß nicht, wie ich das Problem am besten löse.

nm-applet 0.8x braucht natürlich auch networkmanager 0.8x.

Entweder nm-applet 0.8x masken oder networkmanager 0.8x und plugins unmasken.

Viele Grüße
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay