Sie sind nicht angemeldet.

1

03.01.2011, 13:14

GRUB menu erscheint nicht bei boot

HI
Ich hab zwei platten in meinem PC, hda und hdb, auf hdb habe ich wie im gentoo howto sdb1 zu /boot , sdb2 zu swap und sdb3 zu / gemacht
und nach vielen steps auch grub-install -no--floppy /dev/sdb aufgerufen.

Nach einem neustart erscheint zwar dann das grub prompt (grub>) aber nicht das menu mit meinen einträgen aus menu.lst
setze ich dann in der grub command line

Quellcode

1
root (hd1,0)
und sage

Quellcode

1
configfile /grub/grub.conf
erscheint das menü.
Meine frage ist, warum das menü nicht gleich erscheint?

ich hab auch schon versucht grub direkt einzurichten mit

Quellcode

1
2
3
grub> root (hd1,0)
grub> setup 
grub> quit

wie hier http://www.gentoo.de/doc/de/handbook/han…?part=1&chap=10
aber auch ohne erfolg, es kommt immer nur das grub prompt!

hier noch meine konfigs / verzeichnisse, shen eigentlich so aus wie hier http://www.gentoo.org/doc/de/grub-error-guide.xml

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
gentoo ~ # cat /boot/grub/menu.lst
# This is a sample grub.conf for use with Genkernel, per the Gentoo handbook
# http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=10#doc_chap2
# If you are not using Genkernel and you need help creating this file, you
# should consult the handbook. Alternatively, consult the grub.conf.sample that
# is included with the Grub documentation.

default 0
timeout 30
#splashimage=(hd1,0)/boot/grub/splash.xpm.gz

titleGentoo 2.6.36 02.01.2011
root(hd1,0)
kernel/boot/gentoo-2.6.36r5 root=/dev/sdb3


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
gentoo ~ # ls -al /boot/
total 4407
drwxr-xr-x  4 root root1024 Jan  2 21:14 .
drwxr-xr-x 18 root root4096 Jan  3 12:17 ..
-rw-r--r--  1 root root   0 Jan  3 11:59 .keep
lrwxrwxrwx  1 root root   1 Jan  2 16:06 boot -> .
-rw-r--r--  1 root root 4473888 Jan  2 19:21 gentoo-2.6.36r5
drwxr-xr-x  2 root root1024 Jan  3 12:43 grub
drwx------  2 root root   12288 Jan  2 15:35 lost+found
gentoo ~ # ls -al /boot/grub/
total 446
drwxr-xr-x 2 root root   1024 Jan  3 12:43 .
drwxr-xr-x 4 root root   1024 Jan  2 21:14 ..
-rw-r--r-- 1 root root197 Jan  3 12:43 default
-rw-r--r-- 1 root root 30 Jan  2 23:00 device.map
-rw-r--r-- 1 root root   8692 Jan  3 12:43 e2fs_stage1_5
-rw-r--r-- 1 root root   7820 Jan  3 12:43 fat_stage1_5
-rw-r--r-- 1 root root   7088 Jan  3 12:43 ffs_stage1_5
-rw-r--r-- 1 root root668 Jan  3 12:52 grub.conf
-rw-r--r-- 1 root root   7088 Jan  3 12:43 iso9660_stage1_5
-rw-r--r-- 1 root root   8684 Jan  3 12:43 jfs_stage1_5
lrwxrwxrwx 1 root root  9 Jan  2 21:14 menu.lst -> grub.conf
-rw-r--r-- 1 root root658 Jan  3 12:06 menu.lst.save
-rw-r--r-- 1 root root   7292 Jan  3 12:43 minix_stage1_5
-rw-r--r-- 1 root root   9684 Jan  3 12:43 reiserfs_stage1_5
-rw-r--r-- 1 root root  33856 Jan  3 11:59 splash.xpm.gz
-rw-r--r-- 1 root root512 Jan  3 12:43 stage1
-rw-r--r-- 1 root root 107912 Jan  3 12:43 stage2
-rw-r--r-- 1 root root 107912 Jan  2 23:00 stage2.old
-rw-r--r-- 1 root root 107912 Jan  3 11:59 stage2_eltorito
-rw-r--r-- 1 root root   7344 Jan  3 12:43 ufs2_stage1_5
-rw-r--r-- 1 root root   6692 Jan  3 12:43 vstafs_stage1_5
-rw-r--r-- 1 root root   9524 Jan  3 12:43 xfs_stage1_5
gentoo ~ #


vielen dank schon mal!

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »hcc« (05.01.2011, 16:15)


2

03.01.2011, 20:54

Hallo und willkommen im Forum,

So wie es scheint findet er dein "--root-directory=/Pfad zu deinem root" nicht, versuch es mal mit anzugeben.

Quellcode

1
grub-install --no-floppy --no-recheck --root-directory=/Pfad zu deinem root /dev/sdb
ersetze den Pfad, dieser muß auch beim ausführen des Befehls gemountet sein.

Kommst Du damit zurecht?

Grüße-

3

04.01.2011, 07:45

Hallo,

Du wirst grub auf SDA installieren müssen und nicht auf SDB oder stehlt Du immer die Bootreihenfolge um?

Normal wird grub in den MBR von der ersten Festplatte installiert. Das ist dann SDA. Dann kannst Du dort auswählen ob Du Linux oder Windows booten willst.

Wenn Du es auf SDB stellst, musst Du ja jedes mal im Bios die Boot Platte umstellen von sda auf sdb.

Viele Grüße
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

4

04.01.2011, 17:22

Falls wenn DU willst win-doof nicht bald loswerden dann es ist möglich auch linux durch windoze starten
http://www.linuxquestions.org/questions/…-ubuntu-711676/
hab auf ne Kiste so was gemacht, und es funzt.
Allerdings wie im Beispiel C:\fedora.bin , DateiName muss passen im Format 8.3,
sonst XP kann linux nicht starten [ohne zu nörgeln].

5

04.01.2011, 18:06

the tirck is to switch the boot order in the BIOS and set root (hd0,0) instad of hd(1,0)

but i dont understand why grub is not abel to do it the other way! i see no problem in that, if the first disk has no MBR than look into the second disks MBR and run there Grub! Because i think it was that way before whit CentOS. But now its working! THX all
______________________________________
@Kurmis
das ganze ist nur eine Test rechner zum rumspielen, bevor ich die restliche landschaft nachziehe! Aber ich glaub die Grub Doku muss ich mir nochmal genauer anschaun!

6

04.01.2011, 21:19

please set the prefix to your thread by editing your first post so that all users can immediately see that this thread isn't actual anymore.

thanks.

MfG, Andre


//edit: Warum eigentlich englisch? :D
Sys:
AMD FX (tm)-6300 Six-Core Processor
GeForce GTX 650 1024MB
16384 MB DDR3 1600Mhz
ASUS M5A97 R2.0
Samsung SSD 830 (sys)

OS: Gentoo ~amd64
WM: i3
Kernel: vanilla-sources
VGA: nouveau
INIT: OpenRC :)

██ ██ █ ████ everything ███ █████ is █████ ████ ████ fine ████ ███ █ ██████ trust █████ ██████ ███ your █████ ████ government. Parts of this comment have been found in violation of H.R. 3261, S.O.P.A and Senate Bill 968, P.I.P.A. and have been censored for your benefit.

7

05.01.2011, 11:49

//edit: Warum eigentlich englisch? :D

Vielleicht hatte er die Frage ja auch im englischen Forum gestellt und ist jetzt durcheinander gekommen.

:thumbsup: :thumbsup:

Schön das Du es aber jetzt lösen konntest.
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay