Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

24.03.2011, 16:57

esound versus pulseaudio

Hallo allerseits,

habe heute mal meine USE-Flags sortiert und festgestellt, daß ich sowohl "-esd", als auch "-pulseaudio" gesetzt habe. Habe dann versucht, mich mittels google darüber zu informieren, weil ich irgendwie mit pulseaudio nichts anzufangen wusste (Dachte aber nach euse --info, daß es sich mit esd überschneidet). Habe den Eindruck gewonnen, daß beide eigentlich das gleiche machen, aber so richtig gerafft hab ich das nicht.

Konkret ist mir unklar, was ist der Unterschied zwischen den Beiden; bin da etwas verwirrt.

Im Moment habe ich Gnome drauf, esound wird im default runlevel gestartet, pulseaudio nicht.
"eselect esd show" sagt, daß esd gesetzt ist. Sound funzt soweit bestens.

Ist es da sinnvoll, die pulseaudio-useflag rauszunehmen und pulseaudio ganz runterzuschmeissen oder ist es besser, esd gegen pulseaudio zu ersetzen?

Wäre dankbar für ne kleine Erklärung
Beste Grüße
GOS

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »GOS« (25.03.2011, 13:37)


2

24.03.2011, 18:42

Das ist mal wieder eine Frage bei der ich mal wieder weit ausholen kann ;)

Also... Du hast recht, beide machen ungefähr das selbe. Es sind Sound-Server. Daneben kenne ich noch phonon und jack-audio-connection-kit.

Prinzipiell braucht man für den Normal-Gebrauch keinen davon. Die meisten Anwendungen können auch direkt mit Alsa sprechen und tun es standardmäßig auch. Wenn Du also einen der Soundserver nutzen willst, musst Du auch bei allen Anwendungen in den Einstellungen die Ausgabe auf diesen Soundserver umstellen.

esd: War früher Gnome-Standard und gilt inzwischen als veraltet.
Früher konnte immer nur eine Anwendung auf die Soundkarte zugreifen. Daher hatte esd als Hauptaufgabe mehrere Kanäle zur Verfügung zu stellen und zu mixen. Inzwischen kann das Alsa selbst (Stichwort "dmix"). Eine Zeit lang gab es noch Anwendungen die nur über esd den Sound ausgeben konnten. Daher musste man es haben. Hab solche Anwendungen aber schon lange nicht mehr gesehen.

pulseaudio: Aktueller Gnome (btw. Ubuntu) Standard.
Nennenswerte Features sind:
- Lautstärkeregelung pro Anwendung
- bei mehereren Soundkarten - Auswahl der Soundkarte pro Anwendung
- Netzwerkfähig: also Ausgabe auch auf einem anderen Rechner möglich

Hatte damit vor Paar Jahren gespielt, falls der Server abschmiert hast Du gar keinen Sound. Hatte also mehr Probleme als Nutzen.

phonon KDE Standard.
Kann dazu nichts sagen.

jack-audio-connection-kit: Ein Muss, wenn man selbst Musik macht.
Nennenswerte Features sind:
- Latenzzeiten-optimiert
- Ausgabe kann als Input für eine andere Anwendung weitergeleitet werden
- Kann auch MIDI-Ströme umleiten


Ich nutze keines davon. Den Jack starte ich bei Bedarf, wenn ich mal etwas klimpern will.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

3

24.03.2011, 20:13

Hatte damit vor Paar Jahren gespielt, falls der Server abschmiert hast Du gar keinen Sound. Hatte also mehr Probleme als Nutzen.



Da ich Gnome verwende, benutze ich nun schon lange Pulesaudio. Bis jetzt hatte ich damit keine Probleme. Für mich war es vor allem wichtig pulseaudio zu verwenden, weil ich damit sehr gut zwischen Stereo, Surround 4.1, Surround 5.1 usw. umschalten kann.

Das ich für jede Anwendung die Lautstärke einzeln bestimmen kann. Bei meinem kurzen Ausflug mit KDE hatte ich Pulseaudio vor phonon bevorzugt.

Ansonsten hat bell ja schon viel dazu gesagt.

Viele Grüße
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

4

25.03.2011, 11:18

Danke für eure Ausführungen, sehe jetzt schon etwas klarer.

@ bell: Wenn ich das richtig verstehe, hast Du also keines dieser Progs drauf (außer halt alsa mit dmix). Zu dieser Konfiguration müsste ich also kommen, wenn ich esd und pulseaudio raushaue, also die useflag wegmache, den esound dämon entferne und nen world update machen. (Hoffe ich denke da richtig)

@ Planetshift: (Der Pinguin ist klasse!!!) Wenn ich Pulseaudio nehmen möchte, kann ich mich da an das GentooWiki Howto halten? Mich hat unter dem Punkt "audio group" die Aussage stutzig gemacht, daß die User nicht in der audio gruppe seien sollen (die waren da bisher nämlich immer drin) ?!? Hast Du den Dämon für Pulseaudio gestartet?

@ alle: Stellt sich mir jetzt die Frage: Pulseaudio ja oder nein. Die von Bell genannten Features von PulseAudio kommen mir bei meiner Soundnutzung so vor, als wenn man mit Kanonen auf Spatzen schießt. Der Punkt von Planetshift mit der Schaltung der Modi (Stereo, 5.1, 6.1, usw.) scheint mir aber sinnig zu sein. Benötigt man dazu Pulseaudio oder kann das auch alsa alleine???

Beste Grüße
GOS

5

25.03.2011, 11:44

Mich hat unter dem Punkt "audio group" die Aussage stutzig gemacht


Du musst fügst pulse ja der Gruppe plugdev hinzu und in der Gruppe plugdev ist ja auch Dein User selber. Dadurch hast Du dann die Rechte für Pilseaudio, wobei ich muss gestehen das ich meinen User auch in der Gruppe audio habe.

Zitat

Hast Du den Dämon für Pulseaudio gestartet

Also im runlevel ist bei mir nichts drin. Gibt bei mir auch kein /etc/init.d/pulseaudio mehr.

Bei mir wird alles notwendige automatisch gestartet, musste dazu auch nichts extra aktivieren. Kann durchaus sein das es jetzt mittels udev gestartet wird.
Ich habe mir das nicht genau angesehen.

Bei Alsa kann man die Ausgabe über die .asoundrc regeln. Ob man das auch so einfach switchen kann zwischen 5.1, 4.1 usw. weiß ich nicht.
Pulseaudio ist ja auch nicht umsonst bei Gnome der Standard Sound Deamon.

Welchen Windows Manager nutzt Du denn?

Gruß
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

6

25.03.2011, 11:57

Ich nutze Xorg 1.9 mit gnome. hal ist bei mir schon übern jordan gegangen. Ich werde es dann mal mit pulseaudio versuchen und berichten.

Noch ne Frage am Rande, welchen Videoplayer benutzt Ihr denn? Hatte mal Mplayer, der ließ sich dann aber irgendwann nicht mehr richtig emergen, dann hab ich totem genommen, aber der macht so den Eindruck, als könne er nur mit wenigen Formaten umgehen.

Danke und Beste Grüße
GOS

7

25.03.2011, 12:06

Mplayer sollte ohne Probleme gehen. Ich habe Version 1.0_rc4_p20110322 drauf.

Ansonsten ist VLC noch ein sehr guter Player. Die GUI verwendest zwar QT aber mann kann VLC auch nur über die Konsole mit cvlc nutzen.

Gruß
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

8

25.03.2011, 12:26

Die von Bell genannten Features von PulseAudio kommen mir bei meiner Soundnutzung so vor
So habe ich es auch wahrgenommen. Die Umschalterei brauche ich auch nicht, da ich nur 2 Lautsprecher dran habe. Oder verstehe ich was falsch?

mit der Schaltung der Modi (Stereo, 5.1, 6.1, usw.) scheint mir aber sinnig zu sein. Benötigt man dazu Pulseaudio oder kann das auch alsa alleine???
Es lässt sich bestimmt eine statische Konfiguration mit asoundrc erzeugen. Zum Switchen müsstest Du dann jedes mal die ~/.alsasoundrc austauschen. Da ist eine GUI wie die von Pulseaudio schon besser.

welchen Videoplayer benutzt Ihr denn?
Das ist zwar etwas OT:
Als xfce User ist meine erste Wahl media-video/parole. Bei einigen Videos habe ich damit jedoch Probleme: (zB. Seitenverhältnis wird nicht erkannt)
Die zweite Wahl daher ist media-video/gnome-mplayer. Der Mplayer kann ja nahezu alles abspielen
Wenn auch der mplayer nicht spielen will, dann nehme ich media-video/vlc (mag Qt nicht)

Ein Hinweis zu totem, dieser basiert wie parole auf dem GStreamer Framework. Was dies kann oder nicht hängt also von den USE-Flags des Paketes media-plugins/gst-plugins-meta ab, btw. welche Pakete aus

Quellcode

1
eix media-plugins/gst-plugins-*
installiert sind.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

9

25.03.2011, 13:08

Danke an alle für die Antowrten

Auf die Gefahr hin, daß das auch OT ist, aber ich denke nicht ganz

Der Punkt ist, daß ich k3b benutze, aber sonst kein qt (USE="-qt4 +qt3support") habe. Weil hal rausgeflogen ist, mußte ich den dafür erforderlichen Teil von KDE auf 4.6 upgraden, weil K3B sonst ohne hal abschmiert (no optical devices usw.). Sowei so schlecht (bekomm ich aber hin).

Problem ist, daß emerge mir jetzt immer beim world update diesen phonon-mist draufballern möchte. :cursing: Da ich den aber definitiv nicht will (ich denke mal ich nehme entweder Pulseaudio oder halt nischt) frage ich mich: Wie kann ich das verhindern. Habe es schon mit USE="-phonon -vlc" versucht, da lichtet sich zwar der vlc kram, aber phonon will er mir immernoch draufmachen. Das ist besonders ärgerlich, weil phonon-gstreamer (gstreamer-flag wegen totem gesetzt) beim kompilieren absäuft.

Frage also: Wie den Phonon-kram gänzlich beseitigen?

Grüße GOS

10

25.03.2011, 13:13

Wenn Du mplayer nicht bauen kannst, kannst Du es ja mal mit mplayer2 Versuchen. Dafür gibt es auch schon ein Overlay (multimedia, bei Funtoo schon im Portage)

http://www.mplayer2.org

http://gpo.zugaina.org/media-video/mplayer2

PS:

Problem ist, daß emerge mir jetzt immer beim world update diesen phonon-mist draufballern möchte. :cursing: Da ich den aber definitiv nicht will (ich denke mal ich nehme entweder Pulseaudio oder halt nischt) frage ich mich: Wie kann ich das verhindern. Habe es schon mit USE="-phonon -vlc" versucht, da lichtet sich zwar der vlc kram, aber phonon will er mir immernoch draufmachen. Das ist besonders ärgerlich, weil phonon-gstreamer (gstreamer-flag wegen totem gesetzt) beim kompilieren absäuft.


Dafür dann am besten ein neues Thema aufmachen.
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

11

25.03.2011, 13:20

Quellcode

1
2
3
4
 equery d media-sound/phonon
...
kde-base/kdelibs-4.4.5-r3 (>=media-sound/phonon-4.3.80)
...
Sobald Du also KDE-Libs drauf hast, wird Dir Phonon aufs Auge gedrückt. Du musst also alles aus der KDE (Qt ist erlaubt) Ecke beseitigen.

Hast Du Dir schon den Gnome-Standard Brenntool app-cdr/brasero angeschaut? Ist besser in Gnome integriert.
Oder was hat k3b was brasero nicht kann?

PS: Die Frage ist in diesem Forum nicht OT, jedoch in diesem Thema. Es wäre besser, wenn Du neue Themen für neue Fragen aufmachst.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

12

25.03.2011, 13:36

Hallo nochmal,

vielen Dank an Euch beide. :thumbsup: Wenn ich noch weitere Probleme im Umfeld habe, werd ich nen neuen passenden Thread aufmachen um nicht weiter OT zu sein :whistling: .

Beste Grüße
GOS

PS: Ich hab für phonon erstmal -gstreamer gesetzt. Damit läuft der Compiler jetzt. Werd dann ja sehen ob es mit k3b ohne hal funzt oder nicht. Wenn nicht muß k3b halt dran glauben und der ganze KDE Mist fliegt runter.

13

25.03.2011, 23:33

Hallo,

habe jetzt PulseAudio in Betrieb, funzt soweit ich das beurteilen kann. Habe meinen User aus der Audiogruppe rausgenommen, hat bisher zu keinen Problemen geführt. k3b und den anderen Kram habe ich ebenfalls installiert bekommen.

Besten Dank für eure Unterstützung
GOS