Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

22.05.2011, 13:15

VMware-Player Networking

Guten Tag,
ich benutze den VMWare-Player 3.x und würde gerne zwischen Guest und Host kommunizieren.

Stelle ich auf NAT
so bekommen meine Guests eine IP (192.168.122.x) und einen Gateway (192.168.122.2)

Auf meinem Host sieht es so aus:
inet Adresse: 192.168.122.1

und bei route:
Ziel Router Genmask Flags Metrix Ref Use Iface
192.168.122.0 0.0.0.0 255.255.255.0 U 0 0 0 vmnet8

Die Guests können unter einander kommunizieren (pingen), jedoch kann keiner den Host anpingen.
Wenn ich auf NAT gestellt habe, können die Guest, wenn ich mit dem Rechner im Internet bin, ebenfalls ins Internet.

Stelle ich auf Host-Only ist es das gleiche in grün, außer das es halt andere IP-Adresse sind:
20.11.13.x und der gw 20.11.13.1

Die IP-Adressen werden alle über den vminternen DHCP verteilt.

Was für Informationen fehlen noch?
Was für Einstellungen kann ich überprüfen?

2

23.05.2011, 19:46

Ist es nicht Sinnvoll auf Bridge zustellen?

Dann sollte ja Dein VMware Host im ganz normalen Netz sein wie Dein PC. IP entweder dann vom Router über DHCP oder manuell. Das hängt dann davon ab wie Du Dein Netzwerk eingerichtet hast. VMware sollte sich dann nicht mehr um die IP Vergabe kümmern.

Gruß
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

3

24.05.2011, 16:39

Die Sache ist ja folgende:
Wenn ich zuhause bin kann ich auf "bridge" stellen, dann ist der VM-Guest über den Router, weil der einen DHCP hat, über eine eigene IP anpingbar.

Wenn ich ihn jedoch vom Netz nehme, funktioniert es nicht. Es steht dann, das keine IP-Adresse verfügbar ist.
Da ich den ja auch öfters offline Betreibe, würde für mich nur NAT bzw. Host-Only infrage kommen, da so der VM-Interne DHCP beansprucht wird. Dieser verteilt die IPs und den Standardgateway auch richtig (VMs untereinander sind ja anpinbgar), jedoch nicht vom Host.

Vom Host kann ich im NAT betrieb nur:
20.11.13.1 anpingen ( vmnet1 )
und 192.168.122.1 ( vmnet8 )

Die Verteilten IPs gehen von:
20.11.13.128 bis 20.11.13.254 bei Host-Only und Gateway ist 20.11.13.1 (ist jedoch im Host-Only von den VM-Guests ebenfalls nicht anpingbar)
und 192.168.122.128 bis 192.168.122.254 im NAT-Modus und als Gateway 192.168.122.2 (nicht 192.168.122.1 wie ich es sehe wenn ich bei Host "ifconfig vmnet8" eingebe

lg
nesc.
###################################################
EDIT:
Ich habe heute in der Schule ein wenig rumprobiert:
Wenn ich ein AD-Hoc Netzwerk aufmache, mich damit verbinde, mir manuell eine IP-Adresse gebe und eine Route festlege, und das gleiche beim Gast auch funktioniert es. Dies habe ich im Bridged-Mode gemacht.
Der Nachteil daran ist allerdings: Ich muss WLAN-Einschalten, was die Akkulaufzeit minimiert.
Gibt es daher eine Möglichkeit vorzutäuschen das man eine Kabelverbindung hat?

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »nesco58« (25.05.2011, 14:56)