Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

21

08.06.2011, 15:36

Nochmal entpackt und make && make install getan :(

gleicher Fehler :(

Ah man sollte vorher das Verzeichnis löschen ;)

Aber neuer Fehler:

Quellcode

1
2
3
4
5
6
7
8
/root/tbs/linux-s2api-tbs6921/v4l/cx25840-ir.c: In function 'cx25840_ir_probe':
/root/tbs/linux-s2api-tbs6921/v4l/cx25840-ir.c:1239: error: implicit declaration of function 'kzalloc'
/root/tbs/linux-s2api-tbs6921/v4l/cx25840-ir.c:1239: warning: assignment makes pointer from integer without a cast
/root/tbs/linux-s2api-tbs6921/v4l/cx25840-ir.c:1254: error: implicit declaration of function 'kfree'
make[2]: *** [/root/tbs/linux-s2api-tbs6921/v4l/cx25840-ir.o] Error 1
make[1]: *** [_module_/root/tbs/linux-s2api-tbs6921/v4l] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.35-gentoo-r15'
make: *** [default] Error 2

22

08.06.2011, 18:38

genau da bleibt er bei mir auch hängen.
Leider :-(

Ich muss auch korrigieren. Kernel ist bei mir sogar noch den 2.6.32-gentoo-r24. Das war der letzte mit dem alles noch ging.

Gruß
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

23

08.06.2011, 21:05

Das heißt ich muss noch älter einen machen??
Ich habe einfach erstmal alles was ir (brauch ich eh ned) auskommentiert und konnte kompilieren nun restart und modprobe gemacht und was passierte:

Quellcode

1
2
WARNING: Error inserting videobuf_dma_sg (/lib/modules/2.6.35-gentoo-r15/kernel/drivers/media/video/videobuf-dma-sg.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting cx23885 (/lib/modules/2.6.35-gentoo-r15/kernel/drivers/media/video/cx23885/cx23885.ko): Unknown symbol in module, or unknown parameter (see dmesg)


Nochmal neuer Kernel:

Quellcode

1
2
3
4
5
6
7
8
/sbin/depmod -a 2.6.32-gentoo-r24
make -C firmware install
make[1]: Entering directory `/root/tbs/linux-s2api-tbs6921/v4l/firmware'
Installing firmwares at /lib/firmware: vicam/firmware.fw dabusb/firmware.fw dabusb/bitstream.bin ttusb-budget/dspbootcode.bin cpia2/stv0672_vp4.bin av7110/bootcode.bin
make[1]: Leaving directory `/root/tbs/linux-s2api-tbs6921/v4l/firmware'
serverchen v4l # modprobe cx23885
WARNING: Error inserting videobuf_dma_sg (/lib/modules/2.6.32-gentoo-r24/kernel/drivers/media/video/videobuf-dma-sg.ko): Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting cx23885 (/lib/modules/2.6.32-gentoo-r24/kernel/drivers/media/video/cx23885/cx23885.ko): Unknown symbol in module, or unknown parameter (see dmesg)


Dmeg:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
[    4.550273] videobuf_dvb: Unknown symbol dvb_dmxdev_init
[    4.550479] videobuf_dvb: Unknown symbol dvb_register_adapter
[    4.550541] videobuf_dvb: Unknown symbol dvb_dmx_release
[    4.550644] videobuf_dvb: Unknown symbol dvb_net_init
[    4.550694] videobuf_dvb: Unknown symbol dvb_dmx_swfilter
[    4.550751] videobuf_dvb: Unknown symbol dvb_dmxdev_release
[    4.550801] videobuf_dvb: Unknown symbol dvb_frontend_detach
[    4.550851] videobuf_dvb: Unknown symbol dvb_net_release
[    4.550911] videobuf_dvb: Unknown symbol dvb_unregister_frontend
[    4.550967] videobuf_dvb: Unknown symbol dvb_register_frontend
[    4.551017] videobuf_dvb: Unknown symbol dvb_unregister_adapter
[    4.551066] videobuf_dvb: Unknown symbol dvb_dmx_init

[    5.639511] rc used greatest stack depth: 4056 bytes left
[    6.137509] videobuf_dvb: Unknown symbol dvb_dmxdev_init
[    6.137715] videobuf_dvb: Unknown symbol dvb_register_adapter
[    6.137777] videobuf_dvb: Unknown symbol dvb_dmx_release
[    6.137881] videobuf_dvb: Unknown symbol dvb_net_init
[    6.137931] videobuf_dvb: Unknown symbol dvb_dmx_swfilter
[    6.137988] videobuf_dvb: Unknown symbol dvb_dmxdev_release
[    6.138050] videobuf_dvb: Unknown symbol dvb_frontend_detach
[    6.138100] videobuf_dvb: Unknown symbol dvb_net_release
[    6.138160] videobuf_dvb: Unknown symbol dvb_unregister_frontend
[    6.138216] videobuf_dvb: Unknown symbol dvb_register_frontend
[    6.138266] videobuf_dvb: Unknown symbol dvb_unregister_adapter
[    6.138316] videobuf_dvb: Unknown symbol dvb_dmx_init

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Gregor-« (08.06.2011, 21:39)


24

08.06.2011, 22:40

Welchen Treiber hast Du für den 2.6.32er Kernel verwendet?

Da bin ich ja echt froh, das es bei mir funktioniert. Nochmal würde ich von TBS wohl keine Karte mehr kaufen.

Da ich am WE eine Große Radtour mache komme ich halt leider nicht dazu mich genauer damit zu beschäftigen. Ich denke am Mittwoch, Donnerstag, Freitag werde ich dann dazu Zeit haben. Ich hoffe das reicht noch.


Viele Grüße
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

25

09.06.2011, 08:04

Ich hab den Treiber von der Webseite genommen und gekauft habe ich mir die Karte eigentlich nur weil meine Satelco Budget nicht alle Sender macht und TBS ja 100% Linux tauglich ist. :(

26

09.06.2011, 11:05

Habe im Kernel nun alles angeschaltet was Multimedia angeht. Ließ sich ohne Fehler kompilieren danach make && make modules_install und make && make install des treibers.

Reboot.

modprobe cx23885

Quellcode

1
FATAL: Error inserting cx23885 (/lib/modules/2.6.32-gentoo-r24/kernel/drivers/media/video/cx23885/cx23885.ko): Unknown symbol in module, or unknown parameter (see dmesg)


dmesg:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
[   27.833343] pci 0000:01:05.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[  562.429286] cx23885: Unknown symbol cx2341x_ext_ctrls
[  562.429604] cx23885: Unknown symbol __ir_input_register
[  562.429840] cx23885: Unknown symbol cx2341x_ctrl_query
[  562.430034] cx23885: Unknown symbol ir_rc5_timer_keyup
[  562.430717] cx23885: Unknown symbol ir_input_init
[  562.430877] cx23885: Unknown symbol cx2341x_update
[  562.431084] cx23885: Unknown symbol cx2341x_ctrl_get_menu
[  562.431232] cx23885: Unknown symbol ir_input_nokey
[  562.431285] cx23885: Unknown symbol ir_rc5_decode
[  562.431388] cx23885: Unknown symbol cx2341x_log_status
[  562.431461] cx23885: Unknown symbol ir_input_unregister
[  562.431517] cx23885: Unknown symbol cx2341x_fill_defaults
[  562.432104] cx23885: Unknown symbol cx2341x_mpeg_ctrls
[  562.432161] cx23885: Unknown symbol ir_input_keydown
[  562.432217] cx23885: Unknown symbol get_rc_map

27

09.06.2011, 13:48

Hmm.., diese Unknown symbol Errors kenne ich bisher nur wenn zb noch Reste eines alten Moduls im /lib/modules/ Kernel-Version Verzeichnis vorhanden ist, sprich wenn es eine Mischung aus zwei Treibern gib. Oder aber auch wenn Treiber Module mit unterschiedlichen GCC Versionen gebaut wurden.

Ich würde das entsprechende /lib/modules/ Kernel-Version Verzeichnis noch mal entfernen, dann den Kernel mit möglichst wenigen Optionen (wie von Planeshift auch schon empfohlen) unter <M> Multimedia support ---> zu bauen (mit make modules_install) und dann dein externes Treiber Paket vom TV-Karten Hersteller zu installieren.
Du wirst vermutlich ein wenig testen müssen ob nicht doch ein bestimmter Treiber unter Multimedia support ---> benötigt wird...
Sorry, genaueres kann ich hierzu leider auch nicht beitragen da ich dieses ominöse Treiber Paket nicht persönlich kenne... ;)

Viel Erfolg

28

09.06.2011, 14:04

Alles schon durch :( siehe weiter oben :(

Nun habe ich nochmal den 2.6.37 kernel genommen da es angeblich funktioniert. leider bekomme ich einen kompelierungsfehler.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
 CC [M]  /root/tbs/linux-tbs-drivers/v4l/cx88-dvb.o
/root/tbs/linux-tbs-drivers/v4l/cx25840-ir.c: In function 'cx25840_ir_probe':
/root/tbs/linux-tbs-drivers/v4l/cx25840-ir.c:1239: error: implicit declaration of function 'kzalloc'
/root/tbs/linux-tbs-drivers/v4l/cx25840-ir.c:1239: warning: assignment makes pointer from integer without a cast
/root/tbs/linux-tbs-drivers/v4l/cx25840-ir.c:1254: error: implicit declaration of function 'kfree'
make[3]: *** [/root/tbs/linux-tbs-drivers/v4l/cx25840-ir.o] Error 1
make[3]: *** Waiting for unfinished jobs....
  CC [M]  /root/tbs/linux-tbs-drivers/v4l/cx88-video.o
make[2]: *** [_module_/root/tbs/linux-tbs-drivers/v4l] Error 2
make[2]: Leaving directory `/usr/src/linux-2.6.37-gentoo-r4'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/root/tbs/linux-tbs-drivers/v4l'
make: *** [all] Error 2

29

09.06.2011, 14:12

Ich würde das ganze mal im Forum von TBS anfragen, schließlich machen die ja auch die Treiber. Vielleicht wird Dir da geholfen.

Der letzte Fehler ist immer noch das Problem mit dem Modul cx25840-ir.

http://www.buydvb.net/forum/

Gruß
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

30

09.06.2011, 14:14

Du wirst vermutlich ein wenig testen müssen ob nicht doch ein bestimmter Treiber unter Multimedia support ---> benötigt wird...


Wird nicht benötigt. Kann man getrost alles ausschalten. TBS verwendet die v4l dvb Treiber und packt ihre eigenen Treiber mit dazu.

Gruß
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

31

09.06.2011, 14:36

"-ir" hört sich nach Infrarot an. Hast Du bei Dir die Unterstützung für Infrarot im Kernel aktiv, btw. brauchst Du diese?

Im (frisch ausgepackten) Treiber-Verzeichnis kannst Du auch "make menuconfig" ausführen und die zu bauende V4L Module auswählen/abwählen.
Deaktiviere alles, was Du nicht brauchst und was Probleme bereitet. Damit sollte das Bauen auch mit dem neuen Kernel gehen.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

32

09.06.2011, 16:20

Hab mal bischen gestestet, leider funktioniert es so nicht, wie ich es oben beschrieben habe.
Aus Interesse habe ich mal die hier beschriebenen Schritte mal durchgeführt: http://blog.mohammadzadeh.info/index.php…e-tbs-6980#c281

Das Kompilieren lief mit sys-kernel/gentoo-sources-2.6.38-r6 ohne Probleme durch. Testen kann ich nicht, da keine Hardware da.

Beachte, Punkt 9 bezieht sich auf den Haupt-Artikel für TBS 6980. Es müssen die selben Änderungen in den Dateien gemacht werden.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

33

09.06.2011, 17:25

Ich würde das ganze mal im Forum von TBS anfragen, schließlich machen die ja auch die Treiber. Vielleicht wird Dir da geholfen.


Habe ich schon getan bisher keinerlei Reaktion.

34

09.06.2011, 17:27

"-ir" hört sich nach Infrarot an. Hast Du bei Dir die Unterstützung für Infrarot im Kernel aktiv, btw. brauchst Du diese?

Nein die ist komplett aus da ich diese nicht möchte und auch nicht benötige.

Im (frisch ausgepackten) Treiber-Verzeichnis kannst Du auch "make menuconfig" ausführen und die zu bauende V4L Module auswählen/abwählen.
Ist mir bekannt so bin ich auch vorgegangen. Trotzdem danke.

Deaktiviere alles, was Du nicht brauchst und was Probleme bereitet. Damit sollte das Bauen auch mit dem neuen Kernel gehen.

Im Kernel selber is ausser dem Hauptfeld Multimedia Unterstützung alles aus.

35

09.06.2011, 18:21

Im Kernel selber is ausser dem Hauptfeld Multimedia Unterstützung alles aus.
Ich meinte nicht das Kernel-Verzeichnis, sondern das Treiberverzeichnis. Dort gibt es auch so ein Menü. Aber egal, hatte nicht funktioniert. Lies mal meine letzte Post.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

36

09.06.2011, 18:39

Aus Interesse habe ich mal die hier beschriebenen Schritte mal durchgeführt: http://blog.mohammadzadeh.info/index.php…e-tbs-6980#c281
Das Kompilieren lief mit sys-kernel/gentoo-sources-2.6.38-r6 ohne Probleme durch. Testen kann ich nicht, da keine Hardware da.
Beachte, Punkt 9 bezieht sich auf den Haupt-Artikel für TBS 6980. Es müssen die selben Änderungen in den Dateien gemacht werden.


Spitze. Es scheint zu laufen zumindest steht es entsprechend in dmesg und /dev/dvb ist auch da :) ENDLICH.

Habt vielen Dank alles zusammen.

BTW ich meinte auch das Treiberverzeichnis. :) Ausserdem frage ich mich warum der Hersteller soetwas nicht fixt oder in die README schreibt. *kopfkratz*

Ich muss jetzt noch einmal stören :(

Kann mir hierzu noch jemand etwas sagen?:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
[0x1a72120] dvb access debug: frontend has lost carrier
[0x1a72120] dvb access debug: frontend has acquired carrier
[0x1a72120] dvb access debug: frontend has lost carrier
[0x1a72120] dvb access debug: frontend has acquired carrier
[0x1a72120] dvb access debug: frontend has lost carrier
[0x1a72120] dvb access debug: frontend has acquired carrier
[0x1a72120] dvb access debug: frontend has lost carrier
[0x1a72120] dvb access debug: frontend has acquired carrier
[0x1a72120] dvb access debug: frontend has lost carrier
[0x1a72120] dvb access debug: frontend has acquired carrier
[0x1a72120] dvb access debug: frontend has lost carrier
[0x1a72120] dvb access debug: frontend has acquired carrier
[0x1a72120] dvb access debug: frontend has lost carrier
[0x1a72120] dvb access debug: frontend has acquired carrier
[0x1a72120] dvb access debug: frontend has lost carrier
[0x1a72120] dvb access debug: frontend has acquired carrier
[0x1a72120] dvb access debug: frontend has lost carrier


Dies tritt lustiger weise nur bei bestimmten Sendern auf aber ich verstehe nicht wieso? RTL geht Pro7 geht nicht. Kika geht.

Ich vermute das liegt an meiner Senderliste. Hat jemand zufällig eine aktuelle für mich oder kann mir sagen wie ich die erstellen kann? Das was ich bisher dazu gefunden bringt mir Fehler :(

Nochmals vielen Dank an Euch alle.

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »Gregor-« (09.06.2011, 23:20)


37

10.06.2011, 07:18

Hab mal bischen gestestet, leider funktioniert es so nicht, wie ich es oben beschrieben habe.
Aus Interesse habe ich mal die hier beschriebenen Schritte mal durchgeführt: http://blog.mohammadzadeh.info/index.php…e-tbs-6980#c281

Das Kompilieren lief mit sys-kernel/gentoo-sources-2.6.38-r6 ohne Probleme durch. Testen kann ich nicht, da keine Hardware da.

Beachte, Punkt 9 bezieht sich auf den Haupt-Artikel für TBS 6980. Es müssen die selben Änderungen in den Dateien gemacht werden.



Hey fein das Du es schon getestet hast. Ich bin aus Zeitmangel leider noch nicht dazu gekommen. Werde es aber am Dienstag nachholen und berichten.

Viele Grüße
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

38

14.06.2011, 17:26

Hallo,

habe die fertigen Sourcen auf meine Server geladen. Die sollten auch mit Deiner Karte gehen denke ich, da TBS immer alle Treiber mit in die Sourcen packt. Bei mir läuft es jetzt wieder mit dem 2.6.38er Kernel.

Viele Grüße

http://www.amielke.de/linux-s2api-tbs6980_1.tar

EDIT: Bitte nach dem entpacken "make release" ausführen, damit er es auch mit Deinem Kernel baut.
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

39

15.06.2011, 08:41

Hallo Plane, habe es wie ich schon schrieb per Anleitung vom Meister getan und es läuft seit dem ausser das meine Channellist nicht stimmt :(

40

15.06.2011, 10:09

Bei mir geht leider Lirc nicht mit dem 2.6.38 Kernel. Ansonsten würde der Treiber jetzt gehen. Ohne Lirc macht das Umschalten aber keinen Spaß :-(.

Viele Grüße
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay