Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

21.06.2011, 22:45

kernel 2.6.38-r7, nvidia-260,270,275, kde 4-6: desktop effekte massive Probleme

Hallo,

also Nvidia treibt mich in denn Wahnsinn,

Karte:

Quellcode

1
01:00.0 VGA compatible controller: nVidia Corporation G92 [GeForce 9800 GT] (rev a2)


uname:

Quellcode

1
Linux 2.6.38-gentoo-r7 #4 SMP Sun Jun 12 18:55:11 CEST 2011 x86_64 Intel(R) Core(TM)2 Quad CPU Q8300 @ 2.50GHz GenuineIntel GNU/Linux



Desktop: kde-4.6
System: testing

treiber:

Quellcode

1
x11-drivers/nvidia-drivers-260.19.44, x11-drivers/nvidia-drivers-270.41.06, x11-drivers/nvidia-drivers-270.41.19, x11-drivers/nvidia-drivers-275.09.07



funktionieren alle, wenn die Desktop Effekte aus sind, schalte ich sie ein:
bleibt der desktop stehen, tastatur aus(usb) nur die maus lebt (usb), ssh kein login möglich.
und das Bild ändert sich siehe anhang!

ich meine ab dem 260.19* haben diese Problemchen angefangen, aber wer will schon ohne Desktop Effekte leben
bestimmt nicht ich:-)

geht nur mir das so? oder hat noch wer diese Probleme?
»schnippi« hat folgende Datei angehängt:

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »schnippi« (30.07.2011, 11:47)


2

22.06.2011, 00:08

Hmm.., grade mit den nvidia-drivers sollten die KDE Desktop Effekte eigentlich wenig Probleme bereiten und gut funktionieren.
Ich hab hier zb den gleichen G92 Grafik-Chipsatz am laufen und der geht sehr gut mit den aktuellen nvidia-drivers und KDE

Ein Schnellschuss ins Blaue:
Hast du eventuell nicht auf das nVidia eigene OpenGL Interface umgeschaltet? - sprich

Quellcode

1
# eselect opengl set nvidia
nicht gesetzt?

Magst du ansonsten mal deine /var/log/Xorg.0.log mit anhängen?!

3

22.06.2011, 09:37

Hast Du

Quellcode

1
Option      "AddARGBGLXVisuals" "true"
in der xorg.conf drin?
Prüfe mal folgendes HowTo: http://www.gentoo-wiki.info/HOWTO_nVidia_GL_Desktop_Effects
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

4

23.06.2011, 00:17

Hallo,

eselect opengl list:
Available OpenGL implementations:
[1] nvidia *
[2] xorg-x11

xorg.conf:

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
EndSection

Section "Device"
Identifier "Card0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "TwinView" "1"
Option "TwinViewOrientation" "RightOf"
Option "TwinViewXineramaInfoOrder" "DFP-0,DFP-1"
Option "metamodes" "DFP-0: 1920x1080 +0+0, DFP-1: 1920x1080 +1920+0"
Option "AddARGBGLXVisuals" "true"
Option "AllowGLXWithComposite" "true"
Option "RenderAccel" "true"
Option "NoLogo" "true"
Option "UseEvents" "true"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
Modes "1920x1080" "1680x1050" "1280x960" "1280x800" "1152x864" "1152x720" "1024x768" "1024x640" "800x600" "800x500" "768x576" "768x480"
"640x480" "640x400" "640x350" "512x384" "512x320" "400x250" "400x300" "360x240" "360x225" "360x200" "320x400" "320x240" "320x200"
EndSubSection


Section "Extensions"
Option "Composite" "Enable"
EndSection
»schnippi« hat folgende Datei angehängt:
  • Xorg.0.log.txt (18,94 kB - 2 mal heruntergeladen - zuletzt: 09.07.2011, 21:27)

5

23.06.2011, 01:51

Ahhrg, mit TwinView , sorry da muss ich passen...
Aber wenn ich das richtig in Erinnerung hab sollte man dann die USE-Flag "xinerama" möglichst global (in der make.conf) setzen und die entsprechenden Pakete damit bauen.
Zudem aber in der xorg.conf zb in der Section "ServerLayout"

Quellcode

1
    Option         "Xinerama" "0"
setzen.
Diese Info ist aber ungetestet!

6

23.06.2011, 02:12

Stimmt hätte ich dazu sagen sollen, das USE-Flag "xinerama" ist global in der (make.conf) gesetzt
und alle damit verbundenen Pakete gebaut.
Zudem aber in der xorg.conf zb in der Section "ServerLayout"
Okay dann teste ich das mal, mal sehen ob es was bringt!

Danke!

7

25.06.2011, 23:25

Und weiter gehts:-)


173.286353] NVRM: Xid (0000:01:00): 13, 0003 00000000 00008297 00000e04 0f00ff00 00000004


VG
Christian

8

12.07.2011, 19:10

tja ich weiß ja nicht was ich nun groß geändert habe, ich meine aber nichts weiter
bis jetzt läuft es.....

außer ich mache ein konsolenfenster kleiner (mit der maus ziehen)
in dem grad ein emerge --sync läuft... dann bleibt der rechner stehen

9

12.07.2011, 23:54

außer ich mache ein konsolenfenster kleiner (mit der maus ziehen)
in dem grad ein emerge --sync läuft... dann bleibt der rechner stehen

Oja, das Problem kenne ich, hab ich auch bei den Kubuntus. Das tritt aber nur bei den meisten Nvidiachipsätzen auf. Machst das Fenster mal schneller kleiner Größer, stürzt der Xserver ab, das kann so weit gehen das absolut nichts mehr reagiert, dann kann man nur mehr per Remote auf den Rechner draufgehen und der Prozess abschießen. Folgendes gibt Abhilfe:

Systemsettings --> Arbeitsflächeneffekte --> Alle Effekte
Kategorie Fensterverwaltung: "Fenstergröße änder" anhacken
, und schon stürzt es nicht mehr ab.

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

10

23.07.2011, 15:27

Danke boospy,

das hat geklappt, nun ruckelt es beim Fenster ziehen nicht mehr!

und bis jetzt läuft auch alles andere :-)

11

23.07.2011, 16:04

Immer wieder gern ;)

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at