Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

21

28.07.2011, 21:49

hatte gehoft das ich da nur ne datei oder so editierne müste ... aber das es so ausartet dachte ich nicht... :-(

Wieso ausarten. Noch können wir nur raten und auf mögliche Fehler verweisen. Um etwas genauer zu werden bräuchten wir schon noch die Xorg.0.log.
Intel Core2 Quad CPU @ 2.40GHz mit Gentoo/Gnome3

Eigenes Gentoo System auf CD oder USB

22

31.07.2011, 21:00

Hier mal die Xorg.log und die xorg.conf Datei...

hoffe es bring was ....

ich durch such gerade mal die ganzen configs nochmal vieleicht is ja wo was falsch ... hmm

lg
schatti
»Schattenschlag« hat folgende Dateien angehängt:
  • Xorg.0.txt (19,57 kB - 5 mal heruntergeladen - zuletzt: 05.08.2011, 14:45)
  • xorg.txt (2,15 kB - 3 mal heruntergeladen - zuletzt: 02.08.2011, 00:46)
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

23

31.07.2011, 21:40

Da deine Einstellung in der xorg.conf eigentlich ignoriert werden kannst du sie auch löschen. Was besonderes steht da eh nicht drin. Außerdem ist sie eh veraltet. Schau mal unter /etc/X11/xorg.conf.d/ Da sollte es in etwa so aussehen.

Quellcode

1
2
ls /etc/X11/xorg.conf.d/
10-evdev.conf  50-synaptics.conf

Wenn bei dir der Ordner nicht vorhanden ist lege ihn an und kopiere die nötigen Dateien aus /usr/share/X11/xorg.conf.d/, wenn du sie bearbeiten möchtest. Ein kleines Wiki dazu gibt es hier[url]http://de.gentoo-wiki.com/wiki/Evdev[/url]

Noch zur Info

Quellcode

1
2
3
[    23.828] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    23.828] (WW) Disabling Mouse0
[    23.828] (WW) Disabling Keyboard0


Es istauch wichtig das folgende Dienste an sind...
/etc/init.d/consolekit
/etc/init.d/udev
/etc/init.d/dbus
Intel Core2 Quad CPU @ 2.40GHz mit Gentoo/Gnome3

Eigenes Gentoo System auf CD oder USB

24

01.08.2011, 12:27

Machst du mal ein

Quellcode

1
# emerge --info
hier rein?
http://www.dyle.org
IM-Account (Jabber!) sind auf meiner HP ...
There is no place like /home

http://www.gentooforum.de
http://www.gentoofreunde.org

<div>how to annoy a web developer?</span>

25

01.08.2011, 18:43

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
Portage 2.1.10.3 (default/linux/amd64/10.0/desktop/kde, gcc-4.4.5, glibc-2.12.2-r0, 2.6.38-gentoo-r6 x86_64)
=================================================================
System uname: Linux-2.6.38-gentoo-r6-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E7200_@_2.53GHz-with-gentoo-2.0.3
Timestamp of tree: Sat, 30 Jul 2011 07:15:01 +0000
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.2.10
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=core2 -mtune=generic -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="ftp://gentoo.inode.at/source/ ftp://gentoo.lagis.at/ ftp://gd.tuwien.ac.at/opsys/linux/gentoo/ http://gentoo.wetzlmayr.com/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync12.de.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cd cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative decss djvu dri dts dv dvd dvdr emboss encode exif extra-tools fam ffmpeg firefox flac fontconfig fortran gdbm gdu gif gpm iconv imagemagick ipv6 jack java jpeg jpeg2k kde kipi lame lcms ldap libcaca libnotify libsamplerate mad mjpeg mmx mng modules mp3 mp4 mpeg msn mudflap multilib ncurses nls nptl nptlonly nsplugin ogg openexr opengl openmp pam pango pcre pdf perl phonon plasma png policykit ppds pppd python qt-static qt3support qt4 quicktime raw readline realtime sdl semantic-desktop session spell sse sse2 ssl startup-notification static-libs svg sysfs tcpd thumbnail tiff truetype udev unicode usb vcd vdr vorbis wavpack wmf x264 xcb xcomposite xine xinerama xml xorg xscreensaver xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
bootmisc | boot                                          
          consolefont |      default                                  
           consolekit |      default                                  
                cupsd |      default                                  
                 dbus |      default                                  
                devfs |                                        sysinit
                dmesg |                                        sysinit
                 fsck | boot                                          
             hostname | boot                                          
              hwclock | boot                                          
              keymaps | boot                                          
            killprocs |                        shutdown               
                local |      default nonetwork                        
           localmount | boot                                          
              modules | boot                                          
             mount-ro |                        shutdown               
                 mtab | boot                                          
             net.eth0 |      default                                  
               net.lo | boot                                          
             netmount |      default                                  
               procfs | boot                                          
                 root | boot                                          
            savecache |                        shutdown               
                 swap | boot                                          
               sysctl | boot                                          
            syslog-ng |      default                                  
         termencoding | boot                                          
                 udev |                                        sysinit
       udev-postmount |      default                                  
              urandom | boot                                          
           vixie-cron |      default                                  
                  xdm |      default         


so hab es heute mal geschaft das KDE 4 hochfährt und ich mich einogen kann ...freu freu freu ...
nun is es aber leider so das ich sobald ich ein programm starte egal welches (zb. konsole, firefox .... ) alles wieder einfriert...
aber es wird was ... freu freu freu....

vieleicht bekomme ich das auch noch gebacken ..

PS: bin mit root eingelogt !! also das ganze passiert als root und natürlich auch als user ... aber ich kann ja leider nicht die konsole verwenden da ja beim start von der konsole alles einfriert.... und das nervt, kann dann nicht mal zur konsole wechseln per strg-f1 usw..

lg
schatti
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

26

02.08.2011, 08:00

Also irgendwie klingt das für mich nach einer nvidia-Graka-Treiber Inkompatibilität.
Kannst du vlt. mal auch ein plumpes VIDEO_CARDS="vesa" bauen und den nvidia treiber mal aus dem System nehmen?

Auch: schieb mal eine Neuinstallation deiner anderen Treiber nach via

Quellcode

1
# eix -CIc '-*' x11-drivers | cut -d " " -f 1 | xargs emerge -1v
http://www.dyle.org
IM-Account (Jabber!) sind auf meiner HP ...
There is no place like /home

http://www.gentooforum.de
http://www.gentoofreunde.org

<div>how to annoy a web developer?</span>

27

02.08.2011, 12:41

Jo, könnte eventuell auch an der nvidia-drivers Version liegen.
Siehe zb Bug 369365

28

02.08.2011, 19:05

so hab es heute mal geschaft das KDE 4 hochfährt und ich mich einogen kann ...freu freu freu ...
nun is es aber leider so das ich sobald ich ein programm starte egal welches (zb. konsole, firefox .... ) alles wieder einfriert...

Muss nochmal fragen. Du redest die ganze Zeit davon das dir das System einfriert! Ist das wirklich so, oder verschwindet nur die Maus und Tastatur. Oder schmiert dir Xorg weg?

Trage folgendes in die crontab von root ein. Das nervt zwar auch, aber auf der Konsole sollte ja die Tastatur geht. Dann kannst du dir zumindest der Reset sparen.

Quellcode

1
*/5 * * * *     /usr/bin/chvt 1 > /dev/null 2>&1
Intel Core2 Quad CPU @ 2.40GHz mit Gentoo/Gnome3

Eigenes Gentoo System auf CD oder USB

29

02.08.2011, 19:27

@Dirk
Ich dachte am anfang schon das das System einfriert ....
Dank euerer hilfe hab ich es ja geschaft das problem einzugrenzen ...

nun trau ich mir nicht mehr sagen was schuld ist ...
was macht dein crontab eintrag genau ... wenn ich fragen darf ... bin leider nicht so mit crontab auf trab.. sorry

@Josef.95 das mit dem bug könnte in der tat das problem auch sein ... hmm sollte ich mal den alten driver versuchen ? falls er noch zu installieren ist?

lg
schatti
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

30

02.08.2011, 20:30

nun trau ich mir nicht mehr sagen was schuld ist ...
was macht dein crontab eintrag genau ... wenn ich fragen darf ... bin leider nicht so mit crontab auf trab.. sorry

Mit chvt - change foreground virtual terminal wechselt man das Terminal. Wie etwa mit Strg+Alt+F1. Schmiert dir nur X weg, wechselt cron nach der Angegebenen Zeit auf Terminal 1.
Intel Core2 Quad CPU @ 2.40GHz mit Gentoo/Gnome3

Eigenes Gentoo System auf CD oder USB

31

04.08.2011, 17:13

So also ich bin heute vor lauter frust alles nochmal durchgegangen und gemacht !!

Hab es nun mal geschaft das ich ins KDE4 komme und es stürzt nicht ab was mal ok ist..

nur ein problem hab ich noch sobald ich die Konsole im Kde4 öffne und dort versuche das fenster zu vergrössern oder verkleinener alles auf frost wieder ...
hängt das nun mit dem Nvidia treiber zusammen ? bei den anderen fenstern is das nicht der fall zb. beim Firefox kann ich das fenster kleiner machen usw. läuft alles brav weiter

wäre super wenn da einer einen tipp hätte wie ich die Konsole auch noch so hinbekomme das alles past.
ist nun nur eine datei schuld die quer liegt und "nur" die Konsole zum absturzt bring und das die ganze kde suite mit reißt ??

naja ich bin echt froh mal soweit zu sein...
mfg
schatti
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

32

04.08.2011, 17:20

Kannst du noch ein wenig beschreiben woran es denn nun eigentlich gelegen hat, bzw wie du es nun wieder hinbekommen hast?

Wegen der konsole schau mal ob der hier genannte Tipp hilft [gelöst] kernel 2.6.38-r7, nvidia-260,270,275, kde 4-6: desktop effekte massive Probleme

33

05.08.2011, 12:53

Würd ich gern machen Josef.95.

Ich glaub das es nur am KDE4 gelegen haben könnte.

also was ich gemacht hab

Quellcode

1
2
3
4
5
2x emerge -eva world
2x -"-            -"-  system
symlinks -drv /
lafilefixer durchlaufen lassen (hat paar dinge gerichtet)
revdep-rebuild auch 3 mal durchlaufen lassen

und es wurde bei allen 3 durchläufen was ausgebessert beim 4ten durchlauf war dann nix mehr

gestern noch ein update angeschmissen und nun läuft es ..

eben bis auf die Konsole die kann ich ned größe endern ...
der tipp war zwar gut aber bei mir war kein hacken dort ... :-(

aber das werd ich auch noch hinbekommen irgendwie

ach ja und die kdmrc hab ich auch editiert .. war alles ausgeklammert ...
und ich hab unter root alle configs die neu angelegt werden durch programme gelöscht .. also .kde usw..
user hab ich auch zum umfallen immer wieder neu erstellt

lg
schattenschlag
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Schattenschlag« (05.08.2011, 13:18)


34

05.08.2011, 13:30

Manno, ist ja wirklich krass...
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

35

05.08.2011, 14:28

wenn ich die Konsole jetzt mit der maus die größe ändere dann sollte ja irgendwo auch eine Fehlermeldung erscheinen oder nicht ?
nur wo wird sowas gespeichert ? in den /var/logs find ich nix es betrifft nur die konsole komischer weise ...

edit 14:46 uhr
hab mal zur sicherheit ein

Quellcode

1
glsa-check --list all (war alles ok)


also das ein programm zu alt oder so ist wäre hiermit auch ausgeschlossen das querschiessen könnte. ;(

gibts noch paar dinge die ich testen könnte ?
die Hdd is auch ok hab ich schon getestet auch ext4 wurde schon getestet.
(das hab ich mal zur sicherheit gemacht man weis ja nie)

hmm
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Schattenschlag« (05.08.2011, 14:46)


36

05.08.2011, 14:42

Die Ursache wird doch vermutlich zwischen nvidia-drivers und KDE (Composite/Desktop-Effekte) liegen.
Hattest du schon mal eine (aktuellere) nvidia-drivers Version getestet?

Zudem stelle die Desktop Efekte doch zunächst erst mal auf default Werte zurück.

37

05.08.2011, 14:48

Bei KDE ist alles auf "Default Werten" zurück gestellt ...


das hier müste ja stimmten dann
Linuxized.blogspot.com(gentoo)
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

38

05.08.2011, 14:55

Dann teste doch bitte mal die aktuelle =nvidia-drivers-275.09.07 Version aus dem testing-Zweig.

39

06.08.2011, 10:54

Dann teste doch bitte mal die aktuelle =nvidia-drivers-275.09.07 Version aus dem testing-Zweig.


Werde das Montag machen hab leider jetzt am Wochenende nicht viel zeit ..

lg
schatti
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

40

07.08.2011, 18:41

Hallo Schattenschlag,

vielleicht ist dein Rechner nicht so gefroren wie du denkst. ;) Ich hatte vor kurzem ein ähnlichen bis gleiches Problem.
Hier der Tipp von Dirk, der mir geholfen hat.

http://www.gentooforum.de/artikel/19918/…t-anmelden.html .

Quellcode

1
qlist -I -C x11-drivers/

Ich denke einen Versuch ist es wert.

Gruß
Nordländer