Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

06.10.2011, 11:23

newbie tut sich schwer mit dem einbinden/auffinden eines 5-1-cardreaders...

moin,

die überschrift beschreibt ja bereits in etwa mein problem. die umgebung sieht wie folgt aus:

sony vaio vgn-c2s mit 2,5 gb ram und einem vorkonfigurieten sabayon mit kde auf gentoo-basis (sorry kollegen, aber bei der händischen installation von gentoo hab ich einfach irgendwann das handtuch geworfen... vielleicht in ein-zwei jahren wieder.... zumindest hab ich ja auch nen gentoo an bord; wenn auch ein etwas konfektionierteres...;o)

die ausgaben von

Quellcode

1
2
3
# lspci | grep Card
0a:03.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
0a:03.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)



und im anhang dmesg sind dabei

ich würde gern meine sdhc-karten über den internen reader lesen/bearbeiten können. aktuell versuche ich dies mit einer samsung sdhc 4gb. wenn weitere infos benötigt werden, helft mir bitte mit möglichst genauen vorgaben, da ich wirklich nicht so die leuchte hierbei bin ;o)

achja, die sufu hatte ich bereits bemüht. allerdings war der weiterführendste beitrag (aus 2009) dann doch nicht so erfolgreich.

danke
falk
»fastro« hat folgende Datei angehängt:
  • dmesg_1.txt (31,34 kB - 7 mal heruntergeladen - zuletzt: 07.10.2011, 13:17)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »fastro« (07.10.2011, 13:05)


2

06.10.2011, 15:33

moin,

die überschrift beschreibt ja bereits in etwa mein problem. die umgebung sieht wie folgt aus:

sony vaio vgn-c2s mit 2,5 gb ram und einem vorkonfigurieten sabayon mit kde auf gentoo-basis (sorry kollegen, aber bei der händischen installation von gentoo hab ich einfach irgendwann das handtuch geworfen... vielleicht in ein-zwei jahren wieder.... zumindest hab ich ja auch nen gentoo an bord; wenn auch ein etwas konfektionierteres...;o)

die ausgaben von

Quellcode

1
2
3
# lspci | grep Card
0a:03.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
0a:03.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)


und im anhang dmesg sind dabei

ich würde gern meine sdhc-karten über den internen reader lesen/bearbeiten können. aktuell versuche ich dies mit einer samsung sdhc 4gb. wenn weitere infos benötigt werden, helft mir bitte mit möglichst genauen vorgaben, da ich wirklich nicht so die leuchte hierbei bin ;o)
Hallo fastro,

Ich bin zwar selbst noch Schüler, und ich will jetzt meinen Vorschlag nicht als "absolute Lösung" anpreisen, doch habe ich in den letzten Wochen desöfteren den Kernel kompiliert, (baue selbst grade eine manuelle Gentoo-Installation auf), weshalb mir so einiges grade im Gedächtnis ist...

Also ich geh jetzt mal von "Gentoo" DIREKT aus. Sabayon, wie Du sagst ist gentoo-basiert und vorkonfiguriert. Ich würde mal im Kernel nachsehe. Da sind z.B unter

Device Drivers --->
Dann ganz unten:
< > MMC/SD/SDIO Card Support
Darunter:
< > Sony MenoryStick Card Support

Ebenfalls könnte man nachsehen ob unter:

Device Drivers --->
< > X86 Platform Specific Device Drivers --->

Evtl. Einstellungen für SonyVAIO vorzunehmen sind. Da war ich allerdings nicht oft drin, da dies nur spezielle Dinge sind, wie Hotkey-Support ASUS beispielsweise. Da könnte ich mir aber vorstellen, das dort auch Reader Unterstützungen "versteckt" sind.

Wahrscheinlich keine große Hilfe für Dich, aber evtl eine kleine "Anregung".

Denke, Du bekommst von den anderen viel "weiteren" in Sachen gentoo bald eine bessere Antwort.
Gruß
mnt_gentoo
_________________________________________________________________________________________

Die Launen und das Schicksal eines Gentoo-Users: ?( :| :cursing: :wacko: 8| ^^ 8o ;( :P ?( ...

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »mnt_gentoo« (06.10.2011, 17:51)


3

06.10.2011, 16:07

danke bereits für die anregungen.

nun bin ich mir allerdings bei der weiteren umsetzung ein wenig usnicher (wie gesagt: es gab ja gründe, weshalb ich mit der händischen installation von gentoo aufgehört habe ;o)
kann ich diese einstellungen überprüfen oder ggflls. ändern, indem ich über genkernel gehe oder gibt es da eine gefahrlosere variante? ich hab einfach bedenken, daß mein momentan tadellos laufendes system durch meine "spielereien" gegen die wand läuft...

falk

4

06.10.2011, 17:25

Hi fastro

Hmm.., ich vermute das Sabayon die meist benötigten Treiber schon mit im Kernel hat.
Stecke doch bitte einfach mal eine SD Karte ein und schau dann im "dmesg" was der Kernel dazu sagt, dies sollten dann unten die letzten Ausgaben sein.

@mnt_gentoo
Sorry, deine Zitate mit enthaltenen Code Tags schauen furchtbar aus, versuche das doch mal in den Griff zu bekommen ;)

5

06.10.2011, 17:38

Hallo :)

Also wenn Du genkernel hast, würd ich sagen, das er (eigentlich) die richtigen Module laden sollte. Was ich als "Sinn der Sache" von genkernel sehe. Das halt die manuelle "Sucherei" entfällt. Ich bin mit meiner manuellen Konfiguration auch schon ewige Zeiten am Neukompilieren.

Nur ein Beispiel, zuerst bei der Installation, mir schon bekannte Treiber eingesetzt, für xorg nochmal, dann nochmal für die Unterstützung der Soundkarte, für Webcam und Micro. Vorgestern für die lm_sensors (Hw-Temperatur-Unterstützung im KDE-Applet)

Genkernel habe ich bis jetzt noch nicht genutzt in gentoo. Also ich kanns nur "so" sagen, das wenn Du nun beispielsweise eine Konelconfiguration hast, diese zu sichern. Bedeutet, wenn bei "Spielereien, oder nennen wirs besser Testereien" was schief geht, man danach den Kernel mit der alten Konfigurationsdatei neu bauen und somit den alten Zustand wiederherstellt. Warte mal, ich habe irgendwo hier gesehen, das bei genkernel, die Konfigurationen der unterschiedlichen Kompilationen in einem Ordner gesichert werden.

Also zur "Sicherheit". Ich weiß, es ist nicht "DER" Weg. Man sollte im Falle von "verhauenen" Installationen die Live-CD booten und mit chroot von der LiveCD in die Installation wechseln, reparieren, und dann somit wieder funktionsfähig machen. Ich habe (im Moment noch) dafür Acronis. Wenn sehr viel problemlos geklappt hat, ich mit erfolgten Schritten zufrieden bin, erstelle ich Images dieser Platte auf andere. Heißt, man könnte die gesamte gentoo Installation wieder zurückladen und der Fehler wäre einfach "ungeschehen" gemacht. Doch es ist halt nicht der "unbedingte gentoo weg".

Ich seh mal nach, irgendwo habe ich hier mit der genkernel - Config gelesen, das sie automatisch in einem Ordner gespeichert wird... Nur wo... Guck auch mal hier im Thread "Kernel" Das muß unter genkernel stehen.
Gruß
mnt_gentoo
_________________________________________________________________________________________

Die Launen und das Schicksal eines Gentoo-Users: ?( :| :cursing: :wacko: 8| ^^ 8o ;( :P ?( ...

6

06.10.2011, 17:40

@mnt_gentoo
Sorry, deine Zitate mit enthaltenen Code Tags schauen furchtbar aus, versuche das doch mal in den Griff zu bekommen ;)

Hallo josef, Sorry auch, aber irgendwie verstehe ich auch nicht so ganz mit den Zitaten hier. Also in bbcode habe ich das nicht. Mir gefällt das auch nicht, wenn ich ehrlich bin.
Gruß
mnt_gentoo
_________________________________________________________________________________________

Die Launen und das Schicksal eines Gentoo-Users: ?( :| :cursing: :wacko: 8| ^^ 8o ;( :P ?( ...

7

06.10.2011, 17:51

@mnt_gentoo
Das mit den Zitaten sollte man besser in einem eigenen Thread diskutieren, wird sonst zu Off Topic hier.
Schaue ansonsten zb auch in der Hilfe des Forums http://www.gentooforum.de/index.php?page…m=message.quote

8

06.10.2011, 17:53

Ok, Josef, wollt auch nicht offtopic anfgangen, habs aber verbessert.
Gruß ;)
Gruß
mnt_gentoo
_________________________________________________________________________________________

Die Launen und das Schicksal eines Gentoo-Users: ?( :| :cursing: :wacko: 8| ^^ 8o ;( :P ?( ...

9

06.10.2011, 18:06

@fastro:

Habs gefunden. Das ist in meinem Thread gewesen:

Zitat von dyle:

Zitat

Kurzer Hinweis: wenn du mit genkernel arbeitest, findest du deine
Kernel-configs auch in /etc/kernels/. Dort werden die zuletzt
erfolgreich gebauten .config versioniert.
Gruß
mnt_gentoo
_________________________________________________________________________________________

Die Launen und das Schicksal eines Gentoo-Users: ?( :| :cursing: :wacko: 8| ^^ 8o ;( :P ?( ...

10

06.10.2011, 18:07

hallo josef,

dmesg ergibt folgendes:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
27.644865] [drm] initialized overlay support
[   27.785415] checking generic (b0000000 180000) vs hw (b0000000 10000000)
[   27.785420] fb: conflicting fb hw usage inteldrmfb vs VESA VGA - removing generic driver
[   27.785469] Console: switching to colour dummy device 80x25
[   27.786059] fbcon: inteldrmfb (fb0) is primary device
[   27.786501] [drm] Changing LVDS panel from (+hsync, +vsync) to (-hsync, -vsync)
[   27.822553] Console: switching to colour frame buffer device 160x50
[   27.828153] fb0: inteldrmfb frame buffer device
[   27.828156] drm: registered panic notifier
[   27.828227] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0
[   29.166410] vboxdrv: Found 2 processor cores.
[   29.166543] vboxdrv: fAsync=0 offMin=0x3a2 offMax=0x1130
[   29.166630] vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
[   29.166633] vboxdrv: Successfully loaded version 4.1.2 (interface 0x00190000).
[   30.392699] EXT4-fs (dm-0): re-mounted. Opts: (null)
[   30.643102] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[   30.696266] EXT4-fs (dm-1): mounted filesystem with ordered data mode. Opts: (null)
[   33.022798] Bluetooth: RFCOMM TTY layer initialized
[   33.022811] Bluetooth: RFCOMM socket layer initialized
[   33.022814] Bluetooth: RFCOMM ver 1.11
[   33.109136] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   33.109139] Bluetooth: BNEP filters: protocol multicast
[   39.296560] fbcondecor: console 0 using theme 'sabayon'
[   39.388605] fbcondecor: switched decor state to 'on' on console 0
[   39.481498] sky2 0000:02:00.0: eth0: enabling interface
[   39.484950] fbcondecor: console 1 using theme 'sabayon'
[   39.577198] fbcondecor: switched decor state to 'on' on console 1
[   39.674546] fbcondecor: console 2 using theme 'sabayon'
[   39.711229] iwl3945 0000:06:00.0: loaded firmware version 15.32.2.9
[   39.770027] fbcondecor: switched decor state to 'on' on console 2
[   39.875909] fbcondecor: console 3 using theme 'sabayon'
[   39.967590] fbcondecor: switched decor state to 'on' on console 3
[   40.063468] fbcondecor: console 4 using theme 'sabayon'
[   40.155286] fbcondecor: switched decor state to 'on' on console 4
[   40.250582] fbcondecor: console 5 using theme 'sabayon'
[   40.354953] fbcondecor: switched decor state to 'on' on console 5
[   40.452316] vboxguest: VirtualBox Guest PCI device not found.
[   40.462618] vboxguest: VirtualBox Guest PCI device not found.
[   41.808856] NET: Registered protocol family 10
[   41.810288] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   41.810324] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[   45.116961] Adding 2064380k swap on /dev/mapper/vg_mysire-lv_swap.  Priority:-1 extents:1 across:2064380k 
[   48.366207] wlan0: authenticate with 88:25:2c:93:f0:70 (try 1)
[   48.368144] wlan0: authenticated
[   48.377920] wlan0: associate with 88:25:2c:93:f0:70 (try 1)
[   48.380063] wlan0: RX AssocResp from 88:25:2c:93:f0:70 (capab=0x431 status=0 aid=2)
[   48.380070] wlan0: associated
[   48.382161] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   56.785446] ata3.00: configured for UDMA/100
[   56.785452] ata3: EH complete
[   59.362033] wlan0: no IPv6 routers present
[   60.168748] EXT4-fs (dm-0): re-mounted. Opts: commit=0
[   60.633858] EXT4-fs (sda1): re-mounted. Opts: commit=0
[   60.755799] EXT4-fs (dm-1): re-mounted. Opts: commit=0
[ 1597.126061] usb 1-6: reset high speed USB device number 2 using ehci_hcd
[ 1607.374083] usb 1-6: reset high speed USB device number 2 using ehci_hcd
[ 1623.625094] usb 1-6: reset high speed USB device number 2 using ehci_hcd
[ 1623.875066] usb 1-6: reset high speed USB device number 2 using ehci_hcd
[ 1634.123060] usb 1-6: reset high speed USB device number 2 using ehci_hcd
[ 1634.270082] sd 6:0:0:0: Device offlined - not ready after error recovery
[ 3122.398062] CE: hpet increased min_delta_ns to 20113 nsec
[ 6606.237272] warning: `VirtualBox' uses 32-bit capabilities (legacy support in use)


ich hoffe, ich habe jetzt nicht zuviel von der ausgabe genommen. da ich aber nicht wirklich etwas damit anfangen kann: lieber zu viel als zu wenig...

ich vermute mal, daß die zahlen in den eckigen klammern ne art zeitstempel darstellen. somit bräuchte ich den ganzen wust oben also nicht. was mich dabei allerdings wundert: die vb hab ich gar nicht angerührt innerhalb der letzten zwei stunden.... :whistling:

11

06.10.2011, 18:21

Hmm nein, da ist nichts hilfreiches dabei...

Ein anderer Vorschlag:
Nimm die SD Karte noch mal raus
Starte dann in einer Konsole ein

Quellcode

1
# tail -f /var/log/messages

stecke dann die SD Karte in den Card Reader ein
und poste dann die im /var/log/messages hinzugekommenen Ausgaben.

12

06.10.2011, 18:26

...und wie du an der zeit sehen kannst: es tut sich gar nix

Quellcode

1
2
3
4
5
6
7
8
9
10
11
# tail -f /var/log/messages
Oct  6 17:20:01 mysire cron[9896]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Oct  6 17:30:01 mysire cron[9916]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Oct  6 17:35:57 mysire -- MARK --
Oct  6 17:40:01 mysire cron[9949]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Oct  6 17:50:02 mysire cron[9966]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Oct  6 18:00:01 mysire cron[9999]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Oct  6 18:00:01 mysire cron[10000]: (root) CMD (rm -f /var/spool/cron/lastrun/cron.hourly)
Oct  6 18:00:01 mysire run-crons[10006]: (root) CMD (/etc/cron.hourly/vnstat)
Oct  6 18:10:01 mysire cron[10035]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Oct  6 18:20:01 mysire cron[11012]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )



...wie steig ich aus den messages wieder aus? :whistling:

13

06.10.2011, 18:41

...wie steig ich aus den messages wieder aus? :whistling:

Das laufende "tail" kannst du mit Strg+C wieder beenden.

/edit:
Hmm, ich denke das für deinen Texas Instruments Card Reader der "tifm_7xx1" Treiber der richtige sein sollte, und der wird laut deinem ersten dmesg Anhang auch gefunden

Zitat von »fastro dmesg«

Quellcode

1
2
[   26.347695] tifm_7xx1 0000:0a:03.2: enabling device (0000 -> 0002)
[   26.347707] tifm_7xx1 0000:0a:03.2: PCI INT B -> GSI 17 (level, low) -> IRQ 17
soweit sollte es also passen.
Doch warum beim einstecken einer SD Karte nun gar nicht passiert ist mir aktuell auch ein Rätsel..

Ich hab hier in einem Notebook auch einen Card Reader von Texas Instruments (aber ein älteren Typ) welcher auch mit dem "tifm_7xx1" Treiber Modul läuft.
Hier würde das dmesg Log etwa so ausschauen:

Quellcode

1
Oct  3 09:28:01 MD95500 kernel: [    6.354135] tifm_7xx1 0000:06:02.3: PCI INT A -> GSI 16 (level, low) -> IRQ 16
und nach dem einstecken einer SD Karte wird diese dann wie folgt erkannt/eingebunden

Quellcode

1
2
3
4
5
6
Oct  6 17:14:14 MD95500 kernel: [196170.483749] tifm_core: MMC/SD card detected in socket 0:3
Oct  6 17:14:14 MD95500 kernel: [196170.491736] tifm0 : demand removing card from socket 0:3
Oct  6 17:14:26 MD95500 kernel: [196182.903756] tifm_core: MMC/SD card detected in socket 0:3
Oct  6 17:14:27 MD95500 kernel: [196183.363028] mmc0: new SD card at address 5e5a
Oct  6 17:14:27 MD95500 kernel: [196183.427270] mmcblk0: mmc0:5e5a SM02G 1.87 GiB 
Oct  6 17:14:27 MD95500 kernel: [196183.429178]  mmcblk0: p1

Dieses Laufwerk lässt sich dann zb via

Quellcode

1
mount /dev/mmcblk0p1 /mnt/SD-Card/
einbinden.
Das schaut dann zb so aus

Quellcode

1
2
mount | grep SD-Card
/dev/mmcblk0p1 on /mnt/SD-Card type vfat (rw)


Das ganze sollte aber normal auch mit udisks funktionieren, sprich nach dem einstecken einer SD Card sollte im KDE dieser Device Notifer aufploppen und die Laufwerke dann bequem verwendet werden können. (hier tut es das)

Doch warum genau das bei dir nicht funktioniert muss ich aktuell leider passen...

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »josef.95« (06.10.2011, 19:30)


14

06.10.2011, 20:29

Bin auch wieder da ;)

Mal eine Frage... Mag sich blöd anhören... :whistling: hast Du mal eine andere Karte probiert? Bzw. also wenn das ein interner CardReader ist, derhat evtl auch einschübe für andere Kartentypen... Ich habe hier beispielsweise ein SonyVAIO VGN AR11B stehen, also auch älteres Modell. Der hat MemoryStick und SD.

Ich weiß, es gehört nicht hierher, weil es kein Linux betrifft, doch möchte ich erzählen das ich auch mal mit einem CardReader und zwar DIESES SonyVAIO Probleme hatte: Eigentlich war XP auf diesem Notebook. Doch als Vista kam habe ich das installiert. Hab orig Sony-Treiber genommen, die genannten Patches (LED-Support) installiert. Und sobald ich MemoryStick Karte eingesteckt habe -> BSOD.

SD-Karte, der Witz, liefen ;)

Erst mit Win7 behob das Problem wieder.
Gruß
mnt_gentoo
_________________________________________________________________________________________

Die Launen und das Schicksal eines Gentoo-Users: ?( :| :cursing: :wacko: 8| ^^ 8o ;( :P ?( ...

15

06.10.2011, 21:49

also ne andere karte hab ich auch schon probiert. das hier ist ja ne sdhc mit 4gb. dann hatte ich noch ne ältere sd mit 1gb rumliegen. da erfolgt aber ebenso keine reaktion....
ich schätze mal, wenn ich mir im markt nen usb-gerät für nen zehner kaufe, läuft das ohne murren... :wacko:

16

06.10.2011, 23:05

Wenn ich die dmesg Ausgabe richtig deute, so ist der Card-Reader in einem PCMCIA Slot. Jedenfalls ist der yenta_cardbus Treiber davor angesprungen.
Was liefert "tail -f /var/log/messages" wenn Du im laufendem Betrieb den Reader aus dem Slot ziehst und mit eingelegter Karte wieder einschiebst?

Ich muss mnt_gentoo Recht geben. Wahrscheinlich musst Du am Kernel schrauben müssen. Wie es unter Sabayon am besten geht, musst Du bei den Sabayon-Leuten fragen. Bei Gentoo scheiden sich die Geister um "genkernel vs. manuell". Auf jeden Fall sichere mal die Config deines laufenden Kernels weg, damit Du bei Bedarf mit der selben Config den Kern wieder neu bauen kannst.

Quellcode

1
zcat /proc/config.gz > ~/sabayon-kernel-config.txt
Lade die Datei mal auch hoch, damit wir über Deinen Kernel drüber schauen können.
Poste mal auch noch die Ausgabe bei eingestecktem Reader von folgenden Befehlen (Paar Schüsse ins blaue):

Quellcode

1
2
3
4
5
lspcmcia
lspci -nn
lsusb
lsusb -t
rescan-scsi-bus
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

17

06.10.2011, 23:44

so, die gewünschten ausgaben mache ich morgen im laufe des vormittags fertig. der reader steckt in keinem pcmcia-slot sondern ist als kleiner einschub über dem dvd-laufwerk in die seitenwand des notebook integriert; daneben steht "ExpressCard".

der rest wie gesagt morgen und bereits jetzt ein dankeschön und ne ruhige nacht euch allen.

falk

18

07.10.2011, 09:41

moin,

also hier die gewünschten ausgaben:

Quellcode

1
2
# lspcmcia
Socket 0 Bridge:        [yenta_cardbus]         (bus ID: 0000:0a:03.0)


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
# lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 1 [8086:27d0] (rev 02)
00:1c.1 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 2 [8086:27d2] (rev 02)
00:1c.2 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 3 [8086:27d4] (rev 02)
00:1c.3 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 4 [8086:27d6] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 [8086:27c8] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 [8086:27c9] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 [8086:27ca] (rev 02)
00:1d.3 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 [8086:27cb] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller [8086:27cc] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 02)
00:1f.1 IDE interface [0101]: Intel Corporation 82801G (ICH7 Family) IDE Controller [8086:27df] (rev 02)
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller [8086:27c4] (rev 02)
00:1f.3 SMBus [0c05]: Intel Corporation N10/ICH 7 Family SMBus Controller [8086:27da] (rev 02)
02:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8036 PCI-E Fast Ethernet Controller [11ab:4351] (rev 16)
06:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
0a:03.0 CardBus bridge [0607]: Texas Instruments PCIxx12 Cardbus Controller [104c:8039]
0a:03.1 FireWire (IEEE 1394) [0c00]: Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller [104c:803a]
0a:03.2 Mass storage controller [0180]: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD) [104c:803b]


Quellcode

1
2
3
4
5
6
7
8
# lsusb
Bus 005 Device 002: ID 044e:300d Alps Electric Co., Ltd Bluetooth Controller (ALPS/UGPZ6)
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 054c:0281 Sony Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
# lsusb -t
Bus#  5
`-Dev#   1 Vendor 0x1d6b Product 0x0001
  `-Dev#   2 Vendor 0x044e Product 0x300d
Bus#  4
`-Dev#   1 Vendor 0x1d6b Product 0x0001
Bus#  3
`-Dev#   1 Vendor 0x1d6b Product 0x0001
Bus#  2
`-Dev#   1 Vendor 0x1d6b Product 0x0001
Bus#  1
`-Dev#   1 Vendor 0x1d6b Product 0x0002
  `-Dev#   2 Vendor 0x054c Product 0x0281


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
# rescan-scsi-bus
Host adapter 2 (ata_piix) found.
Host adapter 3 (ata_piix) found.
Host adapter 4 (ata_piix) found.
Host adapter 5 (ata_piix) found.
Host adapter 6 (usb-storage) found.
Scanning SCSI subsystem for new devices
Scanning host 2 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning for device 2 0 0 0 ... 
OLD: Host: scsi2 Channel: 00 Id: 00 Lun: 00
      Vendor: PIONEER  Model: DVD-RW  DVR-K17  Rev: 1.00
      Type:   CD-ROM                           ANSI SCSI revision: 05
Scanning host 3 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 4 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning for device 4 0 0 0 ... 
OLD: Host: scsi4 Channel: 00 Id: 00 Lun: 00
      Vendor: ATA      Model: TOSHIBA MK1234GS Rev: AH00
      Type:   Direct-Access                    ANSI SCSI revision: 05
Scanning host 5 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning host 6 for  SCSI target IDs  0 1 2 3 4 5 6 7, all LUNs
Scanning for device 6 0 0 0 ... 
OLD: Host: scsi6 Channel: 00 Id: 00 Lun: 00
      Vendor: Sony     Model: USB   HS-CARD    Rev: 4.52
      Type:   Direct-Access                    ANSI SCSI revision: -1
0 new device(s) found.                     
0 device(s) removed.         


den rescan hab ich einmal mit und einmal ohne eingesteckte karte laufen lassen. die ausgaben waren die gleichen, allerdings hatte ich den subjektiven eindruck, als wenn er zum scannen bei device 6 mehr zeit bei eingesteckter karte gebraucht hat....

@bell: den tail mit und ohne karte hatte ich bereits auf josef anregung hin laufen gehabt.... da gab es keine änderungenn... :(

falk

19

07.10.2011, 10:16

Hm, die Ausgaben bringen zwar etwas Einblick ins System, jedoch keine neue Idee woran es liegen könnte ..
den tail mit und ohne karte hatte ich bereits auf josef anregung hin laufen gehabt.
Um Missverständnissen vorzubeugen: der "teil" sollte nicht vor und nach laufen, sondern während des Einsteckens / Rausnehmens.
Den Vorschlag von Josef habe ich so verstanden, dass Du die "SD" Karte rausnehmen und neu einlegen sollst. Mein Vorschlag daher den kompletten Reader aus dem "ExpressCard" Slot ziehen und wieder einstöpseln.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

20

07.10.2011, 10:35

ahh, ok. dann war das ein verständnisfehler meinerseits. ich hab den kompletten reader mit eingesteckter sdhc-karte mal entfernt und wieder eingesteckt. das tail schaut dann so aus:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
# tail -f /var/log/messages
Oct  7 10:10:01 mysire cron[9416]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Oct  7 10:11:08 mysire -- MARK --
Oct  7 10:20:01 mysire cron[9438]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Oct  7 10:30:01 mysire cron[9456]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Oct  7 10:30:52 mysire kernel: [ 4820.327194] usb 1-6: USB disconnect, device number 2
Oct  7 10:31:07 mysire kernel: [ 4834.991074] usb 1-6: new high speed USB device number 4 using ehci_hcd
Oct  7 10:31:07 mysire kernel: [ 4835.171984] scsi7 : usb-storage 1-6:1.0
Oct  7 10:31:08 mysire kernel: [ 4836.181979] scsi 7:0:0:0: Direct-Access     Sony     USB   HS-CARD    4.52 PQ: 0 ANSI: 0
Oct  7 10:31:08 mysire kernel: [ 4836.183449] sd 7:0:0:0: Attached scsi generic sg2 type 0
Oct  7 10:31:08 mysire kernel: [ 4836.237570] sd 7:0:0:0: [sdb] Attached SCSI removable disk
Oct  7 10:32:20 mysire kernel: [ 4908.561743] usb 1-6: USB disconnect, device number 4
Oct  7 10:32:51 mysire kernel: [ 4939.569075] usb 1-6: new high speed USB device number 5 using ehci_hcd
Oct  7 10:32:51 mysire kernel: [ 4939.749269] scsi8 : usb-storage 1-6:1.0
Oct  7 10:32:52 mysire kernel: [ 4940.759033] scsi 8:0:0:0: Direct-Access     Sony     USB   HS-CARD    4.52 PQ: 0 ANSI: 0
Oct  7 10:32:52 mysire kernel: [ 4940.761558] sd 8:0:0:0: Attached scsi generic sg2 type 0
Oct  7 10:33:23 mysire kernel: [ 4971.110057] usb 1-6: reset high speed USB device number 5 using ehci_hcd
Oct  7 10:33:33 mysire kernel: [ 4981.358046] usb 1-6: reset high speed USB device number 5 using ehci_hcd
Oct  7 10:33:49 mysire kernel: [ 4997.608061] usb 1-6: reset high speed USB device number 5 using ehci_hcd
Oct  7 10:33:49 mysire kernel: [ 4997.858065] usb 1-6: reset high speed USB device number 5 using ehci_hcd
Oct  7 10:34:00 mysire kernel: [ 5008.106071] usb 1-6: reset high speed USB device number 5 using ehci_hcd
Oct  7 10:34:00 mysire kernel: [ 5008.253005] sd 8:0:0:0: Device offlined - not ready after error recovery
Oct  7 10:34:00 mysire kernel: [ 5008.253092] sd 8:0:0:0: rejecting I/O to offline device
Oct  7 10:34:00 mysire kernel: [ 5008.253112] sd 8:0:0:0: rejecting I/O to offline device
Oct  7 10:34:00 mysire kernel: [ 5008.253125] sd 8:0:0:0: rejecting I/O to offline device
Oct  7 10:34:00 mysire kernel: [ 5008.253137] sd 8:0:0:0: [sdb] READ CAPACITY failed
Oct  7 10:34:00 mysire kernel: [ 5008.253145] sd 8:0:0:0: [sdb]  Result: hostbyte=0x01 driverbyte=0x00
Oct  7 10:34:00 mysire kernel: [ 5008.253169] sd 8:0:0:0: [sdb] Sense not available.
Oct  7 10:34:00 mysire kernel: [ 5008.253191] sd 8:0:0:0: rejecting I/O to offline device
Oct  7 10:34:00 mysire kernel: [ 5008.253203] sd 8:0:0:0: [sdb] Write Protect is off
Oct  7 10:34:00 mysire kernel: [ 5008.253212] sd 8:0:0:0: [sdb] Mode Sense: 00 00 00 00
Oct  7 10:34:00 mysire kernel: [ 5008.253223] sd 8:0:0:0: rejecting I/O to offline device
Oct  7 10:34:00 mysire kernel: [ 5008.253235] sd 8:0:0:0: [sdb] Asking for cache data failed
Oct  7 10:34:00 mysire kernel: [ 5008.253243] sd 8:0:0:0: [sdb] Assuming drive cache: write through
Oct  7 10:34:00 mysire kernel: [ 5008.253531] sd 8:0:0:0: [sdb] Attached SCSI removable disk


gruß
falk


/edit: es ist übrigens ein sony vgp-mca20

/ 2. edit: und ein anhang zum kernel.... sorry, bin manchmal vergesslich.... ;o)
»fastro« hat folgende Datei angehängt: