Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

23.01.2012, 00:35

Blocks B

Hi,
beim updaten meines systems habe ich blocks:

Quellcode

1
2
[blocks B      ] <x11-libs/libsexy-0.1.11-r3 ("<x11-libs/libsexy-0.1.11-r3" is blocking media-libs/libpng-1.5.6)
[blocks B      ] <x11-libs/vte-0.28.2-r201:0 ("<x11-libs/vte-0.28.2-r201:0" is blocking x11-libs/gtk+-2.24.8-r1)


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-libs/libsexy-0.1.11-r2::gentoo, installed) pulled in by
    x11-libs/libsexy required by (media-sound/gmpc-0.20.0::gentoo, installed)

  (x11-libs/gtk+-2.24.8-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/gtk+-2.19.5:2 required by (www-client/epiphany-2.30.6-r1::gentoo, installed)
    >=x11-libs/gtk+-2.6:2 required by (mail-client/claws-mail-3.7.9-r1::gentoo, installed)
    >=x11-libs/gtk+-2.8.6:2 required by (x11-plugins/enigmail-1.1.2-r2::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (gnome-base/libgnomekbd-2.32.0::gentoo, installed)
    >=x11-libs/gtk+-2.11:2 required by (dev-libs/libgweather-2.30.3::gentoo, installed)
    >=x11-libs/gtk+-2.8.10:2 required by (gnome-base/libglade-2.6.4::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.24:2 required by (dev-python/pygtk-2.24.0-r2::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.20.1:2[introspection] required by (app-text/poppler-0.16.7::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.18:2 required by (x11-misc/notification-daemon-0.5.0::gentoo, installed)
    >=x11-libs/gtk+-2.6:2 required by (x11-libs/hippo-canvas-0.3.0-r1::gentoo, installed)
    >=x11-libs/gtk+-2.6:2 required by (gnome-base/gdm-2.20.11::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (gnome-base/gnome-keyring-2.32.1::gentoo, installed)
    >=x11-libs/gtk+-2.14.0:2 required by (dev-dotnet/gnome-sharp-2.24.2::gentoo, installed)
    x11-libs/gtk+:2 required by (games-strategy/freeciv-2.3.0::gentoo, installed)
    x11-libs/gtk+:2 required by (app-text/ghostscript-gpl-9.04-r4::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.12:2 required by (media-sound/gmpc-0.20.0::gentoo, installed)
    x11-libs/gtk+:2 required by (x11-libs/wxGTK-2.8.11.0::gentoo, installed)
    >=x11-libs/gtk+-2.14:2 required by (gnome-base/libgnomeui-2.24.5::gentoo, installed)
    >=x11-libs/gtk+-2.19.7:2 required by (x11-libs/libwnck-2.30.6::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (gnome-base/gnome-control-center-2.32.1-r1::gentoo, installed)
    >=x11-libs/gtk+-2.16:2 required by (gnome-extra/gnome-games-2.28.2::gentoo, installed)
    >=x11-libs/gtk+-2.22:2 required by (gnome-base/nautilus-2.32.2.1-r1::gentoo, installed)
    >=x11-libs/gtk+-2.22:2 required by (gnome-base/gnome-panel-2.32.1-r2::gentoo, installed)
    >=x11-libs/gtk+-2.24:2 required by (dev-cpp/gtkmm-2.24.2::gentoo, installed)
    x11-libs/gtk+:2 required by (app-crypt/pinentry-0.8.0::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (sys-apps/gnome-disk-utility-2.32.1-r1::gentoo, installed)
    >=x11-libs/gtk+-2.6:2 required by (dev-python/gnome-python-base-2.28.1::gentoo, installed)
    >=x11-libs/gtk+-2.16:2 required by (media-gfx/f-spot-0.8.2::gentoo, installed)
    >=x11-libs/gtk+-2:2 required by (x11-themes/gnome-themes-2.32.1::gentoo, installed)
    >=x11-libs/gtk+-2.13:2[-aqua,introspection] required by (net-libs/webkit-gtk-1.4.3-r200::gentoo, installed)
    >=x11-libs/gtk+-2.18.0:2 required by (gnome-extra/gnome-media-2.32.0-r1::gentoo, installed)
    >=x11-libs/gtk+-2.21.2:2 required by (gnome-base/gnome-settings-daemon-2.32.1-r1::gentoo, installed)
    >=x11-libs/gtk+-2.12:2 required by (x11-themes/gtk-engines-2.20.2::gentoo, installed)
    >=x11-libs/gtk+-2.8.6:2 required by (www-client/firefox-3.6.17::gentoo, installed)
    >=x11-libs/gtk+-2.12.5:2 required by (media-gfx/gimp-2.6.11-r1::gentoo, installed)
    >=x11-libs/gtk+-2.6:2 required by (net-analyzer/nmap-5.51::gentoo, installed)
    >=x11-libs/gtk+-2.4:2 required by (x11-libs/gksu-2.0.2::gentoo, installed)
    >=x11-libs/gtk+-2.8.6:2 required by (net-libs/xulrunner-1.9.2.17::gentoo, installed)
    >=x11-libs/gtk+-2.22.0:2 required by (gnome-base/gnome-session-2.32.1-r2::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (gnome-extra/gcalctool-5.32.2::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (gnome-base/gnome-desktop-2.32.1::gentoo, installed)
    >=x11-libs/gtk+-2.13:2 required by (gnome-base/libgnomecanvas-2.30.3::gentoo, installed)
    >=x11-libs/gtk+-2.22.1-r1:2 required by (gnome-base/gnome-light-2.32.1::gentoo, installed)
    >=x11-libs/gtk+-2.20.0:2 required by (media-libs/libcanberra-0.26::gentoo, installed)
    >=x11-libs/gtk+-2.16:2 required by (gnome-base/librsvg-2.34.0::gentoo, installed)
    >=x11-libs/gtk+-2.12:2 required by (x11-libs/libgksu-2.0.12-r1::gentoo, installed)
    >=x11-libs/gtk+-2.12:2 required by (x11-libs/gtksourceview-2.10.5-r1::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:2 required by (app-text/aiksaurus-1.2.1::gentoo, installed)
    >=x11-libs/gtk+-2.6:2 required by (media-gfx/ufraw-0.16::gentoo, installed)
    x11-libs/gtk+:2 required by (sys-devel/distcc-3.1-r5::gentoo, installed)
    x11-libs/gtk+:2 required by (dev-dotnet/gdk-sharp-2.12.10::gentoo, installed)
    >=x11-libs/gtk+-2.8.12:2 required by (gnome-base/libbonoboui-2.24.5::gentoo, installed)
    >=x11-libs/gtk+-2.14:2 required by (gnome-base/gconf-2.32.3::gentoo, installed)
    x11-libs/gtk+:2 required by (app-text/acroread-9.4.2::gentoo, installed)
    x11-libs/gtk+:2 required by (app-editors/emacs-23.3-r2::gentoo, installed)
    >=x11-libs/gtk+-2.14.0:2 required by (gnome-extra/gnome-screensaver-2.30.2-r1::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (gnome-extra/yelp-2.30.2-r5::gentoo, installed)
    >=x11-libs/gtk+-2.20.0:2 required by (mail-client/evolution-2.32.2-r3::gentoo, installed)
    x11-libs/gtk+:2 required by (media-libs/gegl-0.1.6::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (x11-wm/metacity-2.30.3::gentoo, installed)
    >=x11-libs/gtk+-2.11:2 required by (dev-libs/libunique-1.1.6::gentoo, installed)
    >=x11-libs/gtk+-2.24:2 required by (x11-libs/gtk+-3.0.12-r1::gentoo, installed)
    x11-libs/gtk+:2 required by (media-libs/libwmf-0.2.8.4-r3::gentoo, installed)
    >=x11-libs/gtk+-2.6:2 required by (media-gfx/gtkimageview-1.6.4::gentoo, installed)
    >=x11-libs/gtk+-2.6:2 required by (gnome-base/libgnomeprintui-2.18.6::gentoo, installed)
    >=x11-libs/gtk+-2.17.1:2[introspection] required by (gnome-extra/polkit-gnome-0.101-r1::gentoo, ebuild scheduled for merge)
    >=x11-libs/gtk+-2.24:2 required by (gnome-extra/evolution-data-server-2.32.2-r1::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (gnome-extra/gnome-system-monitor-2.28.2-r1::gentoo, installed)
    >=x11-libs/gtk+-2.8.6:2 required by (mail-client/thunderbird-3.1.10::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (gnome-extra/zenity-2.32.1::gentoo, installed)
    >=x11-libs/gtk+-2.18:2 required by (x11-terms/gnome-terminal-2.32.1::gentoo, installed)
    >=x11-libs/gtk+-2.20:2 required by (gnome-extra/gtkhtml-3.32.2::gentoo, installed)
    >=x11-libs/gtk+-2.6:2 required by (x11-libs/libsexy-0.1.11-r2::gentoo, installed)
    >=x11-libs/gtk+-2.20:2[introspection] required by (x11-libs/vte-0.28.1-r200::gentoo, installed)

  (x11-libs/vte-0.28.1-r200::gentoo, installed) pulled in by
    >=x11-libs/vte-0.26.0:0 required by (x11-terms/gnome-terminal-2.32.1::gentoo, installed)

  (media-libs/libpng-1.5.6::gentoo, ebuild scheduled for merge) pulled in by
    media-libs/libpng:0 required by (x11-libs/wxGTK-2.8.11.0::gentoo, installed)
    >=media-libs/libpng-1.2.43-r2:0 required by (app-text/texlive-core-2008-r7::gentoo, installed)
    media-libs/libpng required by (games-strategy/freeciv-2.3.0::gentoo, installed)
    media-libs/libpng:0 required by (x11-libs/cairo-1.10.2-r1::gentoo, ebuild scheduled for merge)
    >=media-libs/libpng-1.2.2:0 required by (media-gfx/gimp-2.6.11-r1::gentoo, installed)
    >=media-libs/libpng-1.4:0 required by (x11-libs/gdk-pixbuf-2.24.0-r1::gentoo, ebuild scheduled for merge)
    >=media-libs/libpng-1.4 required by (media-libs/libwmf-0.2.8.4-r3::gentoo, installed)
    media-libs/libpng required by (dev-tex/luatex-0.63.0::gentoo, installed)
    media-libs/libpng:0 required by (x11-libs/qt-gui-4.7.2::gentoo, installed)
    >=media-libs/libpng-1.4:0 required by (www-client/links-2.3_pre1-r1::gentoo, installed)
    >=media-libs/libpng-1.4:0 required by (net-libs/webkit-gtk-1.4.3-r200::gentoo, installed)
    media-libs/libpng required by (dev-python/matplotlib-1.0.1-r1::gentoo, installed)
    media-libs/libpng:0 required by (app-text/ghostscript-gpl-9.04-r4::gentoo, ebuild scheduled for merge)
    >=media-libs/libpng-1.4:0 required by (dev-dotnet/libgdiplus-2.10::gentoo, installed)
    >=media-libs/libpng-1.4.3:0 required by (net-print/cups-1.4.8-r1::gentoo, ebuild scheduled for merge)
    >=media-libs/libpng-1.4:0 required by (dev-java/icedtea-bin-1.10.2::gentoo, installed)

Sind ja eigentlich verbreitete Libraries, oder? Muß ich jetzt gmpc löschen, oder wie gehe ich vor?

Rüdiger

2

23.01.2012, 09:41

<x11-libs/libsexy-0.1.11-r3" is blocking media-libs/libpng-1.5.6

Hierfür sollte ein emerge -av1 libsexy den Konflikt lösen. Du hast noch libsexy-0.1.11-r2 drauf, das scheint nicht mehr im tree zu sein. Keine Ahnung, wieso portage das nicht einfach updatet.

<x11-libs/vte-0.28.2-r201:0" is blocking x11-libs/gtk+-2.24.8-r1

Vielleicht hilft hier ein emerge -av1 vte. Auch hier hat Portage eine alte Version behalten, obwohl es eine neuere stable gibt.
Ist vielleicht was beim emerge --sync schief gegangen?
Oder hast du evtl neuere Versionen der Pakete maskiert? Überprüfe mal deine package.mask.

3

23.01.2012, 10:42

folgendes steht in der package.mask

Quellcode

1
2
3
=x11-libs/qt-gui-4.7.2
=x11-libs/qt-script-4.7.2
=x11-libs/qt-script-4.7.2


Blöderweise habe ich nicht reingeschrieben, warum ich das gemacht habe. Könnte das was damit zu tun haben?

Rüdiger

4

23.01.2012, 11:02

Wohl eher nicht. Kannst du dann sowieso rausnehmen, wenn dein System aktuell ist, weil die beiden Atoms bereits 4.7.4 als stable haben.
Hat es funktioniert, libsexy und vte manuell zu updaten?

Gruß
Foyaxe

5

23.01.2012, 11:12

Hi,
beide -av1 emerges sind durchgelaufen, der libsexy-conflict ist gelöst, vte nicht:

Quellcode

1
[blocks B      ] <x11-libs/vte-0.28.2-r201:0 ("<x11-libs/vte-0.28.2-r201:0" is blocking x11-libs/gtk+-2.24.8-r1)


Rüdiger

6

23.01.2012, 11:24

Welche Version wurde mit emerge -av1 vte installiert?
Eigentlich sollte auf 0.28.2-r202 oder -r300 geupdated werden, was den Konflikt lösen würde.

7

23.01.2012, 11:56

Version von vte:

Quellcode

1
2
equery which vte
/usr/portage/x11-libs/vte/vte-0.28.2-r300.ebuild


Beim installieren gab's aber ein paar Warnungen: http://pastebin.de/22629

Hier die komplette Meldung von emerge -evp system: http://pastebin.de/22630

Übrigens merke ich gerade, dass ich mir mittlerweile das System so weit zerschossen habe, dass der X-Server nicht mehr startet :(

Rüdiger

8

23.01.2012, 13:06

Versuch mal ein emerge -av1 x11-libs/vte:0
Es geht hier um vte im Slot 0, das anscheinend nicht geupdated wurde.

Den x-Server hast du evtl. zerlegt, nachdem du ihn geupdated hast und die Treiber nicht neu gebaut hast. Zumindest passiert mir das immer wieder, inzwischen weiß ich dann schon bescheid.

9

23.01.2012, 13:15

Aha, irgendwas ist da schwer verheddert:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies  ..... done!
[ebuild     U  ] x11-libs/vte-0.28.2-r202 [0.28.1-r200] USE="introspection -debug -doc -glade -python*" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB


>>> Verifying ebuild manifests

>>> Emerging (1 of 1) x11-libs/vte-0.28.2-r202
 * vte-0.28.2.tar.xz RMD160 SHA1 SHA256 size ;-) ...                     [ ok ]
>>> Unpacking source...
>>> Unpacking vte-0.28.2.tar.xz to /var/tmp/portage/x11-libs/vte-0.28.2-r202/work
>>> Source unpacked in /var/tmp/portage/x11-libs/vte-0.28.2-r202/work
>>> Preparing source in /var/tmp/portage/x11-libs/vte-0.28.2-r202/work/vte-0.28.2 ...
 * Applying vte-0.30.1-alt-meta.patch ...
 [ ok ]
 * Fixing OMF Makefiles ...
 [ ok ]
 * Running elibtoolize in: vte-0.28.2/
 *   Applying portage/2.2 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.2.6 patch ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-libs/vte-0.28.2-r202/work/vte-0.28.2 ...
 * econf: updating vte-0.28.2/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating vte-0.28.2/gnome-pty-helper/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating vte-0.28.2/gnome-pty-helper/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating vte-0.28.2/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --build=i486-pc-linux-gnu --host=i486-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-dependency-tracking --disable-gnome-pty-helper --disable-deprecation --disable-maintainer-mode --disable-static --disable-debug --disable-glade-catalogue --enable-introspection --disable-python --with-gtk=2.0 --disable-gtk-doc --disable-maintainer-mode
ls: ignoring invalid width in environment variable COLUMNS: 0
ls: ignoring invalid width in environment variable COLUMNS: 0
configure: loading site script /usr/share/config.site
configure: loading site script /usr/share/crossdev/include/site/linux
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to disable maintainer-specific portions of Makefiles... no
checking which gtk+ version to compile against... 2.0
checking for i486-pc-linux-gnu-gcc... i486-pc-linux-gnu-gcc
checking whether the C compiler works... no
configure: error: in `/var/tmp/portage/x11-libs/vte-0.28.2-r202/work/vte-0.28.2':
configure: error: C compiler cannot create executables
See `config.log' for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/x11-libs/vte-0.28.2-r202/work/vte-0.28.2/config.log
 * ERROR: x11-libs/vte-0.28.2-r202 failed (configure phase):
 *   econf failed
 * 
 * Call stack:
 *          ebuild.sh, line   75:  Called src_configure
 *        environment, line 5552:  Called gnome2_src_configure
 *        environment, line 2865:  Called econf '--disable-gnome-pty-helper' '--disable-deprecation' '--disable-maintainer-mode' '--disable-static' '--disable-debug' '--disable-glade-catalogue' '--enable-introspection' '--disable-python' '--with-gtk=2.0' '--disable-gtk-doc' '--disable-maintainer-mode'
 *   phase-helpers.sh, line  467:  Called die
 * The specific snippet of code:
 *   			die "econf failed"
 * 
 * If you need support, post the output of 'emerge --info =x11-libs/vte-0.28.2-r202',
 * the complete build log and the output of 'emerge -pqv =x11-libs/vte-0.28.2-r202'.
 * The complete build log is located at '/var/tmp/portage/x11-libs/vte-0.28.2-r202/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/vte-0.28.2-r202/temp/environment'.
 * S: '/var/tmp/portage/x11-libs/vte-0.28.2-r202/work/vte-0.28.2'

>>> Failed to emerge x11-libs/vte-0.28.2-r202, Log file:

>>>  '/var/tmp/portage/x11-libs/vte-0.28.2-r202/temp/build.log'

 * Messages for package x11-libs/vte-0.28.2-r202:

 * ERROR: x11-libs/vte-0.28.2-r202 failed (configure phase):
 *   econf failed
 * 
 * Call stack:
 *          ebuild.sh, line   75:  Called src_configure
 *        environment, line 5552:  Called gnome2_src_configure
 *        environment, line 2865:  Called econf '--disable-gnome-pty-helper' '--disable-deprecation' '--disable-maintainer-mode' '--disable-static' '--disable-debug' '--disable-glade-catalogue' '--enable-introspection' '--disable-python' '--with-gtk=2.0' '--disable-gtk-doc' '--disable-maintainer-mode'
 *   phase-helpers.sh, line  467:  Called die
 * The specific snippet of code:
 *   			die "econf failed"
 * 
 * If you need support, post the output of 'emerge --info =x11-libs/vte-0.28.2-r202',
 * the complete build log and the output of 'emerge -pqv =x11-libs/vte-0.28.2-r202'.
 * The complete build log is located at '/var/tmp/portage/x11-libs/vte-0.28.2-r202/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-libs/vte-0.28.2-r202/temp/environment'.
 * S: '/var/tmp/portage/x11-libs/vte-0.28.2-r202/work/vte-0.28.2'

 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Ich habe auch schon ein revdep-rebuild versucht, das läuft bei einem anderen Paket (gimp) in den gleichen Fehler.
Das Gentoo ist einfach zu lange nicht geupdated worden. Ein Jahr nicht zu aktualisieren ist wohl kritisch?

Rüdiger

10

23.01.2012, 13:31

Jetzt funktioniert dein Compiler nicht mehr. Das ist schlecht :-P
Versuche mal, den zuerst zu richten mithilfe folgender Anleitung: http://www.gentoo.org/doc/de/gcc-upgrading.xml
Sprich, mit gcc-config Compilerversion wählen und libtool neu bauen. Dann sollte gcc funktionieren.

11

23.01.2012, 14:49

Nix zu wollen:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies  ... done!
[ebuild     U  ] sys-devel/libtool-2.4-r1 [2.2.10] USE="-test% -vanilla" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB


>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-devel/libtool-2.4-r1
 * libtool-2.4.tar.xz RMD160 SHA1 SHA256 size ;-) ...                    [ ok ]
>>> Unpacking source...
>>> Unpacking ./libtool-2.4.tar to /var/tmp/portage/sys-devel/libtool-2.4-r1/work
>>> Source unpacked in /var/tmp/portage/sys-devel/libtool-2.4-r1/work
>>> Preparing source in /var/tmp/portage/sys-devel/libtool-2.4-r1/work/libtool-2.4 ...
 * Removing useless C++ checks ...
 [ ok ]
 * Applying libtool-1.5.20-use-linux-version-in-fbsd.patch ...
 [ ok ]
 * Running eautoreconf in '/var/tmp/portage/sys-devel/libtool-2.4-r1/work/libtool-2.4/libltdl' ...
 * Running aclocal -I m4 ...
 [ ok ]
 * Running true --copy --force --install --automake ...
 [ ok ]
 * Running aclocal -I m4 ...
 [ ok ]
 * Running autoconf ...
 [ ok ]
 * Running autoheader ...
 [ ok ]
 * Running automake --add-missing --copy --foreign ...
 [ ok ]
 * Running eautoreconf in '/var/tmp/portage/sys-devel/libtool-2.4-r1/work/libtool-2.4' ...
 * Running aclocal -I libltdl/m4 ...
 [ ok ]
 * Running true --copy --force --install --automake ...
 [ ok ]
 * Running aclocal -I libltdl/m4 ...
 [ ok ]
 * Running autoconf ...
 [ ok ]
 * Running autoheader ...
 [ ok ]
 * Running automake --add-missing --copy ...
 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-devel/libtool-2.4-r1/work/libtool-2.4 ...
 * econf: updating libtool-2.4/libltdl/config/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating libtool-2.4/libltdl/config/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --build=i486-pc-linux-gnu --host=i486-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib
ls: ignoring invalid width in environment variable COLUMNS: 0
ls: ignoring invalid width in environment variable COLUMNS: 0
configure: loading site script /usr/share/config.site
configure: loading site script /usr/share/crossdev/include/site/linux
## ----------------------- ##
## Configuring libtool 2.4 ##
## ----------------------- ##

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking build system type... i486-pc-linux-gnu
checking host system type... i486-pc-linux-gnu
configure: autobuild project... GNU Libtool
configure: autobuild revision... 2.4 ()
configure: autobuild hostname... Lummerland
configure: autobuild mode... default
configure: autobuild timestamp... 20120123T134800Z
checking for i486-pc-linux-gnu-gcc... i486-pc-linux-gnu-gcc
checking whether the C compiler works... no
configure: error: in `/var/tmp/portage/sys-devel/libtool-2.4-r1/work/libtool-2.4':
configure: error: C compiler cannot create executables
See `config.log' for more details

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-devel/libtool-2.4-r1/work/libtool-2.4/config.log
 * ERROR: sys-devel/libtool-2.4-r1 failed (configure phase):
 *   econf failed
 * 
 * Call stack:
 *            ebuild.sh, line   75:  Called src_configure
 *          environment, line 2707:  Called default
 *   phase-functions.sh, line  791:  Called _eapi2_src_configure
 *     phase-helpers.sh, line  571:  Called econf
 *     phase-helpers.sh, line  467:  Called die
 * The specific snippet of code:
 *   			die "econf failed"
 * 
 * If you need support, post the output of 'emerge --info =sys-devel/libtool-2.4-r1',
 * the complete build log and the output of 'emerge -pqv =sys-devel/libtool-2.4-r1'.
 * The complete build log is located at '/var/tmp/portage/sys-devel/libtool-2.4-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/libtool-2.4-r1/temp/environment'.
 * S: '/var/tmp/portage/sys-devel/libtool-2.4-r1/work/libtool-2.4'

>>> Failed to emerge sys-devel/libtool-2.4-r1, Log file:

>>>  '/var/tmp/portage/sys-devel/libtool-2.4-r1/temp/build.log'

 * Messages for package sys-devel/libtool-2.4-r1:

 * ERROR: sys-devel/libtool-2.4-r1 failed (configure phase):
 *   econf failed
 * 
 * Call stack:
 *            ebuild.sh, line   75:  Called src_configure
 *          environment, line 2707:  Called default
 *   phase-functions.sh, line  791:  Called _eapi2_src_configure
 *     phase-helpers.sh, line  571:  Called econf
 *     phase-helpers.sh, line  467:  Called die
 * The specific snippet of code:
 *   			die "econf failed"
 * 
 * If you need support, post the output of 'emerge --info =sys-devel/libtool-2.4-r1',
 * the complete build log and the output of 'emerge -pqv =sys-devel/libtool-2.4-r1'.
 * The complete build log is located at '/var/tmp/portage/sys-devel/libtool-2.4-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/libtool-2.4-r1/temp/environment'.
 * S: '/var/tmp/portage/sys-devel/libtool-2.4-r1/work/libtool-2.4'

 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

12

23.01.2012, 15:00

Hast du an den CFLAGS in der make.conf geschraubt? Ansonsten weiß ich jetzt auch nicht weiter.

13

23.01.2012, 17:18

Nix zu wollen:
Das heißt das nun tatsächlich ein vorhandener gcc aktiv gesetzt ist?
Poste doch sonst mal die Ausgabe von

Quellcode

1
gcc-config -l
(ist ein kleines L), oder/und auch die "emerge --info" Ausgabe.
Ansonsten würde ich den Rat aus der

Quellcode

1
2
3
4
5
checking for i486-pc-linux-gnu-gcc... i486-pc-linux-gnu-gcc
checking whether the C compiler works... no
configure: error: in `/var/tmp/portage/sys-devel/libtool-2.4-r1/work/libtool-2.4':
configure: error: C compiler cannot create executables
See `config.log' for more details
beachten, sprich: schau mal ins config.log, dort ist meist genauer einzusehen woran es scheitert.

btw
Auch die

Quellcode

1
 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
solltest du beachten und durchlesen - idR sind dort wichtige und hilfreiche Informationen zu finden.

14

23.01.2012, 22:34

Ich habs gefunden. Es lag an mir. (Woran auch sonst...)
Ich hatte vor 'ner Weile mal distcc getestet. Das hat nicht funktioniert, und danach habe ich die make.conf nicht richtig aufgeräumt. Jetzt ist sie es, und emerge -ev system läuft jetzt (222/268 Paketen, wird wohl gutgehn).

Bei der Gelegenheit habe ich gedacht, teste doch mal den Netzwerkboot. Ich installiere also gerade auf einem WIrtssystem ein neues gentoo für den Rechner. Mit dem stage3-Ball von letzter Woche habe ich schon wieder ein großes B beim world bauen. Die emerge -av1-Taktik hat hier nicht funktioniert:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-arch/xz-utils-5.0.3  USE="nls threads -static-libs" 0 kB
[ebuild     U  ] sys-devel/gnuconfig-20110814 [20110202] 50 kB
[ebuild   R    ] app-arch/bzip2-1.0.6-r3  USE="-static -static-libs" 0 kB
[ebuild   R    ] sys-devel/patch-2.6.1  USE="-static -test" 0 kB
[ebuild   R    ] sys-apps/which-2.20  0 kB
[ebuild  N     ] sys-devel/autoconf-wrapper-12  0 kB
[ebuild  N     ] sys-devel/automake-wrapper-6  0 kB
[ebuild   R    ] virtual/os-headers-0  0 kB
[ebuild     U  ] sys-apps/net-tools-1.60_p20111120203157 [1.60_p20110409135728] USE="nls -old-output% -static" 222 kB
[ebuild   R    ] sys-process/procps-3.2.8_p11  USE="unicode" 0 kB
[ebuild   R    ] sys-apps/module-init-tools-3.16-r1  USE="-static" 0 kB
[ebuild  N     ] sys-devel/m4-1.4.16  USE="-examples" 982 kB
[ebuild   R    ] virtual/libc-0  0 kB
[ebuild     U  ] net-misc/rsync-3.0.9 [3.0.8] USE="acl iconv ipv6 -static -xattr" 775 kB
[ebuild   R    ] net-misc/iputils-20101006-r2  USE="ipv6 ssl -SECURITY_HAZARD -doc -idn -static" 0 kB
[ebuild     U  ] sys-apps/baselayout-2.1 [2.0.3] USE="-build" 40 kB
[ebuild  N     ] dev-util/gtk-doc-am-1.18  0 kB
[ebuild     U  ] sys-apps/texinfo-4.13-r1 [4.13] USE="nls -static" 0 kB
[ebuild     U  ] sys-apps/sed-4.2.1-r1 [4.2.1] USE="acl nls (-selinux) -static" 0 kB
[ebuild     U  ] sys-apps/util-linux-2.20.1-r1 [2.19.1-r1] USE="cramfs crypt ncurses nls unicode -ddate% -loop-aes -old-linux -perl (-selinux) -slang -static-libs% (-uclibc)" 4,507 kB
[ebuild     U  ] sys-apps/coreutils-8.15 [8.7] USE="acl nls unicode -caps -gmp (-selinux) -static -vanilla -xattr" 4,832 kB
[ebuild     U  ] sys-devel/make-3.82-r3 [3.82-r1] USE="nls -static" 0 kB
[ebuild     U  ] sys-apps/findutils-4.5.10-r1 [4.4.2] USE="nls (-selinux) -static" 2,682 kB
[ebuild   R    ] virtual/dev-manager-0  0 kB
[ebuild   R    ] virtual/man-0  0 kB
[ebuild  N     ] app-i18n/man-pages-de-0.8  465 kB
[ebuild  N     ] sys-devel/autoconf-2.68  USE="-emacs" 0 kB
[ebuild  N     ] sys-devel/bison-2.5  USE="nls -static" 1,984 kB
[ebuild  N     ] virtual/yacc-0  0 kB
[ebuild     U  ] app-shells/bash-4.2_p20 [4.1_p9] USE="net nls -afs -bashlogger -examples -mem-scramble -plugins -vanilla" 6,888 kB
[ebuild  N     ] dev-perl/Locale-gettext-1.50.0  0 kB
[ebuild  N     ] sys-apps/help2man-1.40.5  USE="nls" 180 kB
[ebuild  N     ] sys-devel/automake-1.11.2-r1  1,172 kB
[ebuild  N     ] sys-devel/libtool-2.4.2  USE="-static-libs -test -vanilla" 849 kB
[ebuild   R    ] sys-process/psmisc-22.14  USE="X* ipv6 nls (-selinux)" 0 kB
[ebuild  N     ] sys-devel/flex-2.5.35_p10  USE="nls -static -test" 0 kB
[ebuild     U  ] sys-devel/binutils-2.22-r1 [2.21.1-r1] USE="nls zlib -multislot -multitarget -static-libs -test -vanilla" 19,524 kB
[ebuild     U  ] sys-apps/man-pages-3.35 [3.32] USE="nls" LINGUAS="de* -cs -da -fr -it -ja -nl -pl -ro -ru -zh_CN" 1,650 kB
[ebuild     U  ] sys-apps/grep-2.10 [2.5.4-r1] USE="nls pcre" 1,048 kB
[ebuild   R    ] sys-apps/kbd-1.15.3  USE="nls" 0 kB
[ebuild     U  ] sys-apps/gawk-4.0.0 [3.1.8] USE="nls readline%*" 2,016 kB
[ebuild     U  ] app-arch/tar-1.26 [1.23-r2] USE="nls -static" 2,285 kB
[ebuild   R    ] virtual/editor-0  0 kB
[ebuild   R    ] app-arch/gzip-1.4  USE="nls -pic -static" 0 kB
[ebuild   R    ] virtual/pager-0  0 kB
[ebuild     U  ] sys-apps/diffutils-3.2 [3.0] USE="nls -static" 1,977 kB
[ebuild     U  ] sys-devel/gcc-4.5.3-r2 [4.5.3-r1] USE="cxx fortran gtk* mudflap nls nptl openmp (-altivec) -bootstrap -build -doc (-fixed-point) -gcj -graphite (-hardened) (-libffi) (-libssp) -lto (-multilib) -multislot -nocxx -nopie -nossp -objc -objc++ -objc-gc -test -vanilla" 15 kB
[ebuild   R    ] sys-kernel/gentoo-sources-3.2.1  USE="-build -deblob -symlink" 0 kB
[ebuild     U  ] sys-apps/file-5.10 [5.09] USE="zlib -python -static-libs" 595 kB
[ebuild  N     ] dev-libs/libgamin-0.1.10-r2  USE="-debug -python -static-libs" 442 kB
[ebuild   R    ] sys-apps/shadow-4.1.4.3  USE="cracklib nls pam -audit (-selinux) -skey" 0 kB
[ebuild  N     ] app-admin/gamin-0.1.10  0 kB
[ebuild  N     ] virtual/fam-0  0 kB
[ebuild  N     ] dev-libs/glib-2.30.2-r1  USE="fam static-libs -debug -doc (-selinux) -systemtap -test -utils -xattr" 0 kB
[ebuild  N     ] dev-util/pkgconfig-0.26  USE="-hardened" 0 kB
[ebuild  N     ] app-admin/gam-server-0.1.10  USE="-debug" 0 kB
[ebuild     U  ] sys-libs/e2fsprogs-libs-1.42 [1.41.14] USE="nls -static-libs%" 501 kB
[ebuild   R    ] sys-apps/busybox-1.19.3-r1  USE="ipv6 pam -make-symlinks -mdev -savedconfig (-selinux) -static" 0 kB
[ebuild   R    ] virtual/package-manager-0  0 kB
[ebuild   R    ] virtual/ssh-0  USE="-minimal" 0 kB
[ebuild     U  ] net-misc/wget-1.13.4-r1 [1.12-r3] USE="ipv6 nls ssl -debug -gnutls% -idn -ntlm -static" 1,420 kB
[ebuild     U  ] sys-fs/e2fsprogs-1.42 [1.41.14] USE="nls -static-libs%" 5,577 kB
[blocks B      ] <sys-apps/sysvinit-2.88-r3 ("<sys-apps/sysvinit-2.88-r3" is blocking sys-apps/util-linux-2.20.1-r1)

Total: 62 packages (22 upgrades, 19 new, 21 reinstalls), Size of downloads: 62,664 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/sysvinit-2.88-r2::gentoo, installed) pulled in by
    >=sys-apps/sysvinit-2.86-r6 required by (virtual/init-0::gentoo, installed)

  (sys-apps/util-linux-2.20.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/util-linux required by @system
    sys-apps/util-linux[ncurses] required by (virtual/pager-0::gentoo, ebuild scheduled for merge)
    >=sys-apps/util-linux-2.16 required by (sys-fs/udev-164-r2::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/e2fsprogs-1.42::gentoo, ebuild scheduled for merge)


emerge --info (vom Wirtssystem)

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
Portage 2.1.10.44 (default/linux/x86/10.0/desktop/gnome, gcc-4.5.3, glibc-2.13-r4, 2.6.39-gentoo-r3 i686)
=================================================================
System uname: Linux-2.6.39-gentoo-r3-i686-AMD_Athlon-tm-_II_X4_630_Processor-with-gentoo-2.0.3
Timestamp of tree: Mon, 23 Jan 2012 18:15:01 +0000
app-shells/bash:          4.1_p9
dev-lang/python:          2.7.2-r3, 3.1.4-r3
sys-apps/baselayout:      2.0.3
sys-apps/openrc:          0.9.4
sys-apps/sandbox:         2.5
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r1
sys-devel/gcc-config:     1.4.1-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 2.6.39 (virtual/os-headers)
sys-libs/glibc:           2.13-r4
Repositories: gentoo
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -pipe fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.netcologne.de/gentoo/"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j10"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync5.de.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdda cdr cli colord consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam firefox flac fortran gdbm gdu gif gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk iconv ipv6 jpeg lcms ldap libnotify mad mng modules mp3 mp4 mpeg mudflap nautilus ncurses nls nptl nptlonly ogg opengl openmp pam pango pcre pdf png policykit ppds pppd pulseaudio qt3support qt4 readline sdl session socialweb spell ssl startup-notification svg sysfs tcpd tiff truetype udev unicode usb vorbis x264 x86 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="mga" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Wo hängt's hier?

Rüdiger

15

23.01.2012, 22:45

Portage möchte die testing Version von util-linux (2.20.1-r1) installieren, welche aber einen Blocker für die stable Version von sysvinit enthält.
Du musst entweder sysvinit in die package.keywords aufnehmen und vorher upgraden oder util-linux daraus entfernen.
Es wundert mich nur, dass Portage nicht sagt, "following keyword changes are necessary to proceed". Vermutlich, weil sysvinit schon installiert ist.

16

23.01.2012, 23:10

ich habe ja noch keine package.keywords

Vorher upgraden geht ja gerade nicht, der Block wirkt sich auch dann aus.

Rüdiger

17

23.01.2012, 23:16

Ach so, sorry. Ich habe nicht kapiert, dass dein ganzes System testing ist.
Was sagt portage, wenn du sysvinit einzeln updaten möchtest?

18

23.01.2012, 23:47

das hier:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
EG-Server linux # emerge -av sysvinit
sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-apps/sysvinit-2.88-r3 [2.88-r2] USE="(-ibm) (-selinux) -static" 0 kB
[blocks B      ] <sys-apps/util-linux-2.20 ("<sys-apps/util-linux-2.20" is blocking sys-apps/sysvinit-2.88-r3)

Total: 1 package (1 upgrade), Size of downloads: 0 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-apps/util-linux-2.19.1-r1::gentoo, installed) pulled in by
    sys-apps/util-linux required by @system
    >=sys-apps/util-linux-2.16 required by (sys-fs/e2fsprogs-1.41.14::gentoo, installed)
    sys-apps/util-linux[ncurses] required by (virtual/pager-0::gentoo, installed)
    >=sys-apps/util-linux-2.16 required by (sys-fs/udev-164-r2::gentoo, installed)

  (sys-apps/sysvinit-2.88-r3::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-apps/sysvinit-2.86-r6 required by (virtual/init-0::gentoo, installed)
    sysvinit


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

19

23.01.2012, 23:57

Ha, die beiden blockieren sich gegenseitig. Dann wirst du wohl oder übel eines davon deinstallieren müssen, damit sich der Konflikt auflöst.
Util-linux würde ich nicht deinstallieren, weil das ziemlich sicher das System zerstören würde.
Von sysvinit habe ich keine Ahnung, aber es klingt, als ob es nur beim booten gebraucht würde.
Versuch mal emerge -C sysvinit und danach emerge -av1 util-linux und emerge -av1 sysvinit.

20

24.01.2012, 00:05

Hm, jetzt habe ich noch ein Problem.
Das Wirtssystem ist ein neuer AMD, der Rechner, für den ich baue, ist ein Pentium4. Den habe ich auch in der make.conf angegeben. Wenn ich jetzt uitl-linux baue, chrasht aber der compiler, ich vermute jetzt, weil der pentium4-Code auf dem AMD-Rechner laufen muss.

Rüdiger


hier:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
>>> Emerging (1 of 1) sys-apps/util-linux-2.20.1-r1
[sys-apps/util-linux-2.20.1-r1] bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
>>> Downloading 'http://mirror.netcologne.de/gentoo/distfiles/util-linux-2.20.1.tar.bz2'
sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
--2012-01-24 00:00:49--  http://mirror.netcologne.de/gentoo/distfiles/util-linux-2.20.1.tar.bz2
Resolving mirror.netcologne.de... 194.8.197.22, 2001:4dd0:1234:1::deb
Connecting to mirror.netcologne.de|194.8.197.22|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4614302 (4.4M) [application/x-bzip2]
Saving to: `/usr/wirt/usr/portage/distfiles/util-linux-2.20.1.tar.bz2'

100%[======================================>] 4,614,302    320K/s   in 17s

2012-01-24 00:01:15 (265 KB/s) - `/usr/wirt/usr/portage/distfiles/util-linux-2.20.1.tar.bz2' saved [4614302/4614302]

 * util-linux-2.20.1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                                     [ ok ]
[sys-apps/util-linux-2.20.1-r1] bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/var/tmp/portage/sys-apps/util-linux-2.20.1-r1/temp/environment: line 69: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
>>> Unpacking source...
>>> Unpacking util-linux-2.20.1.tar.bz2 to /var/tmp/portage/sys-apps/util-linux-2.20.1-r1/work
>>> Source unpacked in /var/tmp/portage/sys-apps/util-linux-2.20.1-r1/work
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/var/tmp/portage/sys-apps/util-linux-2.20.1-r1/temp/environment: line 69: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
>>> Preparing source in /var/tmp/portage/sys-apps/util-linux-2.20.1-r1/work/util-linux-2.20.1 ...
 * Running elibtoolize in: util-linux-2.20.1/config/
 *   Applying portage/1.2.0 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.2.6 patch ...
>>> Source prepared.
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/var/tmp/portage/sys-apps/util-linux-2.20.1-r1/temp/environment: line 70: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
>>> Configuring source in /var/tmp/portage/sys-apps/util-linux-2.20.1-r1/work/util-linux-2.20.1 ...
 * econf: updating util-linux-2.20.1/config/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating util-linux-2.20.1/config/config.guess with /usr/share/gnuconfig/config.guess
./configure --prefix=/usr --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-fs-paths-extra=/usr/sbin --enable-nls --enable-agetty --enable-cramfs --disable-ddate --disable-elvtune --with-ncurses=auto --disable-kill --disable-last --disable-mesg --enable-partx --enable-raw --enable-rename --disable-reset --disable-login-utils --enable-schedutils --disable-wall --enable-write --without-pam --without-selinux --without-slang --disable-static
/bin/sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
configure: Default --exec-prefix detected.
configure:   --bindir defaults to /bin
configure:   --sbindir defaults to /sbin
configure:   --libdir defaults to /lib
checking for style of include used by make... GNU
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking whether the C compiler works... no
configure: error: in `/var/tmp/portage/sys-apps/util-linux-2.20.1-r1/work/util-linux-2.20.1':
configure: error: C compiler cannot create executables
See `config.log' for more details

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-apps/util-linux-2.20.1-r1/work/util-linux-2.20.1/config.log
 * ERROR: sys-apps/util-linux-2.20.1-r1 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   85:  Called src_configure
 *        environment, line 2781:  Called econf '--enable-fs-paths-extra=/usr/sbin' '--enable-nls' '--enable-agetty' '--enable-cramfs' '--disable-ddate' '--disable-elvtune' '--with-ncurses=auto' '--disable-kill' '--disable-last' '--disable-mesg' '--enable-partx' '--enable-raw' '--enable-rename' '--disable-reset' '--disable-login-utils' '--enable-schedutils' '--disable-wall' '--enable-write' '--without-pam' '--without-selinux' '--without-slang' '--disable-static'
 *   phase-helpers.sh, line  467:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =sys-apps/util-linux-2.20.1-r1',
 * the complete build log and the output of 'emerge -pqv =sys-apps/util-linux-2.20.1-r1'.
 * The complete build log is located at '/var/tmp/portage/sys-apps/util-linux-2.20.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/util-linux-2.20.1-r1/temp/environment'.
 * S: '/var/tmp/portage/sys-apps/util-linux-2.20.1-r1/work/util-linux-2.20.1'
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/var/tmp/portage/sys-apps/util-linux-2.20.1-r1/temp/environment: line 70: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)
sh: warning: setlocale: LC_ALL: cannot change locale (de_DE.UTF-8)

>>> Failed to emerge sys-apps/util-linux-2.20.1-r1, Log file:

>>>  '/var/tmp/portage/sys-apps/util-linux-2.20.1-r1/temp/build.log'

 * Messages for package sys-apps/util-linux-2.20.1-r1:

 * ERROR: sys-apps/util-linux-2.20.1-r1 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   85:  Called src_configure
 *        environment, line 2781:  Called econf '--enable-fs-paths-extra=/usr/sbin' '--enable-nls' '--enable-agetty' '--enable-cramfs' '--disable-ddate' '--disable-elvtune' '--with-ncurses=auto' '--disable-kill' '--disable-last' '--disable-mesg' '--enable-partx' '--enable-raw' '--enable-rename' '--disable-reset' '--disable-login-utils' '--enable-schedutils' '--disable-wall' '--enable-write' '--without-pam' '--without-selinux' '--without-slang' '--disable-static'
 *   phase-helpers.sh, line  467:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of 'emerge --info =sys-apps/util-linux-2.20.1-r1',
 * the complete build log and the output of 'emerge -pqv =sys-apps/util-linux-2.20.1-r1'.
 * The complete build log is located at '/var/tmp/portage/sys-apps/util-linux-2.20.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/util-linux-2.20.1-r1/temp/environment'.
 * S: '/var/tmp/portage/sys-apps/util-linux-2.20.1-r1/work/util-linux-2.20.1'

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Hier dann die config.log:
http://pastebin.de/22666

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Regidür« (24.01.2012, 00:28)