Sie sind nicht angemeldet.

1

09.04.2012, 15:42

Problem gnome-cups-manager

revdep-rebuild will ein Paket, das es nicht gibt. Wie kommt das zustande und wie geht das weg?

Quellcode

1
2
3
4
5
 * Portage could not find any version of the following packages it could build:
 * net-print/gnome-cups-manager:0
 * (Perhaps they are masked, blocked, or removed from portage.)
 * Try to emerge them manually.
 * Warning: Portage cannot rebuild any of the necessary packages.


Quellcode

1
2
3
# emerge gnome-cups-manager

emerge: there are no ebuilds to satisfy "gnome-cups-manager".



Rüdiger

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Regidür« (09.04.2012, 19:43)


2

09.04.2012, 17:49

Das Paket ist schlicht in Portage nicht mehr verfügbar. Deinstalliere es (oder such Dir ein Overlay ;-) ) und versuche danach revdep-rebuild erneut.
Sys:
AMD FX (tm)-6300 Six-Core Processor
GeForce GTX 650 1024MB
16384 MB DDR3 1600Mhz
ASUS M5A97 R2.0
Samsung SSD 830 (sys)

OS: Gentoo ~amd64
WM: i3
Kernel: vanilla-sources
VGA: nouveau
INIT: OpenRC :)

██ ██ █ ████ everything ███ █████ is █████ ████ ████ fine ████ ███ █ ██████ trust █████ ██████ ███ your █████ ████ government. Parts of this comment have been found in violation of H.R. 3261, S.O.P.A and Senate Bill 968, P.I.P.A. and have been censored for your benefit.

3

09.04.2012, 18:37

Das habe ich bereits getan, aber revdep will das immer noch haben...

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
All selected packages: net-print/gnome-cups-manager-0.33-r2

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in:  5 4 3 2 1
>>> Unmerging net-print/gnome-cups-manager-0.33-r2...
 * Updating desktop mime database ...
 * Updating shared mime info database ...
 * Updating icons cache ...                                              [ ok ]

 * GNU info directory index is up-to-date.

 * IMPORTANT: 147 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

 * IMPORTANT: 11 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

gurumusch ~ # revdep-rebuild
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Found existing 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Found existing 2_ldpath.rr.
 * Checking dynamic linking consistency
 * Found existing 3_broken.rr.
 * Assigning files to packages
 * Found existing 4_raw.rr
 * Cleaning list of packages to rebuild
 * Found existing 4_pkgs.rr
 * Assigning packages to ebuilds
 * Found existing 4_ebuilds.rr
 * Evaluating package order
 * Portage could not find any version of the following packages it could build:
 * net-print/gnome-cups-manager:0
 * (Perhaps they are masked, blocked, or removed from portage.)
 * Try to emerge them manually.
 * Warning: Portage cannot rebuild any of the necessary packages.

4

09.04.2012, 18:59

Zitat von »Regidür«

Das habe ich bereits getan, aber revdep will das immer noch haben...

Ja, sofern dein revdep-rebuild abgebrochen wurde liegen die Informationen immer noch im Cache - so wird nicht neu geprüft sondern versucht die vorherig ermittelten Pakete neu zu bauen (was verständlicher weise wieder fehlschlägt)
Nutze, nun nach der deinstallation von gnome-cups-manager, am besten

Quellcode

1
revdep-rebuild -i

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »josef.95« (09.04.2012, 19:04)