Sie sind nicht angemeldet.

[gelöst] udev update Frage

1

10.12.2012, 16:12

udev update Frage

Hi,
habe gerade mit nem world update udev neu gebaut bekommen.

Jetzt sehe ich folgende Meldung:

Quellcode

1
2
3
4
5
 * Messages for package sys-fs/udev-init-scripts-18:

 * The udev-postmount service has been removed because the reasons for
 * its existance have been removed upstream.
 * Please remove it from your runlevels.



Was genau muß ich jetzt tun, damit mein System beim nächsten Booten weiter tut?

Rüdiger

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Regidür« (21.12.2012, 15:45)


2

11.12.2012, 07:15

Guck mal, in welchem runlevel du das laufen hast:

Quellcode

1
# rc-update show -v

und dann dreh es dort mal ab

Quellcode

1
# rc-update del udev-postmount LEVEL
mit LEVEL ersetzt durch den Namen des runlevels

Reboot ... alles gut?
http://www.dyle.org
IM-Account (Jabber!) sind auf meiner HP ...
There is no place like /home

http://www.gentooforum.de
http://www.gentoofreunde.org

<div>how to annoy a web developer?</span>

3

14.12.2012, 16:46

Hi,
folgendes wird angezeigt,

Quellcode

1
2
3
4
          udev |                       sysinit
           udev-mount |                       sysinit
       udev-mount.old |                              
             udev_old | 



Naja, ich würde gerne *vor* dem rebooten wissen, ob mein System dann noch läuft .... ;)

Rüdiger

4

14.12.2012, 22:26

Wird es... Du musst da gar nicht machen, es ist schon alles geschehen.

5

15.12.2012, 00:14

Das verstehe ich nicht -- ich habe nach dem emerge noch nicht rebooted und auch kein udev-skript aus irgendeinem runlevel gelöscht.

Rüdiger

6

15.12.2012, 07:16

Das ist schon alles erledigt. Hat das System für dich gemacht.

7

15.12.2012, 12:28

OK -- und warum kommt dann die Meldung, ich müsse das noch tun?

Rüdiger

8

15.12.2012, 15:20

Hm, da es das /etc/init.d/udev-postmount Initscript in der aktuellen testing udev-Version nicht mehr gibt wird es mit "rc-update show -v" eventuell auch nicht mehr mit aufgelistet. Der udev-postmount Dienst kann aber dennoch im Runlevel registriert sein, auch wenn es ihn gar nicht mehr gibt.

udev-postmount ist normal im default Runlevel gesetzt - schau dort doch mal direkt rein:

Quellcode

1
ls -l /etc/runlevels/default/
Wenn er dort noch gesetzt ist, dann wird es wahrscheinlich nur noch ein toter Symlink sein (solche werden idR rot blinkend dargestellt).
Wenn dem so ist, dann entferne den Dienst wie vorgeschlagen mit einem beherzten

Quellcode

1
# rc-update del udev-postmount default

9

20.12.2012, 13:14

Hm, ist hier wirklich keine Lösung in Sicht? Woran scheitert das ganze denn aktuell noch?

10

21.12.2012, 15:46

Hi,
geht alles! Es war, wie ihr sagtet, die Meldung war Quatsch, alles wurde bereits von den skripts richtig eingerichtet!

Rüidger

11

22.12.2012, 12:03

ich habe zwar das "sys-fs/udev-init-scripts" nicht installiert, aber das udev-postmount auch noch im default level.
muss ich das auch deaktivieren oder ist das nur nötig bei dem script?
Ullrich Andreas
Meine Konfiguration:
x86_64/Gentoo-10.1/gcc Version 4.5.3/KDE-Version 4.9.3/Kernel version 2.6.34-gentoo-r6
Graphic: 2x Nvidia 9600-GT OC SLI,Drucker: Samsung CLP-315W

12

22.12.2012, 12:41

ich habe zwar das "sys-fs/udev-init-scripts" nicht installiert, aber das udev-postmount auch noch im default level.
muss ich das auch deaktivieren oder ist das nur nötig bei dem script?

udev-postmount sollte nur aus dem Runlevel entfernt werden wenn die neueren udev-195 Versionen genutzt werden, welche aktuell noch im Testing-Zweig sind.
Bei der normalen aktuellen stable udev-171-r9 Version sollte man udev-postmount im default Runlevel belassen.