Sie sind nicht angemeldet.

1

24.04.2013, 21:33

DVBSKy S952 funktioniert nicht

Hallo Leute,

hab mir diese Karte extra von China bestellt weil sie sonst niergens lieferbar ist. Leider krieg ich das Teil nicht zum Laufen. Überall in den Foren geht das Ding super, nur bei mir nicht. Also was hab ich gemacht:
Mein Kernel: 3.7.10-gentoo-r1 x86_64
Ich habe die Treiber von http://www.dvbsky.net/Support.html installiert.

- Zuerst habe ich den Kernelpatch angewendet. Der laut Seite nur für 3.7.2~3.7.5 gültig ist. Hat sich aber ohne Probleme und Fehlermeldungen installieren lassen.
- Dann habe ich das Firmewarefile dvb-fe-ds300x.fw nach /lib/firmware kopiert.
- Nach nem Reboot ist noch nix gegangen und unter /dev hatte ich nur ein video0 drinnen (meine Webcam)
- Also auch noch media_build_bst_130126 für Kernel 3.7.x heruntergeladen und installiert
- Nach nem Reboot ging die Karte noch immer nicht, und auch meine Webcam war futsch
- Danach habe ich versucht die Treiber manuell zu laden: "modprobe: ERROR: could not insert 'cx8800': Exec format error" Anscheinend ist mein Kernel zu neu.

Ich wollte es dann mit 3.8.5 versuchen, aber das wäre vergebens das der Download aus irgend einem Grund nicht mehr verfügbar ist. Huch... was kann ich also machen? Ist sowiso strange das ich das linuxtv Zeugs selbst kompilieren muss, gibt es das nicht auch in Portage? Ich kenn mich jetzt leider nicht mehr aus. Vielleich kann mir ja wer helfen.
Für diesen Artikel habe ich hier eine Verlinkung angelegt.

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »boospy« (27.04.2013, 22:01)


2

26.04.2013, 10:34

Wieso musste es diese Karte sein? Hättest Dir eine TBS holen sollen. Die Treiber funktionren ohne Probleme. Was istbei der Karte so besonders?
Alienware 17 R3 16 GB RAM
NVIDIA GTX970 Optimus
Intel Corporation Wireless 8260 AC
Blu-ray Disc ROM & DVD+/-RW
Ubuntu Gnome Desktop
+
Samsung Aktivbook 8, 16 GB DDR3-1666, 2000 GIG SATA
ATI Radeon HD 8870M
Intel Corporation Centrino Advanced-N 6235
Blu-ray Disc ROM & DVD+/-RW
Xbuntu mit debootstrap
+
Intel Core 2 Duo
2 GB MB RAM
ca. 3,5 TB SATA
TBS6980 Dual DVB S2
YaVDR amd64 + VDR1.7.x + XBMC + VDPAU


Mein Overlay:

Quellcode

1
layman -a amielke-overlay

3

27.04.2013, 22:00

Problem gelöst:
http://www.vdr-portal.de/board18-vdr-har…en/#post1141679

Problem gelöst. Anscheinend muss das entsprechende Modul fix im Kernel ein kompiliert werden. Ist ein wenig buggy. Denn wenn man im "menuconfig" Mode nach dem Ort des Eintrages sucht, sieht man die Location. Aber wenn man dann dort hingeht ist nix da. Man kann also nur die ".config" manuell editieren und beim Eintrag statt nem "m" ein "y" machen. Dann Kernel kompilieren, neustarten und freuen. Funzt dann sofort.
Das Mediabuild, wie ich es auch anstelle funktioniert nicht. Warum ist mir nicht klar.

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at