Sie sind nicht angemeldet.

1

04.06.2013, 17:49

Adobe flash im Fullscreen

Halli Hallo.
Ich habe seit mehreren Wochen das Problem, das sich nicht alle Flashvideos im Fullscreen anzeigen lassen. Aber wie gesagt habe ich das Problem nicht überall. Auf YouTube direkt und hdhomerj ist es kein Problem. Eingebette Videos auf anderen Seiten bleiben dann einfach stehen, wenn ich das Fullscreen-symbol betätige.

Nun habe ich natürlich auch schon selbst recherchiert und habe rausgefunden das man unter /etc/adobe/mms.cfg OverrideGPUValidation auf 1 oder enable setzen soll. Leider hat das bei mir nichts gebracht.


cat /etc/adobe/mms.cfg
#
# /etc/adobe/mms.cfg: Adobe Flash privacy and security settings
#
# For more details on the meaning of most of these options, please visit:
# http://www.adobe.com/devnet/flashplayer/…dmin_guide.html
#

# Lets you prevent users from designating any files on the local file system as
# trusted
# 0 = Not Allowed, 1 = Allowed (default)
#AllowUserLocalTrust = 1

# Lets you specify a hard limit on the amount of local storage that Flash Player
# uses for the storage of common Flash components
# Size in megabytes (default is 20), 0 = Component storage disabled
#AssetCacheSize = 20

# Lets you prevent Flash Player from automatically checkingfor and installing
# updated versions
# 0 = Not Disabled (default), 1 = Disabled
AutoUpdateDisable = 1

# Lets you specify how often to check for an updated version of Flash Player
# Number of days, 0 = Every startup
# There is no default value, which falls back to the user's setting (30 days by
# default)
#AutoUpdateInterval =

# Lets you prevent SWF files from accessing webcams or microphones
# 0 = Not Disabled (default), 1 = Disabled
#AVHardwareDisable = 0

# Lets you prevent information on installed fonts from being displayed
# 0 = Not Disabled (default), 1 = Disabled
#DisableDeviceFontEnumeration = 0

# Lets you prevent networking or file system access if any kind
# Set to the executable filename, default is empty
#DisableNetworkAndFilesystemInHostApp =

# Lets you prevent native code applications that are digitally signed and
# delivered by Adobe from being downloaded
# 0 = Not Disabled (default), 1 = Disabled
#DisableProductDownload = 0

# Lets you enable or disable the use of the Socket.connect() and
# XMLSocket.connect() methods
# 0 = Not Disabled (default), 1 = Disabled
#DisableSockets = 0

# Lets you create a whitelist of servers to which socket connections are allowed
# Set to hostname or IP address. This can be specified multiple times in this
# file to allow more than one host, and only takes effect if DisableSockets
# (above) is set to 1.
#EnableSocketsTo = localhost.localdomain
#EnableSocketsTo = 127.0.0.1

# Lets you prevent the ActionScript FileReference API from performing file
# downloads
# 0 = Not Disabled (default), 1 = Disabled
#FileDownloadDisable = 0

# Lets you prevent the ActionScript FileReference API from prerforming file
# uploads
# 0 = Not Disabled (default), 1 = Disabled
#FileUploadDisable = 0

# Lets you disable SWF files playing via a browser plug-in from being displayed
# in full-screen mode
# 0 = Not Disabled (default), 1 = Disabled
#FullScreenDisable = 0

# Lets you specify whether SWF files produced for Flash Player 6 and earlier can
# execute an operation that has been restricted in a newer version of Flash
# Player
# 0 = Deny, 1 = Allow
# There is no default value, which falls back to the user's setting (Defaults to
# "Ask"
#LegacyDomainMatching =

# Lets you specify how Flash Player should determine whether to execute certain
# local SWF files that were originally produced for Flash Player 7 and earlier
# 0 = Deny, 1 = Allow
# There is no default value, which falls back to the user's setting
#LocalFileLegacyAction =

# Lets you prevent local SWF files from having read access to files on local
# drive
# 0 = Not Disabled (default), 1 = Disabled
#LocalFileReadDisable = 0

# Lets you specify a hard limit on the amout of local storage that Flash Player
# uses (per domain) for persistent shared objects
# 1 = no storage, 2 = 10KB, 3 = 100KB, 4 = 1MB, 5 = 10MB,
# 6 = User specified (default)
# If the user does not specify a limit, the default is 100KB.
#LocalStorageLimit = 6

# Lets you override GPU validation checks to force hardware acceleration
# Warning: This may make your player (more) unstable!
# 0 = Check GPU (default), 1 = Skip checks
# More details:
# http://blogs.adobe.com/penguin.swf/2008/…cfg_file_1.html
#OverrideGPUValidation = 0

# Lets you specify whether third-party SWF files can read and write locally
# persistent shared objects
# 0 = disabled, 1 = enabled
# There is no default value, which falls back to the user's setting
#ThirdPartyStorage =

# Lets you disable "Windowless" mode, which may cause crashes in firefox
# version 3.01 and earlier.
# 0 = Not Disabled (default), 1 = Disabled
# More details:
# http://blogs.adobe.com/penguin.swf/2008/…s_mode_fix.html
#WindowlessDisable = 0

Adobe flash neu zu installieren und den Ordner /etc/adobe zu löschen hat leider nichts gebracht. Revdep-rebuild findet beim flash-player auch keine Probleme. Wenn ihr irgendwelche logs braucht, sagt mir Bescheid welche. ;-) Vielleicht habt ihr ja noch einen guten Einfall.

Schöne Grüße
Christian

2

04.06.2013, 21:01

Habe auch so etwas in der Art. Ist aber extrem kompliziert. Ich nutze Firefox und Gnome. Da geht bei Youtube alles. Im Fenster und Fullscreen. Bei Dailymotion sind die Videos im Fenster ohne Farbe, Fullscreen geht aber meistens. Manchmal geht auch gar nichts. Eingebettete Videos funktionieren mal oder mal nicht. Wenn man da so einen Button "Auf Youtube ansehen" findet, dann geht es. Wenn ich jetzt Xfce4 nutze, dann geht auch bei Dailymotion alles ohne Probleme. Und unter Gnome funktioniert Dailymotion perfekt, wenn ich den Gnomebrowser nutze. Mit Chrome/Chromium läuft alles im Fenster ohne Probleme, Fullscreen ruckelt dafür schrecklich.

Ich mach das jetzt so: Normal nehme ich den Firefox. Wenn da eine Seite nicht will, dann kopiere ich den Link in den Gnomebrowser. Und Dailymotion mache ich nur noch damit. Es ist einfach abartig.

3

04.06.2013, 21:51

Achja ich hatte vergessen, bei mir DE und Browser anzugeben. Bei mir ist es ebenfalls Gnome + Chrome und ich habe auch nicht vor einen anderen Browser einzusetzen, nur um Flashvideos im Fullscreen sehen zu können. Und wenn das noch hilft hier die Systemspecs:

Gentoo ~amd64
genkernel
Intel I5 2500k
8GB Ram 1600 CL9
GTX 560 ti mit proprietärem Grafiktreiber
und das System ist eigentlich immer auf dem aktuellsten Stand

Und ja ich weiß, das Flash absolut immer eine Qual ist, ganz gleich welches OS man einsetzt, aber ich wäre für eine Hilfestellung sehr dankbar :-)

4

04.06.2013, 21:51

Wie sind bei www-plugins/adobe-flash die USE-gesetzt? Probiere mal mit und ohne sse2check. Ich gehe jetzt von einem 64-Bit System aus.
Evtl läuft es besser, wenn Du das Paket mit "USE=-64bit 32bit" kompilierst und dann die 32-Bit Version mit www-plugins/nspluginwrapper einbettest.
Eine weitere Sache die Ihr beiden testen könnt ist die Hardware-Beschleunigung ein- oder auszuschalten. (Rechte Maustaste auf ein laufendes Video -> Eigenschaften).
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

5

04.06.2013, 21:58

[ebuild R ] www-plugins/adobe-flash-11.2.202.285 USE="64bit (multilib) sse2check -32bit -kde (-selinux) -vdpau" 0 kB

Ich werde es mal mit vdpau kompilieren. Danach probiere ich es mal ohne sse2check. Schritt für Schritt. Danke für die Tips. Ich melde mich aber wahrscheinlich erst morgen wieder :-)

6

04.06.2013, 22:00

Chrome hat doch den Flashplayer mit dabei. Den bekommt man ja über die chrome-binary-plugins. Da braucht man doch kein separates Flash. Man muss ihn aber mit about:plugins aktivieren, wenn ich das noch so richtig im Kopf habe. Ist schon etwas her, nutze den aktuell nicht.

7

04.06.2013, 22:15

Ahhh sorry ich meinte den Chromium und nicht Chrome und ohne adobe-flash habe ich auch kein flash zum aktivieren unter about:plugins

8

04.06.2013, 22:24

Das ist klar, wenn du gar kein Flash drauf hast, dann kannst du auch keins aktivieren, grins.... Beim Chromium ist ja nichts eingebaut. Schmei? trotzdem mal das adobe-flash runter und probier mal die chrome-binary-plugins, vielleicht ändert sich damit was. Das ist ja die aktuelle Version des Flashplayers. Version 12 gibt es unter Linux nur mit chrome.

9

05.06.2013, 00:52

Nur ein blinder Schuss ins Blaue,
schau doch auch mal ob löschen des Cache eventuell hilft,
~/.adobe/Flash_Player/AssetCache/

10

05.06.2013, 08:37

Guten Morgen,


gerade durch Zufall (eix-diff macht's möglich) das folgende Paket gesehen:

Quellcode

1
2
3
4
5
6
* www-plugins/chrome-binary-plugins 
Available versions: (stable) (~)27.0.1453.110_p202711^msd 
(beta) (~)28.0.1500.29_beta202781^msd 
(unstable) [M](~)29.0.1521.3_alpha202710^msd [M]**9999^msd       {+flash +pdf} 
Homepage:            http://www.google.com/chrome 
Description:         Binary plugins -- native API Flash and PDF -- from Google Chrome for use in Chromium.



Vielleicht interessant?!



A.
Sys:
AMD FX (tm)-6300 Six-Core Processor
GeForce GTX 650 1024MB
16384 MB DDR3 1600Mhz
ASUS M5A97 R2.0
Samsung SSD 830 (sys)

OS: Gentoo ~amd64
WM: i3
Kernel: vanilla-sources
VGA: nouveau
INIT: OpenRC :)

██ ██ █ ████ everything ███ █████ is █████ ████ ████ fine ████ ███ █ ██████ trust █████ ██████ ███ your █████ ████ government. Parts of this comment have been found in violation of H.R. 3261, S.O.P.A and Senate Bill 968, P.I.P.A. and have been censored for your benefit.

Dieser Beitrag wurde bereits 6 mal editiert, zuletzt von »walkman« (05.06.2013, 08:48)


11

05.06.2013, 20:30

Ganz kurzer Zwischenstand: vdpau und sse2check haben das Problem genauso wenig gelöst wie den Cache vom Flashplayer zu löschen. Ich werde es nochmal mit den binary-plugins probieren :-) Danke für die Hilfestellungen.

12

10.06.2013, 15:59

Ich denke es liegt eindeutig am nvidia-treiber. Wenn du so einen Fall hast, gibt es dann in der Xorg.0.log oder dmesg einen Eintrag?

... und mal das gleiche mit nouveau statt nvidia probiert?
http://www.dyle.org
IM-Account (Jabber!) sind auf meiner HP ...
There is no place like /home

http://www.gentooforum.de
http://www.gentoofreunde.org

<div>how to annoy a web developer?</span>

13

10.06.2013, 19:39

Also ich hab den Radeon Treiber und den gleichen Mist. Ich muss inzwischen auch einiges zurücknehmen, was ich oben geschrieben habe. Ich kann einfach nur sagen: Mal geht es und mal nicht. Es ist einfach Flash.

14

10.06.2013, 21:59

Naja, was erwartest Du von Closed-Source. Hast Du schon die 32-Bit Version versucht? (USE="-64bit 32bit" + nspluginwrapper)
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

15

10.06.2013, 22:04

Oh mein Gott, nein, auf so eine perverse Idee bin ich noch nicht gekommen, aber das werde ich sofort ausprobieren.

Edit: Voll geil, so wie man Flash kennt. Dailymotion scheint damit zu funktionieren und dafür meldet Youtube jetzt, es bräuchte die 64bit Version. Also ich mache mir jetzt echt keine Gedanken mehr, warum und weshalb. Es ist Flash. So wie man es kennt.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Reinhard3« (10.06.2013, 22:15)


16

11.06.2013, 15:03

Vorige Tage gabs beim Chromium-update auf Version 28 kurzzeitige Probleme beim kompilieren, weshalb ich mal den Google-chrome ausprobiert habe. Tja flash funzt zickt seit dem nicht mehr rum. Scheinbar hat das flashplugin einfach nur einen an der Waffel :D

@dyle: Nouveau ist für mich leider keine Option, da ich auf dem Rechner auch gelegentlich zocke. In die Xorg.0.log und dmesg habe ich bisher währenddessen noch nicht reingeschaut. Ich hoffe ich denke beim nächsten Mal dran, obwohl Google-Chrome für mich schon eine sehr gute Problemlösung ist.

17

12.06.2013, 22:05

Heute gab es ja ein neues Flash. Version adobe-flash-11.2.202.291. Und bislang ging alles ohne Probleme. Aber wie gesagt, bislang ging es mal so und wenn du dachtest, so ist es, dann war es wieder anders. Aber wie gesagt, bis lang ging alles ohne Probleme.

P.S.: Wurde auf Wunsch geändert.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Reinhard3« (13.06.2013, 07:31)


18

12.06.2013, 23:02

Heute gab es ja ein neues Flash. [...]

Klaus nochmals, gewöhne dir doch bitte mal an die Version mit anzugeben - so ohne Versionsangabe wird in ein paar Tagen kaum noch jemand nachvollziehen können was gemeint war.
Danke