Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

15.07.2013, 11:45

Zwei Gentoo Installationen parallel

Hallo zusammen,

ich steh mal wieder auf dem Schlauch.

Ich habe einen Rechner mit Gentoo. Um nun ein System für Tests zur Verfügung zu haben wollte ich diese Installation kopieren. Es sollen im Ergebnis dann zwei unabhängige Gentoo-Installationen auf dem Rechner sein.

Ich habe also die Rootpartition kopiert, fstab angepasst (Partition für / geändert) und grub2-mkconfig darauf angesetzt. Das erkennt die neue Gentoo-Installation auch, aber dann ist Schluss ...
Zwar sehe ich einen weiteren Eintrag für Gentoo beim Start, aber auch wenn ich den wähle mountet er mir das alte Root-System.

Ich habe sicher irgendwas übersehen und muss mich vermutlich fürchterlich schämen, aber ich komme nicht drauf ...

Was kann ich tun? Danke schon mal,

42m

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »greye« (17.07.2013, 12:43)


2

16.07.2013, 07:38

Wie genau hast du denn grub2-mkconfig ausgeführt? Bist mit chroot rein in das kopierte System? Und wie genau hast du das System denn kopiert? Sollte man immer von einem Rettungsmedium aus machen, also nicht das laufende System selber. Und dann schau doch mal in die grub.cfg, wie die aussieht. Wenn da etwas falsch ist, passe es doch per Hand an.

3

16.07.2013, 13:03

Wie genau hast du denn grub2-mkconfig ausgeführt? Bist mit chroot rein in das kopierte System? Und wie genau hast du das System denn kopiert? Sollte man immer von einem Rettungsmedium aus machen, also nicht das laufende System selber. Und dann schau doch mal in die grub.cfg, wie die aussieht. Wenn da etwas falsch ist, passe es doch per Hand an.
Kopiert habe ich von einem Livesystem von CD aus. Aus dem alten Gentoo heraus habe ich dann die neue Rootpartition gemountet und die fstab angepasst. Von dort aus habe ich auch grub2-mkconfig ausgeführt.
Wenn ich mir die grub.cfg anschaue sehe ich, daß die root UUID für die neue Partition passt, auch die Beschreibung des Eintrags sagt, daß er die richtige Partition meint:

Quellcode

1
menuentry 'Gentoo Base System release 2.2 (on /dev/sdb6)'

Das alte root liegt auf sda5.

Er scheint also soweit alles erkannt zu haben, mountet aber trotzdem das falsche /

Ich steh immer noch auf dem Schlauch ...

42m

4

16.07.2013, 15:10

Wie merkst du denn, dass er in das alte Gentoo bootet?

5

16.07.2013, 15:51

Wie merkst du denn, dass er in das alte Gentoo bootet?

Ich merke nicht, daß er das alte bootet, aber ich merke, daß er statt sdb6 (neu) eben sda5 (alt) als / einbindet.

42m

6

16.07.2013, 23:00

Nimm mal den Devicenamen zum Mounten nicht die UUID und vielleicht legst im neuen System auch ne Datei auf root an damit du dir ganz sicher bist.

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

7

17.07.2013, 07:24

Hast du auch die /etc/mtab überprüft?

Denn die muß ja auch stimmen - wenn ich das richtig in Erinnerung habe.

Möglicherweise mußt du in der chroot-Umgebung eben den kernel und grub neu emergen.
Dann müßt zumindest grub.cfg stimmen. Vor allem die UUID kann ja so nicht mehr stimmen.

Aber wie gesagt, meines Erachtens dürfen fstab und mtab nicht unterschiedlich sein.

Gruss
Manfred

P.S. Ich erinnere mich noch an meine letzte Installation: bevor ich grub-install ausführen konnte,
mußte ich die mtab erstellen - so die Anleitung.

8

17.07.2013, 12:42

Nach der mtab habe ich nicht geschaut, aber ich habe das "Problem" inzwischen gelöst :)

Die gemeinsame /boot Partition war wohl ausschlaggebend.
Nachdem ich den Inhalt der Bootpartition ins /boot der Kopie kopiert habe (wie klingt das denn, zur Kopie kopiert ... pffffft), geht es.
grub2-mkconfig findet nicht nur beide Gentoos sondern es wird auch das richtige / gemountet.

Es geht, obwohl ich es ehrlich gesagt nicht so richtig verstehe ...

Dafür habe ich jetzt ein anderes Problem, aber dafür mache ich einen neuen Thread auf.

42m

9

17.07.2013, 20:05

grub2-mkconfig sucht nicht nach Partitionen sondern nach Kerneln. Und wenn du da nur eine hast, dann hattest du wohl auch nur einen Eintrag im Grubmenü. Ich bin halt immer davon ausgegangen, dass du 2 Einträge hast, bei beiden aber immer das gleiche Gentoo gestartet wird.

Und für eine Boot-Partition gibt es eigentlich keinen Grund mehr. Mit grub2 kannst du inzwischen von so gut wie jedem FS booten. Mit Grub2 macht es eigentlich nur Probleme.