Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

28.07.2013, 17:50

Nvidia Driver läst sich nicht installieren (neuinstallation)

Hab mein Gentoo mal von Grund auf neu installiert (neue HDD, Grafikkarte, usw.)

Nun hab ich ein komischen Fehler den ich so noch nie gesehen hab bei Nvidia Driver Installation ...

Quellcode

1
2
3
4
5
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (		\
echo >&2;							\
echo >&2 "  ERROR: Kernel configuration is invalid.";		\
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";	\


hab es auch ausgeführt .... make oldconfig && make prepare leider ohne Erfolg

kernel Version wäre 3.8.13 oder 3.10.3 Version (bei beiden das gleiche Problem)
nvidia-driver wäre 319.32 oder 325.08 (bei beiden das gleiche Problem)

hat einer eine Ahnung was das bedeutet ? den autoconf.h und auto.conf ist vorhanden bei beiden Kernel Versionen ...
mit eselect kernel wurde auch geachtet das immer der richtige kernel läuft, auch bis zum Nvidia problem wurde auch alles ohne fehler installiert und ausgeführt....


lg
schatti
»Schattenschlag« hat folgende Datei angehängt:
  • build.txt (37,91 kB - 1 mal heruntergeladen - zuletzt: 28.07.2013, 18:09)
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Schattenschlag« (30.07.2013, 20:34)


2

28.07.2013, 18:19

Zitat

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
 * Package:    x11-drivers/nvidia-drivers-319.32
 * Repository: gentoo
 * Maintainer: xxxxxxxxxxxxxxxxxxxxxxxxxx
 * USE:        X acpi amd64 elibc_glibc kernel_linux multilib tools userland_GNU
 * FEATURES:   preserve-libs sandbox
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.10.3-gentoo-r1/build
 * Found sources for kernel version:
 *     3.10.3-gentoo-r1

Es gibt von nVidia bisher noch keine offizielle Treiberversion die mit linux-3.10 kompatibel ist.
Wenn du auf den nVidia blob Treiber angewiesen bist nutz zZt am besten <linux-3.10

3

29.07.2013, 21:48

Es gab - entweder hier oder 'drüben' bei gentoo.org - eine patch-Anleitung für nvidia-drivers 325.08 die bei mir bis 3.10.1 funktioniert, für höher nicht mehr.

Rüdiger

EDIT: Imho sollte der 3.8er Kernel aber entweder mit 319... oder mit 325... funktionieren!

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Regidür« (29.07.2013, 21:57)


4

30.07.2013, 09:39

Hallo

Also ich bekomme es nicht hin egal ob ich jetzt den 3.8.13 oder den 3.10.3 Kernel verwende das gleiche gilt von den nvidia versionen ... es läuft einfach nicht ...

wenn ich jetzt 3.8.13 Kernel verwende mit 319 Nvidia Driver .. kommt das hier


Quellcode

1
(EE) Failed to load module "nvidia" (module-specific error, 0)


obwohl das weiter oben steht

Quellcode

1
2
3
[   133.999] Loading extension GLX
[   133.999] (II) LoadModule: "nvidia"
[   133.999] (II) Loading 


kann denn nicht mal was einfach so klappen ? ....
»Schattenschlag« hat folgende Datei angehängt:
  • Xorg.0.txt (6,54 kB - 1 mal heruntergeladen - zuletzt: 30.07.2013, 09:53)
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

5

30.07.2013, 09:46

Bei mir lief 3.9.4 eine Weile, den 3.8.er habe ich glaube ich übersprungen...

Rüdiger

6

30.07.2013, 10:16

Zitat von »Schattenschlag«

wenn ich jetzt 3.8.13 Kernel verwende mit 319 Nvidia Driver .. kommt das hier [....]

Hehe,
dein Xorg log sagt

Quellcode

1
2
3
4
5
6
7
8
[   133.981] Current Operating System: Linux bone 3.10.3-gentoo-r1
....
[   134.002] (EE) NVIDIA: Failed to load the NVIDIA kernel module. Please check your
[   134.002] (EE) NVIDIA:     system's kernel log for additional error messages.
[   134.002] (II) UnloadModule: "nvidia"
[   134.002] (II) Unloading nvidia
[   134.002] (EE) Failed to load module "nvidia" (module-specific error, 0)
[   134.002] (EE) No drivers available.

Sprich, du baust nvidia-drivers für den 3.8.13er Kernel, lädst dann aber den 3.10.3-gentoo-r1 Kernel (für den das Modul nicht gebaut wurde, und auch nicht verfügbar ist - das kann nicht funktionieren.

Du musst den Kernel booten, aus dessen Sources auch das nvidia Modul gebaut wurde.
Schaue zb mit

Quellcode

1
equery files nvidia-drivers | grep nvidia.ko
für welche Kernelversion dein aktuell installiertes nvidia Modul gebaut wurde.
Und schaue mit

Quellcode

1
uname -r
Wechen Kernel du aktuell nutzt.

Zitat

kann denn nicht mal was einfach so klappen ? ....
Naja, das sind selbstgebaute Fehler... :P

7

30.07.2013, 20:34

Naja, das sind selbstgebaute Fehler... :P

tja ich weiß es ja das es selbst gebaute Fehler sind ... darum ärgere ich mich ja noch mehr ... wenn ich von meinen bekannten die Rechner richte läuft immer alles super .. nur bei meinen eigenen ist immer ständig was gruml

So xorg-server läuft und nvidia driver auch endlich...
Ich denke der Fehler war jetzt das 2 Nvidia Driver oben wahren und die 2 Linux-Kernel .... dürfte da etliches verdreht haben ....

vielen dank für die Hilfe wie immer ....

lg
schatti
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

8

30.07.2013, 21:45

Ja, letzteres hat daran gelegen das für den geboteten 3.10.3-gentoo-r1 Kernel kein nvidia Modul gebaut wurde.
Man kann durchaus mehrere Kernel bauen, man muss dann nur sicherstellen das, sofern externe Module benötigt werden, diese auch jeweils passend zur Kernelversion gebaut wurden - und auch ladbar sind.
Nutze dafür nach dem Kernel bauen am besten ein

Quellcode

1
emerge @module-rebuild

9

31.07.2013, 01:22

Jup mach ich normaler weise eh auch immer .... keine ahnung was ich da wieder mal verbockt haben ...

aber für module habe ich immer diese Befehl verwendet

Quellcode

1
module-rebuild --rebuild


so und nun muss ich mich um diese nerfige Fliege kümmern .. und gucken warum mal wieder nix auf Deutsch hier ist grrrrr

lg
schatti
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

10

01.08.2013, 19:06



aber für module habe ich immer diese Befehl verwendet

Quellcode

1
module-rebuild --rebuild




Der Befehl ist deprecated bzw. dafür vorgesehen deprecated zu werden. Man benutzt jetzt den neuen Befehl den Josef gepostet hat.

Zitat

Pipes sind wie eine Zahnpastatube:
Um den Inhalt zu untersuchen,
muss man ihn erst herausdrücken;
danach gibt es keine Möglichkeit,
ihn wieder hineinzubringen.

--Marc J. Rochkind in "UNIX Programmierung für Fortgeschrittene"

11

02.08.2013, 10:20

Nachtrag: nvidia und >=kernel-3.10 sind keine guten Freunde https://bugs.gentoo.org/show_bug.cgi?id=447566
Es gibt da eine hizige Diskussion, wie mit dem Treiber umzugehen ist. Einige Gentoo Devs weigern sich schlichtweg die verfügbaren Cummunity-Patches für dieses propreitäre Teil einzuspielen, weil dadurch event. Instabilitäten/Sicherheitsrisiken eingeführt werden.
http://www.dyle.org
IM-Account (Jabber!) sind auf meiner HP ...
There is no place like /home

http://www.gentooforum.de
http://www.gentoofreunde.org

<div>how to annoy a web developer?</span>

12

02.08.2013, 10:24

Hallo dyle, gibt es einen Link bzw. ist die Diskussion öffentlich? Das würde mich schon interessieren, welche Risiken das im Einzelnen wären. Ich habe 3.10.1 mit patch am laufen, ohne mehr als die üblichen Wackeleien in Gonme 3 (

Rüdiger

13

02.08.2013, 10:31

Hm, nun ja, vlt. machst du einen IRC auf und schreibst mal die Gentoo Devs direkt an. Bsp.: https://bugs.gentoo.org/show_bug.cgi?id=447566#c123

Zitat

Please stop wasting your time on this. Everybody knows where to find these unofficial patches and we're not going to commit them to the tree.

Use epatch_user if you absolutely must risk data loss and hardware failure.
Das klingt schon recht hart und entnervt: "stop wasting time", "data loss", "hardware failure" ...
http://www.dyle.org
IM-Account (Jabber!) sind auf meiner HP ...
There is no place like /home

http://www.gentooforum.de
http://www.gentoofreunde.org

<div>how to annoy a web developer?</span>

14

02.08.2013, 10:34

naja, entnervt und inhaltslos...

15

02.08.2013, 10:35

[...] Einige Gentoo Devs weigern sich schlichtweg die verfügbaren Cummunity-Patches für dieses propreitäre Teil einzuspielen, weil dadurch event. Instabilitäten/Sicherheitsrisiken eingeführt werden.

Jo, das die Gentoo-Devs sich weigern diese inoffiziellen Patches offiziell mit einzubringen kann ich auch gut verstehen - auch HW-Schäden könnte man kaum sicher ausschliessen.

Sofern man auf einen aktuellen Kernel mit externen nVidia Treiber angewiesen ist würde ich zunächst beim 3.9.11-r1er Kernel bleiben.
Es wird in absehbarer Zukunft aber auch ein neuer Treiber von nVidia released, der dann auch offiziell mit linux-3.10 kompatibel sein wird - sprich, habt ein wenig Geduld bis nVidia soweit ist :)

16

02.08.2013, 23:29

Bin zwar nicht betroffen, aberinteressierten tut mich das Thema hier allemale...

Zu den Entwicklerkommentaren:

Zitat

Please stop wasting your time on this. Everybody knows where to find these unofficial patches and we're not going to commit them to the tree.

Use epatch_user if you absolutely must risk data loss and hardware failure.


...kann ich mal wieder nur sagen, das dies genau der Grund ist, warum ich mich nie bemühe, denen irgendwelche Bugs zu schildern. Entweder kommen solche Antworten wie diese oder garkeine. Nur ein kostenloses OpenSource-Projekt kann es sich leisten, so mit Usern zu verfahren. Passiert soetwas im Kommerz-Bereich, ist diejenige Firma, die soetwas von sich gibt, dem Konkurs nicht mehr weit. Denn dafür zahlt nicht mal ein nur halbwegs funktionierender Geist Geld.

Was stimmt mit diesen NVidia-Treibern denn nicht, das es soein Gezeter rechtfertigt?! Bzw. was ist im Kernel >=3.10 anders, das es zu o.g. kommen könnte...

@Schattenschlag: Du schriebst, Du hast Gentoo auch wegen einer neuen Graka neugemacht. Mal überlegt, eine AMD zu nehmen? Mir scheint es irgendwie, die AMD laufen NVidia gerade den Rang in Beliebtheit seitens Linux ab. Bin derzeit auf Kernel 3.10.4 mit ati-drivers-13.6
Gruß
mnt_gentoo
_________________________________________________________________________________________

Die Launen und das Schicksal eines Gentoo-Users: ?( :| :cursing: :wacko: 8| ^^ 8o ;( :P ?( ...

17

03.08.2013, 12:31

...kann ich mal wieder nur sagen, das dies genau der Grund ist, warum ich mich nie bemühe, denen irgendwelche Bugs zu schildern. Entweder kommen solche Antworten wie diese oder garkeine.

Na, da gehst du aber mit denen recht pauschal und arg hart ins Gericht. Ich denke, die Mehrheit ist schon bemüht und macht gute Sachen.

Ich hatte bsp. letzten einige Diskussion mit der Calligra Developerin Camilla Boeman (zwar nicht Gentoo): https://bugs.kde.org/show_bug.cgi?id=316966. Die war bemüht, nett und recht zuvorkommend.

Das gibt's also auch.
http://www.dyle.org
IM-Account (Jabber!) sind auf meiner HP ...
There is no place like /home

http://www.gentooforum.de
http://www.gentoofreunde.org

<div>how to annoy a web developer?</span>

18

03.08.2013, 14:09

Hi Dyle,

Ich weiß, es hört sich nicht nett von meiner Seite aus an. Aber sei Dir sicher, ich bin ein Mensch, der noch nett und vernünftig argumentiert, wenn viele schon explodiert sind. Ansonsten hätte ich mein Vorhaben, ja gar alles, was ich in den letzten 3Jahren Tat, mindestens schon verworfen und mich völlig von der Materie abgewandt. Was ich mir allein seit ich mich mit Servern auf Linux Bereich in den letzten 2 Jahren anhören durfte, nur weil Linux.wirklich zu 60 Prozent Neuland wieder für mich war, das würde sich so schnell niemand gefallen lassen. Ich habe mehrfach auch Entwicklern geschrieben, und ich habe mit Achtung geschrieben. Es kam entweder GARNICHTS zurück oder das ich mir ein anderes Hobby suchen solle.

Vielleicht glauben die ja, bzw viele, wer nicht genauso viel weiss, ist ein minderjähriges Script-Kiddy mit Langeweile. Mir hat man beigebracht, das es keine dummen Fragen gibt, und das fragen ein Zeichen von Interesse ist. MINDESTENS 2 von den letzten 3 Jahren, Vor allem während meinem anfänglichen Distro-Hopping, die richtige Distri für mich zu finden, die.Einarbeitung in "Linux als Mail-, und Web-Server..." sie war von sehr sehr wenig Hilfe begleitet.

Das wird hier zu sehr OT, ich kann Dir im PN gerne eigene Geschichte, etwas Erlebtes erzählen, da fällst vom Hocker ;)

Ich wollte das hier nur etwas entschärfen, damit es nicht so den Eindruck erweckt, ich sei der unzufriedenste Mensch der Welt. Mein Tonfall hat wirklich Gründe. Glaub(t) mir ruhig.

Einen angenehmen Samstag noch :)
Gruß
mnt_gentoo
_________________________________________________________________________________________

Die Launen und das Schicksal eines Gentoo-Users: ?( :| :cursing: :wacko: 8| ^^ 8o ;( :P ?( ...

19

25.08.2013, 20:05

Hi Leute,

da ja vor kurzem 3.10.7 stable geworden ist, frag ich mich wie es euch dabei geht? Bei mir baut aktuell nvidia 319.32 nicht. 325.15 schon. Ist das jetzt so schon ratsam und Ok, oder nicht.

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

20

25.08.2013, 20:08

Ich habe *15 mit 3.10.9 bauen können ohne patch und alles geht bislang.

Rüdiger