Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

04.10.2013, 19:33

Framebuffer mit Nvidia Karte ?

Hallo zusammen.

Ich habe ein kleines Problem wo ich nicht wirklich weiter komme.
Ich würde gerne die Auflösung nach dem Start von Grub auf 1920x1080 hoch schrauben.
Jetzt habe ich ein paar Howtos dazu gelesen aber irgendwie ist die Vorgehensweise jedesmal
anders und zum laufen bekomme ich das ganze auch nicht.

Da ich noch ein Gentoo Neuling bin bräuchte ich an der Stelle mal Eure Unterstützung. Ich habe
versucht das ganze mittels Framebuffer zu realisieren aber irgendwie tuts das bei mir nicht.
Gnome und OpenGL laufen astrein. Ich habe einen NVidia GTX580 in meinem Rechner und mir
die Nvidia Treiber emerged. Danach lief Gnome in der richtigen Auflösung.

Da ich auch später einen Bootsplash einrichten wollte muß ich ja vorher die Auflösung der Shell
auch auf die 1920x1080 bringen ?
Wenn ich die Gentoo Live DVD einlege dann wird alles genauso angezeigt wie ich mir das vorstelle.

Ich habe die FB Unterstützung für NVidia in meinem Kernel aktiviert. Aber egal was ich in der Grub.conf
einstelle - es funzt nicht.

Hat einer von Euch eine Idee dazu ?

Danke und Gruß
Fulgore

2

04.10.2013, 19:41

Habs mit sämtlichen Grafikkarten geschafft, aber mit Nvidia leider auch noch nicht.

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

3

05.10.2013, 00:16

Den Nvidia-Framebuffer darfst Du nicht nehmen. Der beißt sich mit dem proprietärem Treiber. Versuche es mit uvesafb.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

4

05.10.2013, 14:25

vielleicht Hilft dir dieser Beitrag weiter

[gelöst] UVesaFB-vbe_modes

lg
schatti
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

5

08.10.2013, 07:17

Hallo Schattenschlag.

Danke für den Tip. Jetzt läuft uvesaFB bei mir.
Allerdings habe ich auch das Problem das die gewünschte Auflösung von 1920x1080 bei mir nicht geht.
Ein cat /sys/bus/platform/drivers/uvesafb/uvesafb.0/vbe_modes gibt folgendes aus:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
640x400-8, 0x0100
640x480-8, 0x0101
800x600-8, 0x0103
1024x768-8, 0x0105
1280x1024-8, 0x0107
320x200-16, 0x010e
320x200-32, 0x010f
640x480-16, 0x0111
640x480-32, 0x0112
800x600-16, 0x0114
800x600-32, 0x0115
1024x768-16, 0x0117
1024x768-32, 0x0118
1280x1024-16, 0x011a
1280x1024-32, 0x011b
320x200-8, 0x0130
320x400-8, 0x0131
320x400-16, 0x0132
320x400-32, 0x0133
320x240-8, 0x0134
320x240-16, 0x0135
320x240-32, 0x0136
640x400-16, 0x013d
640x400-32, 0x013e
1280x800-8, 0x0160
1280x800-32, 0x0161

Hat noch jemand eine Idee wie ich auf die Auflösung von 1920x1080 komme ? ?(

6

08.10.2013, 09:27

Bekommst Du denn die gewünschte Aufläsung unter X? Ist diese bei "xrandr" (unter X) dabei? Falls nein, verschweigt Dein Monitor dass er es kann. Dann wird es schmutzig In dem Fall ist die einfachste Variante den Monitor zu tauschen. Falls ja, ist CONFIG_FIRMWARE_EDID im Kernel aktiv?

Verwandtes Thema: http://www.gentooforum.de/artikel/20420/…mode-nicht.html
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

7

08.10.2013, 10:48

Soweit es die Ausgabe von

cat /sys/bus/platform/drivers/uvesafb/uvesafb.0/vbe_modes

sagt kann es dein Monitor diese Auflösung nicht, probiere es mal mit

diese Auflösung 1280x1024-32, falls es damit klappt wäre meine Vermutung das es der Monitor nicht kann korrekt.

lg schatti
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

8

08.10.2013, 15:50

Also mein Monitor hat die native Auflösung von 1920x1080. Diese wird auch unter X korrekt dargestellt.
Auch wenn ich von der Gentoo Live DVD boote habe ich die Auflösung von 1920x1080.

Wenn ich aber ein: cat /sys/bus/platform/drivers/uvesafb/uvesafb.0/vbe_modes eingebe
dann wird sie mir nicht aufgelistet - aber mein Monitor kann diese wie schon geschrieben.

Unter X im Nvidia Treiber sowie in den Monitor Einstellungen wird er auch richtig erkannt ( Iiyama Pro Lite E2773HDS )

Gruß
Fulgore

9

08.10.2013, 15:58

Ok. Ist im Kernel CONFIG_FIRMWARE_EDID aktiv?
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

10

08.10.2013, 21:54

Im Kernel finde ich nur diese Option :

Ich kann zwar mit </> nach CONFIG_FIRMWARE_EDID suchen und werde dann auch zum "support for framebuffer device" geleitet habe
aber dort nur die Option ENABLE FIRMWARE EDID und die ist auch aktiv.
»Fulgore« hat folgende Datei angehängt:
  • kernel.png (78,65 kB - 10 mal heruntergeladen - zuletzt: 14.10.2013, 09:45)

11

10.10.2013, 08:40

OT: Thread nach Nvidia Unterforum verschoben.
http://www.dyle.org
IM-Account (Jabber!) sind auf meiner HP ...
There is no place like /home

http://www.gentooforum.de
http://www.gentoofreunde.org

<div>how to annoy a web developer?</span>

12

14.10.2013, 00:58

An den verfügbaren vbe_modes wirst du vermutlich kaum was ändern können. Soweit mir bekannt sind diese fest im Video-BIOS deiner Grafikkarte gesetzt.

Zitat

Wenn ich die Gentoo Live DVD einlege dann wird alles genauso angezeigt wie ich mir das vorstelle.
Ja, die LiveDVD nutzt wahrscheinlich den nouveau OpenSource Treiber mit KMS, damit gibt es dann einen gut funktionierenden Framebuffer in nativer Auflösung :)
Falls du den testen möchtest siehe zb im http://wiki.gentoo.org/wiki/Nouveau