Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

25.12.2013, 09:00

Eric5 - No module named coverage.misc

Hallo zusammen, frohe Festtage.

Ich habe vor ca einer Woche meinen Laptop komplett aktualisiert. Da ich nur selten die Eric5 IDE am Laptop verwende ist mir erst vorgestern aufgefallen, das eric5 nicht mehr funktioniert.
Er meldet immer es fehle ihm das Modul coverage.misc.

Ich habe versucht durch Neuinstallation von dev-python/coverage und dev-util/eric das Problem zu beheben. Es hat leider nicht gefruchtet.
Die Module sollten aber vorhanden sein.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
An unhandled exception occurred. Please report the problem
using the error reporting dialog or via email to <eric5-bugs@eric-ide.python-projects.org>.
A log has been written to "/home/scriba/.eric5/eric5_error.log".

Error information:
--------------------------------------------------------------------------------
2013-12-25, 08:21:47
--------------------------------------------------------------------------------
<class 'ImportError'>: 
No module named coverage.misc
--------------------------------------------------------------------------------
  File "/usr/lib64/python3.2/site-packages/eric5/eric5.py", line 268, in <module>
    main()
  File "/usr/lib64/python3.2/site-packages/eric5/eric5.py", line 245, in main
    from UI.UserInterface import UserInterface
  File "/usr/lib64/python3.2/site-packages/eric5/UI/UserInterface.py", line 34, in <module>
    from QScintilla.MiniEditor import MiniEditor
  File "/usr/lib64/python3.2/site-packages/eric5/QScintilla/MiniEditor.py", line 26, in <module>
    from .SearchReplaceWidget import SearchReplaceWidget
  File "/usr/lib64/python3.2/site-packages/eric5/QScintilla/SearchReplaceWidget.py", line 16, in <module>
    from .Editor import Editor
  File "/usr/lib64/python3.2/site-packages/eric5/QScintilla/Editor.py", line 35, in <module>
    from DataViews.PyCoverageDialog import PyCoverageDialog
  File "/usr/lib64/python3.2/site-packages/eric5/DataViews/PyCoverageDialog.py", line 22, in <module>
    from DebugClients.Python3.coverage.misc import CoverageException

--------------------------------------------------------------------------------
Version Numbers:
  Python 3.2.5
  Qt 4.8.5
  PyQt4 4.10.2
  sip 4.14.7
  QScintilla 2.7.2
  WebKit 534.34
  eric5 5.3.6 (rev 1d360120e928)

Platform: linux2
3.2.5 (default, Dec 24 2013, 07:21:35) 
[GCC 4.7.3]
--------------------------------------------------------------------------------
Distribution Info:
  /etc/os-release
  NAME=Gentoo
  ID=gentoo
  PRETTY_NAME="Gentoo/Linux"
  ANSI_COLOR="1;32"
  HOME_URL="http://www.gentoo.org/"
  SUPPORT_URL="http://www.gentoo.org/main/en/support.xml"
  BUG_REPORT_URL="https://bugs.gentoo.org/"

  /etc/gentoo-release
  Gentoo Base System release 2.2


Quellcode

1
2
3
4
5
6
/usr/lib64/python2.7/site-packages/coverage
/usr/lib64/python-exec/python2.7/coverage
/usr/lib64/python-exec/python3.2/coverage
/usr/lib64/python-exec/python3.3/coverage
/usr/lib64/python3.2/site-packages/coverage
/usr/lib64/python3.3/site-packages/coverage


Das kompletty System neu Übersetzen hat auch nicht geholfen.

Quellcode

1
revdep-rebuild

sagt alle Links sind ok

Als letzte Änderung kann ich nur die Installation von Blender nennen.
Ich habe

Quellcode

1
PYTHON_TARGETS="python2_7 python3_2 python3_3"
in die /etc/portage/make.conf eingetragen und für Blender

Quellcode

1
media-gfx/blender python_single_target_python3_3 player
in/etc/portage/package.use. Ich finde Eric5 genial und würde nur ungern wechseln. Hat jemand eine Idee?

Kann ich einfach einen Link anlegen /usr/lib/python3.2/site-packages/eric5/DebugClients/Python3/coverage zu /usr/lib64/python3.2/site-packages/coverage ?

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »Scriba« (27.12.2013, 20:39)


2

25.12.2013, 09:55

Klingt nach Bug 487272
und sollte in =dev-util/eric-5.3.8 bereits behoben sein.

Frohe Weihnachten :)

3

25.12.2013, 09:59

Ok, ist zwar noch maskiert aber werde es testen. Danke Josef, dir auch.

4

25.12.2013, 10:01

Es hat ein Phytonupdate gegeben. Hast du den Python-Updater ausgeführt? Auf was für eine Phyton Version bist du jetzt?

Quellcode

1
eselect python list


lg
boospy

Edit: Wie jetzt... da wart ihr jetzt schneller ....
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

5

27.12.2013, 20:20

Hallo,

entschuldigt bitte, dass ich nicht geantwortet hatte. Wir hatten totalen Stromausfall.
War aber mal wieder schön ^^ so ganz ohne Elektrik.

Wie dem auch sei, nach dem Update von Eric lief es wieder reibungslos.

@boospy
Ich habe python-updater nicht ausgeführt und habe momentan die version Python v3.2
ausgewählt und installiert sind momentan folgende.

2.7.5-r3
3.2.5-r3
3.3.2-r2

Sollte ich schon auf 3.3 wechseln oder eher noch abwarten? Ich wollte eigentlich eher noch etwas zuwarte.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Scriba« (27.12.2013, 20:28)