Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

18.03.2014, 14:59

Kein Bild unter Gnome

Hi.
auf meinem Laptop bekomme ich unter gnome kein Bild, unter xfce4 funktioniert alles. Es handelt sich um einen externen Monitor an meinem Laptop, das Laptopdisplay selbst hat das zeitliche gesegnet.

Unter Xfce bekomme ich folgendes im Terminal:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
 xrandr 
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 32767 x 32767
LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1366x768       60.0*+
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080      60.0*+
   1680x1050      60.0  
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1440x900       59.9  
   1280x800       59.8  
   1152x864       75.0  
   1280x720       60.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1


Ich finde keine xorg.conf auf dem Rechner, auch nicht, wenn xfce läuft.

EDIT: Mit 'Kein Bild' meine ich, dass statt des Gnomedesktops nur ein schwarzer HIntergrund mit einem bewegbaren Mauszeiger zu sehen ist. Auch scheint irgendwie ein panning-modus aktiv zu sein, weil der Mauszeiger links aus dem Bildschirm verschwindet, während er an den andern Seiten 'anstößt'.

EDIT2: xrandr kann ich nur aus dem laufenden xfce aufrufen, unter der strg+alt+F1 Shell erhalte ich 'can't open display'

Viele Grüße,
Rüdiger
»Regidür« hat folgende Dateien angehängt:
  • xorg.xfce.txt (25,64 kB - 2 mal heruntergeladen - zuletzt: 20.03.2014, 18:37)
  • xorg.gnome.txt (23,4 kB - 1 mal heruntergeladen - zuletzt: 18.03.2014, 18:45)

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »Regidür« (19.03.2014, 09:18)


2

18.03.2014, 18:15

guck mal hier könnte dir eventuell helfen ....

[gelöst] Nach Update läuft XFCE4 nicht mehr
vielleicht hilft ja dir auch der Tipp von josef.95 wegen "dev-libs/glib-2.38.2"
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

3

18.03.2014, 18:52

Du könntest auch mal versuchen, den externen Monitor als "primary" zu setzen.

Quellcode

1
xrandr --output VGA1 --primary
und dann in den Gnome Einstellungen den Laptop Monitor zu deaktivieren.

Dauerhaft könnte man das wohl auch mit einer entsprechenden xorg.conf lösen und im Abschnitt "Monitor" entsprechende Angaben machen.

4

18.03.2014, 19:06

wie gesagt, xrandr geht nicht 'von außen'

Rüdiger

5

18.03.2014, 21:21

Und wenn du diesen Befehl in ein Startscript packst? Dann sollte es beim Start von Gnome ausgeführt werden. Evtl. kannst du ja unter Xfce

Quellcode

1
gnome-session-properties
aufrufen und es dort aktivieren.

6

19.03.2014, 09:17

Und wenn du diesen Befehl in ein Startscript packst? Dann sollte es beim Start von Gnome ausgeführt werden. Evtl. kannst du ja unter Xfce

Quellcode

1
gnome-session-properties
aufrufen und es dort aktivieren.


Ich habe es so gemacht, und ins Startskript geschrieben:

Quellcode

1
xrandr --output LVDS1 --off --output VGA1 --auto


Ist zwar ein workaround, aber er funktioniert!

Bedankt,
Rüdiger

7

20.03.2014, 18:48

Wenn das Display kaputt ist würde es Sinn machen dieses komplett in der xorg.conf zu deaktivieren. Dann hast Du diese ganzen Dual-Monitor Problematiken nicht mehr. Das würde dann in etwa so aussehen:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
Section	"Device"
	Identifier	"Card0"
	Driver		"intel"
	Option		"monitor-LVDS1"		"LVDS-kaputt"
	Option		"monitor-VGA1"		"VGA-working"
EndSection

Section "Monitor"
	Identifier	"LVDS-kaputt"
	Option		"Ignore"		"True"
EndSection

Section	"Monitor"
	Identifier	"VGA-working"
       #      Deine Monitor Parameter, falls Du was brauchst
EndSection
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.