Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

20.09.2014, 16:28

Bei fast allen Programmen habe ich ähnliche Schwierigkeiten. Woran liegts?

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
localhost andreas # emerge -av sys-fs/udev virtual/udev sys-fs/udev-init-scripts

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-fs/udev-216 [208] USE="acl firmware-loader gudev introspection kmod -doc (-selinux) -static-libs (-openrc%*)" ABI_X86="(64) (-32) (-x32)" 3,530 kB
[ebuild     U  ] virtual/udev-215 [208-r1] USE="-systemd% (-gudev%*) (-introspection%*) (-kmod%*) (-selinux%) (-static-libs%)" ABI_X86="(-32%) (-64%*) (-x32%)" 0 kB
[ebuild     U  ] sys-apps/hwids-20140317 [20130915.1] USE="udev" 1,585 kB
[ebuild     U  ] sys-fs/udev-init-scripts-26-r2 [26] 0 kB

Total: 4 packages (4 upgrades), Size of downloads: 5,115 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

virtual/udev:0

  (virtual/udev-208-r1::gentoo, installed) pulled in by
    virtual/udev[gudev] required by (gnome-base/gvfs-1.18.3::gentoo, installed)

  (virtual/udev-215::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/udev-215 required by (sys-apps/util-linux-2.22.2::gentoo, installed)
    (and 17 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- virtual/mysql-5.1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov <pinkbyte@gentoo.org> (04 Sep 2014)
# Security mask, wrt bugs #488212, #498164, #500260,
# #507802 and #518718 



oder hier:


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177
178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217
218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257
258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
306
307
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354
355
356
357
358
359
360
361
362
363
364
365
366
367
368
369
370
371
372
373
374
375
376
377
378
379
380
381
382
383
384
385
386
387
388
389
390
391
392
393
394
395
396
397
398
399
400
401
402
403
404
405
406
407
408
409
410
411
412
413
414
415
416
417
418
419
localhost andreas # emerge --update --deep --ask system

 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-kernel/linux-headers-3.13 [3.9]
[ebuild     U  ] virtual/libintl-0-r1 [0] ABI_X86="(64%*) -32% (-x32)" 
[ebuild     U  ] app-arch/bzip2-1.0.6-r6 [1.0.6-r3] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/libpng-1.6.12 [1.6.8] USE="-static-libs*" 
[ebuild     U  ] sys-libs/gdbm-1.11 [1.8.3-r4] USE="nls%* -exporter% -static-libs%" ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] sys-devel/gnuconfig-20140212 [20131128]
[ebuild     U  ] dev-libs/lzo-2.08 [2.06] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] sys-libs/timezone-data-2014f [2013d] USE="-right_timezone%" 
[ebuild     U  ] media-libs/giflib-4.1.6-r3 [4.1.6-r2] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] sys-apps/sysvinit-2.88-r7 [2.88-r4]
[ebuild  N     ] dev-libs/libaio-0.3.109-r4  USE="multilib -static-libs {-test}" 
[ebuild     U  ] media-libs/vo-aacenc-0.1.3 [0.1.2] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] dev-libs/libffi-3.0.13-r1 [3.0.11] USE="-pax_kernel%" ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] virtual/libffi-3.0.13-r1 [3.0.11] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] dev-libs/gmp-5.1.3-r1 [5.1.2] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] dev-libs/vala-common-0.24.0 [0.22.1]
[ebuild     U  ] sys-apps/tcp-wrappers-7.6.22-r1 [7.6-r8] USE="-netgroups% -static-libs%" ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] sys-apps/net-tools-1.60_p20130513023548 [1.60_p20120127084908] USE="(-selinux)" 
[ebuild     U  ] dev-libs/gobject-introspection-common-1.40.0 [1.38.0]
[ebuild     U  ] kde-base/kde-env-4.12.5 [4.11.5]
[ebuild   R    ] media-libs/lcms-2.5 
[ebuild     U  ] media-libs/libmng-2.0.2-r1 [1.0.10-r1] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] app-admin/eselect-1.4.1 [1.4]
[ebuild     U  ] app-misc/ca-certificates-20130906-r1 [20130906]
[ebuild     U  ] sys-apps/man-pages-3.70 [3.57]
[ebuild     U  ] app-admin/perl-cleaner-2.16 [2.7]
[ebuild     U  ] virtual/fam-0-r1 [0] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] sys-devel/libtool-2.4.2-r1 [2.4.2] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] sys-libs/db-4.8.30-r1 [4.8.30] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] dev-lang/perl-5.18.2-r1 [5.16.3]
[ebuild     U  ] dev-libs/openssl-1.0.1i [1.0.1f] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] dev-libs/libgcrypt-1.5.4 [1.5.3]
[ebuild     U  ] media-libs/faad2-2.7-r3 [2.7-r2] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/libmad-0.15.1b-r8 [0.15.1b-r7] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] virtual/perl-File-Spec-3.400.0-r2 [3.400.0]
[ebuild     U  ] virtual/perl-Sys-Syslog-0.320.0-r2 [0.320.0]
[ebuild     U  ] virtual/perl-Module-Build-0.400.300-r1 [0.400.300]
[ebuild     U  ] dev-perl/File-BaseDir-0.30.0-r1 [0.30.0]
[ebuild     U  ] dev-perl/File-DesktopEntry-0.40.0-r1 [0.40.0]
[ebuild     U  ] dev-perl/LWP-MediaTypes-6.20.0-r1 [6.20.0]
[ebuild     U  ] virtual/perl-MIME-Base64-3.130.0-r3 [3.130.0-r2]
[ebuild     U  ] dev-perl/URI-1.600.0-r1 [1.600.0]
[ebuild     U  ] dev-perl/Encode-Locale-1.30.0-r1 [1.30.0]
[ebuild     UD ] virtual/perl-libnet-1.220.0-r2 [1.230.0]
[ebuild     U  ] virtual/perl-Digest-MD5-2.520.0-r2 [2.520.0]
[ebuild     U  ] virtual/perl-Time-Local-1.230.0-r1 [1.230.0]
[ebuild     U  ] dev-perl/HTTP-Date-6.20.0-r1 [6.20.0]
[ebuild     U  ] virtual/perl-IO-Compress-2.60.0-r1 [2.60.0]
[ebuild     U  ] virtual/perl-Compress-Raw-Zlib-2.60.0-r2 [2.60.0]
[ebuild     U  ] dev-perl/TermReadKey-2.300.200-r1 [2.300.200]
[ebuild     U  ] dev-perl/Error-0.170.210 [0.170.160]
[ebuild     U  ] dev-perl/XML-Parser-2.410.0-r2 [2.410.0]
[ebuild     U  ] dev-perl/File-Listing-6.40.0-r1 [6.40.0]
[ebuild     U  ] dev-perl/HTML-Tagset-3.200.0-r1 [3.200.0]
[ebuild     U  ] dev-perl/HTML-Parser-3.710.0-r1 [3.710.0]
[ebuild     U  ] dev-libs/libical-0.48-r2 [0.48] USE="-static-libs%" 
[ebuild     U  ] dev-perl/Digest-HMAC-1.30.0-r1 [1.30.0]
[ebuild     U  ] dev-perl/Authen-SASL-2.160.0-r1 [2.160.0]
[ebuild     U  ] virtual/perl-Scalar-List-Utils-1.270.0-r2 [1.270.0]
[ebuild     U  ] dev-perl/Net-SMTP-SSL-1.10.0-r1 [1.10.0]
[ebuild     U  ] dev-util/pkgconfig-0.28-r1 [0.28] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] virtual/pkgconfig-0-r1 [0] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] sys-libs/glibc-2.19-r1 [2.17]
[ebuild     U  ] media-libs/freetype-2.5.3-r1 [2.4.11] USE="adobe-cff%* png%* (-harfbuzz)" ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] net-nds/openldap-2.4.38-r2 [2.4.35-r1] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] dev-lang/orc-0.4.19 [0.4.18]
[ebuild     U  ] media-libs/libvorbis-1.3.4 [1.3.3] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/speex-1.2_rc1-r2 [1.2_rc1] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/libmodplug-0.8.8.5 [0.8.8.4] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] dev-perl/File-MimeInfo-0.170.0-r1 [0.170.0]
[ebuild  N     ] x11-libs/libxshmfence-1.1  USE="-static-libs" ABI_X86="(64) (-32) (-x32)" 
[ebuild     U  ] media-libs/libsamplerate-0.1.8-r1 [0.1.7] USE="-static-libs%" ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] dev-libs/nspr-4.10.6-r1 [4.10.2] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] x11-apps/xauth-1.0.8 [1.0.7]
[ebuild  N     ] x11-proto/dri3proto-1.0  ABI_X86="(64) -32 (-x32)" 
[ebuild  N     ] x11-proto/presentproto-1.0  ABI_X86="(64) -32 (-x32)" 
[ebuild     U  ] net-misc/curl-7.36.0 [7.35.0]
[ebuild     U  ] media-libs/libdvdread-4.2.1 [4.2.0] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/libdvdnav-4.2.1 [4.2.0] ABI_X86="(64%*) (-32) (-x32)" 
[blocks b      ] <media-libs/libdvdnav-4.2.1 ("<media-libs/libdvdnav-4.2.1" is blocking media-libs/libdvdread-4.2.1)
[ebuild     U  ] net-misc/netifrc-0.2.2 [0.1]
[ebuild     U  ] virtual/perl-Storable-2.410.0-r1 [2.390.0]
[uninstall     ] perl-core/Storable-2.390.0 
[blocks b      ] <perl-core/Storable-2.410.0 ("<perl-core/Storable-2.410.0" is blocking virtual/perl-Storable-2.410.0-r1)
[ebuild     U  ] virtual/perl-IO-1.280.0-r1 [1.25]
[uninstall     ] perl-core/IO-1.25 
[blocks b      ] <perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking virtual/perl-IO-1.280.0-r1)
[ebuild     U  ] virtual/perl-Encode-2.490.0-r2 [2.470.0]
[uninstall     ] perl-core/Encode-2.470.0 
[blocks b      ] <perl-core/Encode-2.490.0 ("<perl-core/Encode-2.490.0" is blocking virtual/perl-Encode-2.490.0-r2)
[ebuild     U  ] dev-perl/HTTP-Message-6.30.0-r1 [6.30.0]
[ebuild     U  ] dev-perl/HTTP-Daemon-6.10.0-r1 [6.10.0]
[ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-6.660.0-r1 [6.640.0]
[uninstall     ] perl-core/ExtUtils-MakeMaker-6.640.0 
[blocks b      ] <perl-core/ExtUtils-MakeMaker-6.660.0 ("<perl-core/ExtUtils-MakeMaker-6.660.0" is blocking virtual/perl-ExtUtils-MakeMaker-6.660.0-r1)
[ebuild     U  ] dev-perl/LWP-Protocol-https-6.30.0-r1 [6.30.0]
[ebuild     U  ] media-sound/twolame-0.3.13-r1 [0.3.12] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] sys-apps/acl-2.2.52-r1 [2.2.51] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] app-text/iso-codes-3.55 [3.51] LINGUAS="de%* -af% -am% -ar% -as% -ast% -az% -be% -bg% -bn% -bn_IN% -br% -bs% -byn% -ca% -crh% -cs% -cy% -da% -dz% -el% -en% -eo% -es% -et% -eu% -fa% -fi% -fo% -fr% -ga% -gez% -gl% -gu% -haw% -he% -hi% -hr% -hu% -hy% -ia% -id% -is% -it% -ja% -ka% -kk% -km% -kn% -ko% -kok% -ku% -lt% -lv% -mi% -mk% -ml% -mn% -mr% -ms% -mt% -nb% -ne% -nl% -nn% -nso% -oc% -or% -pa% -pl% -ps% -pt% -pt_BR% -ro% -ru% -rw% -si% -sk% -sl% -so% -sq% -sr% -sr@latin% -sv% -sw% -ta% -te% -th% -ti% -tig% -tk% -tl% -tr% -tt% -tt@iqtelif% -ug% -uk% -ve% -vi% -wa% -wal% -wo% -xh% -zh_CN% -zh_HK% -zh_TW% -zu%" 
[ebuild     U  ] sys-libs/e2fsprogs-libs-1.42.10 [1.42.7] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] sys-devel/flex-2.5.39-r1 [2.5.37] ABI_X86="(64%*) -32% (-x32)" 
[ebuild     U  ] dev-perl/Locale-gettext-1.50.0-r1 [1.50.0]
[ebuild     U  ] sys-apps/help2man-1.43.3 [1.40.11]
[ebuild     U  ] dev-libs/libtasn1-3.6 [2.14] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] net-libs/gnutls-2.12.23-r6 [2.12.23-r4]
[ebuild     U  ] sys-apps/dbus-1.8.8 [1.6.18-r1]
[ebuild     U  ] dev-qt/qtcore-4.8.5-r2 [4.8.5-r1]
[ebuild     U  ] dev-lang/python-2.7.7 [2.7.5-r3]
[ebuild     U  ] dev-util/scons-2.3.0 [2.2.0] PYTHON_TARGETS="python2_7%*" 
[ebuild     U  ] dev-qt/qtgui-4.8.5-r3 [4.8.5-r1]
[ebuild     U  ] sys-libs/ncurses-5.9-r3 [5.9-r2] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] sys-libs/readline-6.2_p5-r1 [6.2_p1] USE="-static-libs%" ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-sound/lame-3.99.5-r1 [3.99.5] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] sys-process/procps-3.3.9 [3.3.8-r2]
[ebuild     U  ] sys-libs/gpm-1.20.7-r2 [1.20.7-r1] USE="-static-libs*" ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] dev-libs/libcdio-0.92 [0.90-r1]
[ebuild     U  ] dev-util/cmake-2.8.12.2-r1 [2.8.11.2]
[ebuild     U  ] dev-db/sqlite-3.8.4.3 [3.8.2] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] kde-base/oxygen-icons-4.12.5 [4.11.5]
[ebuild     U  ] dev-libs/libpcre-8.35 [8.33] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] app-crypt/gnupg-2.0.26 [2.0.22]
[ebuild     U  ] media-libs/openjpeg-1.5.2 [1.5.1] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/openal-1.15.1-r2 [1.15.1] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-gfx/graphite2-1.2.4-r1 [1.2.1] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] dev-lang/python-3.3.5-r1 [3.3.3]
[ebuild     U  ] sys-apps/less-458 [457]
[ebuild     U  ] app-text/qpdf-5.1.1 [4.1.0]
[ebuild     U  ] app-crypt/gpgme-1.3.2-r1 [1.3.2]
[ebuild     U  ] dev-libs/libxml2-2.9.1-r4 [2.9.1-r1] ABI_X86="(64%*) (-32) (-x32)" PYTHON_TARGETS="(-python3_4)" 
[ebuild     U  ] dev-python/cython-0.19.1-r1 [0.19.1] PYTHON_TARGETS="(-pypy)" 
[ebuild     U  ] dev-python/setuptools-2.2 [0.8-r1] PYTHON_TARGETS="(-pypy) (-python3_4)" 
[ebuild     U  ] dev-libs/boost-1.52.0-r7 [1.52.0-r6]
[ebuild     U  ] dev-libs/libxslt-1.1.28-r3 [1.1.28-r1] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/mesa-10.0.4 [9.1.6] USE="-gles2* -llvm-shared-libs% -opencl%" ABI_X86="(64%*) (-32) (-x32)" VIDEO_CARDS="(-freedreno) -ilo%" 
[ebuild     U  ] app-pda/libplist-1.11 [1.10] USE="-static-libs%" PYTHON_TARGETS="python3_3%* (-python3_2)" 
[ebuild     U  ] sys-libs/cracklib-2.9.1-r1 [2.8.19] USE="{-test%}" ABI_X86="(64%*) (-32) (-x32)" PYTHON_TARGETS="python2_7%*" 
[ebuild     U  ] sys-apps/kmod-18-r1 [16] USE="python%*" PYTHON_TARGETS="python2_7%* python3_3%* (-python3_2) (-python3_4)" 
[ebuild     U  ] dev-lang/yasm-1.2.0-r1 [1.2.0] PYTHON_TARGETS="python2_7%*" 
[ebuild     U  ] virtual/opengl-7.0-r1 [7.0] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/x264-0.0.20140308 [0.0.20111220] USE="sse%* -opencl%" ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] sys-libs/pam-1.1.8-r2 [1.1.6-r2] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/xvid-1.3.3 [1.3.2] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/libjpeg-turbo-1.3.1 [1.3.0-r3]
[ebuild     U  ] virtual/pam-0-r1 [0] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/glu-9.0.0-r1 [9.0.0] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] virtual/glu-9.0-r1 [9.0] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] dev-db/postgresql-base-9.3.5 [9.3.3] PYTHON_SINGLE_TARGET="(-python3_4)" PYTHON_TARGETS="(-python3_4)" 
[ebuild     U  ] sys-libs/libcap-2.22-r2 [2.22] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] net-misc/openssh-6.6_p1-r1 [6.4_p1-r1]
[ebuild     U  ] media-libs/libv4l-1.0.0 [0.8.9] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/freeglut-2.8.1-r1 [2.8.1] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild   R    ] media-libs/libsdl-1.2.15-r4  USE="sound%*" 
[ebuild     U  ] dev-db/postgresql-server-9.3.5 [9.3.3] PYTHON_SINGLE_TARGET="(-python3_4)" PYTHON_TARGETS="(-python3_4)" 
[ebuild     U  ] media-libs/libtheora-1.1.1-r1 [1.1.1] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/libmpeg2-0.5.1-r2 [0.5.1] USE="-static-libs%" ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-video/ffmpeg-1.2.6-r1 [1.0.8] USE="iconv%* -libsoxr%" ABI_X86="(64%*) (-32) (-x32)" FFTOOLS="ffescape%*" 
[ebuild     U  ] virtual/ffmpeg-9-r1 [0.10.3] USE="-opus%" ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] dev-util/gdbus-codegen-2.40.0 [2.38.2]
[ebuild     U  ] dev-libs/glib-2.40.0-r1 [2.38.2] USE="(mime%*)" 
[ebuild     U  ] dev-libs/gobject-introspection-1.40.0-r1 [1.38.0]
[blocks b      ] <dev-libs/gobject-introspection-1.40.0 ("<dev-libs/gobject-introspection-1.40.0" is blocking dev-libs/gobject-introspection-common-1.40.0)
[ebuild   R    ] x11-libs/cairo-1.12.16 
[ebuild     U  ] dev-libs/libcroco-0.6.8-r1 [0.6.8] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/gstreamer-0.10.36-r2 [0.10.36] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] dev-libs/atk-2.12.0-r1 [2.10.0] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] x11-libs/gdk-pixbuf-2.30.8 [2.30.6] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/harfbuzz-0.9.28 [0.9.23] USE="introspection* -icu* {-test%}" ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] app-accessibility/at-spi2-core-2.12.0 [2.10.2]
[ebuild     U  ] gnome-base/gsettings-desktop-schemas-3.12.2 [3.10.1]
[ebuild     U  ] media-libs/gst-plugins-base-0.10.36-r1 [0.10.36] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] x11-libs/pango-1.36.5 [1.36.3] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] app-accessibility/at-spi2-atk-2.12.1 [2.10.2]
[ebuild     U  ] net-libs/glib-networking-2.40.1-r1 [2.38.2] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] x11-libs/gtk+-2.24.24 [2.24.22] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/gst-plugins-bad-0.10.23-r2 [0.10.23-r1] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/gst-plugins-ugly-0.10.19-r1 [0.10.19] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-libs/gst-plugins-good-0.10.31-r1 [0.10.31] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-xvideo-0.10.36-r1 [0.10.36] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] net-libs/libsoup-2.46.0-r1 [2.44.2] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-ogg-0.10.36-r1 [0.10.36] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-vorbis-0.10.36-r1 [0.10.36] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-x-0.10.36-r1 [0.10.36] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-alsa-0.10.36-r1 [0.10.36] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-theora-0.10.36-r1 [0.10.36] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r2 [0.10.13_p201211-r1] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-cdparanoia-0.10.36-r1 [0.10.36] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] x11-libs/gtk+-3.12.2 [3.10.7] USE="-cloudprint%" 
[ebuild     U  ] media-plugins/gst-plugins-soup-0.10.31-r1 [0.10.31] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-libmms-0.10.23-r1 [0.10.23] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-dvdread-0.10.19-r1 [0.10.19] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-mad-0.10.19-r1 [0.10.19] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-musepack-0.10.23-r1 [0.10.23] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-dvb-0.10.23-r1 [0.10.23] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-faad-0.10.23-r1 [0.10.23] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-oss-0.10.31-r1 [0.10.31] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-mpeg2dec-0.10.19-r1 [0.10.19] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-dts-0.10.23-r1 [0.10.23] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-wavpack-0.10.31-r1 [0.10.31] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-xvid-0.10.23-r1 [0.10.23] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-lame-0.10.19-r1 [0.10.19] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-x264-0.10.19-r1 [0.10.19] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-a52dec-0.10.19-r1 [0.10.19] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-flac-0.10.31-r1 [0.10.31] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] media-plugins/gst-plugins-resindvd-0.10.23-r1 [0.10.23] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] gnome-base/libglade-2.6.4-r2 [2.6.4] USE="tools%*" ABI_X86="(64%*) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7%* (-pypy)" PYTHON_TARGETS="python2_7%* (-pypy)" 
[ebuild   R    ] net-dns/avahi-0.6.31-r2  USE="(-selinux)" 
[ebuild     U  ] gnome-base/librsvg-2.40.2-r1 [2.40.1-r1] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] net-print/cups-1.7.5 [1.7.1] USE="-systemd%" ABI_X86="(64%*) (-32) (-x32)" LINGUAS="-pt_BR%" 
[ebuild     U  ] net-print/cups-filters-1.0.53 [1.0.43-r1]
[ebuild     U  ] dev-java/icedtea-bin-6.1.13.3-r3 [6.1.12.7] USE="(-selinux) -webstart%" 
[ebuild  N     ] dev-java/icedtea-web-1.4.2  USE="nsplugin -doc -javascript {-test}" 
[ebuild     U  ] dev-db/mysql-5.5.39 [5.1.70] USE="bindist%* -jemalloc% -static-libs% -systemtap% -tcmalloc%" 
[ebuild     U  ] virtual/mysql-5.5 [5.1] USE="-static-libs%" 
[ebuild     U  ] dev-perl/DBD-mysql-4.20.0-r1 [4.20.0]
[ebuild     U  ] app-office/akonadi-server-1.11.0 [1.10.3]
[ebuild  N     ] app-pda/libusbmuxd-1.0.9  USE="-static-libs" 
[uninstall     ] app-pda/usbmuxd-1.0.8-r1 
[blocks b      ] <app-pda/usbmuxd-1.0.8_p1 ("<app-pda/usbmuxd-1.0.8_p1" is blocking app-pda/libusbmuxd-1.0.9)
[ebuild     U  ] app-pda/libimobiledevice-1.1.6 [1.1.5] USE="-static-libs%" PYTHON_TARGETS="python3_3%* (-python3_2)" 
[ebuild     U  ] sys-apps/gptfdisk-0.8.10 [0.8.8]
[ebuild     U  ] dev-libs/apr-1.5.0-r2 [1.4.8-r1]
[ebuild     U  ] dev-libs/apr-util-1.5.3-r2 [1.5.2]
[ebuild  N     ] net-libs/serf-1.3.7  USE="-kerberos" 
[ebuild     U  ] dev-vcs/subversion-1.8.10 [1.7.14] USE="http%*" 
[ebuild     U  ] dev-vcs/git-1.8.5.5 [1.8.3.2-r1] USE="-mediawiki%" 
[ebuild     U  ] sys-fs/udev-216 [208]
[ebuild     U  ] virtual/udev-215 [208-r1] USE="-systemd%" 
[ebuild     U  ] sys-apps/hwids-20140317 [20130915.1]
[ebuild     U  ] sys-apps/util-linux-2.24.1-r3 [2.22.2] USE="bash-completion%* pam%* python%* -caps% -cytune% -fdformat% -tty-helpers%" ABI_X86="(64%*) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7%* (-python3_2) -python3_3% (-python3_4)" PYTHON_TARGETS="python2_7%* python3_3%* (-python3_2) (-python3_4)" 
[ebuild  N     ] virtual/libgudev-215-r1  USE="introspection -static-libs -systemd" ABI_X86="(64) (-32) (-x32)" 
[ebuild     U  ] sys-fs/udev-init-scripts-26-r2 [26]
[blocks b      ] <sys-fs/udev-init-scripts-26-r1 ("<sys-fs/udev-init-scripts-26-r1" is blocking net-misc/netifrc-0.2.2)
[blocks b      ] >=net-misc/netifrc-0.2.1 (">=net-misc/netifrc-0.2.1" is blocking sys-fs/udev-init-scripts-26)
[ebuild  N     ] virtual/libudev-215-r1  USE="-static-libs -systemd" ABI_X86="(64) (-32) (-x32)" 
[ebuild     U  ] sys-fs/e2fsprogs-1.42.10 [1.42.7]
[ebuild     U  ] media-plugins/gst-plugins-v4l2-0.10.31-r1 [0.10.31] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] sys-power/upower-0.99.1 [0.9.23]
[ebuild     U  ] media-plugins/gst-plugins-meta-0.10-r9 [0.10-r8] ABI_X86="(64%*) (-32) (-x32)" 
[ebuild     U  ] kde-base/kdelibs-4.12.5-r2 [4.11.5]
[ebuild     U  ] kde-base/nepomuk-core-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/katepart-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/nepomuk-widgets-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/kdesu-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/khelpcenter-4.12.5 [4.11.5]
[ebuild     U  ] media-video/vlc-2.1.2 [2.0.7] USE="faad%* -chromaprint% -fdk% -opencv% (-qt5) -rdp% -sftp% {-test%} -tremor% (-vdpau)" 
[ebuild     U  ] kde-base/kde-l10n-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/knotify-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/kdepimlibs-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/kwalletd-4.12.5 [4.11.5] USE="semantic-desktop%*" 

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/cairo:0

  (x11-libs/cairo-1.12.16::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/cairo-1.12.16::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/cairo-1.12.14-r4:=[X,svg,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (x11-libs/gtk+-2.24.24::gentoo, ebuild scheduled for merge)
    >=x11-libs/cairo-1.12.14-r4:=[X?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (x11-libs/pango-1.36.5::gentoo, ebuild scheduled for merge)
    >=x11-libs/cairo-1.12.14-r4[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (gnome-base/librsvg-2.40.2-r1::gentoo, ebuild scheduled for merge)

media-libs/lcms:2

  (media-libs/lcms-2.5::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/lcms-2.5:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-libs/libmng-2.0.2-r1::gentoo, ebuild scheduled for merge)

  (media-libs/lcms-2.5::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/glib-perl-1.301.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    >=dev-lang/perl-5.8.8:0/5.16= required by (media-gfx/imagemagick-6.8.8.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)

  (dev-lang/perl-5.18.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-Sys-Syslog-0.320.0-r2::gentoo, ebuild scheduled for merge)
    (and 13 more with the same problem)

media-libs/libsdl:0

  (media-libs/libsdl-1.2.15-r4::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/libsdl-1.2.15-r4[sound,video,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-video/ffmpeg-1.2.6-r1::gentoo, ebuild scheduled for merge)

  (media-libs/libsdl-1.2.15-r4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

virtual/udev:0

  (virtual/udev-208-r1::gentoo, installed) pulled in by
    virtual/udev[gudev] required by (gnome-base/gvfs-1.18.3::gentoo, installed)

  (virtual/udev-215::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/udev-215 required by (sys-fs/udisks-1.0.5::gentoo, installed)
    (and 18 more with the same problem)

media-libs/harfbuzz:0

  (media-libs/harfbuzz-0.9.28::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/harfbuzz-0.9.12:=[glib(+),truetype(+),abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (x11-libs/pango-1.36.5::gentoo, ebuild scheduled for merge)

  (media-libs/harfbuzz-0.9.23::gentoo, installed) pulled in by
    media-libs/harfbuzz:0/0.9.18=[icu(+)] required by (net-libs/webkit-gtk-2.2.5::gentoo, installed)
    media-libs/harfbuzz:0/0.9.18=[icu(+)] required by (net-libs/webkit-gtk-2.2.5-r200::gentoo, installed)

dev-libs/libtasn1:0

  (dev-libs/libtasn1-2.14::gentoo, installed) pulled in by
    >=dev-libs/libtasn1-1:0/0= required by (app-crypt/gcr-3.10.1::gentoo, installed)

  (dev-libs/libtasn1-3.6::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

app-pda/libplist:0

  (app-pda/libplist-1.10::gentoo, installed) pulled in by
    >=app-pda/libplist-1.0:0/0= required by (media-libs/libgpod-0.8.2::gentoo, installed)
    (and 1 more with the same problem)

  (app-pda/libplist-1.11::gentoo, ebuild scheduled for merge) pulled in by
    >=app-pda/libplist-1.11:=[python?,python_targets_python2_7(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,-python_single_target_python2_7(-),-python_single_target_python3_2(-),-python_single_target_python3_3(-)] required by (app-pda/libimobiledevice-1.1.6::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

net-libs/libsoup:2.4

  (net-libs/libsoup-2.46.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=net-libs/libsoup-2.44.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-plugins/gst-plugins-soup-0.10.31-r1::gentoo, ebuild scheduled for merge)

  (net-libs/libsoup-2.44.2::gentoo, installed) pulled in by
    ~net-libs/libsoup-2.44.2[introspection?] required by (net-libs/libsoup-gnome-2.44.2::gentoo, installed)

net-misc/curl:0

  (net-misc/curl-7.35.0::gentoo, installed) pulled in by
    net-misc/curl[-curl_ssl_gnutls,-curl_ssl_nss,curl_ssl_openssl,-curl_ssl_axtls,-curl_ssl_cyassl,-curl_ssl_polarssl] required by (dev-python/pycurl-7.19.0-r3::gentoo, installed)

  (net-misc/curl-7.36.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

media-libs/libpng:0

  (media-libs/libpng-1.6.12::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-libs/libpng-1.6.8::gentoo, installed) pulled in by
    >=media-libs/libpng-1.4.3[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, installed)

sys-libs/gpm:0

  (sys-libs/gpm-1.20.7-r1::gentoo, installed) pulled in by
    sys-libs/gpm[static-libs] required by (media-gfx/splashutils-1.5.4.4-r1::gentoo, installed)

  (sys-libs/gpm-1.20.7-r2::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

media-libs/mesa:0

  (media-libs/mesa-10.0.4::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/mesa-9.1.6[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (virtual/opengl-7.0-r1::gentoo, ebuild scheduled for merge)

  (media-libs/mesa-9.1.6::gentoo, installed) pulled in by
    >=media-libs/mesa-7.12[egl(+),gles2] required by (kde-base/kwin-4.11.5::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-vcs/git-1.8.5.5[subversion,perl]
# required by sys-devel/gettext-0.18.3.2[git]
# required by sys-devel/flex-2.5.39-r1[nls]
# required by sys-libs/pam-1.1.8-r2
# required by sys-apps/util-linux-2.24.1-r3[pam]
# required by sys-fs/udev-216
# required by virtual/libudev-215-r1[-systemd]
# required by media-libs/libcanberra-0.30-r1[udev,alsa]
# required by gnome-base/libgnome-2.32.1-r1
# required by dev-python/libgnome-python-2.28.1
# required by media-sound/soundconverter-2.0.4
# required by @selected
# required by @world (argument)
>=dev-vcs/subversion-1.8.10 -dso

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.




Gentoo ist nicht mehr das, was es mal war!
Nur noch Probleme, seit diese Neuerungen da sind!
Nichts geht mehr ohne solche Schwierigkeiten.
Wenn das so weitergeht, wechsele ich noch zu einer anderen Distri!

Selbst hier muss man inzwischen Gewaltige Programmierkenntnisse besitzen, um dieses zu deuten.
Da verliert man aufgrund der Fehlermeldungen den Überblick. Komme nicht mehr weiter, kann seit einem halben jahr kein Update mehr vollziehen.
Nur noch solche Meldungen. Nichts geht mehr anzustossen. VERDAMMT!!
Ullrich Andreas
Meine Konfiguration:
x86_64/Gentoo-13/gcc Version 4.6.3/KDE-Version 4.12.5/Kernel version 3.7.10
Graphic: 2x Nvidia 9600-GT OC SLI,Drucker: Samsung CLP-315W

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »andreasullrich« (20.09.2014, 16:49)


2

20.09.2014, 18:16

Naja, du solltest dir aber auch mal an die eigene Nase fassen..

Zitat

Quellcode

1
localhost andreas # emerge -av sys-fs/udev virtual/udev sys-fs/udev-init-scripts
Warum lässt du dir solche Abhängigkeiten ins world file schreiben? Das schafft idR nur Probleme - nutze für solche Aktionen doch besser die emerge Option --oneshot

Zitat

Quellcode

1
2
 * IMPORTANT: 4 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
Warum liest du die News zu deinen Installierten Paketen nicht? Das sollte man am besten vor einem Update machen.

Zitat

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-fs/udev-216 [208] USE="acl firmware-loader gudev introspection kmod -doc (-selinux) -static-libs (-openrc%*)" ABI_X86="(64) (-32) (-x32)" 3,530 kB
[ebuild     U  ] virtual/udev-215 [208-r1] USE="-systemd% (-gudev%*) (-introspection%*) (-kmod%*) (-selinux%) (-static-libs%)" ABI_X86="(-32%) (-64%*) (-x32%)" 0 kB
[ebuild     U  ] sys-apps/hwids-20140317 [20130915.1] USE="udev" 1,585 kB
[ebuild     U  ] sys-fs/udev-init-scripts-26-r2 [26] 0 kB

Total: 4 packages (4 upgrades), Size of downloads: 5,115 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

virtual/udev:0

  (virtual/udev-208-r1::gentoo, installed) pulled in by
    virtual/udev[gudev] required by (gnome-base/gvfs-1.18.3::gentoo, installed)

  (virtual/udev-215::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/udev-215 required by (sys-apps/util-linux-2.22.2::gentoo, installed)
    (and 17 more with the same problem)

virtual/udev[gudev]
gibt es so nicht mehr, und wird vom aktuellen gvfs-1.18.3-r1.ebuild so auch nicht mehr benötigt - siehe zb im http://sources.gentoo.org/cgi-bin/viewvc…&r1=1.9&r2=1.10
gnome-base/gvfs neu mergen sollte helfen.

Versuche doch auch mal ein

Quellcode

1
emerge -avuDN @world
statt im veralteten System auf einzelne Pakete loszugehen - damit lösen sich die meisten Abhängigkeiten meist von selbst passen auf :)

3

20.09.2014, 19:22

Also world update geht genauso wenig.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
emerge -avuDN @world

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies -

!!! Problem resolving dependencies for dev-libs/efl from @selected
... done!

!!! The ebuild selected to satisfy "dev-libs/efl" has unmet requirements.
- dev-libs/efl-1.8.5::gentoo USE="X bmp eet egl fbcon fontconfig gif gles gstreamer ico jpeg nls opengl png ppm psd sdl ssl tiff v4l2 xine xpm -debug -doc -drm -fribidi -glib -gnutls -harfbuzz -ibus -jp2k -physics (-pixman) -pulseaudio -scim -sound -systemd -tga -tslib -wayland -webp -xcb -xim" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    gles? ( !sdl )

  The above constraints are a subset of the following complete expression:
    X? ( !xcb ) pulseaudio? ( sound ) opengl? ( any-of ( X xcb sdl wayland ) ) gles? ( any-of ( X xcb wayland ) ) gles? ( !sdl ) gles? ( egl ) xcb? ( pixman ) wayland? ( egl !opengl gles ) xim? ( any-of ( X xcb ) emerge @preserved-rebuild
Calculating dependencies... done!
[ebuild     U  ] kde-base/kde-env-4.12.5 [4.11.5]
[ebuild     U  ] sys-apps/hwids-20140317 [20130915.1]
[ebuild  NS    ] app-text/docbook-xml-dtd-4.5-r1 [4.1.2-r6, 4.2-r2, 4.3-r1, 4.4-r2]
[ebuild     U  ] dev-util/cmake-2.8.12.2-r1 [2.8.11.2]
[ebuild     U  ] kde-base/oxygen-icons-4.12.5 [4.11.5]
[ebuild  N     ] sys-fs/eudev-1.9-r2  USE="gudev hwdb introspection keymap kmod modutils openrc rule-generator -doc (-selinux) -static-libs {-test}" ABI_X86="(64) (-32) (-x32)" 
[ebuild  N     ] virtual/libgudev-215-r1  USE="introspection -static-libs -systemd" ABI_X86="(64) (-32) (-x32)" 
[ebuild  N     ] sys-power/upower-0.99.1  USE="introspection ios" 
[ebuild     U  ] kde-base/kdelibs-4.12.5-r2 [4.11.5]
[ebuild     U  ] kde-base/nepomuk-core-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/katepart-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/nepomuk-widgets-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/kdesu-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/khelpcenter-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/libkworkspace-4.11.9 [4.11.5]
[ebuild     U  ] kde-base/kephal-4.11.9 [4.11.5]
[ebuild     U  ] kde-base/kactivities-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/liboxygenstyle-4.11.9 [4.11.5]
[ebuild     U  ] kde-base/kwin-4.11.9 [4.11.5]
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-fs/eudev-1.9-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-208::gentoo, installed) pulled in by
    sys-fs/udev required by @selected
    >=sys-fs/udev-208[abi_x86_64(-),gudev,introspection,kmod] required by (virtual/udev-208-r1::gentoo, installed)

  (sys-fs/eudev-1.9-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?,static-libs?] (>=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_64(-),gudev,introspection]) required by (virtual/libgudev-215-r1::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- virtual/mysql-5.1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov <pinkbyte@gentoo.org> (04 Sep 2014)
# Security mask, wrt bugs #488212, #498164, #500260,
# #507802 and #518718

- media-video/vlc-2.0.7::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Tom Wijsman <TomWij@gentoo.org> (8 Jun 2014)
# Mask VLC ebuilds that are affected with security bug CVE-2013-6934:
#
#     A vulnerability has been discovered in VLC Media Player, which can be
#     exploited by malicious people to compromise a user's system.
#
# Some ebuilds also have other buffer and integer overflow security bugs like
# CVE-2013-1954, CVE-2013-3245, CVE-2013-4388 and CVE-2013-6283.
#
# Users should consider to upgrade VLC Media Player to at least version 2.1.2.

- dev-db/mysql-5.1.70::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
)

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
emerge --oneshot --noreplace 'sys-power/upower-pm-utils'

 * IMPORTANT: 2 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild     U  ] sys-apps/hwids-20140317 [20130915.1]
[ebuild  NS    ] app-text/docbook-xml-dtd-4.5-r1 [4.1.2-r6, 4.2-r2, 4.3-r1, 4.4-r2]
[ebuild  N     ] sys-fs/eudev-1.9-r2  USE="gudev hwdb introspection keymap kmod modutils openrc rule-generator -doc (-selinux) -static-libs {-test}" ABI_X86="(64) (-32) (-x32)" 
[ebuild  N     ] virtual/libgudev-215-r1  USE="introspection -static-libs -systemd" ABI_X86="(64) (-32) (-x32)" 
[ebuild  N     ] sys-power/upower-pm-utils-0.9.23-r2  USE="introspection ios" 
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-fs/eudev-1.9-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-208::gentoo, installed) pulled in by
    sys-fs/udev required by @selected
    >=sys-fs/udev-208[abi_x86_64(-),gudev,introspection,kmod] required by (virtual/udev-208-r1::gentoo, installed)

  (sys-fs/eudev-1.9-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?,static-libs?] (>=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_64(-),gudev,introspection]) required by (virtual/libgudev-215-r1::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- virtual/mysql-5.1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov <pinkbyte@gentoo.org> (04 Sep 2014)
# Security mask, wrt bugs #488212, #498164, #500260,
# #507802 and #518718

- media-video/vlc-2.0.7::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Tom Wijsman <TomWij@gentoo.org> (8 Jun 2014)
# Mask VLC ebuilds that are affected with security bug CVE-2013-6934:
#
#     A vulnerability has been discovered in VLC Media Player, which can be
#     exploited by malicious people to compromise a user's system.
#
# Some ebuilds also have other buffer and integer overflow security bugs like
# CVE-2013-1954, CVE-2013-3245, CVE-2013-4388 and CVE-2013-6283.
#
# Users should consider to upgrade VLC Media Player to at least version 2.1.2.

- dev-db/mysql-5.1.70::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
emerge @preserved-rebuild
Calculating dependencies... done!
[ebuild     U  ] kde-base/kde-env-4.12.5 [4.11.5]
[ebuild     U  ] sys-apps/hwids-20140317 [20130915.1]
[ebuild  NS    ] app-text/docbook-xml-dtd-4.5-r1 [4.1.2-r6, 4.2-r2, 4.3-r1, 4.4-r2]
[ebuild     U  ] dev-util/cmake-2.8.12.2-r1 [2.8.11.2]
[ebuild     U  ] kde-base/oxygen-icons-4.12.5 [4.11.5]
[ebuild  N     ] sys-fs/eudev-1.9-r2  USE="gudev hwdb introspection keymap kmod modutils openrc rule-generator -doc (-selinux) -static-libs {-test}" ABI_X86="(64) (-32) (-x32)" 
[ebuild  N     ] virtual/libgudev-215-r1  USE="introspection -static-libs -systemd" ABI_X86="(64) (-32) (-x32)" 
[ebuild  N     ] sys-power/upower-0.99.1  USE="introspection ios" 
[ebuild     U  ] kde-base/kdelibs-4.12.5-r2 [4.11.5]
[ebuild     U  ] kde-base/nepomuk-core-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/katepart-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/nepomuk-widgets-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/kdesu-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/khelpcenter-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/libkworkspace-4.11.9 [4.11.5]
[ebuild     U  ] kde-base/kephal-4.11.9 [4.11.5]
[ebuild     U  ] kde-base/kactivities-4.12.5 [4.11.5]
[ebuild     U  ] kde-base/liboxygenstyle-4.11.9 [4.11.5]
[ebuild     U  ] kde-base/kwin-4.11.9 [4.11.5]
[blocks B      ] sys-fs/udev ("sys-fs/udev" is blocking sys-fs/eudev-1.9-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-fs/udev-208::gentoo, installed) pulled in by
    sys-fs/udev required by @selected
    >=sys-fs/udev-208[abi_x86_64(-),gudev,introspection,kmod] required by (virtual/udev-208-r1::gentoo, installed)

  (sys-fs/eudev-1.9-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?,static-libs?] (>=sys-fs/eudev-1.5.3-r1:0/0[abi_x86_64(-),gudev,introspection]) required by (virtual/libgudev-215-r1::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


!!! The following installed packages are masked:
- virtual/mysql-5.1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Sergey Popov <pinkbyte@gentoo.org> (04 Sep 2014)
# Security mask, wrt bugs #488212, #498164, #500260,
# #507802 and #518718

- media-video/vlc-2.0.7::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Tom Wijsman <TomWij@gentoo.org> (8 Jun 2014)
# Mask VLC ebuilds that are affected with security bug CVE-2013-6934:
#
#     A vulnerability has been discovered in VLC Media Player, which can be
#     exploited by malicious people to compromise a user's system.
#
# Some ebuilds also have other buffer and integer overflow security bugs like
# CVE-2013-1954, CVE-2013-3245, CVE-2013-4388 and CVE-2013-6283.
#
# Users should consider to upgrade VLC Media Player to at least version 2.1.2.

- dev-db/mysql-5.1.70::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



Was heißt hier: udev im World-File?
Ich habe nirgends etwas eingetragen. Daran liegt ja das Prob.
diese Meldungen habe ich seit dem letzen Update vor einem halben, Dreiviertel Jahr. Und bekomme diese nicht mehr weg!
Vorher war alles normal, wie immer.

UND!

ICH WILL KEIN GRUB2!!!!!

Bitte beachten!
Ullrich Andreas
Meine Konfiguration:
x86_64/Gentoo-13/gcc Version 4.6.3/KDE-Version 4.12.5/Kernel version 3.7.10
Graphic: 2x Nvidia 9600-GT OC SLI,Drucker: Samsung CLP-315W

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »andreasullrich« (20.09.2014, 20:03)


4

20.09.2014, 20:12

Ogott, glaub ich hab einen großen Fehler gemacht!

habe gvfs neu emergt!

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
* Updating GSettings schemas ...                                                                                                                                                                                                     [ ok ]
>>> gnome-base/gvfs-1.20.2 merged.

>>> Recording gnome-base/gvfs in "world" favorites file...

 * Messages for package sys-fs/udev-216:

 *   CONFIG_FHANDLE:     is not set when it should be.
 * Please check to make sure these options are set correctly.
 * Failure to do so may cause unexpected problems.
 * 
 * Starting from version >= 197 the new predictable network interface names are
 * used by default, see:
 * http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames
 * http://cgit.freedesktop.org/systemd/systemd/tree/src/udev/udev-builtin-net_id.c
 * 
 * Example command to get the information for the new interface name before booting
 * (replace <ifname> with, for example, eth0):
 * # udevadm test-builtin net_id /sys/class/net/<ifname> 2> /dev/null
 * 
 * You can use either kernel parameter "net.ifnames=0", create empty
 * file /etc/systemd/network/99-default.link, or symlink it to /dev/null
 * to disable the feature.
 * 
 * You need to restart udev as soon as possible to make the upgrade go
 * into effect.
 * The method you use to do this depends on your init system.
 * For sys-apps/openrc users it is:
 * # /etc/init.d/udev --nodeps restart
 * 
 * For more information on udev on Gentoo, upgrading, writing udev rules, and
 * fixing known issues visit:
 * http://wiki.gentoo.org/wiki/Udev
 * http://wiki.gentoo.org/wiki/Udev/upgrade
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: x11-libs/libxcb-1.10
 *  - /usr/lib64/libxcb-sync.so.0
 *  - /usr/lib64/libxcb-sync.so.0.0.0
 *      used by /usr/lib64/libkdeinit4_kwin.so (kde-base/kwin-4.11.5)
 *      used by /usr/lib64/libkdeinit4_kwin_gles.so (kde-base/kwin-4.11.5)
Use emerge @preserved-rebuild to rebuild packages using these libraries
localhost portage # /etc/init.d/udev --nodeps restart
 * Stopping udev ...                                                                                                                                                                                                                   [ ok ]
 * Starting udev ...                                                                                                                                                                                                                   [ ok ]
 * Generating a rule to create a /dev/root symlink ...                                                                                                                                                                                 [ ok ]
 * Populating /dev with existing devices through uevents ...                                                                                                                                                                           [ ok ]
 * Waiting for uevents to be processed ...                                                                                                                                                                                             [ ok ]
localhost portage # udevadm test-builtin net_id /sys/class/net/<ifname> 2> /dev/null
bash: Syntaxfehler beim unerwarteten Wort `2'




Traue mich nicht mehr neu zu starten. Ogott!
systemd Ogott. Das ist für Grub2!

Schei..........
Ullrich Andreas
Meine Konfiguration:
x86_64/Gentoo-13/gcc Version 4.6.3/KDE-Version 4.12.5/Kernel version 3.7.10
Graphic: 2x Nvidia 9600-GT OC SLI,Drucker: Samsung CLP-315W

5

20.09.2014, 21:52

Ruhig Blut, niemand zwingt dich grub:2 zu installieren, es zwingt dich auch niemand überhaupt grub zu installieren - außer du tust es selbst :)
Wenn du grub1 installiert hast, und diesen behalten möchtest, dann nehme ihn mit Slotangabe mit im world auf - dann wird normal auch kein Update auf grub2 vorgenommen.
Vorschlag:

Quellcode

1
2
emerge --deselect grub
emerge -avn grub:0
Und alles wird gut :)

Unmerge oder aktualisiere mal bitte virtual/udev (dass sollte den Block mit sys-fs/udev eudev lösen).

Und statt auf =gnome-base/gvfs-1.20.2 zu aktualisieren merge mal bitte =gnome-base/gvfs-1.18.3-r1

Danach schau mal bitte wie "emerge -avuDN world" nun ausschaut.

6

20.09.2014, 22:45

Quellcode

1
2
3
localhost andreas # emerge -av gnome-base/gvfs-1.18.3-r1
!!! 'gnome-base/gvfs-1.18.3-r1' is not a valid package atom.
!!! Please check ebuild(5) for full details.


Quellcode

1
2
3
4
5
6
localhost andreas # eix gvfs
[I] gnome-base/gvfs
     Available versions:  1.18.3-r1^t 1.20.2^t ~1.20.3^t {afp archive avahi bluetooth bluray cdda fuse gnome-online-accounts gphoto2 gtk +http ios libsecret mtp samba systemd test +udev udisks}
     Installed versions:  1.20.2^t(22:09:24 20.09.2014)(avahi cdda gtk http ios udev udisks -afp -archive -bluray -fuse -gnome-online-accounts -gphoto2 -libsecret -mtp -samba -systemd -test)
     Homepage:            https://git.gnome.org/browse/gvfs
     Description:         Virtual filesystem implementation for gio


Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
>>> Installing (1 of 673) sys-libs/timezone-data-2014f
Traceback (most recent call last):
  File "/usr/lib64/portage/pym/portage/dbapi/_MergeProcess.py", line 234, in _spawn
    prev_mtimes=self.prev_mtimes, counter=counter)
  File "/usr/lib64/portage/pym/portage/dbapi/vartree.py", line 4839, in merge
    counter=counter)
  File "/usr/lib64/portage/pym/portage/dbapi/vartree.py", line 3647, in treewalk
    retval = self._security_check(others_in_slot)
  File "/usr/lib64/portage/pym/portage/dbapi/vartree.py", line 3403, in _security_check
    s = os.lstat(path)
  File "/usr/lib64/portage/pym/portage/__init__.py", line 259, in __call__
    rval = self._func(*wrapped_args, **wrapped_kwargs)
OSError: [Errno 40] Too many levels of symbolic links: '/usr/share/zoneinfo/posix/Africa/Conakry'

>>> Failed to install sys-libs/timezone-data-2014f, Log file:

>>>  '/var/tmp/portage/sys-libs/timezone-data-2014f/temp/build.log'

 * Regenerating GNU info directory index...
 * Processed 176 info files.

!!! existing preserved libs:
>>> package: x11-libs/libxcb-1.10
 *  - /usr/lib64/libxcb-sync.so.0
 *  - /usr/lib64/libxcb-sync.so.0.0.0
 *      used by /usr/lib64/libkdeinit4_kwin.so (kde-base/kwin-4.11.5)
 *      used by /usr/lib64/libkdeinit4_kwin_gles.so (kde-base/kwin-4.11.5)
>>> package: sys-libs/gdbm-1.11
 *  - /usr/lib64/libgdbm.so.3
 *  - /usr/lib64/libgdbm.so.3.0.0
 *      used by /usr/bin/avahi-browse (net-dns/avahi-0.6.31-r2)
 *      used by /usr/lib64/apr-util-1/apr_dbm_gdbm-1.so (dev-libs/apr-util-1.5.2)
 *      used by /usr/lib64/libavahi-ui-gtk3.so.0.1.4 (net-dns/avahi-0.6.31-r2)
 *      used by 10 other files
 *  - /usr/lib64/libgdbm_compat.so.3
 *  - /usr/lib64/libgdbm_compat.so.3.0.0
 *      used by /usr/lib64/perl5/5.16.3/x86_64-linux/auto/NDBM_File/NDBM_File.so (dev-lang/perl-5.16.3)
 *      used by /usr/lib64/python2.7/lib-dynload/dbm.so (dev-lang/python-2.7.5-r3)
 *      used by /usr/lib64/python3.2/lib-dynload/_dbm.cpython-32.so (dev-lang/python-3.2.5-r2)
 *      used by /usr/lib64/python3.3/lib-dynload/_dbm.cpython-33.so (dev-lang/python-3.3.3)
Use emerge @preserved-rebuild to rebuild packages using these libraries
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.




Quellcode

1
2
3
4
5
localhost andreas # emerge @preserved-rebuild
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-lang/ruby:1.8".
(dependency required by "@preserved-rebuild" [argument])
Ullrich Andreas
Meine Konfiguration:
x86_64/Gentoo-13/gcc Version 4.6.3/KDE-Version 4.12.5/Kernel version 3.7.10
Graphic: 2x Nvidia 9600-GT OC SLI,Drucker: Samsung CLP-315W

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »andreasullrich« (20.09.2014, 22:59)


7

20.09.2014, 23:14

Quellcode

1
emerge -av1 =gnome-base/gvfs-1.18.3-r1

Quellcode

1
emerge -avuDN world --keep-going


@preserved-rebuild kannst du machen wenn das world Update fertig durch ist.

dev-lang/ruby:1.8 solltest du deinstallieren (gibt es im Tree schon gar nicht mehr (siehe dazu auch in den News))

8

21.09.2014, 12:21

ruby ist erledigt. :)


world-update bricht mit splashutils ab.
Einzelinstallation auch nicht möglich.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
emerge -av splashutils

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-gfx/splashutils-1.5.4.4-r1  USE="fbcondecor gpm mng png truetype -hardened" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) media-gfx/splashutils-1.5.4.4-r1
 * splashutils-lite-1.5.4.4.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                              [ ok ]
 * splashutils-gentoo-1.0.17.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                             [ ok ]
 * miscsplashutils-0.1.8.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                                 [ ok ]
 * libpng-1.4.3.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                                          [ ok ]
 * jpegsrc.v8a.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                                            [ ok ]
 * freetype-2.3.12.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                                       [ ok ]
 * zlib-1.2.3.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                                                                                                                                                                            [ ok ]
>>> Unpacking source...
>>> Unpacking splashutils-lite-1.5.4.4.tar.bz2 to /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Unpacking splashutils-gentoo-1.0.17.tar.bz2 to /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Unpacking miscsplashutils-0.1.8.tar.bz2 to /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Unpacking libpng-1.4.3.tar.bz2 to /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Unpacking jpegsrc.v8a.tar.gz to /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Unpacking freetype-2.3.12.tar.bz2 to /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Unpacking zlib-1.2.3.tar.bz2 to /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Source unpacked in /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work
>>> Preparing source in /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/splashutils-1.5.4.4 ...
 * Applying splashutils-1.5.4.4-gentoo-typo-fix.patch ...                                                                                                                                                                             [ ok ]
 * Applying splashutils-1.5.4.4-freetype-bz2.patch ...                                                                                                                                                                                [ ok ]
 * Applying splashutils-1.5.4.4-bzip2.patch ...                                                                                                                                                                                       [ ok ]
 * Running eautoreconf in '/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/splashutils-1.5.4.4' ...
 * Running libtoolize --install --copy --force --automake ...                                                                                                                                                                         [ ok ]
 * Running aclocal -I m4 ...                                                                                                                                                                                                          [ ok ]
 * Running autoconf ...                                                                                                                                                                                                               [ ok ]
 * Running autoheader ...                                                                                                                                                                                                             [ ok ]
 * Running automake --add-missing --copy --force-missing ...                                                                                                                                                                          [ ok ]
 * Running elibtoolize in: splashutils-1.5.4.4/
 *   Applying portage/1.2.0 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.4.2 patch ...
 *   Applying target-nm/2.4.2 patch ...
 * Running elibtoolize in: splashutils-1.5.4.4/libs/freetype-2.3.12/
 * Running elibtoolize in: splashutils-1.5.4.4/libs/freetype-2.3.12/builds/unix/
 *   Applying portage/2.2 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.2.6 patch ...
 *   Applying target-nm/2.4.2 patch ...
 * Running elibtoolize in: splashutils-1.5.4.4/libs/jpeg-8a/
 *   Applying portage/2.2 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.2.6 patch ...
 *   Applying target-nm/2.4.2 patch ...
 * Running elibtoolize in: splashutils-1.5.4.4/libs/libpng-1.4.3/
 *   Applying portage/2.2 patch ...
 *   Applying sed/1.5.6 patch ...
 *   Applying as-needed/2.2.6 patch ...
 *   Applying target-nm/2.4.2 patch ...
 * Running elibtoolize in: splashutils-1.5.4.4/libs/zlib-1.2.3/
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/splashutils-1.5.4.4 ...
make -j3 CC=x86_64-pc-linux-gnu-gcc LIB=lib64 STRIP=true 
x86_64-pc-linux-gnu-gcc -march=core2 -O2 -pipe -fomit-frame-pointer -Wl,-O1 -Wl,--as-needed fbres.c -o fbres
x86_64-pc-linux-gnu-gcc -march=core2 -O2 -pipe -fomit-frame-pointer -Wl,-O1 -Wl,--as-needed usleep.c -o usleep
true usleep
true fbres
make[1]: Entering directory `/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/miscsplashutils-0.1.8/fbtruetype'
x86_64-pc-linux-gnu-gcc -march=core2 -O2 -pipe -fomit-frame-pointer -I/usr/include/freetype2   -c -o fbtruetype.o fbtruetype.c
x86_64-pc-linux-gnu-gcc -march=core2 -O2 -pipe -fomit-frame-pointer -I/usr/include/freetype2   -c -o messages.o messages.c
x86_64-pc-linux-gnu-gcc -march=core2 -O2 -pipe -fomit-frame-pointer -I/usr/include/freetype2   -c -o console.o console.c
x86_64-pc-linux-gnu-gcc -march=core2 -O2 -pipe -fomit-frame-pointer -I/usr/include/freetype2   -c -o ttf.o ttf.c
x86_64-pc-linux-gnu-gcc -march=core2 -O2 -pipe -fomit-frame-pointer -I/usr/include/freetype2   -c -o luxisri.o luxisri.c
ttf.c:16:30: schwerwiegender Fehler: freetype/ftoutln.h: Datei oder Verzeichnis nicht gefunden
Kompilierung beendet.
make[1]: *** [ttf.o] Fehler 1
make[1]: *** Warte auf noch nicht beendete Prozesse...
make[1]: Leaving directory `/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/miscsplashutils-0.1.8/fbtruetype'
make: *** [all] Fehler 2
emake failed
 * ERROR: media-gfx/splashutils-1.5.4.4-r1::gentoo failed (configure phase):
 *   failed to build miscsplashutils
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called src_configure
 *   environment, line 2856:  Called die
 * The specific snippet of code:
 *       emake CC="${CC}" LIB=$(get_libdir) STRIP=true || die "failed to build miscsplashutils";
 * 
 * If you need support, post the output of `emerge --info '=media-gfx/splashutils-1.5.4.4-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-gfx/splashutils-1.5.4.4-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/miscsplashutils-0.1.8'
 * S: '/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/splashutils-1.5.4.4'

>>> Failed to emerge media-gfx/splashutils-1.5.4.4-r1, Log file:

>>>  '/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/temp/build.log'

 * Messages for package media-gfx/splashutils-1.5.4.4-r1:

 * ERROR: media-gfx/splashutils-1.5.4.4-r1::gentoo failed (configure phase):
 *   failed to build miscsplashutils
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called src_configure
 *   environment, line 2856:  Called die
 * The specific snippet of code:
 *       emake CC="${CC}" LIB=$(get_libdir) STRIP=true || die "failed to build miscsplashutils";
 * 
 * If you need support, post the output of `emerge --info '=media-gfx/splashutils-1.5.4.4-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-gfx/splashutils-1.5.4.4-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/miscsplashutils-0.1.8'
 * S: '/var/tmp/portage/media-gfx/splashutils-1.5.4.4-r1/work/splashutils-1.5.4.4'
Ullrich Andreas
Meine Konfiguration:
x86_64/Gentoo-13/gcc Version 4.6.3/KDE-Version 4.12.5/Kernel version 3.7.10
Graphic: 2x Nvidia 9600-GT OC SLI,Drucker: Samsung CLP-315W

9

21.09.2014, 13:53

world-update bricht mit splashutils ab.

Ja, splash-utils. Mit den USE-Flags wird das auch nichts. Da gab es vor kurzem eine Diskussion hier SplashUtils und USE-Flags - Horror. Ich habe es mittlerweile gelöscht. Das Paket wird auch meines Wissens mit mehr weiter entwickelt. Selbst die angegebene Website ist schon weg....

Wenn emerge abbricht kannst du auch mit emerge --resume --skip-first weitermachen. Meistens geht das, wenn es nicht gerade ein wichtiges Paket ist was Probleme macht. Und splash-utils ist das ja nicht.

Deine Probleme sind auch etwas hausgemacht. Wenn du lange keine Updates machst und die News nicht ließt dann summieren sich die Schwierigkeiten. Was auch Probleme macht ist, das die ebuild Macher manche ebuilds einfach ändern ohne eine neue Revision zu erstellen. Im ebuild kann man das meist sehen. Dort steht (meist) eine Version des ebuild. Wenn du deine Installierten mit den noch vorhandenen vergleichen würdest ist keins mehr so wie es bei der Installation war. Dann kommt es zu Abhängigkeiten die es nicht mehr gibt usw.

Wenn das System recht alt ist und emerge nicht mehr freiwillig ein Update macht hilft meist das Update der einzelnen Programme. Das geht u.a. mit der netten for-Schleife. Das macht man so lange bis emerge -uDN @world wieder geht... Wichtig ist aber auch die NEWs lesen. Manche Pakete sind nicht mehr nötig und müssen gelöscht werden.

Quellcode

1
for x in $(eix -I | grep "\[U" | cut -d' ' -f2); do emerge -1 --keep-going $x; done
Intel Core2 Quad CPU @ 2.40GHz mit Gentoo/Gnome3

Eigenes Gentoo System auf CD oder USB

10

21.09.2014, 14:08

Jup, splashutils sollte mit der genannten emerge Option --keep-going fürs world Update zunächst erst mal kein Problem sein.
(da kannst du dich später drum kümmern).