Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

28.11.2014, 22:46

gnome-shell nicht mit networkmanager

Hi,
nach dem letzten worldupdate ging gnome-shell nur noch ohne networkmanager zu emergen. Auch zwei syncs später habe ich kein en Erfolg.

Quellcode

1
2
3
4
5
[ebuild   R    ] gnome-base/gnome-shell-3.12.2  USE="bluetooth i18n networkmanager* (-openrc-force)" PYTHON_TARGETS="python2_7" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] y


Quellcode

1
2
3
4
5
6
7
checking for NETWORKMANAGER... no
configure: error: Couldn't find NetworkManager.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/gnome-base/gnome-shell-3.12.2/work/gnome-shell-3.12.2/conf$
 ^[[31;01m*^[[0m ERROR: gnome-base/gnome-shell-3.12.2::gentoo failed (configure$
 ^[[31;01m*^[[0m   econf failed


Needless to say dass der natürlich installiert ist:

Quellcode

1
2
Calculating dependencies... done!
[ebuild   R    ] net-misc/networkmanager-0.9.8.10-r1  USE="bluetooth dhcpcd introspection modemmanager nss ppp systemd vala wext wifi -avahi -connection-sharing (-consolekit) -dhclient -gnutls -resolvconf {-test}" 0 kB


bugzilla kennt das nicht, jemand von euch?

Rüidger

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Regidür« (20.04.2015, 06:45)


2

01.12.2014, 10:44

http://www.dyle.org
IM-Account (Jabber!) sind auf meiner HP ...
There is no place like /home

http://www.gentooforum.de
http://www.gentoofreunde.org

<div>how to annoy a web developer?</span>

3

04.12.2014, 15:30

ja, das ist mein Fehler. Schade, dass keine Lösung dabei ist ;-)

Rüdiger

4

22.12.2014, 19:51

Fehler ist immer noch aktuell. NetworkManager ist übrigens nicht nur installiert, sondern auch gestartet:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
systemctl status NetworkManager
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib64/systemd/system/NetworkManager.service; enabled)
   Active: active (running) since Mo 2014-12-22 11:14:37 CET; 8h ago
 Main PID: 336 (NetworkManager)
   CGroup: /system.slice/NetworkManager.service
           ├─336 /usr/sbin/NetworkManager --no-daemon
           └─513 /sbin/dhclient -d -sf /usr/libexec/nm-dhcp-helper -pf /var/run/dhclient-enp2s0.pid -lf /var/lib/NetworkManager/dhclient-b2f813f6-ccee-4563-9263-...

Dez 22 19:30:45 eg-server NetworkManager[336]: <info>    address 192.168.0.76
Dez 22 19:30:45 eg-server NetworkManager[336]: <info>    plen 24 (255.255.255.0)
Dez 22 19:30:45 eg-server NetworkManager[336]: <info>    gateway 192.168.0.2
Dez 22 19:30:45 eg-server NetworkManager[336]: <info>    server identifier 192.168.0.2
Dez 22 19:30:45 eg-server NetworkManager[336]: <info>    lease time 3600
Dez 22 19:30:45 eg-server NetworkManager[336]: <info>    nameserver '192.168.0.2'
Dez 22 19:30:45 eg-server NetworkManager[336]: <info>    domain name 'localdomain'
Dez 22 19:30:45 eg-server NetworkManager[336]: DHCPREQUEST on enp2s0 to 192.168.0.2 port 67
Dez 22 19:30:45 eg-server NetworkManager[336]: DHCPACK from 192.168.0.2
Dez 22 19:30:45 eg-server NetworkManager[336]: bound to 192.168.0.76 -- renewal in 1623 seconds.


Rüdiger

5

05.01.2015, 09:59

Hat denn niemand sonst diesen Fehler? Mittlerweile kann ich auch nicht mehr mit

Quellcode

1
-networkmananger
flag emergen.
Auflaufende updates gehen jetzt auch nicht mehr wirklich, weil die gnome-shell Voraussetzung für verschiedene aktualisierte Pakete ist.

Rüdiger

6

05.01.2015, 14:37

Also bei mir lief es mit Gnome-3.12 und jetzt auch mit Gnome 3.14, wie man auf dem Screenshot sehen kann. Was passiert denn, wenn Du Gnome 3.14 zeitweise mal demaskierst? Ist das System sonst auch komplett sauber(revdep-rebuild, --uaDN --with-bdeps=y @world, depclean etc)? Wie sehen deine USE-flags aus?

Wie ich dem zweiten bugreport auf Funtoo entnehmen konnte, kam da aber auch keine Antwort drauf, ob der Fehler mit Gnome 3.14 auch auftritt. Da es bei Ihnen, aber auch nur mit Gnome statt Gnome-light auftritt, würde ich an deiner Stelle auch noch mal mit emerge --info, eix gnome und eix networkmanager mal deine USE_FLAGS genauer unter die Lupe nehmen.
»OCmylife« hat folgende Datei angehängt:

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »OCmylife« (05.01.2015, 14:43)


7

05.01.2015, 23:09

Das System kann ich aufgrund des Fehlers nicht in einen sauberen Zustand bringen. Der Fehler tritt auch beim Versuch auf, 3.14 zu installieren.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
emerge --info
Portage 2.2.14 (python 3.3.5-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-4.8.3, glibc-2.19-r1, 3.18.1-gentoo x86_64)
=================================================================
System uname: Linux-3.18.1-gentoo-x86_64-AMD_Athlon-tm-_II_X4_630_Processor-with-gentoo-2.2
KiB Mem:    12303292 total,    974016 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Sun, 04 Jan 2015 10:15:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p53
dev-java/java-config:     2.2.0
dev-lang/perl:            5.18.2-r2
dev-lang/python:          2.7.9-r1, 3.3.5-r1, 3.4.1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3-r1, 1.11.6-r1, 1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo elementary jmesmon hnaparst jtriley Rudis
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.netcologne.de/gentoo/"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/elementary /var/lib/layman/jmesmon /var/lib/layman/hnaparst /var/lib/layman/jtriley /usr/local/portage/overlay"
SYNC="rsync://rsync5.de.gentoo.org/gentoo-portage"
USE="(-selinux) X a52 aac acl acpi alsa amd64 apache2 berkdb bluetooth branding bzip2 cairo cdda cdr cli colord cracklib crypt cups cxx dbus dri dts dvd dvdr eds emboss encode evo exif fam ffh264vdpau firefox flac fortran gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk gtk3 iconv introspection ipv6 jpeg lcms libnotify libsamplerate libsecret lm_sensors mad minizip mmx mng modules mono mp3 mp4 mpeg multilib mysql nautilus ncurses nls nptl ogg opengl openmp pam pango pcre pdf php pipe png policykit ppds pulseaudio python qt3support qt4 readline sdl session socialweb spell sse sse2 ssl startup-notification svg systemd tcpd telepathy threads thunderbird tiff truetype udev udisks unicode upower usb vaapi vala vdpau vorbis winbind wxwidgets x264 xcb xml xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="rme96" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile unixd socache_shmcb authn_core authz_core authm_core authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif speling status unique_id userdir usertrack vhost_alias mod_access xml python nls ubicode postgres cgi cgid" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DVB_CARDS="af9005" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="i386" QEMU_USER_TARGETS="i386" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

8

07.01.2015, 22:54

Ich habe jetzt gnome-shell gekeyworded, und dann mit USE="-networkmanager" bauen können. Jetzt bekomme ich beim Starten von gdm dn berühmten 'oh no...' Screen.
Mir kam ohnehin schon merkwürdig vor, dass ich so viele Pakete keyworden musste. Wie komme ich jetzt wieder an ein lauffähiges System? package.accept_keywords löschen und so lange Pakete aus dem worldfile entfernen, bis ein worldupdate sauber durchläuft?

Rüdiger

Quellcode

1
2
3
4
5
6
7
8
9
Jan 07 23:05:58 eg-server gdm-Xorg-:0[7370]: (==) AIGLX enabled
Jan 07 23:05:58 eg-server gdm-Xorg-:0[7370]: (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
Jan 07 23:05:58 eg-server gdm-Xorg-:0[7370]: (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
Jan 07 23:05:58 eg-server gdm-Xorg-:0[7370]: (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
Jan 07 23:05:58 eg-server gdm-Xorg-:0[7370]: (II) AIGLX: Screen 0 is not DRI2 capable
Jan 07 23:05:58 eg-server gdm-Xorg-:0[7370]: (EE) AIGLX: reverting to software rendering
Jan 07 23:05:58 eg-server gdm-Xorg-:0[7370]: (EE) AIGLX error: dlopen of /usr/lib64/dri/swrast_dri.so failed (/usr/lib64/dri/swrast_dri.so: undefined symbol: _glapi_tls_Dispatch)
Jan 07 23:05:58 eg-server gdm-Xorg-:0[7370]: (EE) GLX: could not load software renderer
Jan 07 23:05:58 eg-server gdm-Xorg-:0[7370]: (II) GLX: no usable GL providers found for screen 0


Der Fehler sollte laut vielen Google-Ergebnissen durch neubauen von nvidia-drivers erledigt sein, ist er aber leider nicht...

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Regidür« (07.01.2015, 23:23)


9

07.01.2015, 23:21

Habe deinen ersten Post nochmal gelesen und heute kommt er mir doch recht bekannt vor. Hatte diesen Fehler zwar nicht bei der Gnome-Shell die den Networkmanger nicht fand sondern bei anderen Paketen. Aber, obwohl die Programme installiert waren, waren die Dateien unter /usr/include/... nicht erreichbar. Habe leider nicht nachgesehen ob die Dateien wirklich nicht vorhanden waren oder nur was mit der/einer Konfiguration nicht stimmt. Ich habe dann die angeblich fehlende Pakete (bei dir der NetworManger) manuell neu installiert und dann ging es weiter und weiter bis alles fehlende installiert war. Hatte so einen Fehler auch noch nie! Sicherheitshalber hatte ich das System auf diesem Rechner komplett mit emerge -e @world neu gebaut.
Intel Core2 Quad CPU @ 2.40GHz mit Gentoo/Gnome3

Eigenes Gentoo System auf CD oder USB

10

08.01.2015, 00:17

das geht zunächst tatsächlich!

Quellcode

1
warning: 'clutter_texture_set_cogl_texture' is deprecated 


Dann kommt aber beim emake ein neuer Fehler. Uff, jetzt aber keine Lust mehr...

Rüdiger

11

17.04.2015, 20:52

Bei configure Fehler hilft es meist (wie von portage vorgeschlagen) auch mal ins config.log zu schauen Dort sind meist genauere Informationen zu finden.

Im config.log schaut es wahrscheinlich so aus -->

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
configure:19071: checking for NETWORKMANAGER
configure:19081: $PKG_CONFIG --exists --print-errors "libnm-glib
                     libnm-util >= $NETWORKMANAGER_MIN_VERSION
                     libnm-gtk >= $NETWORKMANAGER_MIN_VERSION
                     libsecret-unstable"
Package libnm-gtk was not found in the pkg-config search path.
Perhaps you should add the directory containing `libnm-gtk.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libnm-gtk' found
configure:19087: $? = 1
configure:19107: $PKG_CONFIG --exists --print-errors "libnm-glib
                     libnm-util >= $NETWORKMANAGER_MIN_VERSION
                     libnm-gtk >= $NETWORKMANAGER_MIN_VERSION
                     libsecret-unstable"
Package libnm-gtk was not found in the pkg-config search path.
Perhaps you should add the directory containing `libnm-gtk.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libnm-gtk' found
configure:19113: $? = 1
configure:19130: result: no
No package 'libnm-gtk' found
configure:19179: error: Couldn't find NetworkManager.

Vermisst wird hier die libnm-gtk.so welche mit gnome-extra/nm-applet kommt,
sprich vorher gnome-extra/nm-applet mergen sollte wahrscheinlich funktionieren.

Mitlerweile gibt es dazu auch einen Bugreport (aktuell noch ungefixt), siehe https://bugs.gentoo.org/show_bug.cgi?id=546606

12

19.04.2015, 18:09

nm-applet ist bereits installiert.


Rüdiger

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Regidür« (19.04.2015, 18:19)


13

19.04.2015, 23:19

Magst du bitte das conf.log (so wie von portage empfohlen) mit bereitstellen (am besten das komplette, als Dateianhang).

14

20.04.2015, 06:45

Das problem ist verschwunden, ich konnte gnome-shell gerade wieder mit den networkmanager emergen.

Rüdiger