Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

01.01.2016, 22:56

Rauschen des Bildes bei Last, DVBSky S952 mit Kernel 4.1, Treiber schon inkludiert... wie jetzt?

Hallo Leute,

ich verlinke hier auf einen Beitrag im VDRforum den ich gerade geschrieben habe, da er doch etwas Getnoo spezifisch ist. http://www.vdr-portal.de/board18-vdr-har…iert-wie-jetzt/

Falls ihr dazu eine Idee habt bitte teilt mir das mit. Ich poste die Ergebnisse natürlich auch im VDRforum.

Vielen Dank und lg
boospy

Zitat

ich habe meinen VDRserver seit letztes Jahr, glaub im Februar am laufen.
-HDvdr mit der DVBSky S952 "01:00.0 Multimedia video controller: Conexant Systems, Inc. CX23885 PCI Video and Audio Decoder (rev 04)"
-System Gentoo mit Kernel 3.12.38 als VM auf Proxmox (KVM)
-Treiber, Kernelmodul und Firmware von dvbsky.net

Nun hab ich immer wieder mal so flackern und Bildaussetzer, ganz sporadisch, bei Last am Server (da genügt ein "eix -I") also i/O und CPU. Nur CPU macht garnix. Das nervt dann doch auf die Dauer. Also hab ich mal das ganze System upgedatet, läuft alles soweit, leider noch die gleichen Fehler. Der Vorteil: Diese Fehlermeldung von hier Komische Meldung in den Logs ist jetzt mal weg. Ich dann natürlich auch den VDRprozess mal auf nice -20 gesetzt. Aber das gab keine Änderung. Das auch mal alle paar Wochen passierte ist das sich der Prozess aufhängt. Alle Ports was VDR betreffen sind dann zu. Der Dienst selbst läuft aber noch, aber auf 100%.

Kernel habe ich 4.1.12 LTS. Mir ist aufgefallen das die Treiber für die genannte Karte bereits im Kernel inkludiert sind. Find ich mal gut. Hab mir dann die aktuelle Firmware von der Homepage gesaugt. Dann funzte die Karte mit dem Kernel sofort. VDR Version benutze ich 2.2.0 aus Portage. Das Verhalten das der Dienst auf 100% geht und sich aufhängt kann ich für kernel 4.1 natürlich noch nicht bestätigen da der ja noch ganz frisch ist. ;D


Hier ein kurzes Testvideo wo man das Rauschen sieht: http://tux.osit.cc/public/0001.ts
Das hab ich hier mit "emerge -vpuDNkg world" reproduziert. Nach der Eingabe des Befehls dauert es nur 2 Sekunden bis das Rauschen anfängt. I/O Last liegt dann bei 20%. Würde es event. helfen die VM auf einen eigenen SSD Speicher zu schieben? Konnte das leider nicht testen da ich im Server nur 6 SATA (WD RED PRO 7200 mit ZFS im Raid10) eingebaut habe. Mehr Platten dazustecken würde da wohl auch nicht so viel bringen... glaub ich zumindest.

Hat denn jemand das Problem auch so wie ich hier? Ich würde es gerne lösen. Hab am Kernel nun mal als Desktopkernel (1000mhz) gebacken. Dachte mir das hilft vielleicht. Hatte vorher das ganze als low latency gebaut. Gibt es event. Optimierungen für den Zweck VDR.

Wie ist denn eurer Erfahrung nach überhaupt der Stand? Kernel 4.1 mit ingegriertem Treiber oder doch das Mediabuild von der Homepage. Die Firmware von der Homepage, oder es gebe auch diese in Portage: media-tv/linuxtv-dvb-firmware-2009.09.19 die wohl zu alte sein wird ;) oder event. ist die richtige da dabei: sys-kernel/linux-firmware-20150812
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »boospy« (12.04.2016, 22:43)


2

02.01.2016, 14:18

Ich habe ne usb Version von dvb sky ich verwende aber kein Gentoo dafür sondern OpenELEC ....
Eventuell findest du hier irgendwelche hinweise oder Tipps die dir weiterhelfen !?

Das einzige was ich auch mitbekommen habe ist das alte Nvidia Grafikkarten beschissen unterstützt werden ....
''''''''''''''''''''''''''''''''''''''''''''''''
Gentoo-Linux
der G-Punkt eines Pc´s

''''''''''''''''''''''''''''''''''''''''''''''''

3

04.01.2016, 09:39

Hab mit DVB und so zwar keine Erfahrung, aber wenn das Problem durch hohe IO-Last reporduzierbar ist, könntest Du ja neben "nice" noch mit "ionice" versuchen dem VDR eine höhere IO-Priorität zu geben.

Quellcode

1
ionice -c 1 -p \${VDR_PID}
Der zweite Versuch wäre mit "-c 0".

Etwas OT: Portage kennt in der make.conf auch

Quellcode

1
2
PORTAGE_NICELESS=20
PORTAGE_IONICE_COMMAND="ionice -c 3 -p \${PID}"
Damit stören die Aktualisierungen die "normale Nutzung" des Systems fast gar nicht.
Auch wenn Open-Source kostenlos ist, ist sie nicht umsonst. Dein Preis ist Dein Engagement und Mitarbeit an OS-Projekten.
Wenn Du keinen Preis bezahlen willst, bist Du die Ware. Und das ist nicht Open Source, geschweigedenn frei.

4

04.01.2016, 23:59

Hallo Leute,

hab die Portagenicewerte aktiviert. Gesetzt waren sie ja, aber auskommentiert. Das IO für den VDRprozess konnte ich nicht setzten.

Quellcode

1
2
ionice -c 1 -p \${VDR_PID} 
ionice: ungültiges PID-Argument: '${VDR_PID}'

Ich habs dann direkt auf die laufende PID gesetzt. Leider alles ohne merkenswerte Auswirkungen. Ich habs aber nun nachvollziehbar gelöst. Kann man die Nicewerte für VDR wo statisch setzen? Im VDR Startscript von Systemd habe ich jetzt nichts gefunden.

1. War das Antennenkabel an der Karte etwas locker, deshalb war der Empfang laut "femon" nur auf 48% und der Wert "ber" war bei 34235236. Der sollte "0" sein. Nachdem ich das Kabel wieder feststeckte, war der Empfang auf 96-98% und der Wert bei "ber" tatsächliche auf "0". Trotzdem ist des nur ein wenig besser geworden.

2. Die sich positiv auswirkende Maßnahme war die virtuelle Maschine auf das SSD Raid zu verschieben. Seit dem ist das Rauschen völlig verschwunden. Auch ein eix oder so juckt jetzt überhaupt nicht mir. Glasklares Bild. Die VM kann da drauf jetzt zwar nicht bleiben, ist der Teil für das OS. Aber für's erste passt das mal.

So, nun hab ich mir gedacht was sich verändert hat, immerhin hat es ja schon mal funktioniert. Ab und zu, ja ganz selten gab es ein Rauschen. Ich denke mir ich weis auch die Ursache. Am Anfang wie ich das alles gebaut hatte, hatte ich nur 4 Festplatten (WED RED Pro). Nach einiger Zeit wurde eine Festplatte kaputt (wohl Materialfehler). Ich hatte noch eine WD GREEN da, also tauschte ich diese mal so aus. Hab dann die RED ausgetauscht bekommen, diese aber nie mehr mit der GREEN ersetzt. Ok... nach einiger Zeit habe ich das ZFS Raid10 mit 2 weitern Festplatten erweitert. Blöderweise wieder mit WD GREEN weil noch zwei da waren vom alten Server. Jetzt vermute ich mal das es an den Drehzahlen liegt. Die GREEN dreht nur mit 5400 rpm und die Red mit 7200 rpm. Jetzt sind 3 GREEN und 3 RED im Verbund. Ist wohl Suboptimal für SpezialVMs.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
=== START OF INFORMATION SECTION ===
Model Family:     Western Digital Green
Device Model:     WDC WD20EARX-00ZUDB0
Serial Number:    WD-WCC1H0343538
LU WWN Device Id: 5 0014ee 601e41d62
Firmware Version: 80.00A80
User Capacity:    2,000,398,934,016 bytes [2.00 TB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    5400 rpm
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA8-ACS (minor revision not indicated)
SATA Version is:  SATA 3.0, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Mon Jan  4 23:23:18 2016 CET
SMART support is: Available - device has SMART capability.
SMART support is: Enabled


=== START OF INFORMATION SECTION ===
Model Family:     Western Digital Red Pro
Device Model:     WDC WD2001FFSX-68JNUN0
Serial Number:    WD-WMC5C0D688XW
LU WWN Device Id: 5 0014ee 003f548a4
Firmware Version: 81.00A81
User Capacity:    2,000,398,934,016 bytes [2.00 TB]
Sector Sizes:     512 bytes logical, 4096 bytes physical
Rotation Rate:    7200 rpm
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   ATA8-ACS (minor revision not indicated)
SATA Version is:  SATA 3.0, 6.0 Gb/s (current: 6.0 Gb/s)
Local Time is:    Mon Jan  4 23:23:43 2016 CET
SMART support is: Available - device has SMART capability.
SMART support is: Enabled


Ich glaube wenn ich die tausche, und alles RED PRO habe, wird es auch da drauf funzen. Für die anderen VMs war die Drehzahl nicht das wichtigste Thema, da war die Sectorsize das wichtigste. Ausserdem gibt es hier nur Gigabit und kein 10 Gigabit.

lg
boospy
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at

5

12.04.2016, 22:42

So, hab nun alles auf RedPro getauscht, es ist viel besser, aber SSD ist einfach noch besser. Wer mir hierfür noch ne eigene SSD einbauen. Dann wirds passen. Schön empfindlich ne VDR in ner VM.... ;)
Gentoo Can Do!
>>>> boospy@jabber.ccc.de <<<<
Wiki auf: http://deepdoc.at