Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

31.12.2016, 16:39

Xorg -configure erstellt keine Konfiguration, startx läuft nur unkonfiguriert

Hallo,

ich bin nach etwa 10 Jahren mal wieder zu gentoo zurückgekehrt, bin also nicht mehr gerade "auf dem Laufenden". Ich habe einen ASUS EeePC 1215N und so weit lief auch alles ganz gut (abgesehen von laaaangen Compile-Zeiten). Nun will aber Xorg nicht so recht. So erstellt mir "Xorg - configure" etwa keine Konfigurationsdatei. Ich gehe wie hier im sticky vorgeschlagen vor:

Quellcode

1
2
3
grep -e EE -e WW Xorg.0.log 
[	31.751] Current Operating System: Linux ben 4.9.0-rc6-next-20161125 #18 SMP PREEMPT Fri Dec 9 20:41:36 CET 2016 x86_64
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.




Alles endet mit

Quellcode

1
[	32.063] No devices to configure.  Configuration failed.


und ich erhalte keine xorg.conf. Auch wenn ich mit "startx" versuche zu starten meldet mir mein Window-Manager (LXDE),
dass die Server-Verbindung verloren gegangen sei (steht aber nur in einer Message-Box). Maus und Tastatur funktionieren auch nicht so recht (ok, die Tastatur wird mit dem falschen Layout betrieben wegen der fehlenden xorg.conf). Ich habe aber auch eine Funk-USB-Maus, die ich nicht benutzen kann, also von Xorg nicht erkannt wird. lsusb zeigt sie mir aber an. Mein Touchpad funktioniert eingeschränkt (z.B. das Scrollen an der Seite funkioniert gar nicht).

Ich würde mich sehr freuen, wenn man mir hier weiterhelfen könnte.


Ich wünsche euch Allen ein schönes neues Jahr und einen guten Rutsch!


Und natürlich vielen Dank im Voraus :thumbsup:

EDIT:

In meiner Log-Datei steht unten

Quellcode

1
2
[	32.063] (II) modeset(G1): using drv /dev/dri/card1
[	32.063] (II) modesetting: Driver for Modesetting Kernel Drivers: kms


und weiter oben sehe ich

Quellcode

1
2
[	31.756] (II) xfree86: Adding drm device (/dev/dri/card0)
[	31.757] (II) xfree86: Adding drm device (/dev/dri/card1)
.


Verwechselt Xorg evtl. meine Karten, also etwa die integrierte Intel-Karte, die ja verwendet werden sollte, mit der Nvidia-Karte die, so weit ich verstehe, nur für Nvidia Optimus Anwendung finden sollte?
Oder stimmt das so alles? ?( Ich verstehe das nicht si ganz.

Ich benutze den Intel-Treiber und den Nouveau-Treiber, respektive (in Kernel und xorg-drivers).

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »DecadeN00b« (31.12.2016, 18:47)


2

01.01.2017, 10:29

Ich habe gentoo in Virtualbox installiert.

Nach dem letzten Update vor einer Woche etwa ist "/etc/init.d/xdm start" ohne Wirkung geblieben.

Als ich vorhin deinen Thread gelesen habe, wollte ich wissen, ob bei mir auch ohne xorg.conf etwas passiert.

Ich habe die xorg.conf von /etc/X11 nach /root/tmp verschoben (nur zur Sicherheit nicht gelöscht).

Jetzt startet xdm problemlos und ich kann mich wieder auf dem Desktop einloggen.

Fazit: offensichtlich wird keine xorg.conf mehr benötigt.

Gruß Manfred und ein gutes neues Jahr.

3

01.01.2017, 15:09

Hi Windhund,

nein, ich denke das ist ein anderes Problem: xorg-server ist so konfiguriert, dass er out-of-box (also mit startx z.B.) immer laufen sollte. Ohne xorg.conf funktioniert vieles und viele Geräte aber nicht so wie sie sollten (z.B. meine USB-Maus, ich habe ein englisches Tastaturlayout...).
Natürlich muss man nichts konfigurieren, wenn einem denn der "minimalistische out-of-box-modus" reicht. Wem das nicht reicht, der braucht aber eine funktionierende xorg.conf die

Quellcode

1
Xorg -configure
zumindest größtenteils erzeugen sollte.


Grüße,
N00b

4

01.01.2017, 16:18

Wenn das so ist, dann frage ich mich auch, warum keine xorg.conf mehr erstellt werden kann bzw. warum die bestehende keinen Start von sddm/xdm zuläßt.

Ich bin gerade dabei, den neuesten Kernel zu installieren: 4.9.0 - bin gespannt, ob sich die Virtualbox-Module installieren lassen.
Und natürlich, ob danach auch wieder der KDE-Desktop erreichbar ist.

Gruß
Manfred

5

03.01.2017, 19:42

Hi

Das EEE ist ja schon etwas älter, Schau mal hier, da wird beschrieben das es geht und wie man X und den Kernel einstellt. Ist zwar von Arch sollte aber mehr oder weniger übertragbar sein. https://wiki.archlinux.org/index.php/ASUS_Eee_PC_1215n

Für die Konfiguration von X gibt es eine Beschreibung hier: https://wiki.gentoo.org/wiki/Xorg/Guide/de
Intel Core2 Quad CPU @ 2.40GHz mit Gentoo/Gnome3

Eigenes Gentoo System auf CD oder USB