Sie sind nicht angemeldet.

1

21.03.2017, 00:21

emerge: there are no ebuilds to satisfy ">=dev-qt/qtquick1-5.5.0:5"

Mahlzeit!

Wenn ich emerge -uDN @world durchführen will kommt diese Fehlermeldung:

Quellcode

1
emerge: there are no ebuilds to satisfy ">=dev-qt/qtquick1-5.5.0:5"


Wie kommt das? Brauche ich dafür etwa ein Overlay?

2

22.03.2017, 15:22

So wie es aussieht wurde qtquick1 aus dem tree entfernt, wahrscheinlich weil es in ein anders packet gewandert ist , und somit nicht mehr gebraucht wird. Wenn ich nämlich qt-creator starte und auf neues Projekt gehe, kann ich da Qtquick anwendung auswählen, also sollte das vorhanden sein, und bei mir ist kein qtquick1 installiert.
Solltest du einfach mit

Quellcode

1
emerge --depclean qtquick1 

deinstallieren können, und trotzdem sollkte noch alles funktionieren

3

22.03.2017, 17:09

Das Problem ist, qt-meta will das installieren. Ich habe es gar nicht installiert.

4

23.03.2017, 00:42

gib mal die Ausgabe von

Quellcode

1
equery l *dev-qt*


und ob Dein system testing oder stable ist

5

23.03.2017, 07:45

Mein System ist testing und anscheinend habe ich gar nichts in dev-qt? Das finde ich jetzt irgendwie ungewöhnlich!

6

23.03.2017, 12:54

Sorry ich hab mich verschrieben Du musst

Quellcode

1
equery l *qt*

7

23.03.2017, 15:07

Dabei kommt das raus:

Quellcode

1
[IP-] [  ] app-eselect/eselect-qtgraphicssystem-1.1.1:0[IP-] [  ] dev-qt/qt-meta-4.8.6:4[IP-] [  ] dev-qt/qt3support-4.8.7:4[IP-] [  ] dev-qt/qtbearer-4.8.7:4[IP-] [  ] dev-qt/qtchooser-0_p20151008:0[IP-] [  ] dev-qt/qtconcurrent-5.7.1:5/5.7[IP-] [  ] dev-qt/qtcore-4.8.7-r2:4[I--] [??] dev-qt/qtcore-5.7.1-r1:5/5.7[IP-] [  ] dev-qt/qtdbus-4.8.7:4[IP-] [  ] dev-qt/qtdbus-5.7.1:5/5.7[IP-] [  ] dev-qt/qtdeclarative-4.8.7:4[IP-] [  ] dev-qt/qtgui-4.8.7:4[IP-] [  ] dev-qt/qtgui-5.7.1:5/5.7[IP-] [  ] dev-qt/qthelp-4.8.7:4[IP-] [  ] dev-qt/qtmultimedia-4.8.7:4[IP-] [  ] dev-qt/qtnetwork-5.7.1:5/5.7[IP-] [  ] dev-qt/qtopengl-4.8.7:4[IP-] [  ] dev-qt/qtopengl-5.7.1:5/5.7[IP-] [  ] dev-qt/qtprintsupport-5.7.1:5/5.7[IP-] [  ] dev-qt/qtscript-4.8.7:4[IP-] [  ] dev-qt/qtserialport-5.7.1:5/5.7[IP-] [  ] dev-qt/qtsql-4.8.7-r1:4[IP-] [  ] dev-qt/qtsql-5.7.1:5/5.7[IP-] [  ] dev-qt/qtsvg-4.8.7:4[IP-] [  ] dev-qt/qtsvg-5.7.1:5/5.7[IP-] [  ] dev-qt/qttest-4.8.7:4[IP-] [  ] dev-qt/qttranslations-4.8.7:4[IP-] [  ] dev-qt/qtwebkit-4.8.7:4[IP-] [  ] dev-qt/qtwebkit-5.7.1:5/5.7[IP-] [  ] dev-qt/qtwidgets-5.7.1:5/5.7[IP-] [  ] dev-qt/qtx11extras-5.7.1:5/5.7[IP-] [  ] dev-qt/qtxml-5.7.1:5/5.7[IP-] [  ] dev-qt/qtxmlpatterns-4.8.7:4

8

24.03.2017, 14:41

Ok das sieht soweit in Ordnung aus. Gib mir mal auch noch die Ausgabe von

Quellcode

1
emerge -pv qt-meta


dann mal falls hier auch qtquick rein will qtquick ohne Version maskieren nochmals emerge -pv qt-meta, und dann die ganzen required die dann gehagelt kommen werden auch noch dazugeben