Sie sind nicht angemeldet.

1

08.08.2017, 22:48

Neuinstallation von Gentoo-stable auf HD

Hallo zusammen,

ich bin dabei, Gentoo auf HD zu installieren.
Die Basis-Installation ist schon vorbei, auch das generelle Update nach erstem Start ist gut vorübergegangen.

Nun will ich kde-plasma/plasma-meta installieren.

Doch wird schon das zweite Paket polkit-pkla-compat nicht installiert - Fehler, der in der build.log zu suchen ist.
Sie befindet sich im Anhang.

Übrigens: es wundert mich, da ich vor 2 Tagen erst gentoo-stable ohne jeden Fehler in Virtualbox installiert hatte.
Warum nun ausgerechnet dieses Programm sich zum Störenfried aufspielt, ist mir ein Rätsel.

Gruß
Manfred
»Windhund« hat folgende Datei angehängt:
  • build-polkit.txt (27,15 kB - 2 mal heruntergeladen - zuletzt: 09.08.2017, 07:14)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Windhund« (10.08.2017, 07:12)


2

09.08.2017, 09:49

Nun kommt noch etwas dazu, was ich nicht nachvollziehen kann:

Wenn ich kde-plasma/plasma-meta eingebe, wird mir eine Liste von Paketen gezeigt,
die in package.use gespeichert werden sollen mit der Bezeichnung x64_32.

Ist das denn richtig, wenn ich stable installieren will und ich einen 64bit-Rechner habe?

Irgendwie komme ich nicht mehr zurecht damit. Oder verstehe ich da etwas falsch?

Denn bei der Installation in VirtualBox kommen diese Pakete in package.use nicht vor.

Habe ich möglicherweise irgendeine Einstellung falsch gemacht?

Ich hänge einmal die make.conf an, vielleicht liegt ja dort ein Problem.

Gruß
Manfred
»Windhund« hat folgende Datei angehängt:
  • make.conf.txt (882 Byte - 3 mal heruntergeladen - zuletzt: 14.08.2017, 19:12)

3

09.08.2017, 11:33

Nachdem immer mehr Merkwürdigkeiten auftauchten,
habe ich mich entschlossen, neu anzufangen und auf unstable umzusteigen.

Nun bin ich sehr gespannt, ob hier wenigstens alles so läuft, wie ich es mir vorstelle.

Gruß
Manfred

4

09.08.2017, 12:38

Es wäre schön, wenn Du Deine Anlagen mal mit wgetpaste erstellen würdest, das erleichtert das Lesen ungemein :)

Wenn ich Deine make.conf richtig gelesen habe, nutzt du die USE-Variable KDE für plasma.
Wenn ich das alles richtig verstanden habe, wirst Du damit wohl nie zum Ziel kommen

Zitat

The plasma profile now takes care of the right settings for a full-blown KDE Plasma/Applications installation. In the foreseeable future, this entails both Qt 4 as well as Qt 5 based packages. It also handles possible USE flag conflicts on a per-package basis. If there are any existing definitions of qt4, kde or plasma in /etc/portage/make.conf, make sure to remove them before proceeding, else conflicts may arise. Also, never set -minimal in /etc/portage/make.conf. In case of USE handbook, the recommendation is to either remove it as well, or disable it if the KDE documentation is not needed.
Der wichtige Satz ist:

Zitat

If there are any existing definitions of qt4, kde or plasma in /etc/portage/make.conf, make sure to remove them before proceeding, else conflicts may arise.
Ist zwar der Hinweis auf ein Upgrade, aber ich habe es bei der Neuinstallation so beherzigt.

Kannst du alles hier lesen https://wiki.gentoo.org/wiki/KDE/Plasma_5_upgrade#make.conf

Die USE-Variablen für Plasma findest Du hier: https://wiki.gentoo.org/wiki/KDE/de#Installation

5

09.08.2017, 13:12

Hallo sdoubleyou,

erst einmal danke, daß du dich auf meine - zugegeben - oft schnell dahingeschriebenen Dinge überhaupt eingelassen hast.

Was meinst du mit "wgetpaste" ?

Alles andere, was du mir da mitgeteilt hast, habe ich aufmerksam gelesen.
Da im Moment noch das Update der Basis-Installation läuft (317 Pakete),
habe ich schnell aus der make.conf qt4 und kde entfernt, in der Hoffnung,
daß es noch nicht zu spät ist. Eigentlich müßte ich das Update sofort unterbrechen und neu starten,
um die Änderungen wirken zu lassen.

Ja, ich bin in dieser Hinsicht streng nach der Gentoo-Anleitung vorgegangen.
Doch sehe ich ein, daß da solche Alternativen wie hier nicht angesprochen werden.

Ich werde nun weiter berichten, was passiert, und ich werde zu meinen Fehlern stehen.

Immerhin lerne ich immer wieder etwas dazu, was mir schon wichtig ist.

Danke also noch einmal.

Gruß
Manfred

6

09.08.2017, 13:31

Hallo Manfred,

wenn Du deine Basisinstallation beendet hast, bzw. du Dich in der chroot-Umgebung befindest, kannst du dir ja jedes Paket installieren.

wgetpaste ist ein sehr hilfreiches Tool um logs oder Inhalte von Dateien für andere lesbar zu posten https://wiki.gentoo.org/wiki/Wgetpaste
Sieht z.B. so aus[url]https://paste.pound-python.org/show/iADBUWgeOtKKLuJHhVWr/[/url]

Wenn Du die USE-Variablen richtig gesetzt hast, kannst Du auch wieder auf stable gehen bevor du plasma richtig angehst. Das bringt Dir bestimmt erst einmal mehr Ruhe ins Geschehen. ;) Wenn Du dann einzelne Pakete (wie z.B. cantata aus dem unstable-Bereich einsetzen möchtest, kannst Du sie ja in der /etc/portage/package.accept_keywordseinzeln definieren.

7

09.08.2017, 13:42

Nun lerne ich doch wirklich noch etwas dazu.

Das ist ja super, wie die Daten dann aussehen.

Das werde ich demnächst auch nutzen, um hier nicht solch ein Durcheinander zu liefern.

Übrigens: in den o.g. 317 Paketen sind schon einige kde-frameworks- Pakete dabei.
Das eigentliche Basis-Update hätte nur 37 Pakete umfaßt.

Also war ich einerseits zu schnell mit dem Update - bevor ich deine Ratschläge umsetzen konnte.
Andererseits zu langsam, weil schon 64 Pakete installiert sind, daß 65. ist gcc-6.4.0 - was ewig dauert.

Ich habe nun das Update weiterlaufen lassen.

Wenn die Reihe an plasma kommt, habe ich ja nun einen Einblick bekommen, was ich davon nutzen oder bleiben lassen soll.

Gruß
Manfred

8

09.08.2017, 17:02

Erste Zwischenmeldung:

Das große Update der Basis-Installation mit 317 Paketen ist fehlerlos durchgelaufen.

Nun habe ich statt kde-plasma/plasma-meta einmal mit plasma-desktop begonnen.
230 Pakete sind es diesmal, hauptsächlich noch viele kde-frameworks-Pakete.

Da auch - wie ich sehen konnte - etlich dev-qt-Pakete dazukommen, rechne ich mit einer langen
Laufzeit.

Daß ich diese Meldungen schreiben kann, ist meinem Notebook zu danken, das ich während der Installation von gentoo
nutzen kann.

Weitere Meldungen kommen, sollte es Unterbrechungen geben, oder wenn diese Installationen durch sind.

Gruß
Manfred

9

09.08.2017, 19:00

Ich sitze gerade vor dem PC.
Wir sind bei 243 von 262 Paketen gelandet.
Und wenn ich das richtig einschätze , dauert es noch eine ganze Weile.

Korrektur zum vorigen Text: nicht 230,
sondern 262 Pakete sind es.

Gruß Manfred

10

09.08.2017, 20:56

Also ich bin merkwürdig berührt, daß das Programm qtwebengine jetzt schon fast eine Stunde braucht. Das ist doch Wahnsinn.

Sorry, wenn ich das so schreibe. Aber es frustriert, wenn es nicht weitergeht.

11

09.08.2017, 22:22

Immerhin bin ich inzwischen auf dem Desktop gelandet.

Es ist noch nicht alles fertig, aber ich freue mich doch, daß es geklappt hat.

Gruß
Manfred

12

10.08.2017, 21:53

Heute habe ich VirtualBox installiert, einfach um zu sehen, ob das so geht mit plasma-Desktop.

In der VirtualBox installiere ich gerade gentoo-unstable nach den neuen Regeln, die ich hier kennengelernt habe.

Nun bin ich sehr gespannt, was dabei herauskommt. 296 Pakete sind nach der Basis-Installation dran,
davon ca 74 als reine Updates.

Im Moment ist gcc-6.4.0 an der Reihe, das dauert sehr lange, vermutlich lasse ich das über Nacht laufen.

Gruß
Manfred

13

11.08.2017, 18:37

Letzte Meldung in diesem Thread:

Ich konnte zwar gentoo in VirtualBox installieren,
aber als ich dann diese Installation startete und auf den Desktop gelangte,
konnte ich nichts mehr machen, vernutlich, weil zweimal plasma trotz 8 GB RAM und 8 CPUS
wohl doch etwas zu viel sind.

Gruß
Manfred

14

11.08.2017, 19:50

Zitat


Ich konnte zwar gentoo in VirtualBox installieren,
aber als ich dann diese Installation startete und auf den Desktop gelangte,
konnte ich nichts mehr machen, vernutlich, weil zweimal plasma trotz 8 GB RAM und 8 CPUS
wohl doch etwas zu viel sind.
Verstehe ich jetzt nicht. Was ist denn passiert?

15

11.08.2017, 19:58

Also folgendes:

Vor einiger Zeit habe ich schon einmal auf PCLinuxOS-plasma versucht, Gentoo in VirtualBox zu installieren,
doch da ist mein Computer irgendwann bei einem sehr aufwändigen Installationsprozess ausgegangen.

Jetzt bei Gentoo auf HD habe ich auch in VirtualBox gentoo installiert.

Als das Ganze fertig war, habe ich gestartet, landete auch auf dem Desktop,
aber dann habe ich versucht, das Menu zu öffnen, ging nicht, die Uhrzeit zu ändern, ging nicht.
Das System hat nicht reagiert auf irgendeine Maustätigkeit.

Das war passiert.

Wenn ich es auf meinem KDE4-Desktop laufen lasse, habe ich damit keinerlei Probleme.

Gruß
Manfred