Sie sind nicht angemeldet.

1

15.05.2019, 22:17

Anfänger hä.... emerge Forxlor

Hallo,
ich versuche mich aktuell MAL WIEDER an gentoo, ich finde gentoo von der Idee her sehr sehr schön.
Im gegenteil zu Debian immer aktuelle Software zu haben, warum ein Arch nutzen wenn ich die für mich interessante Software auch bei einem Arch aus dem AUR installieren muss, welches die Software auch dann Kompiliert bevor ich es nutzen kann... dann kann ich auch direkt ALLES direkt Kompilieren...
Jedoch habe ich ein paar Probleme wo ich IMMER wieder drüber stolper. Ich hoffe das Ihr nicht sagt noob geh weg und nimm weiter ne andere Distribution. Auch ein Chat bekannter den ich noch aus einem Linux IRC Chat kenne hat und auch in der Vergangenheit Gentoo genutzt hatte konnte mir nicht mehr so richtig Helfen.
Mein Grooooossseees Problem ist emerge :)
Ich verstehe noch nicht so ganz was emerge von mir verlangt und wie ich damit umgehen muss.

Aktuell stehe ich vor dem Problem das ich Froxlor installieren möchte. Dazu habe ich https://github.com/Froxlor/Froxlor/wiki/…oxlor-on-gentoo als Anleitung genommen.

Bis zu dem Punkt wo ich zu "emerge froxlor" komme klappt alles, ab da jedoch hänge ich.

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
* IMPORTANT: 15 news items need reading for repository 'gentoo'.
* Use eselect news read to view new items.

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=net-mail/dovecot-2.2.0[mysql,ssl=]".
!!! One of the following packages is required to complete your request:
- net-mail/dovecot-2.3.6::gentoo (Missing IUSE: ssl)
- net-mail/dovecot-2.3.5.2::gentoo (Missing IUSE: ssl)
- net-mail/dovecot-2.3.5.1::gentoo (Missing IUSE: ssl)
(dependency required by "www-apps/froxlor-0.9.40.1::froxlor" [ebuild])
(dependency required by "froxlor" [argument])

Okay Emerge sagt mir das Ihm useflags fehlen und die Pakete von dovecot diese vorraussetzen und .... äähhh ... HILFE ... was möchte emerge von mir was soll ich machen? Ich habe zwar bereits verusch in der make.conf in der Use Flag ssl hinzuzufügen, auch zu entfernen ... aber irgendwie ...... ???

ps: ich würde gerne bei emerge bleiben und kein eix oder derartiges nutzen.

Vielen dank im vorraus(Weitere Probleme womit ich noch in Zukunft sicher nerven möchte ist ein Kompiling Host, so das ich auf einen Raspberry emerge nutzen kann und distcc diesen an den AMD64 host weitergibt zum Kompilieren. Meine Probleme hoffentlich einmal komplett klären zum Unmasken von Paketen, festsetzen von Versionen (das diese nicht aktualisiert werden und immer auf der gleichen Version bleiben, Sollte sich jemand als Privater Mentor bereitstellen möchte den ich mit meinen emerge Problemen nerven darf würde mich das sehr freuen)

Armin

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Merlin2k11« (17.05.2019, 16:08)


2

17.05.2019, 16:08

Hallo,
die frage hat sich soeben gelöst. Im Gentoo Chat hat mir jemand eine Info für mein Problem gegeben...
Dovecot besitzt keine SSL Flag, somit ist das ebuild welches das gefordert hat wohl nicht korrekt gewesen.
Nach löschen von ssl als Useflag bei Dovecot funktioniert das Kompilieren von froxlor.