Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

11.05.2004, 10:59

Kriege ELSA AirLancer MC-2 nicht zum laufen

Hi

Ich habe grade eine ELSA AirLancer MC-2 geschenkt bekommen und würde sie gerne in einen alten Laptop für meine Mutti einsetzen.
Ich habe keine Ahnung von Wireless, sorry. Die Treiber für Kernel 2.4 sind unter http://mc2drv.berlios.de/ zu finden.

Hier ein auszug aus der Anleitung:

----------------snipp

this driver for the ELSA Airlancer MC-2 WLAN card was derived from the
original ELSA source for kernel 2.0.x, 2.2.x by Alfred Arnold.

1. Requirements
---------------

a) David Hinds PCMCIA package
b) a kernel 2.2.x or 2.4.x with correctly configured kernel sources

2. Actions
----------

a) Copy the tar archive (wl24n_cs-N.M.tgz) into the PCMCIA package's
root directory and untar it there.

b) Call
./Configure ; make ; make install (last step as root)
If you want to install a new config file /etc/pcmcia/AirLancer.conf,
call
make inst_etc
as well.

This should produce two files:
- /etc/pcmcia/Airlancer.conf (from "make inst_etc" only)
- /lib/modules/.../pcmcia/wl24_cs.o

c) Edit the Airlancer.conf file (see Configuration below)

d) Restart the cardmanager (e.g. killall -HUP cardmgr) and insert the
MC-2 card.


3. Configuration
----------------Snipp
Ich komme aber mit der installation nicht klar.
Wo finde ich den PCMCIA root? Damit geht es schon los.
Kann mir jemand da durch helfen?

Danke im vorraus.

nico

2

11.05.2004, 11:07

Nachtrag:
Mein Test-Laptop ist ein Siemens 510 AGP. Er ist komplett konfiguriert, was PCMCIA und Netzwerk betrifft. Ich setze eine PCMCIA 1389too Karte ein.
Die Elsa Airlancer wird auch beim einstecken vom Cardmgr erkannt.
Ich weiss "nur" nicht wie ich die Treiber einbinden soll. *kriese*

Danke

3

21.05.2004, 14:50

Wenigstens Treiber läuft schon mal [Elsa AirLancer MC-2]

<spott>
Ihr seid die Größten!!!
Diese Flut von Beiträgen, meine güte sind hier wieder eine Menge kompetente Leute unterwegs.
</spott>

So,
den Treiber habe ich, dank Hilfe von jemanden aus der Fli4l NG (Danke Sebastian), endlich zum Laufen gebracht.
Da ich von Wireless keine Ahnung habe, stehe ich wieder bisschen ratlos da.
Ich kriege mich zwar am AP angemeldet aber kriege keine IP per DHCP. Setze ich sie per Hand, bleibt alles unerreichbar. Kann das an meinen AP liegen? Ist ein D-Link.
Mit iwconfig kann ich die ESSID, den MODE und paar andere Sachen ändern.

Irgendwie schnalle ich die Funktionen für Wireless bei Gentoo nicht. Kann es sein das WLan nicht wirklich in Gentoo eingeplant ist?

4

21.05.2004, 15:07

Und es geht weiter >> wireless-config

Ich habe jetzt dieses wireless-config ebuild emergt
Von hier: http://forums.gentoo.org/viewtopic.php?t=122435&postdays=0&postorder=asc&start=0&sid=cfaf951ffd7937fbecbe224682bf365e
Klappt schon mal besser mit dem Laden beim hochfahren des Netzwerkes. So etwas ist dann tatsächlich nicht offiziell :?: Irgendwie bitter, dafür das es schon so alt ist.

Alles ist aber beim alten:
:arrow: Netzwerk fährt hoch
:arrow: Treiber wird geladen
:arrow: Wlan Sachen werden indiziert
:arrow: IP wird per DHCP nicht vergeben
:arrow: Tue ich das per Hand oder ist sie fest, dann kommt keine Verbindung zu stande.
per Hand = http://www.gentooforum.de/viewtopic.php?t=2116&highlight=wlan&sid=2405f0a3ec3c857c381b3486cba0b6c7

Also auf Wlan ebene klappt das alles gut, dass sehe ich im Syslog. :shock: Aber weiter geht es nicht. :(

Mal gucken, wir haben ja gleich Wochen Ende.... :roll:

5

22.05.2004, 09:56

Kernel Panic

Jetzt ist bisschen etwas reproduzierbares passiert was mich absolut nicht erfreut.

Sehr häufig passiert folgendes:

Wenn ich der Karte per Hand eine IP verpassen will schießt sich der Kernel in den Kosmos.

:arrow: ifconfig eth1 up
:arrow: dhcpcd eth1
:arrow: Im syslog tut sich ordlich kryptisches
:arrow: dhcpcd beendet schließlich
:arrow: ifconfig zeigt nix ausser mac adresse
:arrow: iwconfig kann nix mehr finden
:arrow: wenn ich dann die Karte rausziehe blinkten meine Tastatur LEDs :(

Das ist ganz schön Krass. Auch wenn ich vorher ifconfig eth1 down mache passiert es.